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1. Project Management Introduction         
About project management

After an initiative is created for a client, you can create projects for the initiative. The 
approval rules for projects for clients are defined in initiatives.

You use projects to define and track work that is being done for a client or an initiative. You 
can set up projects as chargeable or nonchargeable. The progress of a project is tracked 
through tasks that define the project work. You assign tasks to resources, and the resources 
enter their time and expenses for the tasks into Changepoint.

You can group related tasks under summary tasks and create  dependencies between tasks. If 
a project is large or complex, you can divide it into subprojects. Each project can support up 
to 20 levels of tasks and subprojects. These levels are displayed in the Projects tree view.

When you no longer require the project to be available in Changepoint, you can archive the 
project data.

About project resources

The typical resources that work with projects are the following:

• Project manager – has full edit access to the project and its tasks. The project manager is 
specified on the project profile. There can only be one project manager for a project at a 
time. 

• Project plan editors – can edit existing project tasks and can view the project dialog box 
but cannot edit the project profile. Project plan editors are granted access to the project 
by the project manager. The project manager can also specify whether project plan 
editors can create and delete project tasks, save project baselines, and take over the 
project to become the project manager.

• Summary task managers – can view the summary tasks and subtasks under the summary 
tasks that they have been assigned to. The project manager can also specify whether 
summary task managers can create, edit and delete the subtasks under their summary 
tasks.

• Resources assigned to project tasks – can view and update the status of the tasks that 
they have been assigned to.
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About resource leveling
If resource leveling is enabled for your Changepoint installation, all entries that affect task 
assignments are validated. If the task assignments will result in a resource being overbooked, a 
validation report displays a list of the affected task assignments.

Depending on how the staffing workgroup for the initiative that is associated with the project 
has been configured, the validation report will contain either warnings or failures:

• If the validation report contains warnings, then you can choose either to accept the 
warning and save the task assignment or cancel the task assignment.

• If the validation report contains failures, the task assignment cannot be saved.

 

About soft-bookings
Soft-bookings are tentative bookings of resources for planning purposes. Soft-booked time is 
shown as flexible on the resource schedule calendar. Available for task assignments, project 
team entries, request demand items, projected resources and calendar entries.

If resource request workflow is not used and soft-booking is allowed, resource request 
initiators determine whether a resource is soft-booked at the time they create the resource 
request.

If resource request workflow is used and soft-booking is allowed:

• Resource requests created by non-resource managers are treated as soft-bookings until they 
are approved by the resource manager.

• When a resource request is approved, the booking changes to hard-booked and the 
resource is committed for the duration of the request.

Resource managers can directly hard-book resources. The default setting for initiatives and 
projects is soft-booked, and for tasks it is hard-booked.
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About methods for creating projects

The following methods for creating a project are available:

• Create project – you can create a detailed project plan, and the related tasks, and task 
assignments. The related client, initiative, and cost structure must already exist. For more 
information, see "Creating a project" on page 18.

• Quick Plan – you can set up a simple initiative, project and task in one step. For more 
information, see the "Creating a project using the Create Quick Plan report" section on 
page 145.

• Quick project – if you do not require a detailed project plan, you can create a quick 
project from an initiative. A quick project is based on the work team information that is 
defined on the Projected resources tab of the initiative dialog box. For more 
information, see "Creating a project based on the projected resources of an initiative" on 
page 152.

• Copy an existing project – you can use an existing project as a template to create a 
project or a project and its tasks. For more information, see "About copying projects" on 
page 41.

Accessing a project
1. Click Project > Profiles. 

The Projects tree view appears. 

2.  Expand the tree view, and then select the project.

The project profile appears.

About the noneditable sections in the project profile

The project profile contains the following sections that cannot be edited:

• Record information – displays information about when the project was created and by 
whom, and when the project was last updated.

• Fiscal year breakdown – displays the planned, actual and remaining hours for the 
project distributed across the fiscal years that the project covers. This section displays 
only if fiscal periods have been specified for the project.
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• Portfolio memberships – displays only if the project is part of a portfolio. You can click 
the portfolio names to view the portfolios.

• Project dependencies – displays all of the information related to both predecessor and 
successor tasks.

Icons in the Projects tree view

The following table describes the project icons that display in the project tree view.

Blue project icon indicates that you are the project manager for the project.

Gray project icon indicates that you have view access to the project.

Microsoft Project icon indicates that the project is linked to a Microsoft 

Project project.

About creating projects
After clients and initiatives have been created, you can create your project, add tasks and 
assign resources. All projects in Changepoint are associated with an initiative.

You can create a project using the New option or from an entity (initiative, client, candidate or 
request) profile. When you create a project from an entity profile, the entity-related 
information is automatically added to the project.

You can create a project by completing only the following fields and then saving the project:

• Project

• Client

• Initiative

You can then enter the rest of the information for the project in stages.

The following fields are required, but because they have default values, you do not have to 
enter values for them:

• Planned start

• Planned finish

• Planned hours
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• First status (required only if Status required is selected in the Project type field)

You can enter values for the planned fields when you create the project, but the actual values 
based on the project data can be determined by rolling up the project after the tasks have been 
added.

About project statuses

The project status affects all of the tasks related to the project, and controls the project-related 
functionality that resources are able to perform. 

The following table lists the standard project statuses and descriptions of how the statuses can 
be changed in the workflow.

Status Description

Draft The project is under revision. Only the project manager has 

access to the project profile while it is in Draft status. 

Assigned resources cannot view the project, update the 

status of project tasks, or enter time and expenses. When you 

create a new project, it is in Draft status.

Draft can be changed to any other status.

Active The project is in progress. Only the project manager can edit 

the project profile and tasks. All other resources can access 

the project and its tasks and enter time and expenses 

according to their access rights.

Active can be changed to Completed or Inactive. 

Project Management | 15



2. Creating Projects

Status Description

Completed The project has been completed. 

When status is changed to Completed:

• all associated tasks are marked as Completed and are 

locked

• Resources cannot enter project expenses or time for 

project tasks.

• actual finish date is calculated

Completed status can be changed to Active or Inactive.

Inactive The project is suspended. Resources cannot enter project 

expenses, or time against project tasks until the status is 

changed back to Active.

Inactive can be changed to Active or Completed.

About project phases

Project phases represent the stages in a project’s life cycle. When you create tasks, you can 
specify the project phase in which the work should be done. When a project is rolled up, the 
current project phase is based on the latest phase of the tasks that have actual hours recorded, 
and is displayed in the Project phase field on the project profile.

Note: The Project phase field displays on the project profile only after the project is 
rolled up.

If the project includes summary tasks, the project phase is based on the summary task and not 
its subtasks. As a best practice, you should ensure that either all tasks under a summary task 
have the same project phase as the summary task, or that no phase is specified (provided that 
project phases are not mandatory). If no project phase is specified for the summary task, then 
the project phase of its subtasks is taken into consideration.

The Proposed phase field on the project profile displays the phase that the project is working 
towards. If project workflow is enabled, the field displays the workflow step that is currently 
in progress. By comparing the proposed phase with the actual phase, you can see if work is 
occurring within a phase that has not yet been approved to start.

About task status updates

Status updates for project tasks can be mandatory or not required:
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• Status required – Resources must update the status of their assigned tasks. However, you 
can remove the status requirement for specific tasks and task assignments if necessary.

• Status not required – Resources are not required to update the status on their assigned 
tasks. You cannot specify that certain tasks require status updates. Therefore, if you require 
updates on any tasks in your project, you must select the Status required project type 
when setting up your project.

For task assignments that do not require status updates:

• Only the project manager, project plan editor, or the resource who is assigned to the task 
can specify when the task is completed. Rolling up a project does not automatically set the 
task assignments as complete. 

• When a project is rolled up, the remaining hours are calculated as:

planned hours – actual hours

If the actual hours are greater than or equal to the planned hours, the remaining hours are 
set to 1. The percentage complete is calculated as follows: 

actual hours/(actual hours + remaining hours). 

About using fiscal periods on projects

If you want to use fiscal periods on a project, you must add them before you create tasks and 
task assignments.

When you add fiscal periods to a project, the planned effort is recalculated using a specific 
default loading method and can result in changes to planned hours totals and allocations. Also, 
you cannot edit dates and planned hours in past fiscal periods.

About restricting time entry for projects

You can restrict resources to entering time only when the time entry complies with one or both 
of the following conditions:

• date of the time entry is within the planned start and planned finish dates of the project, 
task or task assignment

• total amount of time entered for the task or task assignment is within the total planned 
effort of the project, task or task assignment 

You can set default settings for the time entry restrictions on the following entities:
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• cost structures –  for the projects for the cost structure initiatives 

• projects – for the tasks and task assignments for the project

• tasks – for the task assignments for the task

The default settings are automatically applied to new entities, but can be overridden on 
individual projects, tasks, and task assignments. The options selected on task assignments take 
priority over task settings, which take priority over the project settings.

About setting or changing time entry restrictions when there are existing 
projects

The time entry restriction settings are not automatically applied to projects, tasks, and task 
assignments that exist when you enable or change the settings. Therefore you must manually 
apply the settings to existing entities as follows:

• To restrict time entries based on project planned data, enable the setting on each project.

• To restrict time entries based on task planned data, enable the setting on each task.

• To restrict time entries based on task assignment planned data, enable the setting on each 
task assignment.

You can specify time entry restriction settings for tasks and task assignments on projects as 
well as in Project Worksheet and the task editing view. 

Creating a project
1. Click My Tools > New and then select Project from the list.

The Create Project dialog box appears.

2.  In the General tab, complete the fields as required. For more information, see "Create/Edit 
Project dialog, General tab options" on page 19.

3.  Click Save. The project is created.

4.  To complete the project, see the following topics:

• "Entering budget information for a project" on page 21

• "Specifying time approvers for a project" on page 22

• "Specifying a work location and work code for a project" on page 24

• "Allowing resources to submit project expenses" on page 30
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• "About granting access to projects" on page 26

• "Associating a project to an application" on page 31

Create/Edit Project dialog, General tab options

Field Description

Project field Name of the project.

Alternate name field Specifies the alternate name for the project. Typically used 

to display the project name in a different language

Client type-ahead field client for which the project is being created.

Initiative list Initiative for which the project is being created.

Planned start field Start date for the project.

Planned finish field Finish date for the project.

Planned hours field Planned hours for the project.

Status list Overall status of the project.

Proposed phase list Project phase that the project is currently working towards. 

If project workflow is enabled, the field displays the state in 

the current workflow process.

Project ID field ID for the project. Depending on the organization, the 

project ID may be automatically assigned by the system.

 project check box When selected, specifies that the project is chargeable.

Time-based project check 

box

When selected, specifies that the project tasks are time-

based and will be assigned to resources using Service 

Scheduler.

Project contact list Contact from the client that is associated to the project.

Cross charge contact list Contact to whom the cross charges will be sent.
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Field Description

Project type list Option that specifies whether resources must update the 

status of their assigned tasks. Options are:

• Status required
• Status not required

First status date field Date that resources must start updating the status of their 

assigned tasks, if the project type is set to Status 
required.

Status every [ ] weeks field Frequency in weeks that resources are required to enter a 

status update for their assigned tasks.

CP project type list Custom project type that allows the project to be 

categorized within Changepoint.

Fiscal period type-ahead 

field

Cost structure whose fiscal periods apply to the project.

Cost center type-ahead field Cost center that is associated with the project. The cost 

center determines the burden rate that applies to cost rates 

for budgeted services, when specific resources are not 

selected.

Work performed for type-

ahead field

Client for which the work is performed, as specified in the 

associated initiative.

Candidate type-ahead field Candidate to associate to the project

Request field Request number of the originating request, if applicable.

View in Client Portal check 

box

When selected, Client Portal users can view the project 

and its tasks, and create requests for the project.

Display MSP WBS in tree 
view check box

When selected, displays the Microsoft Project work 

breakdown structure (WBS) number for a task before the 

task name in the Projects tree view.
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Field Description

Calculate critical path 

check box

When selected, critical path is calculated for the project.

Comments field Comments regarding the project.

Entering budget information for a project

The budget information that you enter here is for information purposes only and is displayed in 
the Budget information section of the project profile. To estimate and track the labor, material 
and expenses required to perform the work defined in the project, you can create a project-
specific budget.

1. Access the project.

2.  Click Actions > Edit.

The Edit Project dialog box appears.

3.  Click the Budget and approval information tab.

4.  Complete the fields as required. For more information, see "Create/Edit Project dialog, 
Budget and approval information tab options" on page 23.

5.  Click Save.

About specifying time approvers for projects

By default, the time approver specified for a resource in user setup approves all time for a 
resource. However, if a time approver has been specified for an initiative, then the  time 
approver approves time for all projects under the initiative.

If an initiative is configured to allow time approval on projects, you can also enable time 
approval and specify a time approver for individual projects under the initiative. In this case, 
the specified project time approver approves the project time, followed by the initiative 
approver. If a project time approver is not specified, then the resource approver approves the 
time, followed by the initiative approver.

If a time approver is not specified for the initiative, then the project time is approved by the 
project time approver only.
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The following table shows the time approvers when time approvers are specified on more than 
one entity.

Initiative Time 
Approver

Project  Time 
Approver

Resource Time 
Approver

Time entry approvers

Specified Specified Specified or not 

specified

The project time approver, then 

the initiative time approver.

Not specified Specified Specified or not 

specified

The project time approver.

Specified Not specified Specified If time approval is enabled for 

the project: the resource time 

approver, then the initiative time 

approver

If time approval is not enabled 

for the project: the initiative time 

approver.

Specifying time approvers for a project

1. Access the project.

2.  Click Actions > Edit.

The Edit Project dialog box appears.

3.  Click the Budget and approval information tab.

4.  Complete the fields as required. For more information, see "Create/Edit Project dialog, 
Budget and approval information tab options" on page 23.

5.  Click Save.

Setting default time entry restrictions for a project

The time entry restrictions that you specify for a project are the default settings for the tasks 
and/or task assignments for the project.

1. Access the project for editing

2.  Click the Budget and approval information tab.
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3.  To prevent resources from entering time entries that are not within the planned dates for 
the project, task, and/or task assignment, in the Restrict time entries to within the 
planned dates for option, select the applicable entity check boxes.

4.  To prevent resources from entering time entries when the planned effort for the project, 
task, and/or task assignment is exceeded, in the Restrict time entries to within the 
planned effort for option, select the applicable entity check boxes.

5.  Click Save.

Create/Edit Project dialog, Budget and approval information tab options

Field Description

Labor field Proposed labor budget for the project.

Expenses field Proposed reimbursable expense budget for 

the project.

Other expense field Proposed budget for other expenses for the 

project.

Project value field Value of, and currency for, the project.

The project value is one of the search criteria 

for resources.

Enable project time approval check box When selected, the time worked on the 

project must be approved at the project level.

Time approver field Resource who approves the time submitted 

for the project.

Secondary time approver field Resource who approves the time that the time 

approver submits.

Time entry restrictions section
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Field Description

Restrict time entries to within the 
planned dates for [project, task, task 
assignment] check boxes

Prevents resources from entering time for 

dates that are outside of the planned start and 

planned finish dates of the selected option.  

(project, task, task assignment).

Restrict time entries to within the 
planned effort for [project, task, task 
assignment] check boxes

Prevents resources from entering time when 

the total time entered for the selected option 

exceeds the planned effort.

About specifying work locations and work codes for a project

Work locations and work codes are required to assign the correct taxation information when 
cross charging the client. Work locations specify where the work is performed, and work codes 
specify the type of work. 

The work locations and codes for a project come from the associated initiative. However, you 
can specify different work locations and work codes or change the default ones for the project. 
The default work location and work code display on all time and expense records for the 
project. 

You can allow resources to change the work location on time and expense entries. You can 
also allow resources to select a work location that has not been specified for the project. The 
system administrator can set up an email notification to let you (the project manager) know 
when expenses are being entered for a location that is not specified on the project.

If work locations or work codes are changed or removed from the initiative, they display in 
red. They are still available to select at another time.

Specifying a work location and work code for a project

1. Access the project. 

2.  Click Actions > Edit.

The Edit Project dialog box appears.

3.  Click the Work locations/work codes tab.

4.  In the Selected work locations list, expand the tree view and select the work location.

5.  To change the default work location:
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a. Right-click a work location.

b. Select Set as default.

6.  To allow resources to select a different work location for expenses, select the Allow 
expense location override check box.

7.  To allow resources to choose a work location that is not in the Selected work locations 
list for an expense, select the Allow non-project locations check box.

8.  In the Selected work codes list, expand the tree view and select the work codes.

9.  To change the default work code:

a. Right-click a work code.

b. Select Set as default.

10.  Click Save.

Setting up split charge charging for a project

You select clients and specify the percentage that each client will be cross charged. You can 
either specify the percentage manually as you select each client, or select all of the clients first 
and then select the option to automatically split the cross charge amount evenly between the 
clients.

1. Access the project for editing.

The Edit Project dialog box appears.

2.  Click the Split charges tab.

3.  To specify a client:

a. Right-click in the table, and then select Insert.

b. In the Client type-ahead field, select the client.

4.  To add the clients that have already been for the initiative, right-click in the table and 
select Load initiative split charge.

5.  To specify the percentage, do one of the following:

• To specify the percentage manually, enter the value in the Percentage field.
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• To split the charge evenly between all clients, right-click in the table and select Auto-
split.

6.  Click Save.

About granting access to projects
As project manager, you automatically have access rights to view and edit all aspects of the 
project. 

However, you can manage the access for other resources. For more information, see the 
following:

• "Granting a resource view access to a project" on page 26

• "Removing view access restrictions to project requests" on page 27

• "Specifying access for project plan editors" on page 27

• "Granting access to summary task managers" on page 28

• "Granting access to subprojects" on page 29

• "Allowing resources to save baselines" on page 29

• "Allowing resources to submit project expenses" on page 30

Granting a resource view access to a project

When you grant view access to a project to a resource, the resource can view the project and 
all of its tasks.

1. Access the project. 

2.  Click Actions > Edit.

The Edit Project dialog box appears.

3.  Click the Access tab.

4.  In the View project list, select the resources. 

Tip: To add resources to the View project list, and optionally to your preferred resources, 
right-click in the list and then select Manage Resources.

5.  Click Save.
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Removing view access restrictions to project requests

If system-wide restrictions for viewing requests have been set up by your organization, only 
the resources that have been granted specific access to a project can view the project requests. 
However, you can remove the restrictions for a project. 

If system-wide restrictions have not been set up, you cannot add access restrictions to a project.

1. Access the project. 

2.  Click Actions > Edit.

The Edit Project dialog box appears.

3.  Click the Access tab.

4.  In the Request access section, select the Disable view access restrictions for viewing all 
requests under this project check box. 

5.  Click Save.

About specifying access for project plan editors

You can designate resources as project plan editors for a project. Only resources who have the 
security access to manage tasks are available as potential project plan editors. By default, 
project plan editors can only view and edit project tasks. However, you can set additional 
options to allow them to also create and delete project tasks, assign summary tasks, and take 
ownership of the project. 

You can remove project plan editor access from resources at any time, except for the default 
project plan editors.

Specifying access for project plan editors

1. Access the project. 

2.  Click Actions > Edit.

The Edit Project dialog box appears.

3.  Click the Access tab.

4.  In the Edit project plan list, select the resources to be project plan editors for your 
project.
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Tip: To add resources to the Edit project plan list, and optionally to your preferred 
resources, right-click in the list and then select Manage Resources.

5.  In the Project plan editor access section, do the following:

• To allow project plan editors to assign summary tasks to resources, select the Allow to 
assign summary tasks check box.

• To allow project plan editors to create new tasks for the project, select the Allow to 
create new tasks check box.

• To allow project plan editors to delete tasks from project, select the Allow to delete 
tasks check box. 

• To allow project plan editors to take ownership of the project, select the Allow to take 
ownership of the project check box.

6.  Click Save.

Granting access to summary task managers

A summary task manager is a resource who has been assigned to a summary task for the 
project. You can set options to allow summary task managers to create, edit and/or delete the 
subtasks under their assigned summary tasks.

1. Access the project. 

2.  Click Actions > Edit.

The Edit Project dialog box appears.

3.  Click the Access tab.

4.  In the Summary task manager access section, do the following:

• To allow summary task managers to edit the subtasks under the summary tasks to 
which they are assigned, select the Allow to edit tasks check box.

• To allow summary task managers to add new tasks under the summary task, select the 
Allow to add new tasks check box.

• To allow summary task managers to delete subtasks associated with the summary task, 
select the Allow to delete tasks check box.

5.  Click Save.
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Granting access to subprojects

1. Access the project. 

2.  Click Actions > Edit.

The Edit Project dialog box appears.

3.  Click the Access tab.

4.  In the Subproject settings section, do the following:

• To allow resources to create a subproject under the project, select the Allow 
subprojects to be created check box.

• To automatically make the project manager a project plan editor for all subprojects, 
select the Allow the project manager complete access to all subprojects check box.

• To display all subprojects in the Projects tree view, select the Display subprojects in 
the project tree view check box. If this check box is cleared, only the project manager 
of the subproject can view it in the tree view only.

• To have planned start, planned finish and planned hours roll up from subprojects to the 
parent project task when the project is rolled up, select the Roll up planned 
information from subprojects to parent task check box.

5.  Click Save.

Allowing resources to save baselines

You can control whether project plan editors and summary task managers can save baselines. 
You can also give resources the option to save a baseline for a task with or without affecting 
higher-level tasks. For more information, see "About saving a task baseline without affecting 
higher level tasks" on page 69.

1. Access the project. 

2.  Click Actions > Edit.

The Edit Project dialog box appears.

3.  Click the Access tab.

4.  In the Baseline settings section, do the following:
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• To allow project plan editors to save baselines for the project, select the Allow project 
plan editors to save baselines check box.

• To allow summary task managers to save baselines for their summary tasks and 
subtasks, select the Allow summary task managers to save baselines check box.

• To give resources the option to save baselines without affecting higher-level tasks, 
select the Allow users to save task baselines without affecting higher-level tasks 
check box.

5.  Click Save.

Allowing resources to submit project expenses

You can allow all of the resources who are assigned to project tasks to submit expenses for the 
project. You can also allow:

• individual resources to submit expenses even if they are not assigned to any project tasks

• all resources who are assigned to the project to override the chargeable status on expenses, 
even if the expenses for the project are chargeable

The Expense only users list includes your preferred resources who have access rights to 
create expenses. If resource requests are enabled at the project level, then list also includes the 
resources from the project team who have access rights to create expenses. 

1. Access the project. 

2.  Click Actions > Edit.

The Edit Project dialog box appears.

3.  Click the Expense access tab.

4.  To allow resources to submit expenses even if they are not assigned to any project tasks, 
select the resources in the Expense only users list. 

Tip: To add resources to the Expense only users list, and optionally to your preferred 
resources, right-click in the list and then select Manage Resources.

5.  To prevent all of the resources who are assigned to the project from submitting expenses, 
clear the Allow resource with task assignments to enter expenses check box.
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6.  To allow all of the resources who are assigned to the project to override the chargeable 
status for a particular expense, select the Allow users to override the [Chargeable] status 
on expenses entered for this project check box.

7.  Click Save.

Associating a project to an application
You can associate projects to the applications for which the work is being done. When you 
associate a project to an application, all of the project tasks are automatically associated with 
the application. You can also associate individual tasks in the same project to different 
applications. For more information, see "Associating a task to an application" on page 57.

The first application you select is marked as the primary application and is used for reporting 
purposes. 

1. Access the project. 

2.  Click Actions > Edit.

The Edit Project dialog box appears.

3.  Click the Applications tab.

4.  In the Applications list:

a. Expand the tree view and select the primary application associated with the project.

b. Select additional applications, as required.

5.  To change the primary application, click the name of the application instead of the check 
box. 

6.  Click Save.

Removing the association between a project and an application

1. Access the project. 

2.  Click Actions > Edit.

The Edit Project dialog box appears.

3.  Click the Applications tab.

Project Management | 31



2. Creating Projects

4.  To remove the association to a primary application, you must first select a different 
primary application by clicking the name of the application instead of the check box.

5.  Clear the check box for the primary application.

6.  Click Save.

About creating subprojects
You can create subprojects when you require a more complex project structure. Subprojects 
appear the same as projects in all tree views.

By default, only the project manager of the subproject can view it in the Projects tree view. 
To allow all resources who have access to the project to view the subproject, you must select 
the option for displaying subprojects on the parent project. 

Creating a subproject

You must create a subproject from the profile of a task that has been created for that purpose, 
and you must be assigned to that task.

1. Create a task. 

2.  Assign the task to yourself.

3.  From the task profile, click Actions > Create > Subproject.

The Edit Project dialog box appears.

4.  Complete the fields as required. For more information, see "Creating a project" on page 
18.

5.  Click Save.
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About project teams

If resource requests are enabled at the project level, the Project team tab is available on the 
project dialog box. You define your general resource requirements by adding project team 
entries. Project team entries consist of combinations of staffing levels, functions, and the 
duration and estimated effort of assignments.

You manage the project team resources as follows:

• add project team entries

• submit the resource requests for approval

• track the progress of resource requests 

• after resource requests have been approved, assign resources to project tasks

Creating a project team entry

For planning purposes, you can create project team entries that are based on staffing levels, 
instead of naming specific resources. Later, you can use these project team entries to submit 
resource requests.

1. Access the project for editing. 

2.  Click the Project team tab.

3.  In the Project Team Details section, complete the fields as required. For more 
information, see the "Edit Project dialog, Project team tab options" section on page 34.

4.  To add resources to your preferred resources list, in the Project Team Details section, 
click Actions > Manage resources.

5.  In the section, click Actions > Apply.

The entry is added to the project team table.

6.  Click Save.
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Edit Project dialog, Project team tab options

Field Description

Assigned resource type-

ahead field

Resource that has been assigned to the project team. This 

field is editable when no resource request is associated 

with this project team. This list includes resources who are 

exempt from the resource request process.

Requested resource list Resource that you request for project team entry. 

Available only when no resource has been assigned.

When you submit the resource request, the requested 

resource in this section is set by default from the 

requested resource in the project team. You can modify 

this value later, if required.

Cost structure list Cost structure from the project. You can select a different 

cost structure to access a different set of staffing levels.

Staffing level list Staffing level of the project team entry.

Function type-ahead field Job function of the resource.

Start date field Date the resource will start.

Finish date field Date the resource will finish.

Estimated hours field Number of hours that you require the resource.

Soft-booked check box When selected, indicates that the resource is tentatively 

booked for planning purposes. Available only if soft-

booking is enabled on the cost structure.For more 

information, see "About soft-bookings" on page 12.

Add to calendar check box When selected, adds the project team entry to the 

resource’s personal calendar and the resource scheduling 

calendar

Submit request check box When selected, displays the Requested resource and 

the Number of resource requests fields that are 

required to submit a resource request.
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Field Description

Requested resource list Resource that you request.

Number of resource 
requests field

Number of resources that you require.

Comments field Instructions for the resource manager.

Resource request status 

field

After the resource request has been submitted, the project 

team entry displays the request number.

Specified qualifications 

field

Qualifications that the resource must have.

Assigned tasks field List of project tasks that can be assigned to resources.

Project team comments 

field

Comments about the project team entry.

Copying projected resources to a project team

The projected resources from the initiative that is associated with a project can be copied to the 
project team as project team entries. Assigned resources are copied only if they are exempt 
from resource requests. You can then edit the project team entries as required.

1. Access the project for editing. 

2.  Click the Project team tab.

3.  Click Actions > Copy from projected resources.

The projected resources records from the initiative are added to the project team table.

4.  To edit a project team entry:

a. Select the row in the project team table. The details appear in the Project Team 
Details section.

b. Make the necessary changes.

c. Click Actions > Apply.
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5.  To include an entry in the resource’s personal calendar and the resource scheduling 
calendar, select the Add to calendar check box.

6.  Click Save.

Submitting a resource request for a project team

When you submit a resource request, you can either request a specific resource or leave the 
resource field blank and have the resource manager assign the resource. The resources 
available for selection are the resources from your preferred resources list. You can also 
submit a resource request for multiple resources based on a staffing level only. For example, 
you could submit a resource request for 5 developers.

1. Access the project for editing. 

2.  Click the Project team tab.

3.  In the table, select the project team entry for which you want to submit a request.

The details of the project team entry are displayed in the Project Team Details section.

4.  In the Project Team Details section, select the Submit request check box. 

The Requested resource type-ahead field, the Number of resource requests field and the 
Comments field appear.

5.  To request a specific resource, in the Requested resource type-ahead field, select the 
resource.

6.  To request multiple resources:

a. Leave the Requested resource field blank.

b. In the Number of resource requests field, enter the number of resources that you 
require. 

7.  To mark a qualification as preferred, in the Specified qualifications tree view, right-click 
the qualification and select Set as preferred. 

8.  In the Comments field, enter instructions for the resource manager.

9.  In the Project Team Details section, click Actions > Apply.

In the project team table, a check mark is displayed in the Submit request column of the 
project team entry row.
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10.  Click Save.

The resource request is submitted to the resource manager for approval. 

Tip: You can search for available resources by clicking Actions > Resource search. For 
more information, see "Resource Searches" in the Resource Management User Guide.

Editing a project team entry

You can edit a project team entry only if a resource request has not been submitted, or the 
associated resource request is still in the New status. Once the resource request is no longer in 
the New status, changes can only be made by editing the resource request.

1. Access the project for editing. 

2.  Click the Project team tab.

3.  In the table, select the project team entry.

4.  Make the necessary changes. For more information, see "Edit Project dialog, Project team 
tab options" on page 34.

5.  In the Project Team Details section, click Actions > Apply.

6.  Click Save.

Deleting a project team entry

You can delete a project team entry provided that a resource request has not yet been submitted 
for it, or the resource request has been submitted but it is still in the initial status. 

1. Access the project for editing. 

2.  Click the Project team tab.

3.  In the table, select the project team entry.

4.  In the Project Team Details section, click Actions > Delete.

5.  Click Save.

Assigning a project team resource to a task

After a resource request has been approved, you can assign the resource to tasks. The duration 
and effort for the task must be within the duration and effort of the project team entry.

1. Access the project for editing. 
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2.  Click the Project team tab.

3.  In the table, select the project team entry.

A list of project tasks appear in the Assigned tasks list. 

4.  In the Assigned tasks list, select the tasks that you want to assign to the resource.

5.  To set the planned hours for a task: 

a. Right-click the task and select Set planned hours. The Set Planned Hours dialog box 
appears.

b. In the Planned hours field, enter the number of planned hours planned for this task 
assignment.

c. Click OK.

6.  In the Project Team Details section, click Actions > Assign task.

7.  Click Save.
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About editing projects

Only the project manager can edit the project profile; that is, change the information in the 
project dialog box. Project plan editors can view the project dialog box only. This topic 
includes information to consider before making certain changes to the project profile.

Changing the cost structure of a project

If you change the cost structure, all planned effort that has been manually allocated for 
project task assignments will be lost, except in the following circumstances:

• allocations for loading methods 3 and 4 that do not replace planned effort in past periods 
with actual hours are retained

• allocations for loading methods 0, 1 and 2 that replace  planned effort in past periods  are 
retained when the past data does not have to be recalculated, for example:

• the cost structure is removed and no new cost structure is selected

• the start date of the current fiscal period on the new cost structure matches the start 
date of the current fiscal period on the previous cost structure

• the planned start date of the task assignment is in the current fiscal period or a future 
fiscal period of the new cost structure

Changing the chargeable status of a project

You cannot change the setting of the Chargeable project check box when the Split charges 
check box has been selected on the Cross charge information tab of the initiative, and 
either of the following conditions exist:

• Cross charges exist for an initiative or phantom initiative that is in Draft, Pending 
Approval, Pending second approval or Approved status.

• All cross charges are committed, but there is time or expenses for the initiative or 
phantom initiative that have not been fully cross charged.

Changing the requirement for task status updates

You can change whether task status updates are required for a project by changing the 
project type.
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If you change the requirement for task status updates from Status required to Status not 
required, the requirements for all existing tasks and task assignments as well as new tasks and 
task assignments created later will automatically be changed to Status not required.

If you change the requirement for task status updates from Status not required to Status 
required, you have the following options:

• change the requirement for existing as well as new tasks and task assignments

• change the requirement for new tasks and task assignments only

Editing a project

1. Access the project.

The project profile appears.

2.  Click Actions > Edit.

The Edit Project dialog box appears.

3.  Make the necessary changes. For more information, see "Create/Edit Project dialog, 
General tab options" on page 19.

4.  Click Save.

About deleting a project

When you delete a project, all of the project and task information is deleted. You cannot delete 
a project if any of the following conditions exist:

• there are time and expense entries for the project that have not been cross charged and 
archived

• the project contains an active subproject

• the project is included in a project portfolio

• there is a project task associated to an expense

Deleting a project

1. Access the project for editing. 

The Edit Project dialog box appears.

2.  Click Delete.
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3.  Click OK to confirm.

About copying projects
You can copy project information to update an existing project or create a new project. When 
you copy project information, all project and task field values, including the configurable field 
values from the source project, are automatically copied to the target project, except for the 
settings in the Access tab. 

Note: If resource requests are required for the project, then you cannot copy task 
assignments from the source project to the new project.

When you copy project information, you can:

• Specify a project manager (for new projects only). The new project manager must be in 
your preferred resources list and have the security access to manage tasks in order for the 
project tasks to be copied to the target project

• Specify whether the planned start and finish dates for the target project are based on a 
specified start or end date.

• Copy project-related knowledge items.

• Copy resource assignments and/or specify a default resource.

• Copy resource staffing levels.

• Copy work locations and work codes for the project.

• Copy work locations and work codes for the tasks and task assignments.

About copying a project to update an existing project

You can copy project information from a source project to an existing target project provided 
that you have edit access to both the source and target projects and/or the projects’ tasks, and 
the project manager of the target project is in your preferred resources list. 

You can only copy the type of information that you have edit access to on the target project. 
For example, if you are the project manager for both the source and target projects, you can 
copy all project and task information. However, if you are the project manager for the source 
project, but only a summary task manager for the target project (and summary task managers 
can create tasks for the project), then you will only be able to add tasks under the summary 
tasks that you have access to in the target project.
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Copying a project

1. Access the profile of the source project. 

2.  Click Actions > Copy.

3.  If knowledge items exist for the source project, a dialog box appears. Do one of the 
following:

• To include the knowledge items, click OK.

• To exclude the knowledge items, click Cancel.

The Copy Project dialog box appears.

4.  Do one of the following:

• To create a new project from an existing project, do not select the Update project 
check box.

• To update an existing project with the information of the source project, select the 
Update project check box.

5.  Complete the fields as required. For more information, see "Copy Project dialog box 
options" on page 42.

6.  Click Save.

Copy Project dialog box options

Field Description

Copy source field Name of the source project which information are copied.

Update project check box When selected, the source project information is copied to an 

existing project.

When cleared, the source project information is used to create 

a new project.

Project manager list Project manager of the target project. The field displays your 

name by default.
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Field Description

Target project type-

ahead field

Project to which the information is copied.

Insert into summary 
task type-ahead field

Summary task under which tasks are copied

Name of new project 
field

Name for the new project.

Alternate name field Alternate name for the project.

Client type-ahead field Client for which the project is created.

Client ID type-ahead field ID of the client.

Initiative list Initiative associated with the project.

Phase list Phase of the tasks. 

If phases are selected, only the tasks that are in one or more 

phases of the source project are copied to the project.

Base new timescale on. 

Start date check box

When selected, planned dates are based on the start date of 

the source project.

Base new timescale on, 

End date check box

When selected, planned dates are based on the end date of 

the source project.

Date field Start or end date for the project.

Copy resource 
assignments into the 
new project check box

When selected, copies the resource assignments from the 

tasks in the source project to the new project.

Copy resource staffing 
levels into the new 
project check box

When selected, copies the staffing levels from the tasks in the 

source project to the new project.
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Field Description

Default resource list Default resource to be used when the resources from the 

source project are not available.

Copy selected work 
locations and work 
codes from the source 
project check box

When selected, copies the work locations and codes from the 

source project to the new project.

Copy selected work 
locations and work 
codes from the source 
tasks and task 
assignments check box

When selected, copies the work locations and codes from 

source tasks and task assignments to the new project.

About completing the Copy Project dialog box

Copying tasks

By default, all tasks are copied from the source project. However, you can specify that only 
the tasks that are associated to one or more project phases in the source project are copied.

Selecting a default resource

You can select a default resource from your preferred resources list to be used when the 
resources from the source project are not available. For example, the default resource is used 
when a resource from the source project has been deleted or unassigned from a task or is 
unavailable to the new project manager. If resource requests are enabled on the initiative, the 
Default resource list contains resources from the projected resources for the initiative.

Specifying the target project timescale

You can specify whether the target project planned dates are based on a start date or end date. 
If you specify that the project timescale be based on a start date, then the planned start dates 
for the target project tasks are based on the relative period of time between the planned start 
date of the source project tasks and the planned start date of the source project. 

For example, if the planned start date for a source project task was 10 days after the planned 
start date of the source project, then the start date for the target project task will be 10 days 
after the start date that you specify for the target project. 
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Similarly, if you specify that the project timescale be based on an end date, the planned finish 
dates for the target project tasks will be based on the relative period of time between the 
planned finish date of the source project tasks and the planned finish date of the source project.

Copying resource assignments

You can copy resource assignments from the tasks in the source project to the tasks in the 
target project. If resource leveling is enabled for your organization, the copied task assignments 
are validated for any resource leveling restrictions when you save the target project. If resource 
requests are enabled at the initiative level and the option to override task restrictions is not 
selected, then task assignments are not created.

Only the invalid task assignments in the source project that include planned hours are copied to 
the target project and assigned to the default resource. The planned hours for the copied task 
assignment will be the total hours of all of the invalid task assignments for the same task.

Copying staffing levels

You can copy the staffing levels from the tasks in the source project to the tasks in the target 
project. Only the staffing levels that are valid and available are copied to the target project.

Copying project work locations and work codes

You can specify whether the selected work locations and codes, including the defaults, are 
copied from the source project or from the initiative of the target project. In either case, only 
the work locations and codes that are specified in the initiative of the target project are valid 
for the target project. If you specify to copy the work locations and codes from the project and 
none of them are valid, then the work locations and codes from the initiative of the target 
project are used. 

Note: When the work locations and codes are copied, the settings for expense overrides 
and whether non-project locations can be used are also copied.

Copying work codes and locations for tasks

You can specify whether the selected work locations and codes for tasks and task assignments, 
including the defaults, are copied from the source project. If the default work location and 
work code from the tasks and task assignments of the source project are not valid for the target 
project, then the default values from the target project are used.
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If the selected work locations and codes for tasks and task assignments are not copied from the 
source project, then the work locations and codes from the target project are used for new 
tasks and task assignments.

Note: When the work locations and codes are copied, the settings for expense overrides 
and whether nonproject locations can be used are also copied.

Reassigning a project
Project managers can reassign a project to any resource that has access rights to edit the 
project plan. When you reassign a project, the resource becomes project manager of the project 
and has full edit rights, and you become a project plan editor. 

1. Access the project for editing.

The Edit Project dialog box appears.

2.  Click the Access tab.

3.  In the Edit project plan list, right-click the resource to whom you want to reassign the 
project and select Reassign.

4.  Click OK to confirm.

5.  Click Save.

Taking ownership of a project
Project plan editors can take ownership of a project if the project manager has enabled the 
option on the project. When a project plan editor takes ownership of a project, the project plan 
editor becomes the project manager and the project manager becomes a project plan editor. 
Project managers can take back ownership of a project when necessary.

1. Access the project.

2.  Click Actions > Transfer project to me. 

About saving project baselines
After you have set up your project, you can save a baseline for the entire project, subproject, 
summary task or individual task. This topic describes saving project baselines. For task 
baselines, see "About saving task baselines" on page 67.
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When you save a baseline for a project, the planned information for the project is rolled up 
first to ensure that accurate information is available at the task, summary task and project 
levels. 

The baseline information for the project, summary tasks, tasks and task assignments, including 
the date and time that the baseline was created and the resource who created it, is stored in the 
database. The following information is displayed in the Status information section of the 
project profile:

• Baseline start – the earliest planned start date of all project tasks

• Baseline finish – the latest planned finish date of all project tasks

• Baseline hours – total planned hours for the project tasks

If the option to roll up planned information from subprojects to parent tasks has been enabled 
for the parent project, then during summary tasks will be updated to also include the rolled up 
information from subtasks and subprojects and the baseline information will be captured in the 
general section of the summary task profile. 

Note: The baseline functionality is not available for projects that are linked to Microsoft 
Project. Also, if a parent project of the project being baselined is linked to Microsoft 
Project, then baseline information will not roll up to the parent project.

You can save a baseline at any time. When you save a new baseline, the current and previous 
baseline information is stored in the database. All baseline information can be accessed by 
creating custom reports.

The project manager can also give resources the option to save a baseline for a task without 
affecting higher-level tasks. Note however, that saving a baseline without affecting higher-level 
tasks can result in the project and task baselines being out of balance.

Note: Some example project and task baseline scenarios are available. For more 
information, see "Scenarios for saving baselines" on page 179.

Saving a project baseline

1. Access the project.

2.  Click Actions > Baseline.

3.  To view the baseline information:

a. Refresh the Details view by clicking the project in the tree view.
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b. Expand the Status information section.

About rolling up projects
When you roll up a project manually, the system rolls up the following information from the 
task assignments to the tasks, and then from the tasks to the project:

• planned, actual, and forecast start dates – the earliest of each of these dates from the task 
assignments becomes the planned, actual, and forecast start dates for the project

• planned, actual, and forecast finish dates – the latest of each of these dates from the task 
assignments becomes the planned, actual, and forecast finish dates for the project

• planned, actual, and forecast hours – the totals of these hours from the task assignments 
become the planned, actual, and forecast hours for the project 

• remaining hours – the remaining hours (forecast hours) for the task assignments roll up to 
the tasks and then the project

To ensure the project information is as accurate as possible, it is recommended that you roll up 
a project after all of the project tasks have been created.

Rollup rules for draft tasks

The information from draft tasks is not rolled up.

Rollup rules for open tasks

The planned start, finish and hours from the task assignments of open tasks do not roll up. 
Only the actual and forecast dates and hours roll up to the open task and then to the project.

Rollup rules for summary tasks

The planned, actual and forecast information from the task assignments of both the summary 
task and its subtasks roll up to the summary task and then up to the project.

Rollup rules for subprojects

The planned, actual and forecast information from the task assignments roll up to the tasks 
which roll up to the parent task of the subproject and then to the parent project.

If the parent project has been configured to NOT roll up planned information from subprojects 
to parent tasks, then only the actual and forecast information from the tasks assignments of the 
tasks of the subproject is rolled up to the subproject task and then up to the parent project.
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Automatic roll up of projects

Projects for which fiscal periods have been selected, and projects that belong to portfolios are 
automatically rolled up by system updates. Projects are rolled up automatically in the following 
situations:

• When there is a change to the project that makes a rollup necessary, for example, changes 
to planned, actual, and forecast  information.

• The project has task assignments with loading methods that replace past data with actual 
data. These projects are rolled up at the beginning of the fiscal period that was selected for 
the project.

Rolling up a project manually

1. Access the project.

2.  Click Actions > Rollup.

The planned, actual and forecast information is rolled up and updated in the task and 
project profiles.
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About tasks

After a project is created, the next step is to create tasks and assign them to resources. You 
can create the following type of tasks for your projects.

Tasks

You create tasks for specific project work and assign them to resources. Only the resources 
who are assigned to a task can enter time for it.

Summary tasks

Summary tasks are tasks that contain subtasks, which are the tasks grouped under them in the 
Projects tree view. You use summary tasks to organize the major phases and subphases in a 
project. 

By default, time can be entered for summary tasks. During project rollup, the time amounts 
from the subtasks are added to the summary task amounts.

Tip: To prevent time entry on a summary task or its subtasks,  select the Locked task 
check box on the task.

Open tasks

Open tasks are tasks that all resources can enter time for. Examples of open tasks are status 
meetings or tasks that can be performed by any resource in a resource pool. You can also use 
open tasks to track non-project related tasks instead of using non-project time buckets that 
must be configured by the system administrator. 

You can restrict access to an open task by role or workgroup. Open tasks cannot contain 
subtasks and therefore cannot be summary tasks. When a resource enters time for an open 
task, a task assignment is automatically created for the resource.

If resource leveling is enabled, the planned hours for open tasks is 0 (zero) and cannot be 
edited. 

If resource leveling is not enabled, you can specify the planned hours for an open task so that 
when a resource logs time against the task, the planned hours are automatically defined.

Milestone tasks

Milestone tasks mark a significant point in a project. Milestone tasks can have a duration of 
zero or more days and appear as a diamond-shaped icon in the Gantt chart. 
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Task icons

The following table list the various task icons and their descriptions.

Task Icon Description

A green task icon indicates that you are assigned as a resource to the task. 

Assigned tasks are also included in the Time Sheet tree view.

A gray task icon indicates that you have access to view the task, but are not 

assigned to the task.

A task icon with a diamond indicates the task is a project milestone.

A task icon with a circled check mark icon indicates the task is complete.

Accessing a task
You can only access the tasks to which you are assigned, and tasks within a project for which 
you are the project manager, project plan editor or summary task manager.

1. Click Project > Profiles.

The Projects tree view appears.

Tip: To locate a task, you can enter the full or partial task name in the Filter field and 
then click Filter. The tree view displays the projects that contain tasks that match the filter 
text.

2.  Expand the Projects tree view to display the tasks.

3.  Select the task.

The task profile appears.

About creating tasks
After creating a project, you create a task for each activity that you want to track. 

You can create tasks from many different starting points. The starting point determines the 
amount and type of task-related data that is automatically completed for the task. For example, 
if you create a task from a project, then the project-related information will automatically be 
completed for the task. 
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Task editing view, General section options

Option Description

Project list Project for the task.

Task name field Name for the task.

Planned start date field Date that the task should start. The default date is 

the date that the task is created.

Planned finish date field Date that the task should be completed. The default 

date is the day after the date that the task is 

created.

Planned hours field Estimated number of hours that are required to 

complete the task. The planned hours for the task 

must equal the total of the planned hours for the 

task assignments.

Project phase field Project phase that the task applies to. For more 

information, see "About project phases" on page 16.

Staffing level type-ahead field Default staffing level for resources that are 

assigned to the task. You can override the default 

when making specific staff assignments. The 

staffing levels come from the initiative. If no staffing 

levels are specified for the initiative, or the default 

was cleared for the task, the task assignment is 

created without a staffing level.

Function list Default job function for resources that are assigned 

to the task. You can override the default for task 

assignments.

Request type-ahead field Number of the request that is associated with the 

task.
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Option Description

Locked task check box When selected, prevents resources from entering 

time for the task assignments for the task. However, 

you can change the setting for individual task 

assignments.

Include in resource demand 

check box

When selected, new task assignments created for 

this task are included in resource demand analysis 

by default. Selected by default on new tasks.

You can override the default for task assignments.

Open task check box When selected, makes the task an open task and 

the Assignment planned hours field appears. 

For more information, see "Open tasks" on page 51.

Chargeable task check box When selected, makes the task chargeable.

Cross-charged to fixed-fee 
portion of the initiative check box

When selected, cross charges the task to a fixed-

fee portion of the initiative. The time entered for this 

task does not display on the cross charge.

Fixed fee list Deliverable to which the task is associated, if the 

Cross charged to fixed-fee portion of the 
initiative option is selected. Specifying a 

deliverable allows costs and revenues to be tracked 

against fixed fees.

Utilization eligible check box When enabled, the task time is included in the 

utilization for assigned resources. 

For chargeable projects, the option is automatically 

selected. For nonchargeable projects, the option is 

automatically cleared. The project manager can 

change the utilization eligible setting of any task.

Milestone check box When selected, identifies the task as a milestone on 

the Gantt chart, and automatically sets planned 

hours to zero. 
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Option Description

Capital check box When selected, designates the task as a capital 

cost.

Completed check box When selected, sets the task to completed status. 

Typically used for tasks that are not assigned to 

resources, such as milestone tasks. When a task is 

set to complete, the status for the task assignments 

is automatically set to complete.

The task is automatically set as completed when all 

of its task assignments are completed. 

Add to calendar check box When selected, the planned hours for the task are 

included in the personal calendars of the assigned 

resources and the resource scheduling calendar. 

Initiative non-labor item field  Non-labor items that can be associated with the 

task and  cross charged based on the status of the 

task.

Intiative non-labor item ready to 
cross-charge check box

When selected, the  non-labor item that is 

associated with the task becomes available for 

cross charging.

Comments field Additional information about the task. Comments 

can be viewed by all resources assigned to the task.

Time entry restrictions section

Restrict time entries to within the 
planned dates for option

Prevents resources from entering time for dates 

that are outside of the planned start and planned 

finish dates of the selected option  (task, task 

assignment).

Restrict time entries to within the 
planned effort for option

Prevents resources from entering time when the 

total time entered for the selected option exceeds 

the planned effort.
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Creating a task

You can create a task for planning purposes by completing only the following fields in the 
General section:

• Task name

• Project

• Planned start

• Planned finish

• Planned hours

After you have saved the task, you can complete the remaining fields and sections as required. 
For a list and description of all task fields, see "Task editing view, General section options" on 
page 53.

Note: Tasks at the top WBS level can be created or activated only by a project manager or 
project plan editor who has the project locked. 

1. Click My Tools > New and then select Task from the list.

The task editing view appears.

2.  In the Task name field, type the task name. 

3.  In the Project field, select the project for which the task is being created.

4.  In the Planned start field, enter the date that you expect the task to be started.

5.  In the Planned finish field, enter the date you expect the task to be finished.

6.  In the Planned hours field, enter the estimated number of hours required to complete the 
task.

7.  Do one of the following:

• To save the task, click Actions > Save. The task is created.

• To complete the remaining task sections, see "Completing the General section of the 
task editing view" on page 57.
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Completing the General section of the task editing view

For more information about the task fields, see "Task editing view, General section options" on 
page 53.

1. Access the task.

2.  Click Actions > Edit.

The edit task view appears.

3.  Complete the fields as required. 

4.  To make the task an open task:

a. Select the Open task check box. The Assignment planned hours field displays. If 
resource leveling is enabled, the value is 0 and cannot be edited.

b. If resource leveling is not enabled, you can specify planned hours for the open task. 

5.  To charge the task to a fixed fee portion of the initiative:

a. Select the Charged to fixed-fee portion of the initiative option.

b. In the Fixed fee field, specify the deliverable to which the task is associated.

6.  Click Actions > Save.

7.  To complete the remaining sections, see the following topics:

• "Changing the work location and work code settings for a task" on page 76

• "Assigning a resource to a task assignment" on page 58

• "Associating a task to an application" on page 57

Associating a task to an application

You can associate a task to one or more applications. The first application you select is marked 
as the primary application and is used for reporting purposes.

1. Access the task.

2.  Click Actions > Edit.

The edit task view appears.

3.  Expand the Applications section.
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4.  Expand the tree view and select the check boxes of the applications associated with the 
task. 

Tip: To change the primary application, click the name of the new primary application 
instead of the check box. 

5.  Click Save.

Assigning a resource to a task assignment
You can assign resources to tasks from the task editing view by creating a task assignment. 
When you create a task assignment, most of the fields have the same values as in the task, but 
they can be changed. The resources that you can assign to a task come from your preferred 
resources list or from the project team, when resource requests have been enabled.

1. Access the task.

2.  Click Actions > Edit.

The task editing view appears.

3.  Expand the Assignments section.

4.  Complete the fields as required. For more information, see "Task editing view, 
Assignments section options" on page 59.

5.  To specify a resource, in the Resource list, select the name of the resource that you want 
to assign to the task. 

6.  To add a resource to the list (and optionally to your preferred resources), click , which 

opens the Select  Resources dialog box.

7.  To specify the planned start and planned finish dates, do one of the following:

• Enter the dates in the Planned start and Planned finish fields.

• To have the system allocate effort for this task assignment, and calculate the planned 
start and finish dates, see the "About allocating planned hours for a task assignment 
automatically" section on page 64. 

8.  In the Assignments section, click Actions > Save. 

The resource is added to the task assignment table. 

9.  On the task editing view, click Actions > Save. 
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Task editing view, Assignments section options

Option Description

Resource list Resource assigned to the task.

Planned start date field Date that the task should start. The default date is the 

date that the task is created.

Planned finish date field Date that the task should be completed. The default date 

is the day after the planned start date.

Planned hours field Estimated number of hours that are required to complete 

the task. The planned hours for the task must equal the 

total of the planned hours for the task assignments.

Allocate effort based on 
resource's current 
committed workload check 

box

When selected, the effort is allocated and the planned 

start and finish dates are calculated automatically.

Staffing level type-ahead 

field

Default staffing level for resources that are assigned to 

the task. You can override the default when making 

specific staff assignments. The staffing levels come from 

the initiative. If no staffing levels are specified for the 

initiative, or the default was cleared for the task, the task 

assignment is created without a staffing level.

Cross charge rate field Cross charge rate for the resource. 

Staffing level cost rate and 

Resource cost rate fields

Staffing level-based or resource-based cost rate that is 

applicable to the task assignment. 

Function list Default job function for resources that are assigned to the 

task. You can override the default for task assignments.

Locked task check box When selected, prevents resources from entering time for 

the task assignments for the task. However, you can 

change the setting for individual task assignments.
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Option Description

Include in resource demand 

check box

When selected, new task assignments created for this 

task are included in resource demand analysis by default. 

Selected by default on new tasks. 

You can override the default for task assignments.

Status not required check 

box

When selected, resources are not required to update the 

status of their task assignments.

Work location group list

Work location list

Work location group and work location where the work will 

be performed.

Work code category list

Work code list

Work code category and work code of the task.

Allow work location 
override check box

When selected, resources can choose a different work 

location when they enter time for the task.

Allow work code override 

check box

When selected, resources can choose a different work 

code when they enter time for the task.

Soft-booked check box When selected, the resource is tentatively booked for 

planning purposes. Soft-booked time is shown as flexible 

on the resource schedule calendar.

When cleared, the resource is committed to the project.

Assignment comments field Additional information about the task assignment.

About selecting resources for tasks

The following options to help you select resources are available from the Actions menu on the 
Assignment section of the task editing view: 

• Check available hours to check if each assigned resource has enough available hours to 
cover the planned hours for the task. For more information, see "Checking the available 
hours of a resource" on page 61.

• Resource search to search for an available resource. For more information, see "Resource 
Searches" in the Resource Management User Guide.
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• Resource availability to view the calendar of a resource. For more information, see the 
"Resource Scheduling Calendar" in the Resource Management User Guide.

Checking the available hours of a resource

To avoid overbooking resources, you can check their available hours directly from the task 
editing view.

1. Access the task.

2.  Click Actions > Edit.

The edit task view appears.

3.  Expand the Assignments section and verify the Planned hours values for each of the 
resources.

4.  In Assignments section, click Actions > Check available hours.

The Check Available Hours dialog box appears. For more information, see "About 
checking the available hours for resources" on page 61.

When the planned hours for the task exceed the available hours for a resource, the values 
are displayed in red. However, you can still assign the task to the resource.

About checking the available hours for resources

The Check Available Hours dialog box displays the following information for each resource 
listed in the Assignment section of the task editing view. 

Resource name and task duration

The duration of the task is displayed next to the resource name. If the task status has not been 
updated, then the Planned start and Planned finish dates are used for the task duration. If the 
task status has been updated, then the Actual start and Forecast finish dates are used. 

Planned hours for this task

The planned hours for the current task.

Planned hours for all other tasks

For each task other than the current task, the total planned hours for the task are divided by the 
number of working days in the task duration to calculate a daily amount. The total of the daily 
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amounts for the tasks is then multiplied by the number of working days for the current task. If 
the task status has been updated, then Remaining hours are used instead of Planned hours.

Resource calendar entries

The total hours from all calendar entries, excluding the task assignment entries.

Available hours

Available hours = Total working hours – (Planned hours for all other tasks + Resource 
calendar entries)

Total working hours = Number of working days in the task duration * daily capacity for the 
resource

If the available hours is less than the planned hours for the current task and resource, then all 
of the values for the resource display in red. If the available hours is 0 or less, then 0 is 
displayed.

Example of Check Available Hours calculations

This example consists of a current task for a resource, who has also been assigned task A and 
task B during the same time period, and an explanation of how each of the values in the 
Check Available Hours dialog box is calculated.

Current task information

Planned start: Monday, January 1

Planned finish: Monday, January 8

Planned hours: 15

Non-working days: Monday, January 1 (legal holiday), Saturday, January 6, and Sunday, 
January 7

Working days in the task duration = 8 – 2 weekend days – 1 legal holiday = 5 days

Daily capacity (specified in user setup) = 8 

Total working hours: 5 * 8 = 40 

Planned hours for this task = 15

The planned hours for the task in this example is 15, which comes from the task assignment.
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Planned hours for all other tasks = 14

The planned hours for this task is 14, calculated as follows:

Task A, status has not been updated

Planned start: January 2

Planned finish: January 11

Working days in task A duration = 8 days

Planned hours = 16

Planned hours per day: 16 / 8 = 2

Planned hours for the current task duration (January 2 to 8) = 2 * 5 = 10

Task B, status has been updated

Actual start: January 5

Forecast finish: January 10

Remaining hours = 8

Working days in task B duration = 4 days

Planned hours per day: 8 / 4 = 2

Planned hours for the current task duration (January 5 and January 8): 2 * 2 = 4

Total planned hours for task A and task B: 10 + 4 = 14

Resource calendar entries = 12

The resource has three calendar entries, each for 4 hours.

4 * 3 = 12

Available hours = 14

The available hours is 14.

Available hours = Total working hours – (Planned hours for other tasks + Resource calendar 
entries) 

40 – (14 + 12) = 14
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The values in the Check Available Hours dialog box would display in red because the 
available hours (14) is less than the planned hours (15) for the current task.

About viewing cross charge rates and cost rates in task assignments

If you have view access rights to cross charge rates, the Cross-charge rate column and either 
Resource-based cost rate or Staffing level-based cost columns display in the task assignment 
table, and the corresponding fields display in the Assignments section. The rates come from 
the cost structure and cannot be edited.

You can show or hide the cross charge rate and cost columns that display in the task 
assignment table. Right-click anywhere on the task assignment table and select the appropriate 
option (Hide/show cross charge rates, Hide/show cost rates).

About allocating planned hours for a task assignment automatically

If your organization uses resource leveling, you can have the system allocate effort (planned 
hours) for a task assignment based on the availability of the resource. The system calculates 
the resource’s availability based on the following formula:

daily capacity * (percent available / 100) – committed resource demand hours

Where:

• daily capacity is the number of hours specified in user setup

• percent available is the percent available for planned work for the workgroup that the 
resource belongs to

• committed resource demand hours are the hours from demand items that resource has 
already been committed to

You also specify that the planned start and/or planned finish dates should be calculated 
automatically:

• Planned start date only – planned hours are allocated starting from the planned finish date 
and then to each working day before the finish date until all of the planned hours are 
allocated. The earliest date for which planned hours are allocated becomes the planned 
start date.

• Planned finish date only – planned hours are allocated starting from the planned start date 
and then to each working day after the planned start date until all of the planned hours are 
allocated. 
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• Both planned start and planned finish – the first date that the resource has hours available 
and which is on or after the current date or the earliest planned start date (whichever is 
later) becomes the planned start date. 

Planned hours are allocated starting from the planned start date and then to each working 
day after it until all of the planned hours are allocated. The latest working day for which 
planned hours have been allocated becomes the planned finish date.

In all cases, if the calculated planned start date is earlier than the original planned start date or 
the calculated planned finish date is later than the original planned finish date for the task, then 
the original planned dates for the task are changed accordingly.

Note: If project-level resource requests are enabled, then the hours can be allocated only 
within the planned start and finish dates in the approved resource request.

Allocating effort for a task assignment automatically

1. Access the task.

2.  Click Actions > Edit.

The edit task view appears.

3.  Expand the Assignments section.

4.  In the Resource list, select the resource.

5.  Select the Allocate effort based on Resource’s current committed workload check box.

6.  To specify the earliest date that the task assignment can start:

a. Select the Calculate start date check box. The Planned start field changes to No 
earlier than.

b. Enter the earliest acceptable start date.

7.  To specify the latest date that the task assignment can end:

a. Select the Calculate finish date check box. The Planned finish field changes to 
No later than. 

b. In the No later than field, enter the latest acceptable finish date.

8.  Click Allocate effort.
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The dates in the Planned start field and Planned finish fields are updated based on the 
allocation calculation.

Submitting resource requests for tasks
If resource requests have been enabled for tasks, you cannot assign a resource to a task 
directly. You must first submit a resource request, which must be approved by a resource 
manager. 

1. Access the task.

2.  Click Actions > Edit.

The edit task view appears.

3.  Expand the Assignments section.

4.  In the Planned hours field, enter the estimated number of hours required to complete the 
task.

5.  In the Planned start field, enter the planned start date for the task assignment. 

6.  In the Planned finish field, enter the planned finish date. 

7.  In the Staffing Level type-ahead field, enter a staffing level for the task assignment. 

8.  To request a specific job function, in the Function list, select the function.

The qualifications for the function appear in the Qualifications field.

9.  To request a specific resource, in the Requested resource type-ahead field, enter the name 
of the resource.

10.  In the Number of resource requests field, enter the number of resources that you require. 

11.  If no function and no resource is specified, in the Qualifications field, you can select 
specific skills and competencies for the resource request. 

12.  To mark a qualification as preferred, right-click the qualification and then select Set as 
preferred. 

13.  In the Assignment comments field, enter instructions for the resource manager.

14.  In the Assignments section, click Actions > Save.

The resource request is added to the assignment table and is marked as soft-booked. 

15.  At the top of the task editing view, click Actions > Save. 

66 | Changepoint PPM 2021



About saving task baselines

The request is submitted to the resource manager for approval. 

Deleting resources from task assignments

You can delete resources from task assignments provided that none of the following conditions 
exist:

• the resource has entered time or expenses for the task assignment

• the parent task is associated with a subproject

• there are outstanding resource requests that have not been canceled

If any of the above conditions exist for a resource, the delete option will not be available.

1. Access the task editing view. 

2.  Expand the Assignments section.

3.  Select the resource in the assignments table. 

4.  In the Assignments section, click Actions > Delete.

5.  Click OK to confirm.

6.  In the task editing view, click Actions > Save. 

About saving task baselines
You can save baselines for summary tasks, subtasks and tasks. When you save a baseline for a 
task, the planned information is first rolled up to the project level. If the option to roll up 
planned information from subprojects to parent tasks has been enabled for the parent project, 
then summary tasks will be updated to include the rolled up information from subtasks and 
subprojects. The system does not check whether resources have access to the subprojects 
before performing the rollup.

After the rollup, the baseline information for the task and its task assignments and the 
subprojects and projects above it in the WBS is saved. If the task is a summary task, then the 
baseline information for all tasks below the summary task and the project above it is also 
saved. If the task is a subtask, then the baseline information for all tasks and task assignments 
below the subtask, and the summary task and project above it is saved.

When you save a task baseline, the system uses the previous (most recent) baseline values for 
the other project tasks and task assignments when they are required to calculate summary task 
and project baselines. 
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Example of saving task baselines

In the following table, the Initial baseline column shows the baseline planned hours for a 
project after an initial baseline. The Updated column shows that the planned hours for 
subtask 1.1 and 1.2 were changed to 7 hours each. The Baseline subtask 1.1 column shows 
the baseline planned hours after a baseline was saved for subtask 1.1, which the system 
calculated by using:

• the updated planned hours for subtask 1.1 and the previous baseline planned hours for 
subtask 1.2, to calculate the baseline planned hours for task 1

• the previous baseline planned hours for subtask 2.1 to calculate the baseline planned hours 
for task 2

• the previous baseline planned hours for task 2 and the updated planned hours for task 1 to 
calculate the baseline planned hours for project 1

Project item

Initial 
baseline 
planned 
hours

Updated 
planned 
hours

Baseline 
subtask 1.1 
planned hours

Project 1 (rolled up from tasks 1 and 2) 21  22

Task 1 (rolled up from subtasks 1.1 

and 1.2)

11  12

Subtask 1.1 6 7 7

Subtask 1.2 5 7 5

Task 2 (rolled up from subtask 2.1) 10  10

Subtask 2.1 10  10

After a baseline is saved, the following information is displayed in the task profile and task 
assignment profile:

• Baseline start – the earliest planned start date of the tasks

• Baseline finish – the latest planned finish date of the tasks

• Baseline hours – total planned hours for the tasks
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Note: For some example project and task baseline scenarios, see "Scenarios for saving 
baselines" on page 179.

You can save a task baseline at any time. When you save a new task baseline, the previous 
baseline information is stored in the database. 

Saving a task baseline

1. Access the task.

2.  Click Actions > Baseline.

The Baseline start, Baseline finish, and Baseline hours are updated based on the current 
planned start date, finish date and hours of the task or subtasks.

3.  Refresh the details view to display the baseline information for the task and task 
assignments.

About saving a task baseline without affecting higher level tasks

Normally when a task baseline is saved, the system rolls up the baseline for all affected tasks 
below the selected task to the selected task itself, and then up to the appropriate project level 
above the selected task in the WBS. For more information, see "About saving task baselines" 
on page 67.

However, the project manager can enable the option to save a task baseline without affecting 
higher level tasks. If this option has been enabled for a project, when resources save a task 
baseline, they have the option to save the task baseline as usual, or up to the selected task level 
only.

Warning: Saving a baseline without affecting higher-level tasks can result in the project 
and task baselines being out of balance. 

If the option to roll up planned information from subprojects to parent task is enabled, it takes 
precedence over the option to save a baseline without affecting higher level tasks. In this case, 
if you baseline a subtask of a subproject, the baseline will be rolled up to the parent task even 
if you select the option to baseline without affecting higher level tasks.

For some example project and task baseline scenarios, see "Scenarios for saving baselines" on 
page 179.

Saving a task baseline without affecting higher level tasks

1. Access the task.
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2.  Click Actions > Baseline.

A dialog box appears.

3.  Select one of the following options:

• To save the baseline as usual, select Baseline all tasks above and below the selected 
task.

• To save the baseline without affecting higher level tasks, select Baseline only the 
selected task and tasks below it.

4.  Click OK.

5.  To view the baseline information for the task and task assignments, click the task in the 
tree view.

Restricting access to an open task

You can restrict access to open tasks to specific workgroups and roles. However, the resources 
who have been assigned to an open task can enter time for the task regardless of any access 
restrictions.

1. Access the task.

2.  Click Actions > Edit.

The edit task view appears.

3.  Expand the Restrict access for open tasks section.

4.  To enable access restrictions, select the Changepoint users allowed to enter time against 
this task check box.

5.  Select the check boxes for the workgroups and roles that can enter time for the task. 

6.  To automatically include the workgroups that are below the selected workgroups in the 
hierarchy, select Include children.

7.  Click Actions > Save.

Note: The access restrictions are automatically removed if the Open task check box is 
cleared on the task editing view.

About task dependencies (linked tasks)
You can create the following types of task dependencies between tasks:
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• finish-to-start – successor task cannot start until on or after the predecessor task finish date

• start-to-start – successor task cannot start until on or after the predecessor task start date

• finish-to-finish – successor task cannot finish until on or after the predecessor task finish 
date

• start-to-finish – successor task cannot finish until on or after the predecessor task start date

Note: Changepoint handles start-to-finish dependencies slightly differently than Microsoft 
Project. In Changepoint, the predecessor finish date is the working day before the 
successor start date, whereas in Microsoft Project, the predecessor finish date is the same 
date as the successor start date.

Note: You can link tasks in different projects in the task profile only. 

You cannot change the start date of the successor task directly if the start date is determined by 
the predecessor task. Similarly you cannot change the finish date of a successor task directly if 
the finish date is determined by the predecessor task. 

Task dependency options

Field Description

Dependency type field Dependency type. Options are:

• Finish-to-start (default)

• Start-to-start

• Finish-to-finish

• Start-to-finish

Lag time field Number of days between planned start date or finish date 

of the predecessor task and the planned start date or finish 

date of the successor task, according to the dependency 

type. Default value is 0 days. 
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Field Description

Move successor task date check 

box

When enabled, does the following:

• allows the successor task dates to be moved when the 

predecessor task is moved

• when the predecessor task is moved, removes any 

gap between the linked tasks according to the 

constraints of the dependency type 

Selected by default.

Successor can start anytime 
after the predecessor  check box

When enabled, if a predecessor task is moved, the 

successor task dates are moved only when required to 

ensure that the successor starts after the predecessor. 

Cleared by default.

Send notification check box When enabled, sends an email notification to the project 

manager when the planned dates are moved due to task 

dependencies. Selected by default.

Linking tasks from the task profile

In the Create Task Dependency dialog box, the Successor tasks tab displays a table of the 
tasks that are already linked to the current task. When the View selected tasks option is 
selected, a project tree view displays under the options that shows the hierarchy of linked 
tasks. On the Successor tasks tab, you configure dependencies in which the current task is a 
predecessor task. On the Predecessor tasks tab you configure dependencies in which the 
current task is a successor task.

1. Access the task. 

2.  Click Actions > Create > Task dependency.

The Create Task Dependency dialog box appears.

3.  In the Successor tasks tab, select Modify selected tasks.

A project tree view displays all of the projects and related tasks to which you have edit 
access rights. 

4.  Expand the tree view to locate the successor task. Tasks that are already successor tasks of 
the current task are displayed in bold font.

5.  Double-click the successor task.
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The task is added to the table.

6.  Specify the options as required. For more information, see "Task dependency options" on 
page 71.

7.  To save the link, click in the table, but outside of the current row.

8.  Click OK to confirm.

9.  Click OK.

10.  To specify a predecessor task:

a. Click the Predecessor tasks tab.

b. Create the link as described above.

11.  Click Close.

Unlinking tasks from the task profile

1. Access the task.

2.  Click Actions > Create > Task dependency.

The Create Task Dependency dialog box appears.

3.  Do one of the following:

• Right-click the successor task in the table and select Delete.

• Click the Predecessor tab and then right-click the predecessor task in the table and 
click Delete.

The task is unlinked and removed from the table.

4.  You can unlink tasks from tree view at the bottom of the dialog:

a. Select the Modify selected tasks option. 

b. Search for the task or expand the tree view to locate the linked task. The names of 
linked tasks are in bold text.

c. Right-click the linked task and select Remove from successor task or Remove from 
predecessor task. The task is unlinked and removed from the table.

5.  Click Close.
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Accessing the task editing view
1. Click Project > Profiles. 

The Projects tree view appears.

2.  Expand the project that the task belongs to. 

3.  Do one of the following:

• Double-click the task name.

• Right-click the task name and select Edit.

• Select the task to open the task profile and then click the Actions menu and select 
Edit.

The task editing view appears.

About editing the Chargeable status of a task

If you change the chargeable status of a task, the Effective date check box appears.

If you specify an effective date, then the time records from the effective date and later use the 
new chargeable status. All cross charges created before the effective date use the previous 
chargeable status. 

If you do not specify an effective date, all time records that have not been cross charged use 
the new chargeable status.

If an effective date was previously entered for the chargeable status, and you do not specify an 
effective date, then all of the time records use the new chargeable status.

For example, a new task is marked as chargeable, and time is entered for May 1 to 5. If the 
chargeable option is later cleared and an effective date of May 3 is specified, then time for 
May 1 and 2 would be chargeable, but time for May 3, 4 and 5 would be nonchargeable. 
However, if the chargeable option is cleared and an effective date is not specified, time for 
May 1 to 5 would be nonchargeable.

You cannot change the Chargeable task option if any of the following conditions exist:

• the initiative has not been configured to allow project managers to override the chargeable 
status
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• the split charges option has been enabled on the initiative, and cross charges exist under 
the initiative or phantom initiative which is in Archive status

• the split charges option has been enabled on the initiative, and all cross charges have been 
committed but there is time under the initiative or phantom initiative that has not been 
fully cross charged

About editing configurable fields on tasks

When you create a task, the values of the configurable fields for the task are automatically 
applied to task assignments, even if you create the task assignments at the same time as you 
are creating the task. However, if you edit the values for a configurable field and you want the 
new value to be applied to new task assignments, you must save the task first before creating 
the new task assignments.

Changing the staffing level for a task

When you change a staffing level, you must also specify an effective date for the change. You 
must ensure that the appropriate staffing level is in effect when time records for the task 
assignment are cross charged. Changes made to the staffing level are tracked in the task 
assignment history. 

Note: You cannot change the effective date for a staffing level once you have saved it, and 
subsequent changes to staffing levels must have an effective date that is later than the 
current effective date.

1. Access the task.

2.  Click Actions > Edit.

The edit task view appears.

3.  Expand the Assignments section.

4.  Select the row for the resource whose staffing level is being changed.

5.  In the Assignments section, click Actions > Change staffing level.

The Change Staffing Level dialog box appears.

6.  In the Staffing level list, select the new staffing level.

7.  In the Effective date field, enter the effective date of the new staffing level.

8.  Click Save.
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9.  Click OK to confirm.

10.  In the Assignments section, click Actions > Apply.

11.  At the top of the task editing view, click Actions > Save. 

Changing the work location and work code settings for a task

The default work locations and work codes come from the project, but you can change them 
for tasks. You can also allow resources to choose a different work location or code when they 
enter time for a task.

1. Access the task.

2.  Click Actions > Edit.

The edit task view appears.

3.  Expand the Work locations/work codes section.

4.  In the Work location group list, select the general location where the work will be 
performed. 

5.  In the Work location list, select the specific work location where the work will be 
performed.

6.  From the Work code category list, select the work code category.

7.  From the Work code list, select the work code.

8.  To allow resources to choose a different work location when they enter time for the task, 
select the Allow work location override check box.

9.  To allow resources to choose a different work code when they enter time for the task, 
select the Allow work code override check box.

10.  Click Actions > Save.

Deleting a task

You cannot delete a task if either of the following conditions exist:

• chargeable time has been entered for the task and that time has not been cross charged

• an expense has been associated to the task
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Also, if the Add to calendar option is enabled on the task when it is deleted, the planned 
hours for the task are removed from the personal calendar of the assigned resources and from 
the resource scheduling calendar.

1. Access the task.

2.  Click Actions > Edit.

The edit task view appears.

3.  Click Actions > Delete.

4.  Click OK to confirm.

About reopening a completed task

Project managers, and the resources that are assigned to a completed task, can reopen the task 
provided that the project is still active. If the task has locked task assignments, you must 
unlock them first. 

When you reopen a task, all of its task assignments are reopened with the following settings: 

• percentage complete is set to 99

• remaining hours is set to 1.00

• actual finish date is cleared

When you reopen a subtask, the summary task is also reopened. Reopening a subtask 
automatically opens all related tasks up to the highest level.

Reopening a completed task (for project managers)

This procedure applies to project managers. For the procedure for resources, see "Updating the 
Status of a Task" in the Time and Expense Management User Guide.

1. Access the task.

2.  Click Actions > Edit.

The edit task view appears.

3.  Expand the Assignments section.

4.  If there are locked task assignments that you want to reopen, you must unlock them.

a. Select the task assignment.
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b. Clear the Locked task check box.

c. In the Assignments section, click Actions > Save.

d. Repeat for each locked task assignment.

5.  In the General section, clear the Completed check box.

6.  Click Actions > Save.

A message appears, asking if you want to reset the forecast dates. 

7.  Do one of the following:

• To reset the forecast start and finish dates to the planned start and finish dates for all 
reopened task assignments, click OK.

• To leave the dates unchanged, click Cancel.

Sorting tasks

You must use Project Worksheet to change the order of tasks. 
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Project Worksheet basics

Project Worksheet is a spreadsheet-like application that you use  to do the following:

• create tasks and edit all task fields

• assign resources to tasks

• create task assignments and edit all task assignment fields

• allocate planned effort to daily or fiscal periods

By default, the tasks that you create in Project Worksheet are  draft, and must be activated 
before they appear in the projects tree view and the timesheet. 

The Gantt chart appears by default, but you can hide it or display only the Gantt chart and 
not the table rows. 

Project Worksheet settings

You can set default settings for Project Worksheet. For more information, see the following 
topics:

• "Automatically activating draft tasks in Project Worksheet" on page 136

• "Setting up a warning when effort distribution on task assignments is overridden" on 
page 120

• "Specifying a default dependency type and lag time in Project Worksheet" on page 113

Project Worksheet best practices

For the best results when using Project Worksheet, the following best practices are strongly 
recommended.

Add only the required resources to your preferred resources list

It is not good practice to add all of the resources in your organization to your preferred 
resources. Add only the resources that you assign to tasks regularly. A long list of preferred 
resources increases the loading time of Project Worksheet because the nonworking days data 
for each resource is preloaded.
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Limit the length of task durations

Limit the length of task durations, ideally to a year or less. It is not good practice to have an 
open task with a duration that spans many years. The nonworking day information is preloaded 
for each task based on the date range within the worksheet, which means that tasks that have 
long durations require years of data to be preloaded. 

Limit the number of tasks, and resources assigned to a task

Keep the number of tasks within a project, and the number of assignments for each task to a 
reasonable level. Having a single open task that hundreds or thousands of resources enter time 
for can cause serious performance issues in Project Worksheet. If you require tasks for year-
long activities such as training and development, nonchargeable work, or meetings, consider 
doing the following instead:

• creating a new project for each fiscal year

• creating separate projects for different parts of the organization

• restricting access to open tasks by workgroups or functions

Keep projects at a manageable size

Keep project size from 400 – 1200 task or task assignment rows, and do not have more than 
100 rows under any given level.

Create at least three levels of hierarchy in projects

Projects with a flat list of tasks are difficult to manage and take longer to be displayed in 
Project Worksheet because all of the tasks must be displayed each time you access the 
worksheet. In contrast, when the tasks in a project are organized in a hierarchy, you can 
expand and collapse sections to focus on the data that you need to modify.

Grant "view project" access to summary task managers 

Grant View project access to summary task managers so that they can view the entire project 
in Project Worksheet. Otherwise summary task managers can only view the tasks under their 
summary tasks, and if they make changes, the values will be rolled up to include only the 
amounts from their summary tasks and not the project totals.

Avoid saving the worksheet frequently

Doing work in batches and then saving will result in better performance and less waiting.
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Use Firefox or Chrome browsers

The Firefox and Chrome browsers are recommended because they are more efficient at 
processing data than other browsers.

Do not access different versions of Changepoint at the same time

If you have access to different versions of Changepoint for example, in test and production 
environments, do not access them at the same time because you might encounter issues due to 
the caching of files. Ensure that you clear your browser cache before signing into a different 
environment.

Ensure all time records are actual time before marking tasks or task 
assignments as completed.

The point at which time records are considered actual time by your organization is controlled 
by a setting  in Changepoint Administration. The setting options are:

• when the time is entered in the time sheet

• when the time records are submitted in the time sheet

• when the time records have been approved

The actual finish date is determined based on the actual time for the tasks or task assignments 
at that time that the task or task assignment is marked as completed. If time records are 
considered actual time only after time is submitted or approved, and  a task or task assignment 
is marked as completed before the time records have been submitted or approved, there might 
be an actual finish date, but no true actual hours. 

About accessing Project Worksheet

The type of work you can do in Project Worksheet depends on your project role, access rights, 
and locked state of the project and tasks. The locked state of the tasks is indicated in the State 
column:
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Locked state 
icon

Meaning

You have locked the task.

Task is locked by another resource. To view the resource's name, 

point to the icon.

You do not have access to lock the task.

[blank] Task lock has been released and it is available to be locked.

When the project manager or a project plan editor accesses a project in Project Worksheet:

• the project is locked, provided that none of the tasks are locked by other resources. When 
you have a project locked, "Locked by: me" appears beside the project name. No other 
resources can lock any tasks unless the project manager or project plan editor unlocks one 
or more tasks. 

Note: Top-level WBS tasks can be created and activated only when the project manager or 
project plan editor has locked the project.

• if some tasks are locked, then all of the project tasks that are not currently locked by other 
resources are automatically locked

• when tasks are locked by summary task managers, the project manager and project plan 
editors can still view the locked tasks but not edit them

• only the project manager can override the locks that other resources have on tasks

When a summary task manager accesses a project in Project Worksheet:

• all of the tasks in the WBS branches of their summary tasks for the project that are not 
already locked by another resource are automatically locked

• only the tasks in the WBS structure of the summary tasks and any successor tasks of those 
tasks are displayed

Note: It is recommended that summary task managers be granted view access to the 
project so that they can view the entire project structure.
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When tasks are locked by other resources, the lock icon in the State column is grayed out. 
When the tasks are unlocked by the other resource, the lock icon disappears. You can then 
obtain the locks by reloading the Project Worksheet.

Tip: To identify the resource who has the tasks locked, point to the lock icon.

Note: When a task is locked in Project Worksheet, none of the tasks for the same project 
can be edited outside of Project Worksheet.

Accessing Project Worksheet

1. Click Project > Profiles.

The Projects tree view appears.

2.  In the tree view, do one of the following:

• Right-click the project and select Project Worksheet.

• Click the project to open the project profile, and then click Actions > Project 
Worksheet.

Project Worksheet appears. The tasks that you have edit access to are automatically locked. 
If you are the project manager or project plan editor and all the tasks in the project are 
locked, your name is displayed beside the project name.

About using Project Worksheet

Project Worksheet includes a task view and Gantt chart in the top half of Project Worksheet 
and a task assignment view and Gantt chart in the bottom half. When you first access Project 
Worksheet, your default task and task assignment views are displayed. If you change one or 
both of the views,  the same views are displayed until you exit from Project Worksheet.

Task assignments that correspond to the tasks in the task view are automatically displayed in 
the task assignments view. When no tasks are selected, then all task assignments are displayed. 
When you select tasks or apply filters to tasks or task assignments, the list of task assignments 
changes accordingly.

The Worksheet toolbar is displayed above the views and includes the actions that apply to the 
overall worksheet . The task or task assignment view that is currently active displays an 
Actions toolbar below the view. To make the other view active, click anywhere within the 
view.
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Adjusting the task or task assignment view in Project Worksheet

1.  To make a task or task assignment view active, click anywhere in the view. The top border 
of the active view becomes blue, the view name appears in the Worksheet toolbar and the 
Actions toolbar appears below the view.

2.  To change the height of a view, select and drag the horizontal split bar.

Locking and unlocking tasks

You lock additional tasks by reloading the worksheet after tasks are unlocked by other 
resources. When you unlock a task, all associated tasks in the WBS structure are also 
unlocked.

Project managers can override locks on tasks in their projects. When a project manager 
overrides a lock on a task, all of the task locks that the same resource had locked are 
overridden.

1. To lock tasks that have become available, reload the worksheet by clicking Refresh.

2.  To unlock a task, click the lock icon  in the State column for the task row.

3.  To unlock all tasks, click  More > Unlock all tasks.

4.  To override the lock that another resource has on a task, do one of the following:

• To override the locks on some tasks, select the tasks and then click  More > 

Override locks.

• To override all locks on all tasks, do not select any tasks (or select all tasks) and then 
click  More > Override locks

Warning: When locks are overridden, the resources who previously had the tasks locked 
will lose all of their unsaved changes.

About the project summary totals in Project Worksheet

The following project summary totals are displayed in the worksheet above the tool bar:

• planned start

• planned finish

• planned effort

• actual effort
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• remaining effort

All of the values except for actual effort are updated as you make changes in the worksheet. 
The actual effort is updated only after you validate the changes or save the worksheet. 

Note: The values for draft tasks are included in the project summary totals in Project 
Worksheet only. Therefore these project summary totals may be different than the values 
that are displayed in the project profile, which exclude draft task values.

Tip: To obtain the most accurate results for the remaining effort amount, you must enable 
status updates for all project tasks and ensure that resources update the status of their tasks 
regularly.

Project Worksheet keyboard shortcuts

Action Key combination

Add a task row Insert key

Copy selected tasks Ctrl+C

Go to next cell Tab

Go back to previous cell Shift+Tab

Go to row or item above Up Arrow key

Go to row or item below Down Arrow key

Edit a text field

• Go to the beginning of the text (when the text is highlighted) –Left Arrow

• Go to the end of the text (when the text is highlighted) – Right Arrow

• Go right within the text – Right Arrow

• Go left within the text – Left Arrow

• Go right to the next word – Ctrl+Right Arrow

• Go left to the next word – Ctrl+Left Arrow

Expand tasks Alt+Shift+Plus sign (+)

Collapse tasks Alt+Shift+Minus sign (-)

Indent selected tasks Alt+Shift+Right Arrow
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Action Key combination

Outdent selected tasks Alt+Shift+Left Arrow

Paste selected tasks Ctrl+V

Search – open the search field

Search – move up (or down) through the matching rows

Ctrl+F, F3

F3 (Shift+F3)

Select or clear a check box Spacebar

Adjusting the width of columns in Project Worksheet

1. Point to the divider between two column headings until the cursor changes to a double-
sided arrow.

2.  Move the cursor to the desired width.

To adjust the width for all Effort distribution columns at once 

Note: This adjustment is temporary and applies only while you are working in the current 
view.

1. Press and hold the Ctrl key and point to the divider between two Effort distribution 
columns (daily or fiscal period) headings until the cursor changes to a double-sided arrow.

2.  Adjust the column to the desired width. All effort distribution columns are adjusted to the 
same width.

Expanding and collapsing tasks in Project Worksheet

You can show and hide the subtasks under a task by expanding and collapsing tasks, subtasks, 
or the entire project as follows:

• To expand a single task or subtask, click the right arrow next to the task or subtask name.
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• To collapse a single task or subtask, click the down arrow next to the task or subtask name.

• To expand or collapse all subtasks under a task, click the task row, and then click  or 

.

• To expand or collapse all tasks in a project, do one of the following:

• ensure no tasks are selected and then click  or 

• select all tasks, and then click  or 

Note: If the project is large, it may take a while for all tasks to be expanded.

Indenting and outdenting tasks in Project Worksheet

You can indent or outdent one or more tasks at a time.

1. Access Project Worksheet.

2.  Select one or more tasks.

3.  To indent the tasks, click .

4.  To outdent the tasks, click .

Searching in Project Worksheet

You can search for items in Project Worksheet. The search applies to all information that is 
included in the current worksheet view.

1. Click the search icon .

2.  Enter the search text into the search field and then press Enter. The number  of rows that 
include matching results is displayed in the search field and the first matching row is 
highlighted.

3.  To navigate through the rows that include matching results, click the up and down arrows 
in the search field.

4.  To close the search field, click the x on the right side of the search field.

Moving a task in Project Worksheet

You can move one or more tasks to a different row in Project Worksheet. When you move a 
task, all of its subtasks are moved, and the row IDs are adjusted accordingly, including in the 
Predecessor column of dependent tasks. 
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1. Select the tasks that you want to move.

2.  Point to the ID column.

3.  When the cursor changes to a two-headed arrow , drag it to the desired row. A line 

appears above the row where the tasks will be inserted.

Displaying time periods that start from a specific date in Project Worksheet

To display fiscal or daily periods starting from a specific date, click the Enter date icon , 

specify the date, and then press Enter.

The range of fiscal periods, starting with the fiscal period that includes the specified date or 
the range of daily periods, starting with the daily period for the date, is displayed. If you select 
a date for which no fiscal or daily periods have been configured, then no periods are displayed 
at all.

Displaying different fiscal periods or daily periods in Project Worksheet

When fiscal periods have been selected for a project, you can display different fiscal periods, 
or daily periods in Project Worksheet.

Click the Switch fiscal periods icon  and then select the fiscal or daily periods to be 

displayed.

Displaying the previous or next specified number of periods in Project 
Worksheet

1. In the number of periods field , do one of the following:

• for fiscal periods, enter a number (x) between 1 and 24 for the number of fiscal 
periods that you want the starting fiscal period to change by

• for daily periods, enter a number (x)  between 1 and 31 for the number of daily periods 
that you want the starting fiscal period to change by

2.  To display the range of periods that starts with the x number of periods before the current 
starting period, click .

3.  To display the range of periods that starts with the x number of periods after the current 
starting period, click .
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About printing in Project Worksheet

You can print Project Worksheet by clicking  More > Print. The printout includes each 

row, but only includes the columns and portion of the Gantt chart that are displayed in the 
current view. 

Running a report from Project Worksheet

You can run reports from Project Worksheet. Reports that are configured to be launched from 
either the project or task profile page will be available. 

When a report is run from Project Worksheet, the following differences apply:

• links to entity records are not available

• draft tasks will appear in reports only if the report is based on the unsecured Cognos data 
model

To run a project report

In the Worksheet toolbar, click Reports, and then select the project or task report.

To run a task report 

1.  Select a task row.

2.  In the Worksheet toolbar, click sReport and then select a task report from the list that 
appears.

Exporting Project Worksheet data to Microsoft Excel.

You can export the worksheet data in the current view to a Microsoft Excel spreadsheet. 

Tip: To be able to sort the rows by WBS order in Excel, be sure to include the WBS field 
in the view.

Click  More > Export to Excel.

Copying values in rows in Project Worksheet

You can copy a value from a column in a source row to one or more target rows that are below 
the source row. You can copy a value from any of the columns in the current Project 
Worksheet view, except for the Resources column.

1. In Project Worksheet, select the source row that contains the value that you want to copy.

2.  Select one or more target rows that are below the source row.
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3.  Click    Fill down, and then select the name of the column that contains the value that 

you want to copy.

The value is copied to each of the target rows.

Saving baselines in Project Worksheet

To save a project baseline

Click  More > Save project baseline.

The baseline information is saved to the project profile.

To save a task baseline

1. Select the task row.

2.  Click . One of the following occurs:

• The baseline information is saved to the task profile.

• If the option to save task baselines without affecting higher level tasks has been 
enabled on the project, then the Save Baseline Options dialog box appears.

3.  In the Save Baseline Options dialog box, select one of the following options:

• To save the baseline as usual, select Baseline all tasks above and below the selected 
task.

• To save the baseline without affecting higher level tasks, select Baseline only the 
selected task and tasks below it.

4.  Click OK.

About using Project Worksheet for time-based projects

For time-based projects, you use Project Worksheet only to create the tasks to be assigned 
using Service Scheduler. The assignments that are created in Service Scheduler are displayed 
in Project Worksheet with the following limitations:

• assignments are read-only and can only be edited in Service Scheduler

• the effort for an assignment is displayed on the start date of the assignment, even when the 
assignment spans over two calendar days. For example, you create an assignment with a 
two hour duration from 11:00 PM February 1 to 01:00 AM February 2. The same 
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assignment in Project Worksheet is displayed on February 1 with a planned effort of two 
hours.

• open tasks and task dependencies are not supported

• summary tasks do not support time-based assignments, but the subtasks do

• time-based projects can be copied but their assignments cannot be copied

Note: In the above case, time entry restrictions for the task will not be effective because 
the restrictions cannot be applied to the individual assignment time slots.

About Project Worksheet views
Project Worksheet views control the data that is displayed in Project Worksheet. There is a 
default view for tasks, which contain a subset of the task fields. You can edit the default task 
view as well as create your own task and task assignment views.

Task views

You use task views to do the following:

• create tasks

• edit task fields

• create task assignments that use the default loading method

In general, task assignments that are created in the task view automatically inherit the values of 
the task fields that are displayed in the task view when the task assignment is created. 

In some cases, you might not be able to edit the planned start, planned finish, or planned effort 
in a task view (for example, if any assignments have a manual loading method). In these cases, 
you must switch to a task assignment view.

Task assignment views

You use task assignment views to do more detailed assignment work such as:

• manually distribute effort to daily or fiscal periods

• use different loading methods for assignments for the same task

• assign different planned start and planned finish dates to assignments for the same task

• change the assigned resource
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• add additional resources to a task once one or more of the points above apply to it

Note: Only task assignments are displayed in a task assignment view. Therefore there 
must be at least one existing task assignment for a task before you can assign additional 
resources to the task.

You add a new task assignment or copy a task assignment based on an existing task 
assignment. New task assignments have current dates and inherit the default loading method 
only. Copied task assignments are the same as the original task assignments but do not have 
the assigned resources.

About creating Project Worksheet views

You can create your own task views or task assignment views, where you do the following:

• include either task or task assignment fields

• specify the standard and configurable fields  that are displayed as columns in Project 
Worksheet

• add columns to, and remove columns from, the frozen pane

• change the order of the columns

• specify a view as your default view

• share your views with other resources

• specify a sort order for the rows

Note: Only the values of fields that are in a view that has been displayed in the current 
Project Worksheet session are inherited or copied when you create or copy a task or task 
assignment, or replace assigned resources. 

About related columns

The following pairs of columns are related and either must be updated at the same time, or the 
value in one affects the value in the other. Therefore it is best to display both columns in the 
worksheet if you plan to work with them:

• Staffing level and Staffing level expiry date. If you change the staffing level, you must 
specify the date after which the new staffing level becomes effective.

• Chargeable task and Effective date

• Cross charged to fixed-fee portion of the initiative and Fixed fee
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• Work code category and Work code

• Work location group and Work location

• Locked and Include in resource demand

• Open task and Assignment planned hours

Creating a Project Worksheet view

1. Access Project Worksheet.

2.  Click the Switch or manage views icon  > Manage views.

3.  In the Manage Views dialog box, do one of the following:

• To create a new view, click  New.

• To copy an existing view:

• In the Views list, select the view that you want to copy.
• Click  Copy.

4.  Complete the fields as required. For more information, see:

• "Manage Views (Project Worksheet) dialog box options" on the next page

• "Available columns for Project Worksheet task views" on page 95

• "Available columns for Project Worksheet task assignment views" on page 100

5.  To add columns to the view, in the Available columns list, do one of the following:

• select one or more columns and then drag them to a specific location in the Selected 
columns list

• double-click a column to add it to the bottom of the list in the  Selected columns list

• select one or more columns and then click 

Tip: You can filter the columns by typing the column name in the Filter available 
columns field.

6.  To prevent a column from scrolling horizontally, click the Frozen check box.
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Note: Frozen columns must be placed together at the top of the Selected columns list 
before columns that are not frozen.

Note: Do not select this option for the Effort distribution column because it can cause 
issues due to its size.

7.  To remove a column from the view, do one of the following:

• double-click the column or click 

• drag the column to the Available columns list

• select one or more columns and then click 

8.  To move all of the columns in a section at once, click Select all, and then drag the 
columns to the desired list, or click  or .

9.  To change the order of the columns, select a column name and then drag it to the desired 
position in the list. The columns display left to right in Project Worksheet in the order that 
they are listed in the Selected columns lists. 

10.  When you are finished,  click Save.

Manage Views (Project Worksheet) dialog box options

Option Description

View list Current view. 

Name field Name for the  view.

Type of view field Option to select whether the view displays tasks or task 

assignments.

Share view with others 
check box

When selected, allows other resources to use the view. 

Available only if you have the access rights to share views.

Set as my default view 

check box

When selected, makes the current view the default view for 

the current resource and removes the default status from the 

view that was previously specified as the default, if applicable.

Available Columns section
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Option Description

All columns list List of available entity fields to be displayed as columns.

Selected Columns section

Frozen check box When selected, the column remains in place even when you 

scroll horizontally. The order of the columns from top to bottom 

in the list is the order that the columns display in Project 

Worksheet from left to right.

Sort data in  section

Sort by column data list Determines the sort order for the  rows. For more information, 

see "Sorting the rows in Project Worksheet " on page 105.

Available columns for Project Worksheet task views

Column name Description

Actual finish date field Date of the latest time record or the date that the task is marked 

as completed.

Actual hours field Total number of hours  of work that have been entered for the 

task.

Actual start date field Earliest date that hours have been entered for work done for a 

task.

Add to calendar check 

box

When selected, the planned hours for the task are included in 

the personal calendars of the assigned resources and the 

resource scheduling calendar. 

Allow work code 
override check box

When selected, resources can choose a different work code 

when they enter time for the task.

Allow work location 
override check box

When selected, resources can choose a different work location 

when they enter time for the task.
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Column name Description

Assignment planned 
hours field

For open tasks only.  Planned hours for new task assignments 

that are created when a resource enters time for the open task. 

This field is not available when resource restrictions or resource 

leveling is enabled.

Baseline finish date 

field

Latest planned finish date of all task assignments and subtasks, 

as at the last time a baseline was created for the project or task.

Baseline hours field Total planned hours for project tasks.

Baseline start  date 

field

Earliest planned start date of all task assignments and 

subtasks, as at the last time that a baseline was created for the 

project or task.

Capital check box When selected, designates the task as a capital cost.

Chargeable task check 

box

When selected, indicates that the task is chargeable.

Comments field Additional information about the task.

Completed check box When selected, sets the task to completed status. Typically 

used for tasks that are not assigned to resources, such as 

milestone tasks. When a task is set to complete, the status for 

the task assignments is automatically set to complete.

The task is automatically set as completed when any of the 

following occur:

• all of its task assignments are completed

• Percent complete is set to 100

• Remaining effort set to 0

Critical check box Read-only. When selected, indicates that task is on the critical 

path for the project. 
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Column name Description

Cross-charged to 
fixed-fee portion of 
the initiative check box

When selected, cross charges the task to a fixed-fee portion of 

the initiative. The time entered for this task does not display on 

the cross charge.Note: Changing the setting affects all 

uncharged time.

Draft check box Read-only. When selected, indicates the task is draft.

Duration field Number of working days between planned start and planned 

finish dates of the assignment. If no assignments exist or 

multiple assignments exist, the working days come from the 

staffing workgroup of the initiative.

Changing the value to 0 automatically makes the task a 

milestone and enables the Milestone option and sets the 

planned hours to 0. 

Effective date field The date of the new chargeable status for the task if the 

chargeable status of the task has been changed. The new 

status is applied to all uncharged time records dated on or after 

the specified date. 

Tip: To clear all existing history of changes to the chargeable 

status and apply the new status to all uncharged time records, 

you can leave the field blank.

Effort Distribution 

columns

Displays daily or fiscal period columns for allocating planned 

effort manually or automatically, depending on the loading 

method.

Fixed fee list Deliverable to which the task is associated, if the Cross 
charged to fixed-fee portion of the initiative option is 

selected. Specifying a deliverable allows costs and revenues to 

be tracked against fixed fees.

Forecast finish date 

field

Estimated date that the task will be completed.

Forecast start date 

field

Estimated date that work will begin for a task.
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Column name Description

Function list Default job function for resources that are assigned to the task. 

You can override the default for task assignments.

ID Row identifier for use in task dependencies. Also used for 

moving tasks where applicable.

Include in resource 
demand check box

When selected, new task assignments created for this task are 

included in resource demand analysis by default. Selected by 

default on new tasks.

You can override the default for task assignments.

Initiative non-labor 
item ready to cross-
charge check box

When selected, the initiative non-labor items that are 

associated with the task become available for cross charging.

Initiative non-labor 
items field

Non-labor items that are associated with theinitiative and for 

which the Allow selection on tasks option has been selected. 

When an initiative non-labor item is associated with a task, it 

can be cross charged based on the status of the task. 

Locked by field Read-only. Resource who has locked the task.

Locked task check box When selected, prevents resources from entering time for the 

task assignments for the task. However, you can change the 

setting for individual task assignments.

Milestone check box When selected, indicates that the task is a milestone. 

Milestones are displayed as diamond-shaped icons in the Gantt 

chart.

When first selected, the duration and planned hours are 

automatically set to 0.  

MSP WBS number 
field

For MSP projects only. The Microsoft Project work breakdown 

structure number for the task.
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Column name Description

Non-labor item list Non-labor item associated with the task for reporting purposes. 

That is, you can create reports based on the e non-labor items 

that are associated with the tasks. 

If you associate more than one non-labor item with a task, thee 

non-labor item that is closest to the top of the list alphabetically 

is designated as the primary e non-labor item. If required, you 

can change the primary non-labor item in the task editing view.

Open task check box When selected, makes the task an open task and the 

Assignment planned hours field appears. 

For more information, see "Open tasks" on page 51.

Open task restriction 

check box

Read-only. When selected, access to the current open task has 

been restricted. 

Phase Specifies the project phase that the task belongs to.

Planned finish Date that work for the task is scheduled to finish.

Planned hours Estimated effort that is required to complete the task. If you use 

the Resources list on a task view to assign more than one 

resource, the effort is initially split evenly among the resources.

Planned start Date that work for the task is scheduled to start.

Predecessors Task ID of the task on which the current task has a dependency. 

Remaining hours field Number of planned hours remaining to complete the task, 

based on resource status updates.

Request type-ahead 

field

Number of the request that is associated with the task.

Resources list Resources who are assigned to the task.

Staffing role field Default staffing level for resources that are assigned to the task. 

The staffing levels come from the initiative.
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Column name Description

Status not required 

check box

When selected, resources are not required to update the status 

of their task assignments. The project rollup calculates the 

remaining hours as planned hours minus actual hours. If the 

actual hours are greater than the planned hours, remaining 

hours will be set to 1. The option can be overridden on the task 

assignments.

Task name field Name of the task.

Utilization eligible 

check box

When enabled, the task time is included in the utilization for 

assigned resources. 

WBS field Work breakdown structure for the task.

Work code category 

list

Work code list

Work code category and work code of the task. Can be used for 

taxation and reporting purposes.  Can be used for reports and 

calculating taxes.

Work location group 

list

Work location list

Work location group and work location where the work will be 

performed.  Can be used for reports and calculating taxes.

Available columns for Project Worksheet task assignment views

Option Description

Actual finish date field Date of the latest time record or the date that the task 

assignment is marked as completed.

Actual hours field Total number of hours  of work that have been entered for 

the task assignment.

Actual start date field Earliest date that hours have been entered for work done 

for a task assignment.

Allow work code override 

check box

When selected, resources can choose a different work 

code when they enter time for the task assignment.
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Option Description

Allow work location 
override check box

When selected, resources can choose a different work 

location when they enter time for the task assignment.

Assignment comments field Additional information about the task assignment.

Baseline finish date field The finish date of the last baseline that was saved for the 

task assignment.

Baseline hours field The planned hours of the last baseline that was saved for 

the task assignment.

Baseline start date field The start date of the last baseline that was saved for the 

task assignment.

Completed check box Read-only. When selected, the task assignment has been 

set to completed status. Typically used for tasks that are 

not assigned to resources, such as milestone tasks. 

When a task is set to complete, the status for the task 

assignments is automatically set to complete.

The task is automatically set as completed when all of its 

task assignments are completed. 

Cost rate field Read-only. The staffing level-based or resource-based 

cost rate that applies to the task assignment and which is 

in effect as at the planned start date of the task 

assignment.

Cross charge rate  field Read-only. Cross charge rate for the assignment and 

which is in effect as at the planned start date for the 

assignment. For more information, see "About cross 

charge rates for initiatives" in the Initiative Management 
User Guide .

Draft check box Read-only. When selected, indicates the task is draft.

Duration field Number of working days between planned start and 

planned finish dates. 
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Option Description

Effort Distribution columns Displays daily or fiscal period columns for allocating 

planned effort manually or automatically, depending on 

the loading method.

Forecast finish date field Estimated date that the task assignment will be 

completed.

Forecast start date field Estimated date that work will begin for a task assignment.

Function list Job function for the task assignment. The default function 

comes from the task, but you can override the function on 

task assignments.

Include in resource demand 

check box

When selected, the task assignment is included in 

resource demand. You can override the setting for task 

assignments.

Last status date field Most recent date that the status was updated for the task 

assignment.

Loading method field Loading method for the task assignment.

Locked by field Read-only. Resource who has locked the task.

Locked task check box When selected, prevents the resource from entering time 

for the task assignment. The setting is inherited from the 

task but can be changed on task assignments.

Percent complete field Percentage of the planned effort for the task that has 

been completed.

Planned finish date field Estimated date that the assignment will be completed. 

The default date is the day after the planned start date. 

For manual loading methods, the planned finish date 

must be on or later than the last date that contains effort.
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Option Description

Planned hours field Estimated number of hours required to complete the 

assignment. If the loading method is manual, then the 

planned hours cannot be edited. If the loading method is 

one that updates past periods, then the planned hours 

must be equal to or greater than the total number of actual 

hours in past periods.

Planned start date field Date that the work should begin. The default date is the 

date that the task assignment is created. If the loading 

method is manual, then the date must be on or before the 

earliest date that contains effort.

Remaining hours field Number of hours remaining to complete the task.

Requested Resource field Read-only. Resource that was requested on the 

associated resource request. 

Resource comment field Resource's comment from the task status update.

Resource list Resource who is assigned to the task.

Resource Request number 
field

Number of the resource request.

Soft-booked check box When selected, the resource is tentatively booked for 

planning purposes. Soft-booked time is shown as flexible 

on the resource schedule calendar.

When cleared, the resource is committed to the project.

Staffing role expiry date If the staffing level is changed, the date after which the 

new staffing level becomes effective.

Staffing role field Staffing level for the task assignment. The available 

staffing levels come from the initiative.
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Option Description

Status not required check 

box

When selected, resources are not required to update the 

status of their task assignments. The project rollup 

calculates the remaining hours for assignments that do 

not require updates as planned hours minus actual hours. 

If the actual hours are greater than the planned hours, the 

remaining hours is set to 1.

Status up to date check box Read-only. When selected, indicates the task status is 

current.

Task name field Read-only. Name of the task.

WBS order field Read-only. Number for the task that corresponds to the 

order of the work breakdown structure. It can be used for 

sorting purposes in views and when exporting data to 

Excel.

Work code category list

Work code list

Work code category and work code of the task. Used in 

reports and for calculating taxes.

Work location group list

Work location list

Work location group and work location where the work will 

be performed. Used in reports and for calculating taxes.

About sorting rows in Project Worksheet

By default, rows in Project Worksheet are in WBS order, but you can define a different sort 
order for rows based on the data in one or more columns. Keep in mind that changing from the 
default sort order affects how items are displayed and limits the functionality in the worksheet 
as follows:

• items are listed in a flat list

• Gantt chart is not available

• some column data might be repeated 

• you cannot do the following: 

• add or remove rows or reorder rows

• indent or outdent rows
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• copy and paste rows

• select or deselect tasks for activation

Sorting the rows in Project Worksheet 

You can specify a sort order for the rows based on the data in one or more columns. For 
example, you can sort task assignments by resource, then by planned start date.

1. Click the Switch or manage views icon  > Manage Views. The Manage Views dialog 

box appears.

2.  In the Sort data in selected columns (Section 2 of 2) section, drag the column that you 
want to sort by first to the top of the Sort by column data list.

3.  To specify the sort order, do one of the following:

• To sort in ascending order, click the arrows until only the up arrow  is displayed.

• To sort in descending order, click the arrows until only the down arrow .is 
displayed.

4.  To sort by additional columns: 

a. Drag the column that you want to sort by second to just below the first column.

b. Specify the sort order by clicking the arrows, as above.

5.  To remove sorting from a column, click the arrows until both the up and down arrows  

appear.

6.  Click Save. An arrow in the headers of the columns in the worksheet indicates that sorting 
(  ascending,  descending) has been applied. 

Editing a Project Worksheet view

You can edit all of the settings for a view except for the view type.

1. Access Project Worksheet.

1. Click the Switch or manage views icon  > Manage Views. The Manage Views dialog 

box appears.

2.  From the View list, select the view that you want to edit.

3.  To delete the view, click  Delete, and then confirm the deletion.
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4.  To change the name of the view, type the new name in the Name field.

5.  Make the necessary changes. For more information, see "Creating a Project Worksheet 
view" on page 93.

6.  When you are finished, click Save.

About switching Project Worksheet views and filters

You can temporarily switch the Project Worksheet view by clicking the Switch or manage 
views icon , and then selecting a different view. Similarly you can temporarily switch the 

Project Worksheet filter by clicking the Switch or manage filters icon  and then selecting 

a different filter. The selected views and filters will be displayed until you exit from Project 
Worksheet.

Note: To display a view or filter each time you access Project Worksheet, you must edit 
the view or filter and mark it as default.

About filtering data in Project Worksheet
There are two layers of filtering that are available in Project Worksheet. The primary level of 
filtering is the Project Worksheet filter, which determines the data to be displayed in the 
worksheet. You can also do ad hoc filtering, which is based on the column data that is 
displayed in the worksheet, with or without using a Project Worksheet filter.

Note: When you apply a Project Worksheet filter or column filter to a task view, the filter 
results include the hierarchy of the work breakdown structure (WBS) of the filtered tasks, 
provided that a sort order for one or more columns has not been specified in the view 
settings. If a sort order has been defined, the tasks are displayed in a flat list.

For more information, see:

• "About Project Worksheet filters" on page 106

• "About filtering rows based on column data in Project Worksheet" on page 109

About Project Worksheet filters

You filter the data in Project Worksheet by creating a  filter and then applying it to Project 
Worksheet so that only the tasks or task assignments that match the filter criteria are displayed. 
For example, you can create a filter that displays only the tasks that were created after a 
specific date, or only the task assignments that have fewer than 8 planned hours.
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You base the filter criteria on the data in the task or task assignment fields (columns). There 
are logical AND and OR operators and parentheses that you can use to create more complex 
filter criteria.

You can apply a filter only if it is for the same entity type as the current view. The names of 
the current view and filter are displayed at the bottom left corner of Project Worksheet. 

Note: Filter criteria is applied to the values for configurable fields only after the 
configurable field has been saved, whereas filter criteria is applied to standard field values 
as soon as the value is entered in Project Worksheet.

Creating a Project Worksheet filter

1. Access Project Worksheet.

2.  In the Worksheet toolbar, click the Switch or manage filters icon  > Manage filters. 

The Manage Filters dialog box appears.

3.  Do one of the following:

• If this is the first filter being created, enter the filter name.

• If there is a filter name in the Name field, click  New.

4.  Complete the fields as required. For more information, see "Manage Filters (Project 
Worksheet) dialog box options" on page 108.

5.  To specify filter criteria:

a. Click  Add new.

b. In the Filter on column, select the column that the criteria row applies to.

c. In the Condition column, select the condition for the information in the Filter on 
column.

d. In the Value column, select the values that the condition must meet.

6.  To add an AND or OR operator, or parentheses, click in the Operators column in the row 
and then select the item from the list.

7.  To add a criteria row, click  Add new below the last row.

8.  To delete a criteria row, click  at the end of the row.
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9.  Click Save.

Manage Filters (Project Worksheet) dialog box options

Option Description

Filter list Current filter.

Name field Name of the filter.

Type of filter options Option to select whether the filter displays task or task 

assignments.

Set as my default filter 
check box

When selected, the current filter is automatically applied each 

time that you access Project Worksheet.

Share filter with others 

check box

When selected, other resources can use the filter.

Operators columns Lists of operators (AND, OR) and parentheses for complex 

filter criteria.

Filter on column Column or field that the filter criteria applies to.

Condition column Condition for the criteria row.

Value column Value for the condition. 

Editing a Project Worksheet filter

You can edit the settings for a filter except for the type of filter.

1. Access Project Worksheet.

2.  In the Worksheet toolbar, click the Switch or manage filters icon  > Manage filters. 

The Manage Filters dialog box appears.

3.  In the Filter list, select the filter.

4.  Do one of the following:

• Make the necessary changes. For more information, see "Creating a Project Worksheet 
filter" on page 107.

• To delete the filter, click  Delete, and then click OK to confirm the deletion.
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5.  When you are finished, click Save.

Copying a Project Worksheet filter

You can copy and then edit an existing filter.

1. Access Project Worksheet.

2.  In the Worksheet toolbar, click the Switch or manage filters icon  and then select 

Manage filters. 

The Manage Filters dialog box appears. 

3.  In the Filter list, select the filter that you want to copy, and then click .

4.  Complete the fields as required. For more information, see "Manage Filters (Project 
Worksheet) dialog box options" on page 108.

5.  To specify filter criteria:

a. In the Filter on column, select the column that the criteria row applies to.

b. In the Condition column, select the condition for the information in the column.

c. In the Value column, select the values that the condition must meet.

6.  To add an AND or OR operator, or parentheses, click in the Operators column in the row 
and then select the item from the list.

7.  To add a criteria row, click  Add new below the last row.

8.  To delete a criteria row, click  at the end of the row.

9.  Click Save.

About filtering rows based on column data in Project Worksheet

You can temporarily filter the information that is displayed by specifying filter criteria for the 
data in one or more of the columns. The filter criteria is based on the data in the column. 
Depending on the type of data in the column, you can specify one or more specific data values, 
a range of data values, or the rows that have no value in the column. 

The values that are available as filter criteria are based on the values in the rows that are 
currently in the view. For example, if only active tasks are in the view, there will not be an 
option to filter on draft tasks. 
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You can edit column filters by adding or removing the data values. 

Note: Unlike Project Worksheet filters, column filters are temporary and remain in effect 
only until you either refresh or close Project Worksheet. 

Filtering rows based on column data in Project Worksheet

Column filters are temporary and remain in effect only while you have Project Worksheet 
open. 

1. Click the column header. The filter criteria appear.

2.  Select the filter criteria:

• For check boxes, select the check boxes for the values that you want to include in the 
view. To display the rows that do not have a value in the column, select the check box 
for (Blanks).

• For a range of values, specify the from and to values. To specify a single value, enter 
the same value in both fields. 

3.  Click OK. The following occurs:

• only the rows that include values that match the filter criteria are displayed

• a filter icon  appears to the right of the column name 

4.  To remove a column filter:

a. Click the column name. The filter criteria appear.

b. Click  Clear filter.

5.  To remove the filters from all of the columns, click the State column header >  Clear 

all column filters.

About creating tasks in Project Worksheet
You can create tasks in Project Worksheet by either adding a new task and then specifying the 
task details, or by copying an existing task. 

When you add a new task, it is inserted into a new row that is under but at the same WBS 
level as the selected task. If no task is selected, the new task is inserted at the bottom row of 
the worksheet but at the top WBS level. 
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Note: Tasks at the top WBS level can be created or activated only by a project manager or 
project plan editor who has the project locked. 

Tip: To minimize the effect on other resources who could be editing other parts of the 
project, it is good practice to insert tasks where they are least likely to affect the WBS, for 
example, at the bottom of the task hierarchy or worksheet, or within a summary task.

Summary task managers must select an insertion point that is below the summary task because 
they do not have edit access to the summary task itself.

About creating milestone tasks

You create a milestone task the same way as a regular task but with the following differences:

• When you select the Milestone check box for a task for which the planned start and 
planned finish are the same date, the duration and planned hours are each automatically set 
to 0.

• Similarly, when you set the duration for a task to 0 days, then the planned hours is set to 0, 
the planned finish is changed to the same date as planned start, and the milestone option is 
enabled automatically. 

• You can later increase the duration and planned hours if required, but if the duration is 0, 
then planned hours must also be 0.

Note: The task editing screen does not include the Duration field, but the behavior is the 
same. You can view the changes in Project Worksheet.

Creating a task in Project Worksheet

1. Access Project Worksheet.

2.  Ensure that a task view is displayed.

3.  To create a top-level task, click . The new task row appears on the bottom row.

4.  To insert a task into a specific row, click the task row under which you want the new task 
to be, and then click  (or press the Insert key). The new task row appears after the 

subordinate tasks of the task that you clicked.

5.  Complete the fields as required. 
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For more information, see "Available columns for Project Worksheet task views" on page 
95.

6.  You can create a summary task by indenting tasks under a task, or outdenting a task over 
other tasks:

• To indent a task, select the task and then click  (or press Alt+Shift+Right Arrow).

• To outdent a task, select the task and then click  (or press Alt+Shift+Left Arrow).

7.  For information about assigning resources, see "Assigning resources to a task in Project 
Worksheet" on page 117.

8.  Click Save.

The draft task is created. 

9.  To activate tasks, see "Activating a task in Project Worksheet" on page 135

Tip: To work with task assignment details such as allocating different planned effort to 
daily or fiscal periods manually to assigned resources, switch to a task assignment view. 

About rollup in Project Worksheet

In Project Worksheet, the project data is rolled up automatically as you work so that you can 
view the effects of your changes to the project totals. Note however, that the totals include 
only the tasks or task assignments that are currently displayed in Project Worksheet and are 
not saved until you save Project Worksheet. 

For general information about how project data is rolled up, see "About rolling up projects" on 
page 48.

Note: Only a portion of the project is displayed when a filter has been applied, or if the 
resource is a summary task manager who does not have view access to the project. Also, 
summary task totals are not displayed when a sort order is defined in a Project Worksheet 
view.

About linking tasks in Project Worksheet

You can create dependencies between tasks in the worksheet and the Gantt chart. For more 
information about using the Gantt chart, see "Linking tasks in the Gantt chart in Project Work-
sheet" on page 140

Note: Inter-project dependencies between tasks are not supported in Project Worksheet.
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You link tasks in the worksheet by specifying the dependency information in the Predecessors 
column of the successor task, using the following format:

[task ID][dependency type][+/–lag time]

Where:

• [task ID] is the number from the ID column

• [dependency type] is the two-letter abbreviation (case-insensitive) for the type:

• FS – finish-to-start (default type)

Note: Because finish-to-start is the system default dependency type, the “FS” is not 
required, and will be removed if you enter it. This does not apply to your default 
dependency settings, if set.

• SS – start-to-start

• FF – finish-to-finish

• SF – start-to-finish

• [+/– lag time] – plus sign for lag time, or minus sign for lead time, and the number of 
working days

For example, if the [task ID] is “3”, dependency type is start-to-start, and [lag time] is two 
days, then you would enter:

3SS+2

You can add multiple predecessor tasks by separating them with a comma, for example:

3SS+2, 5SF-3

Specifying a default dependency type and lag time in Project Worksheet

The default dependency type for linking tasks is finish-to-start, but you can specify a different 
dependency type as well as a lag time. If you specify a different default dependency type and 
lag time, when you enter the task ID in the Predecessors field, the dependency type and lag 
time are added automatically. 

For example, you specify Start-To-Start as the dependency type and "4" as the lag time, and 
you want to create a dependency for task ID 3. You can simply enter 3 in the Predecessors 

Project Management | 113



6. Project Worksheet

field. When you click out of the cell, "3SS+4" appears automatically. You can specify other 
dependency types and lag periods as required.

1. Access Project Worksheet.

2.  Click  More > Project Worksheet settings. The Project Worksheet settings dialog 

box appears.

3.  In the Task dependencies section: 

a. In the Default type list, select the dependency type.

b. In the Lag time field, specify the number of lag days between the tasks. 

4.  Click Save. 

Specifying time entry restriction settings in Project Worksheet (Project 
Worksheet)

You can specify the time entry restrictions for both tasks and task assignments in task views 
and for task assignments only in task assignment views.

1. Add the following fields to the Project Worksheet view:

• Restrict time entries to within the planned dates for the task

• Restrict time entries to within the planned effort for the task

• Restrict time entries to within the planned dates for the task assignment

• Restrict time entries to within the planned effort for the task assignment

2.  In Project Worksheet, edit the settings for tasks or task assignments as required.

3.  Click Save.

Copying a task in Project Worksheet

You can copy one or more tasks and then paste them into Project Worksheet. When you copy 
a task, all of its subtasks are included. If you copy tasks from different WBS levels, the tasks 
are pasted into the row below the task that you select as the insertion point, but into the same 
WBS level as the task. 

Values for fields that are included in your view are copied. In some cases, default values are 
applied to fields that are missing from your view.
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1. Access Project Worksheet.

2.  Select one or more tasks 

3.  Click  (or press Ctrl+C).

4.  Select the row above where you want to insert the tasks, and then click  (or press 

Ctrl+V).

5.  Edit the tasks, if required.

6.  Click Save.

About assigning resources to tasks in Project Worksheet
There are two ways to assign resources to tasks:

• using a task view

• creating task assignments using a task assignment view

Note: It is best to use a task assignment view for doing detailed work, such as assigning 
different amounts of planned effort to resources. For more information, see "Creating a 
task assignment in Project Worksheet" on page 121.

You can assign one or more resources and/or personal groups to a single task or to multiple 
tasks all at once. You can split the planned effort equally among the resources or specify 
different effort amounts or percentages for each resource. Percentages of planned effort are 
calculated based on the total planned effort for the task.

About the preferred resources list in Project Worksheet

The preferred resources list includes the resources that are assigned to tasks in the current 
project in addition to the resources that you added to the list. 

Note: You can add resources to your preferred resources list by clicking  More > 

Manage preferred resources.

About project teams in Project Worksheet

For projects for which resource requests are enabled, the resources from the project team and 
resources that are exempt from resource requests are available in place of the preferred 
resources list. If you assign a task to a personal group, only the resources that are in the project 
team or are exempt from resource requests are assigned to the task. Only the personal groups 
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that have at least one resource the is from the project team or is exempt from resource requests 
will be available.

Assigning personal groups to tasks

When you select a personal group in the Resources column, all resources in the personal 
group are assigned to the task, and the planned effort is distributed evenly among the 
resources. To edit the planned effort amounts manually, switch to a task assignment view.

Assigning multiple resources to a task

When you assign more than one resource to a task, either individually or by assigning a 
personal group, you can add, edit, and delete resources, and specify the effort amounts for each 
resource all in one dialog box. If the total of the planned effort that is allocated to resources is 
different from the total planned effort for a task, you must either update the task total, or adjust 
the allocated amounts to equal the task total. 

If you select a group using the Assign resources or Reassign resources dialog box, the 
planned effort or percentage that you specify in the row will be assigned to each member of 
the group, but can be changed later.

Assigning resources to multiple tasks

Each resource will be assigned to all of the selected tasks, except for the tasks to which they 
are already assigned, which remain unchanged.

If no resources have already been assigned to the task, you have the option to evenly distribute 
the planned effort among the newly assigned resources. 

Assigning resources to summary tasks

When you select resources in the Resources column to assign them to summary tasks, the 
planned effort is automatically set to 0 because time cannot be entered for summary tasks in a 
task view.

However, you can assign effort to summary tasks in the Assign resources or Reassign 
resources dialog box or in a task assignment view. Total planned effort for a summary task 
includes the assignments to the summary task as well as its subtasks.

About duration calculations in Project Worksheet

The duration of a task is calculated based on the number of working days between the planned 
start and the planned finish dates. If no resources are assigned to the task, then the working 
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days of the staffing workgroup of the initiative are used. If only one resource is assigned to the 
task, then the working days of the resource are used.

If more than one resource is assigned to a task, then the working days of the staffing 
workgroup of the initiative are used. The planned start date will be the earliest planned start 
date of the resources that are assigned to the task, and the planned finish date will be the latest 
planned finish date. 

Note: If you make changes in a task assignment view, the duration is not recalculated for 
summary tasks. It will be calculated when the project is saved and a rollup occurs. 
However the rollup values are updated on summary tasks when you make changes in a 
task view.

Assigning resources to a task in Project Worksheet

1. Access Project Worksheet.

2.  In the Resources column of the task, select one or more resources or personal groups to be 
assigned to the task.

If you assigned personal groups or multiple resources, the planned effort is distributed 
evenly to each resource. 

If all of the existing assignments have a manual loading method, new resources are 
assigned 0 planned effort and the existing assignments are not changed. 

3.  You can change the distribution amounts in the task assignment view.

Assigning resources to multiple tasks in Project Worksheet

The options to allocate effort by percentage and distribute effort evenly are available only 
when there are no existing assignments for the selected tasks.

1. Select the tasks that you want to assign resources to.

2.  In the Actions toolbar, click  > Assign. The Assign resources dialog box appears.

3.  Do one of the following:

• To allocate effort based on a percentage of the total effort for the task, select the 
Percentage option.

• To allocate effort based on the planned effort amounts that you specify, select the 
Effort option.
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4.  To assign a resource:

a. In the Resource type-ahead field, select a resource. 

b. In the Effort (or Percentage) column, enter the planned effort (or percentage).

5.  To allocate the planned effort evenly to the selected resources click the Distribute evenly 
icon .

6.  Click Save.

About searching for resources when assigning tasks in Project Worksheet

You can search for resources to be assigned to a task or task assignment. When you select a 
task or task assignment and then launch Resource Match, the planned hours, planned start and 
planned finish dates, and function from the task or task assignments are automatically loaded 
into the corresponding sections in Resource Match. You can change or add criteria to search 
for suitable resources in Resource Match and then assign resources from the results.

Note: You can also use Resource Match to search for resources without selecting a task 
or task assignment first, in which case you must define all of the search criteria.

When you launch Resource Match from a task that has no existing task assignments, a new 
task assignment is created for each resource that you selected in the Resource Match results. 
The total planned hours for the task is assigned to the first task assignment and you must alloc-
ate the planned hours to the remaining task assignments.

If the task has one or more task assignments, then a new task assignment with zero planned 
hours is created for each resource that you selected in the Resource Match results.

When you launch Resource Match from a task assignment, the currently assigned resource is 
replaced by the first selected resource and new tasks assignments are created for the remaining 
resources. If the currently assigned resource has entered time or expenses, it cannot be 
replaced and therefore a new task assignment with zero planned hours is created for each new 
resource to be assigned.

Searching for resources when assigning tasks in Project Worksheet

1. In Project Worksheet, select the task or task assignment that you want to assign resources 
to.

2.  Click  . The Resource Match dialog box appears.
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3.  Specify the search criteria. For more information, see "Resource Matches" in the Resource 
Management User Guide or online help.

4.  In the Resource Match Results, select the check boxes beside the resources that you want 
to assign to the task or task assignment.

Note: If you selected a task assignment and want to keep the current resource assignment, 
select the check box for the assigned resource.

5.  Click Actions > Create > Task assignment.

6.  Click Save in Project Worksheet.

About displaying resource availability in Project Worksheet

You can show either actual effort or availability for task assignments in blue text beside the 
planned hours.

Keep the following in mind when using this functionality:

• Resource availability is provided only from the current date forward, but planned hours are 
allocated across the duration of the task assignment, even if the planned start is in the past. 
Therefore, changing planned start dates in the past can change the allocation of planned 
hours, which in turn changes the resource availability.

• Overallocations can distort the resource availability. For example, the duration of a task 
assignment is two weeks, and a resource is overallocated for the first week, but is 
completely available for the second. Because the total resource availability will be reduced 
by the number of overallocated hours, it will appear that the resource has less availability 
than they do.

The resource’s availability is calculated as follows: 

Daily capacity * Percent available for planned work – Committed hours

Where:

• Daily capacity is the number of hours per working day for the resource.

• Percent available for planned work is from the resource’s workgroup. 

• Committed hours includes all demand for all items in the current project and other 
projects, and in all other demand items that are configured as committed.
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• Total availability is calculated from the later of the current date or planned start date to the 
planned finish date for the task assignment. 

Note: The availability will be recalculated when changes are made within Project 
Worksheet, but not when demand items are added or edited outside of Project Worksheet.

Showing actual effort or availability in Project Worksheet

You can show either actual effort or availability for task assignments in blue text beside the 
planned hours in the Planned hours and daily or fiscal period columns.

1. Create or switch to a task assignment view that includes the Planned hours and Effort 
distribution columns.

2.  Click the Show actual effort or availability icon , and then select the applicable 

option.

The actual hours or availability for the task assignment appears in blue text to the left of 
the planned hours values.

3.  To remove the actual hours or availability, click the Show actual effort or availability 
icon , and then select None.

Setting up a warning when effort distribution on task assignments is 
overridden

You can set up a warning so that a message appears when you a make a change that affects the 
existing distribution of effort on task assignments. 

For example, selecting another resource from the Resources list will evenly split the planned 
effort among resources. If effort is different for task assignments, a warning message appears. 
The effort amounts are compared up to 2 decimal places. 

1. Access Project Worksheet.

2.  Click  More > Project Worksheet settings. The Project Worksheet settings dialog 

box appears.

3.  In the Warning messages section, select the Display warnings before planned effort is 
overridden check box.

4.  Click Save.
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About reenabling the message that the planned effort is different for one or 
more tasks

You can reenable the message that appears in the Assign/Replace Resources dialog box when 
the total planned effort for task assignments is different than the planned effort for one or more 
tasks by deleting the server cookies in My preferences.

Creating a task assignment in Project Worksheet

Use a task assignment view to do more detailed work with task assignments such as:

• manually distributing effort to daily or fiscal periods

• using different loading methods for assignments for the same task

• assigning different planned start and planned finish dates to different resources who are 
assigned to the same task

• adding additional resources to a task once one or more of the previous points are 
applicable

• assigning planned effort to summary tasks

Before you can create a task assignment in a task assignment view, there must already be a 
task assignment for the same task in the task assignment view.  

Tip: In a split view, you can select a task in the task view half and then switch to the task 
assignment view half to create the task assignments. 

1. Access Project Worksheet and select a task assignment view.

2.  To add a new task assignment, select an existing task assignment for the same task and 
then click .

3.  To copy a task assignment:

a. Select the task assignment that you want to copy, and then click .

b. Click .

4.  Complete the fields as required. For more information, see "Available columns for Project 
Worksheet task assignment views" on page 100.

5.  Click Save.
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About resource requests and task assignments in Project Worksheet

If your organization uses resource requests, there are restrictions on how you can edit task 
assignments in  Project Worksheet, depending on whether resource requests are enabled at the 
initiative level, project level, or task level. 

Note: In all cases, you can create task assignments for resources that are configured to be 
exempt from resource requests.

If resource requests are enabled at the initiative level, then you can create or copy a task 
assignment for a resource on the worksheet only if there is a resource request for the resource 
in the Projected resources tab of the initiative.

If resource requests are enabled at the Project level, then the following restrictions apply to 
the worksheets: 

• you can only assign a resource to a task assignment if there is a resource request for the 
resource that covers the planned start, planned finish and planned hours for the task 
assignment.

• you can copy and paste a task assignment, but you can save it only if there is a resource 
request for the resource that covers the planned start, planned finish and planned hours for 
the task assignment

If resource requests are enabled at the task level, then the following restrictions apply to the 
worksheets:

• you cannot create or copy and paste task assignments

• you can only reopen resource requests from the task editing view or resource request 
dialog box

• the following columns are not editable on the worksheets:

• Resource

• Planned start

• Planned finish

• Planned hours

• Effort distribution

• Daily periods
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• Loading method

• Open task

Editing a task assignment in Project Worksheet

1. Access Project Worksheet and select a task assignment view.

2.  To assign a different resource to a task assignment:

a. Copy-paste the task assignment.

b. Assign the resource to the new task assignment.

c. Delete the old task assignment.

3.  Edit the fields as required. For more information, see "Available columns for Project 
Worksheet task assignment views" on page 100.

4.  To delete a task assignment, select the task assignment and then click 

5.  Click Save.

About marking task assignments as completed in Project Worksheet

In a task assignment view, you mark an assignment as completed  by setting the percent 
complete to 100 or remaining effort to 0. 

When time has been entered for a task assignment:

• The actual start date is set to the date of the earliest time record and the actual finish date is 
set to the date of the latest time record.

• If the completed task assignment is later reopened, the actual finish date is cleared, and the 
actual start date will remain unchanged.

If there are no actual hours for the task assignment: 

• The actual finish date is automatically set to the current date, but you can change the date. 

• The actual start date is set to the same date as the actual finish date and these dates both 
roll up to the task and summary tasks normally. 

• If the completed task assignment is later reopened, both the actual start and actual finish 
dates are cleared.
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Note: If you change the actual finish date in a task assignment view, the revised actual 
start and actual finish dates will not appear in a task view until Project Worksheet has been 
saved and reloaded.

Best practice regarding actual time

The point at which time records are considered actual time by your organization is controlled 
by a setting  in Changepoint Administration. The setting options are:

• when the time is entered in the time sheet

• when the time records are submitted in the time sheet

• when the time records have been approved

The actual finish date is determined based on the actual time for the tasks or task assignments 
at that time that the task or task assignment is marked as completed. If time records are 
considered actual time only after time is submitted or approved, and  a task or task assignment 
is marked as completed before the time records have been submitted or approved, there might 
be an actual finish date, but no true actual hours. 

As a best practice, ensure all time records are actual time before marking tasks or task 
assignments as completed.   

About replacing assigned resources  in Project Worksheet

In Project Worksheet you can replace a resource with one or more resources on all tasks in the 
project or only selected tasks. This functionality is useful for replacing a resource who is 
leaving the customer or has been removed from a project, or for replacing generic resources 
with actual resources when template projects are used as a starting point.

When replacing a source resource, you select one or more target resources and specify the 
percentage of the effort amount that is to be reassigned to each target resource. You can also 
specify a date range for the resource to be replaced.

A new assignment is created for each target resource based on the information from the source 
task assignment. Daily effort distributions are multiplied by the percentage, and the total of the 
daily distributions becomes the total planned effort for the target resource.

• If the percentage is 100% or higher, the source resource is removed from the task, unless 
there is actual effort for the source resource, in which case the source resource remains 
assigned to the task with effort set to 0.
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• If the percentage is 100% and there are multiple target resources, a slightly higher amount 
might be assigned to one of the target resources due to rounding.

• If a target resource is already assigned to the source task, the effort will be added to the 
existing effort for the target task.

Note: For performance reasons, some processing is not done immediately in Project 
Worksheet, such as replacing effort in past periods with actual effort. As a result, there 
may be changes in effort amounts after you save changes or switch to another view.

Replacing an assigned resource in Project Worksheet

1.  Do one of the following:

• To replace a resource on all tasks in the project, in the Actions bar click .> 

Reassign.

• To replace a resource on one or more selected tasks:

• Select the tasks first. 
• In the Actions bar click  > Reassign.

The Reassign resources dialog box appears.

2.  In the From field, select the source resource (resource that you want to replace).

3.  To specify a date range for replacing the resource, enter dates in to the Start date and End 
date fields.

4.  Add one or more target resources in the Resource table.

5.  Specify a percentage for each target resource.

6.  Click Save.

About allocating planned hours in Project Worksheet
The methods that you can use to allocate planned hours depend on whether or not fiscal 
periods have been selected for the project, and the loading methods that are specified for tasks.

If you select fiscal periods for the project:

• you can allocate planned hours to fiscal periods and edit planned start, planned finish and 
planned hours, provided that they are in current or future fiscal periods. You require the 
appropriate security feature to edit information in past fiscal periods.
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• the default loading method for tasks is 1 - Auto distribute - update past and future. 

Note: If you do not want planned hours in past fiscal periods to be updated with actual 
hours, then you must change the loading method for each task to loading method 3 or 4. 
For more information, see "About selecting loading methods" on page 126.

If you do not select fiscal periods for the project, then only the following loading methods are 
available:

• 3 - Manually distribute – no update

• 4 - Auto-distribute – no update to past (default)

You can allocate planned hours to nonworking days if the loading method is a manually 
distribute method. If there are no nonworking days between the planned start and planned 
finish dates, effort can be allocated to nonworking days either manually or automatically.

You can change a planned start date that is the past when the loading method is one that 
replaces planned hours in past periods with actual hours, provided that you have access rights 
to edit data in past fiscal periods. 

Note: If you change a planned start date this way, keep in mind that existing actual hours 
can cause the date to revert back to the original date upon saving. Also, if there are no 
actual hours at the time that you change the date, actual hours on a future date can change 
the date automatically. 

About selecting loading methods

The default loading method for tasks is:

• if fiscal periods are selected for the project – 1 - Auto-distribute – update past and future

• if fiscal periods are not selected for the project – 4 - Auto-distribute – no update to past

The loading method applies to each task assignment for the task. In Project Worksheet, you 
can change the loading method for task assignments. 

To allocate planned hours, you can select the loading method to specify how planned hours are 
distributed across fiscal periods, and how (or whether) actual hours are applied to past fiscal 
periods when the project is rolled up.

When you select a manually distribute loading method, you can manually allocate the planned 
hours in the current and future fiscal periods. However, you cannot edit the total planned hours 
for the task assignment.
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When you select one of the auto-distribute loading methods, you can update planned start, 
planned finish and planned hours for the task assignment, but the system automatically 
allocates the hours to the fiscal periods.

Note: When open tasks are rolled up, the planned hours for the task are evenly distributed 
to each fiscal period between the planned start and planned finish dates, and planned hours 
are not rolled up from task assignments. Therefore the total planned hours for open tasks 
might not balance with the total task assignment hours.

The loading method affects how planned and actual information is rolled up for each task 
assignment.

0 - Manually distribute – update past only

• Planned hours in past periods are replaced by actual hours

• Planned start and planned finish in past periods are replaced if time records are earlier than 
the planned start or later than the planned finish. For more information, see "About 
replacing planned start and finish dates with actuals" on page 128.

• Current and future planned hours are not changed

• Total planned hours are set to: past period hours + current and future planned hours

• Resources can manually update current and future periods

1 - Auto-distribute – update past and future

• Planned hours in past periods are replaced by actual hours

• Planned start and planned finish in past periods are replaced if time records are earlier than 
the planned start or later than the planned finish. For more information, see "About 
replacing planned start and finish dates with actuals" on page 128.

• Total planned hours minus planned hours from past periods, are distributed evenly to 
current and future periods

2 - Auto-distribute – update past only

• Planned hours in past periods are replaced by actual hours

• Planned start and planned finish in past periods are replaced if time records are earlier than 
the planned start or later than the planned finish. For more information, see "About 
replacing planned start and finish dates with actuals" on page 128.

Project Management | 127



6. Project Worksheet

• Current and future periods are not changed (unless the resource changes the planned start, 
planned finish or planned hours)

• Total planned hours are set to: past period planned hours + current and future planned 
hours

3 - Manually distribute – no update

• Planned hours in past periods are not replaced by actual hours

• Resources can manually update current and future periods

• Resources with the required access rights can manually update past periods

4 - Auto-distribute – no update to past

• Planned hours in past periods are not replaced by actual hours, but can change when 
planned start, planned finish or total planned hours are changed

• Total planned hours are evenly distributed across the working days between the planned 
start and finish dates, and the planned hours for fiscal periods (including past fiscal 
periods) are updated accordingly

About replacing planned start and finish dates with actuals

If the loading method for a task assignment is one that includes “update past”, then if a time 
record is entered before the planned start date in a past period, the planned start date is 
changed to the date of the time record. Similarly, the planned finish date in a past period is 
changed to the date of a time record that is later than the planned finish date.

When the planned start date for a task assignment is changed in this way, then all effort that is 
allocated to daily periods for the task assignment is deleted.

However, the planned start and finish dates for task-level or project-level resource requests 
that have resource restrictions enabled will not be replaced with dates of time records if the 
new dates are outside of the dates for the original resource request item.

Loading method examples

The following table shows the results after a project rollup, of the different loading methods on 
a task assignment with the following conditions:

• Planned start: September 1

• Planned finish: October 31
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• Planned hours: 50

• Fiscal periods selected for the project, and the fiscal periods are months (September, 
October)

• 20 actual hours were entered during the September fiscal period

• The current fiscal period is October

Note: All of the tables in the loading method examples show the results after the project 
has been rolled up. 

Loading Method
Total 
Planned 
Hours

Fiscal Period 
September

Fiscal 
Period 
October

Original task assignment 50 25 25

0 - Manually distribute – update past only 45 20 25

1 - Auto-distribute – update past and future 50 20 30

2 - Auto-distribute – update past only 45 20 25

3 - Manually distribute – no update 50 25 25

4 - Auto-distribute – no update to past 50 25 25

The following table shows the results of the loading methods on the same original task 
assignment, but with 60 actual hours entered during the September fiscal period.

Loading Method
Total 
Planned 
Hours

Fiscal Period 
September

Fiscal 
Period 
October

Original task assignment 50 25 25

0 - Manually distribute – update past only 85 60 25

1 - Auto-distribute – update past and future 60 60 0
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Loading Method
Total 
Planned 
Hours

Fiscal Period 
September

Fiscal 
Period 
October

2 - Auto-distribute – update past only 85 60 25

3 - Manually distribute – no update 50 25 25

4 - Auto-distribute – no update to past 50 25 25

The following table shows the results of the loading methods on the same original task 
assignment, but with 40 actual hours entered in the September fiscal period and the planned 
hours changed to 60. You can only change planned hours on task assignments that have auto-
distribute methods, therefore this example applies to the auto-distribute methods only.

Loading Method
Total 
Planned 
Hours

Fiscal Period 
September

Fiscal 
Period 
October

Original task assignment 50 25 25

1 - Auto-distribute – update past and future 60 40 20

2 - Auto-distribute – update past only 70 40 30

4 - Auto-distribute – no update to past 60 30 30

About allocating planned hours to daily or fiscal periods in Project 
Worksheet

You can allocate planned hours to daily or fiscal periods  to individual resources in a task 
assignment view:

• for fiscal periods, one year of fiscal periods starting from the fiscal period that contains the 
current date is displayed

• for daily periods, 31 days from the current date are displayed initially

You can scroll backward and forward within the fiscal periods, or set a different start date for 
them. 
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To display daily or fiscal periods in Project Worksheet you must add the Effort distribution 
column to the view. 

Using different fiscal periods in Project Worksheet

By default, the fiscal periods come from the cost structure for the project. You can use 
different fiscal periods (if available) in Project Worksheet without changing the project cost 
structure. For example, you might want to use daily or weekly periods for the current time 
period, and then switch to monthly periods for future time periods. 

When you switch from fiscal periods to daily periods, the daily periods start at the first date of 
the first fiscal period that was in the view prior to switching. When you switch from daily 
periods to fiscal periods, the fiscal periods start at the one that contains the first date of the 
daily periods that were in the view prior to switching.

Whichever periods that you use last are saved in Project Worksheet until you switch them 
again. 

Note: Regardless of which periods you use in the view, the project data is always rolled up 
and stored in the fiscal periods that come from the cost structure for the project.

Allocating recurring planned effort in Project Worksheet

You can allocate recurring effort in Project Worksheet within a date range. There are weekly 
and monthly options. For example, you can allocate effort for a task assignment for every day 
during a project, or for a task assignment that must be performed at the end of each month. 

The recurring effort allocation replaces existing effort allocations for the selected demand 
items within the specified date range. Any existing effort allocations for the selected demand 
after the date range are removed. 

Note: It is not possible to allocate recurring effort for time-based tasks or when FTEs are 
used.

1. In Project Worksheet, display a task assignment view with daily distributions so that you 
can view the results of your work. 

2.  Select the task assignment that the recurring demand will be allocated for.

3.  Click .

The Recurring allocations dialog box appears.

4.  Enter the date range, and the number of hours for the recurring allocation.
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5.  In the Recurrence pattern section, select either the weekly or monthly options. You can 
override one or more daily amounts in the weekly options, if necessary.

6.  Click Save. The demand is allocated according to the options that you selected.

Using a formula to allocate recurring planned hours  in Project Worksheet

You can allocate planned effort of the same amount over a number of consecutive daily or 
fiscal periods.

To allocate planned effort over daily or fiscal periods that are not consecutive, see "Allocating 
recurring planned effort in Project Worksheet" on page 131.

To allocate the same number of planned hours to consecutive daily or fiscal periods 

Using the following formula, enter the recurring planned hours into the daily or fiscal period 
where you want the allocations to begin:

[Planned hours amount]x[Number of daily or fiscal periods]

For example, to allocate 5 hours each to the next 10 daily or fiscal periods,  enter "5x10" in the 
first daily or fiscal period.

To evenly distribute planned hours over consecutive daily or fiscal periods

Enter the recurring planned hours based on the following formula into the daily or fiscal 
period where you want the allocations to begin:

[Planned effort amount]/[Number of daily or fiscal periods]

For example, to evenly distribute 50 hours over the next 10 daily or fiscal periods, enter 
"50/10" in the first daily or fiscal period. Five hours would then be allocated to each of the 10 
consecutive daily or fiscal periods.

About replacing planned effort or forecast effort in Project Worksheet

This topic describes the options for replacing planned or forecast effort in Project Worksheet.

Replace planned effort with past actual effort plus forecast effort

This option applies only to task assignments with auto-distribute loading methods. 

When this option is selected:

• Planned effort in past days or fiscal periods is replaced with the actual effort.
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• Planned effort on the current date or in the current fiscal period is replaced with remaining 
hours, which are evenly distributed in the current fiscal period

• Planned effort is replaced up to the current date or fiscal period, or the specified date, 
depending on the Project Worksheet settings

Replace past planned effort with actual effort

This option applies to all loading methods. 

When this option is selected:

• Planned effort in past days or fiscal periods is replaced with actual effort, up to the current 
date or fiscal period, or the specified date (if selected on the Project Worksheet settings).

Note: The default Project Worksheet settings for replacing past effort do not apply to 
loading methods that replace past planned effort with actual effort (loading methods 0, 1, 
2).

• If actual effort exists:

• total planned effort becomes the total of actual effort that replaced planned effort (up 
to the current date or fiscal period, or the specified date), plus planned effort in the 
current and future fiscal periods or up to the specified date

• planned start date is changed to the actual start date; planned finish is not changed

• If there is no actual effort:

• total planned effort is the total of all past, current and future effort distributions

• planned start date is not changed

Replace forecast remaining effort with planned effort minus actual effort

This option does not affect planned hours, and applies to all loading methods.

When this option is selected, remaining effort is replaced with planned effort less the actual 
effort. 

Note: Remaining effort is not replaced if the actual effort up to the specified or current 
date exceeds the planned effort.

Replacing planned effort or forecast effort in Project Worksheet

1. In the Worksheet toolbar, click Replace effort and then select the option:

Project Management | 133



6. Project Worksheet

• Replace planned effort with past actual effort plus forecast effort

• Replace past planned effort with actual effort

• Replace forecast remaining effort with planned effort minus actual effort

2.  If the Replace effort dialog box appears, select the end date and then click Save.

Specifying the default settings for replacing past effort in Project Worksheet

You can specify the default settings for when you want to replace planned effort in past 
periods with actual effort. 

You can specify whether the planned effort in past periods is replaced with all of the existing 
actual effort, or only up to a date that you specify at the time when you want the effort 
replaced. You can also specify that only the effort for task assignments that have actual effort 
be replaced.

1. In Project Worksheet, click Replace effort > Manage Settings. The Replace effort 
settings dialog box appears.

2.  In the Replace past planned effort with actual effort section:

• To replace the planned effort in past periods with all actual effort for those past 
periods, select Up to the current date.

• To replace the planned effort only up to a date that you specify at the time that you 
select the option to replace the planned effort, select Up to a specified date.

Note: This setting applies only to loading methods that do not replace past planned effort 
with actual effort (loading methods 3 and 4).

3.  To replace the planned effort in past periods only for task assignments that have actual 
effort for the past periods, select the Do not replace planned effort when actual effort is 
0 check box.

4.  Click Save.

About activating tasks in Project Worksheet
You must activate tasks in Project Worksheet before they are available to resources in the time 
sheet and Projects tree-view. 

To activate a task, you must first mark it for activation. When you mark a task for activation, 
all of the tasks in the same task hierarchy and all of the tasks linked to the tasks in the 
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hierarchy are marked as well. For this reason, tasks can be activated only from a task view that 
has no sorting or filter applied.

Once you have marked tasks for activation, you cannot make any edits to the tasks that affect 
the WBS or task dependencies.

You can choose to automatically mark tasks for activation by selecting the option in Project 
Worksheet settings. For more information, see "Automatically activating draft tasks in Project 
Worksheet" on page 136.

When you mark tasks for activation and then click Save:

• all active tasks that you modified and all draft tasks that you marked for activation will be 
validated in a background process

• active tasks that pass validation are saved

• all draft tasks are activated only if they all pass validation (none of the draft tasks are 
activated if one or more fail validation)

• warnings are cleared

• Project Worksheet is closed and errors appear the next time you access Project Worksheet

Tip: To review error and warning messages immediately, click  Apply instead of Save .

Tasks that pass validation are activated and can be viewed and edited in all the usual ways. 
Tasks that fail validation are flagged and the error messages are available in the State column. 
You can either correct the errors and activate the tasks, or delete them.

Activating a task in Project Worksheet

To activate a task, you first mark it for activation and then submit it for activation. You can 
remove a task from being marked for activation, but you cannot revert an activated task to 
draft status.

Note: Tasks at the top WBS level can be created or activated only by a project manager or 
project plan editor who has the project locked. 

1. To mark tasks for activation, select one or more draft tasks, and then click .

The cell in the Draft column turns green.

2.  To remove a task from being activated, select the task and then click .

Project Management | 135



6. Project Worksheet

3.  To activate the marked tasks, click Save or  Apply.

Validating changes in Project Worksheet

Because only basic validation is performed when you create and edit tasks and task 
assignments in Project Worksheet, it is possible that you unknowingly introduce errors as you 
work. You can validate your work to check it for errors so that you can view and correct the 
errors before activating or saving. 

1. Select the draft tasks that you want to validate, and then click .

Note: Active tasks that have been edited are automatically included.

2.  Click  Validate.

Automatically activating draft tasks in Project Worksheet

You can set an option to automatically mark draft tasks for activation. After you select this 
option, all existing tasks and new tasks for the current project are activated when you save the 
project in Project Worksheet. Existing draft tasks in other projects are activated only after you 
access   and then save each project in Project Worksheet. 

Note: This setting applies to all projects that you access in Project Worksheet.

1. Access Project Worksheet.

2.  Click  More > Project Worksheet settings. The Project Worksheet settings dialog 

box appears. 

3.  In the Draft tasks section, select the Automatically activate draft tasks check box.

4.  Click Save.

About editing tasks in Project Worksheet

Changing the loading method 

If you change the loading method for a task assignment from one that does not replace planned 
hours in past fiscal periods with actual hours to one that does, the planned hours in past fiscal 
periods will initially be replaced with an even distribution of the total actual hours. To see the 
true distribution of actual hours in the past, you must save the project in Project Worksheet. 
Saving the project saves the daily distribution of the task assignment and initiates a project 
rollup.
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Editing the planned start date

When you change the planned start date of a task, the start dates of its task assignments are 
moved to maintain the same relationship to the task start date. That is, if the original start date 
of the task assignment was 5 days after the original task start date, then the new start date of 
the task assignment will be 5 days after the new task start date. The duration remains the same, 
and the finish date is changed based on the duration.

If the new start date for a task assignment is on a nonworking day, the effort is moved to the 
next available working day and  the new finish date is determined based on the duration, which 
can move the task finish date. Planned start and planned finish dates can be on nonworking 
days, but effort can only be allocated to nonworking days manually. If there are no nonworking 
days between the planned start and planned finish dates, effort can be allocated to nonworking 
days either manually or automatically.

When you change the planned finish date of a task, the dates of its task assignments are moved 
relative to the new finish date. The planned start date remains the same and the duration is 
recalculated.

If dependencies on other tasks prevent the finish date from being moved, or the new finish date 
is earlier than the planned start date of the task assignment, the task assignment dates are set to 
same date as the task start date.

Editing a task in Project Worksheet

1. Access Project Worksheet.

2.  Check that you have the tasks locked.

3.  Make the necessary changes.

4.  Click Save.

About marking tasks and task assignments as completed in Project 
Worksheet

In a task view, you mark a task as completed by selecting the Completed check box.

If there are actual hours for the task, the following occurs:

• the actual start date is set to the date of the earliest time record and the actual finish date is 
set to the date of the latest time record. 
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• The actual start date, finish date, and completed status are applied to all subtasks and task 
assignments that are not completed and have no actual hours. 

• If a task assignment has actual hours, the actual start date is set to the date of the earliest 
time record and the actual finish date is set to the date of the latest time record. 

• If the completed task is later reopened, the actual finish date is cleared.

If there are no actual hours for the task,

• the actual start date is set to the same date as the actual finish date and the actual finish 
date is automatically set to the current date. You can change the actual finish date.

• If a completed task is later reopened, both the actual start and actual finish dates are 
cleared and will be updated during the save and project rollup.

About the Gantt chart in Project Worksheet
You can move tasks, change task durations, and create or delete task dependencies within the 
same project in the Gantt chart.

The items in Project Worksheet are represented in the chart as follows:

• tasks – blue bars

• summary tasks – dark gray bars

• milestone tasks – black diamonds

To show/hide the Gantt chart

In the Gantt toolbar, click .

To align both Gantt charts

To align the display of the Gantt charts to match the Gantt chart in the active view, click . 

The following items are changed to match the active Gantt chart:

• position of the split bar

• starting date

• timescale (zoom level)
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To show/hide the worksheet

Click the darker Show worksheet/Hide worksheet bar in the split bar between the worksheet 
and the Gantt chart.

To scroll outside of the time frame that is currently displayed

There is a second set of arrows in the horizontal scroll bar of the Gantt chart that you can use 
to scroll outside of the time frame that is currently displayed.

To scroll to dates prior to the earliest date displayed, click the arrow on the far left.

To scroll to dates after the latest date displayed, click the arrow on the far right.

To scroll vertically on the Gantt chart

To scroll up or down in the Gantt chart, you use the scroll bar that is between the worksheet 
area and the Gantt chart. 

Changing the timescale in the Gantt chart in Project Worksheet

You can zoom in to show less information in greater detail, or zoom out to show more 
information in less detail. 

To change the timescale in the Gantt chart

To zoom in, click . The lowest zoom level shows the timescale in days per week.

To zoom out, click . The highest zoom level shows the timescale is semiannual.

To display the entire Gantt chart in the available space

Click . The Gantt chart is scaled to fit in the width of the pane.
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To start the time frame displayed in the Gantt chart at the planned start date of a task

Click the task row and then click .

To start the time frame displayed in the Gantt chart at a specific date

Click the Go to the selected date date at the bottom right of the Gantt chart and then select 
the date.

Managing tasks in the Gantt chart in Project Worksheet

You can change the planned start date of a task by moving it forward or back in the timescale. 
The duration for the task remains the same. If you move a predecessor task,  its successor tasks 
are moved automatically to maintain the constraints of the dependency type. 

You can change the planned finish date of tasks  as well as shorten or lengthen their duration 
by moving the right (planned finish) end of the task bar.

Note: You cannot move a successor task, nor change its dates that are dependent on its 
predecessor task.

To change the planned start date for a task

Point to the task, and when the four-sided arrow appears, move the task forward or back to the 
desired date.

To change the planned finish date for a task

Point to the right (planned finish) end of the task bar, and when the two-sided arrow appears, 
drag the end to the desired date.

Linking tasks in the Gantt chart in Project Worksheet

Tasks that you link in the Gantt chart initially have the system default dependency type 
(finish-to-start) unless you set up a different default dependency type. You can change the 
dependency type and add a lag or lead time.

1. Click the predecessor task, and then drag it down towards the successor task.

A tooltip indicates the potential successor tasks as you point to them.

2.  Release the predecessor task on the successor task.
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The successor task is moved to start on the first working day after the finish date of the 
predecessor task. A line links the predecessor task to the successor task.

3.  To change the dependency type, right-click the link and then select the dependency type.

4.  To add a lag, in the Predecessors column, add +n, where n is the number of lag days (or -n 
to specify lead time).

To unlink tasks

Right-click the dependency link, and then select Delete.
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Viewing the Task Status Compliance report

Project managers can access the Task Status Compliance report to view and update the 
status of tasks in their projects. 

1. Click Report > Reports.

The Reports tree view appears.

2.  Expand the Project Management folder.

3.  Select the Task Status Compliance report.

The filter criteria window appears.

4.  To include subprojects in the report, select the Include subprojects check box.

5.  To include completed tasks, select the Include completed tasks check box.

6.  In the Project list, select one or more projects.

7.  Click Go.

The Task Status Compliance report appears. 

8.  To update the status of a task:

a. Click  or the task name in the task row. The Update Task Status dialog box 

appears.

b. Update the status. For more information, see "Update Task Status dialog box 
options" in the Time and Expense Management User Guide.
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Creating a project using the Create Quick Plan report

You can use the Create Quick Plan report to enter initiative, project, task, and resource 
assignment information in one place. The report guides you through the required fields for 
creating an initiative, project, task, and resource assignment.

1. Click Report > Reports.

2.  Expand the Project Management folder.

3.  Click Create Quick Plan.

The Create Quick Plan opens in a new window.

4.  Complete the initiative fields as required. For more information, see "Create Quick Plan 
report, initiative options" on page 145.

5.  Click Save.

6.  To add other initiative information, click Initiative Details .

The Edit Initiative dialog box appears. 

7.  Complete the fields as required. 

8.  Complete the project fields as required. For more information, see "Create Quick Plan, 
project options" on page 149.

Create Quick Plan report, initiative options

For detailed information about initiatives, see the Initiative Management User Guide.

General section

Field Description

Client type-ahead field Client of the initiative.

Client ID type-ahead field ID of the client.

Initiative name field Name of the initiative.
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Field Description

Alternate Name field Alternate name for the initiative.

Description field Description of the initiative.

Cost structure list Cost structure for the initiative.

Initiative status list Status of the initiative.

Manager type-ahead field Resource responsible for the initiative.

Staffing workgroup type-ahead 

field

Workgroup for the initiative.The staffing workgroup is 

used in resource demand calculations. Default is the 

workgroup of the initiative manager.

Main contact list Main client contact.

Candidate list Candidate that resulted in the initiative.

Additional contact list Additional contact. 

Enable two-level approval check 

box

When selected, a second level of approval after the 

initiative manager is required for all cross charges for 

the initiative.

Enable two-level approval if 
approved amount is exceeded 

check box

When selected, a second level of approval after the 

initiative manager is required for cross charges with 

net amounts that exceed the approved amount.

Second-level approver type-

ahead field

Resource who approves the cross charges after 

theinitiative manager approves the cross charges.

Enable two-level approval for 
write-offs/ups check box

When selected, a second level of approval after the 

initiative manager is required for cross charges that 

contain write-offs.

T/E Approver field Resource who approves time and expenses.
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Field Description

Secondary T/E Approver field Resource who approves the time and expenses for 

the resource specified in the T/E Approver field.

Operations center list Operations center that handles issues for the 

initiative.

Reference section

Field Description

Reference number field Reference number for the initiative

Start date field Date that the initiative begins.

Approved amount field Total amount of the approved contract, excluding 

taxes.

End date field Date that the initiative ends.

Cross Charge information section

Field Description

Currency list Cross charge currency for the initiative.

Chargeable check box When selected, the initiative is chargeable.

Cross charge type list Cross charge type.

Expense cross charge field Portion of the expenses for the initiative that will be 

cross charged to the client. The options include:

• All expenses
• No expenses
• Percentage of expenses
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Field Description

% field Percentage of expenses to be cross charged. 

Available only if Percentage of expenses is 

selected in the Expense Charge.

Cross charge format list Cross charge format.

Remit-to address list Address to which the client sends remittances. 

Default is the remit-to address specified for the cost 

structure.

To display the full address, point to the Remit-to 
Address field.

Expense GL account list Resource whose cost center is responsible for the 

expenses associated with the initiative.

Cross charge-to location group 

list

Location group where the work will be cross charged 

(for taxation purposes)

Cross charge-to location list Location where the work will be cross charged (for 

taxation purposes)

Details section

Field Description

Work code category list Work code category for taxation purposes.

Work code list Work code for taxation purposes.

Defining the project for a quick plan

The project section of a quick plan includes the mandatory project fields only. However, after 
you save the project, you can edit it as required. 

1. Click the Project tab.

2.  Complete the fields as required. For more information, see "Create Quick Plan, project 
options" on page 149.

3.  To link the project with an application:
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a. Expand the tree view and select the primary application associated with the project. 
The primary application is used for reporting purposes.

b. To change the primary application, select the name of the application instead of the 
check box. 

c. Select additional applications, as required.

4.  Click Save.

Create Quick Plan, project options

Field Description

Project name field Name of the project.

Planned start date field Estimated start date of the project.

Client field Client for the project.

Planned finish field Estimated end date for the project.

Initiative name field Initiative for the project.

Planned hours field Estimated planned effort for the project.

First status field Date that resources must perform the first status 

updates for their assigned tasks.

Status field Status of the project.

CP project type list Custom project type that represents how the 

project is categorized within Changepoint.

Project plan editors field Project plan editor for the project.

Chargeable check box When selected, the project is chargeable.

Labor budget field Proposed labor budget for the project.

Expense budget field Proposed reimbursable expense budget for the 

project
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Field Description

Other expense field Proposed budget for other expenses for the 

project.

Project value field and currency list Value and currency of the project.

Fiscal period type-ahead field Cost structure whose fiscal periods apply to the 

project.

Comments field Comments regarding the project.

Work location group list Work location group for the project.

Work location list Work location for the project.

Work code category list Work code group for the project.

Work code list Work code for the project.

Applications list Applications associated with the project.

Adding and assigning tasks for a quick plan 

You must enter and save all required information in the Project section before you can add the 
task information.

1. Click the Task tab.

2.  Complete the fields as required. For more information, see "Create Quick Plan, task 
options" on page 151.

3.  To link the task with an application:

a. Expand the tree view and select the primary application associated with the project. 
The primary application is used for reporting purposes.

b. To change the primary application, select the name of the application instead of the 
check box. 

c. Select additional applications, as required.

4.  Click Save.
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Create Quick Plan, task options

Field Description

Task name field Name of the task.

Planned start field Estimated start date for the task.

Project field Project name.

Planned finish field Estimated finish date for the task.

Planned hours field Estimated effort for the task. The value must equal 

the total planned hours of the task assignments.

Staffing level list Staffing level for the task.

Function list Function for the task.

Chargeable task check box When selected, the task is chargeable.

Comments field Comments about the task.

Allow work location override check 

box

When selected, resources can override the work 

location when entering time for the task.

Allow work code override check 

box

When selected, resources can override the work 

code when entering time for the task.

Work location group field Work location group for the task.

Work location field Work location for the task.

Work code category field Work code category for the task.

Work code field Work code for the task.

Resource type-ahead field Resource who is assigned to the task.

Planned hours field Estimated hours that the resource requires to 

complete the task.
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Field Description

Staffing level field Staffing level for the task assignment.

Application field Applications associated with the task assignment.

Creating a project based on the projected resources of an initiative
You can create a project based on the projected resources of an initiative. A task is created for 
each projected resource that you select. The project status is Draft and task status updates are 
required once a week. The planned start date for the project is the earliest start date from the 
tasks, and the planned finish date is the latest finish date from the tasks.

1. Access the initiative. 

2.  Click the Projected resources tab.

3.  Select the projected resources for which tasks will be created in the project.

4.  Right-click and select Create Quick Project.

The Project name field, which includes the initiative name, appears, and the following 
columns are added to the table: 

• Quick project – flag that indicates the projected resources to be created as project 
tasks

• Task – includes the name of the staffing level of the projected resources as the task 
names

5.  Edit the project name and task names, if required.

6.  Click Save. 

The project is created. The project resources that have been created as tasks for the project 
display a  in the first column of the Projected resources tab.

 

152 | Changepoint PPM 2021



9. Microsoft Project Integration
About Microsoft Project integration

The integration of Changepoint with Microsoft Project combines the benefits of high-level 
planning options and detailed task lists from Microsoft Project with the capture of time and 
status information in Changepoint.

After a Changepoint project is linked to Microsoft Project (called a linked MSP project), the 
project manager creates the tasks and resource assignments in the MSP project, and resources 
update their task status in  Changepoint. The actual data from the task status updates is 
transferred to the linked MSP project when the project manager updates the linked MSP 
project. 

Although Changepoint does not integrate with Microsoft Project calendar functionality, the 
project manager can transfer nonworking days from Changepoint to the Microsoft Project 
calendar and set the resource maximum units based on the resources’ available hours per 
day. Also, if the option to update the calendar is enabled for a task in Changepoint, the 
personal calendar will be updated for resources who are assigned to the task in the linked 
MSP project.

Note: Depending on the Microsoft Project version used in your organization, procedures 
may differ. For more information, see the Microsoft Project help.

About data transfer between linked MSP projects and Changepoint

The first time that you link a Changepoint project to Microsoft Project, the system creates a 
new MSP project with the same name as the Changepoint project. The MSP project is stored 
in a temporary Microsoft Project file (.mpp) on your computer while you are working with it. 
When you save and exit from Microsoft Project, the linked MSP project is saved in 
Changepoint.

The following information in the Changepoint project is transferred to the new MSP project:

• Project name

• Resources

• Resource cost information, if the project manager has access rights

• Planned, actual, remaining and baseline start and end dates

• Planned hours
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• Tasks and task dependencies within the project

All tasks automatically have the fixed duration task type, regardless of the Microsoft Project 
default setting. The task duration, work start and finish match the values from Changepoint. 
After the project is linked, you can change the task type to fixed work or fixed units in 
Microsoft Project and the values will be recalculated.

When you edit and save a linked MSP project, the following information is transferred back to 
the Changepoint project:

• Task names

• Project planned start date

• Planned start and finish dates of tasks

• Phase information for tasks

• Resource assignments

• Work breakdown structure

After the transfer, the information is automatically distributed to project resources. If resource 
leveling is enabled for your organization, the system validates the task assignments and a 
validation report is displayed if there are any conflicts.

Data transferred from Changepoint when updating a linked MSP project

Each time you access a linked MSP project, you can select whether you want to update the 
following information from Changepoint:

• Actual hours spent on tasks 

• Actual time by assignment, by date

• Actual start dates for assignments

• Task status (forecast to complete in hours)

• Estimated completion date of tasks (if not finished)

• Forecast start date of task assignments

Changepoint allows the status update requirement for projects to be overridden for specific 
tasks and task assignments, but this capability is not supported in Microsoft Project. If you 
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create a task or task assignment in Microsoft Project and then transfer the task to Changepoint, 
applies the project status requirement to the task or task assignment.

Data transferred between Changepoint and MSP

You can enter the following task-related information in either Changepoint or Microsoft 
Project:

• Specification of whether a task is chargeable

• Text fields 1, 2, 3

• Code fields 1, 2, 3 (single values only)

• Utilization eligible

• Update resource calendar

• Associate with fixed fee

• Fixed-fee item

Steps required before linking a project
The following list describes the steps required before a Changepoint project can be linked with 
Microsoft Project.

1. Creating a project in Changepoint, with or without tasks and task assignments. For more 
information, see "About creating projects" on page 14.

2.  Creating a list of resources for the project in Changepoint. For more information, see 
"About creating a list of resources for a linked MSP project" on page 155.

3.  Setting up exchange rates in Changepoint Administration.

If different currencies are used in Changepoint and Microsoft Project, ensure that the 
appropriate exchange rate values have been set up and activated in Changepoint 
Administration. Otherwise, an exchange rate value of 1 will be used during data transfers.

4.  Installing the Changepoint MSP COM Add-in. For more information, see "Installing the 
Changepoint MSP COM Add-in" on page 156.

About creating a list of resources for a linked MSP project

Before you link your Changepoint project to Microsoft Project, you must ensure that all of the 
resources that you intend to assign to project tasks are specified in  Changepoint. The type of 
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resource list depends on how resource requests are used by your organization:

• If resource requests are not used, the resources from your Preferred resources list are 
used. 

• If resource requests are submitted from the initiative or task editing view, then the 
projected resources from the initiative are used. If task restrictions have been set up for the 
initiative to restrict assignments to projected resources, then these task restrictions are also 
applied in Microsoft Project.

• If resource requests are submitted from the project, then the resources from the project 
team are used. 

Installing the Changepoint MSP COM Add-in

1. In Changepoint, click Preferences.

The Preferences view appears.

2.  Expand the Add-in installations section, and click the Install Changepoint MSP COM 
Add-in link.

A file download dialog box for Changepoint MSP COM Add-in installer appears.

3.  Click Run to launch the installer.

Depending on your browser, you may have to save the installer first and then run it. 

4.  If a security warning displays, acknowledge the warning and continue with the installation.

5.  Follow the installer prompts:

• When you are prompted to select a language, select your Windows operating system 
language.

• When you are prompted for the URL of the Changepoint website, copy and paste the 
URL from the MSP subsection of the Add-in installations section of the Preferences 
view.

6.  When the installation complete message displays, click Finish.

The following Changepoint-related items are added to the Microsoft Project interface:

• Changepoint command on the Add-Ins tab.

• CP Gantt view, accessible from the Gantt Chart command on the View tab.
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• Changepoint fields for selection, accessible from the Insert Columns command on the 
Gantt Chart Tools Format tab.

Default schedule settings for Microsoft Project

It is recommended that you set the following schedule settings as default settings in Microsoft 
Project, before linking to Changepoint. The options are in the Schedule tab of the Options 
dialog box in Microsoft Project. For more information, refer to the Microsoft Project help.

MSP Schedule option Recommended setting

Show assignment units as a Percentage

Auto-scheduled tasks scheduled on Project Start Date

Duration is entered in Days

Work is entered in Hours

Default task type Fixed Duration

(All tasks in Changepoint are defined as fixed 

duration.)

Show that scheduled tasks have 

estimated durations

Clear the check box

Configuring the Changepoint website settings
If you access different Changepoint websites, for example, an internal website at the office and 
an Internet website from home, then you must switch the Changepoint website settings in 
Microsoft Project.

Tip: When you open a linked MSP project, the Changepoint URL displays in the bottom 
left corner of the Microsoft Project window.

1. In Microsoft Project, click the Add-ins tab.

1. ClickChangepoint > Changepoint Setup.

The Changepoint Setup dialog box appears.

2.  Enter the URL or website address for Changepoint.

3.  Click OK.
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Your Changepoint website settings are validated and saved. These settings are used the 
next time you link to Changepoint.

Accessing a linked MSP project
After a project is linked, you can view and edit it using Microsoft Project. 

1. In Microsoft Project, click the Add-ins tab.

2.  Click Changepoint > Link Changepoint Project.

3.  If the Changepoint sign in dialog box displays, enter your Changepoint user ID and 
password and click OK.

The Changepoint Project List dialog box appears.

4.  Expand the Linked Projects folder and select a project.

5.  Click OK.

The Link Changepoint Project dialog box appears.

6.  Do one of the following: 

• To access the linked project without transferring data from Changepoint, select the Do 
not update the data in Microsoft Project option and then click OK. 

• To update the linked project before accessing it, select the relevant update option and 
then click OK. For more information, see "Link Changepoint Project dialog box 
options" on page 159.

The linked project opens in Microsoft Project.

About linking Changepoint projects to Microsoft Project
If you do not select additional update options when first linking a project, the start date, finish 
date and hours for tasks and task assignments in Microsoft Project will be preserved. If you 
select additional update options (such as, Update the actual start date or Update actual 
hours), it could cause Microsoft Project to recalculate the start date, finish date and effort, 
which means that these values will be different than what was originally in Changepoint will 
not interfere with the Microsoft Project calculations. 

Note: Open tasks are not supported in linked MSP projects because entering time for open 
tasks creates an assignment in Changepoint, which is not allowed in linked MSP projects. 
Therefore, you cannot link a Changepoint project that includes open tasks.
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If you link an MSP project that already contains actual work, costs, start dates or finish dates, 
this information is not transferred into Changepoint. Instead, the actual values are overwritten 
with values from Changepoint when you link and update the project. However, you can choose 
not to link certain tasks from the MSP project and the actual values for these tasks will not be 
overwritten.

After an MSP project is linked to a Changepoint project:

• You must enter all planning and resource assignment changes in the linked MSP project. 

• The project manager, project plan editor, or summary task manager for the task can do 
limited editing on tasks in Changepoint, but cannot add tasks or modify them using Project 
Worksheet. However, you can make changes to the project that are not related to tasks. For 
example, you can still change access rights in Changepoint.

• You cannot create open tasks for linked MSP projects.

• You cannot save baselines for linked MSP projects.

Link Changepoint Project dialog box options

In the Link Changepoint Project dialog box, you specify the options for transferring data 
from Changepoint to the MSP project.

Option Description

Do not update the data 
in Microsoft Project

When selected, data is not transferred from Changepoint to 

the MSP project. Not available the first time the project is 

linked. 

Update the modified 
tasks in Microsoft 
Project

When selected, transfers data only from tasks for which 

resources have entered time or status updates. Not available 

the first time the project is linked.

Update all tasks in 
Microsoft Project

When selected, transfers all of the data. Use this option to 

transfer all of the data from Changepoint if the linked project 

gets out of sync, for example, if an update is interrupted or 

there is a system crash. Not available the first time the project 

is linked.
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Option Description

Update the rates for 
Microsoft Project

When selected, transfers the cost rates for resources.

Update project and 
resource-level 
nonworking days and 
calculate resource 
maximum units

When selected, transfers the nonworking days from the 

project and resource-level to MSP. Also, calculates the 

maximum units for resources based on the percent available 

for planned work from the Changepoint workgroup and the 

default hours per day from MSP.

Update the actual start 
date

When selected, transfers the actual start dates of task 

assignments.

Update actual hours When selected, transfers actual hours that resources entered 

against tasks.

Update remaining hours When selected, transfers the remaining hours for tasks.

Update planned effort 
distributions

When selected, transfers allocated planned hours from the 

project to the MSP project the first time that the project is 
linked only. After the project is linked, time allocation data is 

transferred only from Microsoft Project to Changepoint. This 

option is set automatically and cannot be changed if a cost 

structure has been associated with the Changepoint project.

Only update tasks with 
a planned start date 
within the following date 
range

When selected, transfers the actual hours and dates for the 

tasks that have a planned start date that is within the date 

range that you specify. Not available the first time a project is 

linked.
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Option Description

Update the summary 
time in Microsoft Project

When selected, transfers time at the task assignment level, 

and only the Actual Work column is updated in Microsoft 

Project. 

For example, if time records for a task include 6 hours on 

Monday and 8 hours on Tuesday, the Actual Work column in 

Microsoft Project displays a total of 14 hours. However, 

Microsoft Project distributes the actual time based on the 

planned hours for each day. If 8 hours were planned for 

Monday and 8 hours for Tuesday, the actual time would be 

distributed as 8 hours on Monday and 6 hours on Tuesday in 

Microsoft Project. 

Available only when Update actual hours is enabled and a 

cost structure has been associated with the Changepoint 

project. 

Update the detailed time 
in Microsoft Project

When selected, transfers actual data at a detailed level, 

including a breakdown of task time by day. For example, if 

time records for a task include 6 hours on Monday and 

8 hours on Tuesday, the actual time would be distributed in 

Microsoft Project as 6 hours on Monday and 8 hours on 

Tuesday.

Available only when Update actual hours is enabled and a 

cost structure has been associated with the Changepoint 

project. 

Linking a Changepoint project to Microsoft Project

1. In Microsoft Project, click the Add-Ins tab.

2.  Click Changepoint > Link Changepoint Project.

3.  If the Changepoint sign-in dialog box displays, enter your Changepoint user ID and 
password and then click OK.

The Changepoint Project List dialog box appears. The Available projects folder lists 
projects for which you are a project manager. The Linked projects folder lists your 
projects that are already linked with Microsoft Project.

4.  Expand the Available projects folder, select the project, and then click OK.
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The Link Changepoint Project dialog box appears.

5.  Do one of the following:

• To create the link to Microsoft Project without transferring actual data, or if no data 
exists yet, do not select any options. You can always update the actual data at a later 
time.

• To transfer data from the Changepoint project, select the relevant options. For more 
information, see "Link Changepoint Project dialog box options" on page 159.

6.  Click OK.

The new MSP project is created and linked to the Changepoint project.

About editing a linked MSP project
After a Changepoint project is linked to an MSP project, you must edit and create all tasks and 
task assignments in the MSP project. You can also enter additional project information and 
monitor project progress.

Note the following differences in behavior for working with linked MSP projects:

• When projects and tasks are linked through interproject dependencies, you cannot move 
the start date of the successor task to an earlier date than the latest finish date for the 
parent task plus lag time for all parent tasks.

• When adding a new task, you must enter values for fields that are mandatory in 
Changepoint.

• If you change the staffing level for a task assignment, it is saved in Changepoint with the 
current date as the effective date. If you want to specify a different effective date, you 
must perform the change in Changepoint, which requires breaking the link to Microsoft 
Project. 

• When using the Insert project option to import an existing MSP project, you must clear 
the Link to project check box. Otherwise, data will not be updated from Microsoft Project 
to Changepoint . Also, keep in mind that actual times and dates in this plan will be 
overwritten with actual data from Changepoint when the link is updated.

• When you create a task assignment in a linked MSP project, the effort amounts are 
converted to hours, days, or FTEs based on the system-level Daily capacity setting and 
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not the Daily conversion factor that is normally used when task assignments are created 
in Changepoint.

Editing a linked MSP project

1. Access the linked project in Microsoft Project.

2.  Make the necessary changes.

3.  To update a task in the Changepoint project, select Yes in the Update CP column.

4.  Click the Save icon.

5.  Exit from Microsoft Project.

6.  If a message appears, asking if you want to save the project, click Yes. 

7.  In Changepoint, roll up the project to update the planned hours, planned start and planned 
finish dates. For more information, see "Rolling up a project manually" on page 49.

Deleting a task or task assignment from a linked MSP project

You cannot delete a task or task assignment that has actual time or expenses entered against it. 
When you delete a task from a linked MSP project, the task is removed from Changepoint, but 
remains in Microsoft Project. If the task is an integral part of the Projects tree view, it remains 
in Changepoint but is inactive.

1. Access the linked project in Microsoft Project.

2.  To delete a task in the Changepoint project only, select Yes in the Remove CP column.

3.  Click the Save icon.

4.  Exit from Microsoft Project.

5.  If a message appears, asking if you want to save the project, click Yes. 

Updating actual time and dates in a linked MSP project
Resources enter the time that they spend working on tasks into Changepoint, but this data is 
not transferred to the linked MSP project until you update it.

1. Access the linked MSP project.

The Link Changepoint Project dialog box appears.

2.  Select the Update the modified tasks in Microsoft Project check box.
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3.  Select the type of information you want to transfer to the MSP project. For more 
information, see "Link Changepoint Project dialog box options" on page 159.

4.  Click OK.

The data is transferred to the MSP project, which opens.

About identifying Changepoint resources in a linked MSP project
In linked MSP projects, there is a custom Changepoint resource flag that you can use to 
identify Changepoint resources. You can either insert the flag as a column into a resource 
sheet, or insert a column in your linked MSP project. For more information, see the Microsoft 
Project help.

About forecast start and finish dates in linked MSP projects
Only planned start and finish dates are updated from Microsoft Project to Changepoint, but not 
forecast start and finish dates. In both Changepoint and Microsoft Project, the forecast start 
and finish dates are the same as the planned start and finish dates until the first time that a 
resource updates the status of a task. After a resource updates the status of a task, the forecast 
start and finish dates are stored in separate fields in Changepoint and transferred to Microsoft 
Project into the Start10/Finish10 fields for information purposes. Changes to the planned start 
and finish dates, whether done in Microsoft Project or Changepoint, no longer affect the 
forecast start and finish dates.

Forecast dates in Changepoint may be different than the start and end dates in Microsoft 
Project. Forecast start and finish dates in Changepoint are updated when resources update the 
task status. Start and end dates in Microsoft Project are updated when the project manager 
changes planning information and by Microsoft Project calculations. 

Viewing task usage information in a linked MSP project
Use the Task Usage view in Microsoft Project to view the distributed time information as it 
has been entered in Changepoint. Actual time is exported from Changepoint to Microsoft 
Project by assignment date. 

1. Access the linked MSP project.

2.  Click the View tab.

3.  Click Task Usage > Task Usage.
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About removing the MSP link
If you want to manage a linked MSP project in Changepoint without interfacing with Microsoft 
Project, you can remove the MSP link. When the MSP link is removed:

• All dependencies between Changepoint and Microsoft Project are removed. Reconnecting 
the MSP link after will not re-establish the dependencies.

• A snapshot of the MSP project is saved as an .mpp file attachment in the Related 
knowledge section of the project profile. The .mpp file is for information purposes only.

Removing the MSP link

You must use Microsoft Project to remove the link.

1. In Microsoft Project, click the Add-Ins tab.

2.  Click Changepoint > Remove Changepoint project link.

3.  If the Changepoint sign-in dialog box displays, enter your Changepoint user ID and 
password and then click OK.

The Changepoint Project List dialog box appears. 

4.  Expand the Linked projects folder and select the project that you want to unlink.

5.  Click OK.

A confirmation dialog box appears.

6.  Click Yes.

The link is removed.

Microsoft Project and Changepoint field mappings
The following tables detail how the project, task and task assignment fields in Changepoint are 
mapped to the corresponding fields in Microsoft Project, and how and when the fields are 
updated automatically.

Note: The Changepoint Alternate Name field is not supported in Microsoft Project.

Restrictions with configurable fields in linked MSP projects

The Changepoint configurable fields Text 1, Text 2, and Text 3 for projects are mapped to the 
Text 1, Text 2, and Text 3 fields in Microsoft Project, which are text only. To ensure that 
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these fields in linked MSP projects are updated properly, the field type of the Changepoint 
configurable fields must be text. Do not change the field type to numeric or date.

Project field mappings

Changepoint field Direction
During creation 
and/or update

MSP column

Project name To Creation Project Name

Chargeable To Creation and Update Chargeable

First status To Creation Status date

Currency To Creation and Update Currency

Project start 

(calculated)

To Creation Project Start

Cross charge type To and From Creation and Update Text 2

Task field mappings

Changepoint Field
Direction of 
Feed

During Creation 
and/or Update

Microsoft 
Project Column

Task name To, during creation only. From, during 

updates

Name

Description To and From Creation and Update Task Notes

Baseline start From Creation Baseline Start

Baseline finish To during creation only. From during 

updates

Baseline Finish

Baseline hours To during creation only. From during 

updates

Baseline Work

Forecast start To and From Creation and Update Start 10
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Changepoint Field
Direction of 
Feed

During Creation 
and/or Update

Microsoft 
Project Column

Forecast finish To and From Creation and Update Finish 10

WBS To Creation Outline Level

WBS From Update Outline Number

Chargeable task To and From Creation and Update Chargeable

Text 1 To and From Creation and Update Text 1

Text 2 To and From Creation and Update Text 2

Text 3 To and From Creation and Update Text 3

Cross charged to 

fixed-fee portion of the 

initiative

To and From Creation and Update Fixed Fee (Flag 5)

Fixed fee (deliverable 

name)

To and From Creation and Update Fixed Fee Item 

(Text 4)

Utilization eligible To and From Creation and Update Utilization Eligible 

(Flag 6)

Capital To and From Creation and Update Capital (Flag 10)

Project phase To during creation only. From during 

updates

Phase (Text 12)

Configurable code 1 To and From Creation and Update Text 6

Configurable code 2 To and From Creation and Update Text 7

Configurable code 3 To and From Creation and Update Text 8

Add to calendar To and From Creation and Update Calendar CP 

(Flag 4)
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Changepoint Field
Direction of 
Feed

During Creation 
and/or Update

Microsoft 
Project Column

Locked task To and From Creation and Update Locked (Flag 7)

Open task To Creation and Update Not editable in 

Microsoft Project

Work code To and From Creation and Update Work Code 

(Text 9)

Location To and From Creation and Update Location (Text 10)

Task status 

(completed only)

To and From Creation and Update Percent Complete

Planned hours 

(computed value)

To and From Creation Duration

Staffing level To and From Creation and Update Text 5

Function To and From Creation and Update Text 11

Capital To and From Creation and Update Capital (Flag 10)

Allow work code 

override

To and From Creation and Update (Flag 9)

Allow work location 

override

To and From Creation and Update (Flag 8)

Planned start To during creation only. From during 

updates

Start

Actual start To during creation, if the option to update 

the actual start date is selected.

Thereafter, from during updates.

Actual Start

Actual finish From Update Actual Finish
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Changepoint Field
Direction of 
Feed

During Creation 
and/or Update

Microsoft 
Project Column

Planned finish To during creation only. From during 

updates

Finish

Milestone To and From Creation and Update Milestone

Task assignment field mappings

Changepoint Field
Direction of 
Feed

During Creation 
and/or Update

Microsoft 
Project Column

Planned hours To during creation only. From during 

updates

Work

Not stored in 

Changepoint

To and From Creation and Update Units

MSP calculates 

units based on 

work/duration, 

which is updated 

from 

Changepoint.

Actual hours To during creation only. Actual Work 

(summary)

Time Scale Actual 

Work (detailed)
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Changepoint Field
Direction of 
Feed

During Creation 
and/or Update

Microsoft 
Project Column

Forecast start

Forecast finish

When the task 

assignment is not 

completed, these are 

set to planned start 

and planned finish. 

When resource 

completes the task 

and agrees to update 

the planned hours, 

then they are set to 

planned start and 

planned finish.

To and From Creation and Update Start (Start 10)

To and From Creation and Update Finish (Finish 10)

Actual start To Creation and Update Actual Start

Actual finish To Creation and Update Actual Finish 

(Changepoint 

updates the actual 

start and MSP 

calculates the 

actual finish)

Manager comments

Notes entered in MSP 

will be updated in 

Manager comments 

only.

To and From Creation and Update Notes

Both manager 

comments and 

resource 

comments are 

updated in Notes.

Resource comments To Creation and Update Notes

Planned start From Creation Start

Planned finish From Creation Finish

170 | Changepoint PPM 2021



Microsoft Project and Changepoint field mappings

Changepoint Field
Direction of 
Feed

During Creation 
and/or Update

Microsoft 
Project Column

Cost to date

(task assignment – 

This figure is the total 

hours times the 

resource’s hourly cost 

rate)

To Creation and Update Actual Cost

(This value is 

calculated based 

on time entries 

and the effective 

dates on cost 

rates for each task 

assignment 

through a 

scheduled job run 

in Changepoint. 

The values 

calculated are 

added to the field 

in Microsoft 

Project.)

Remaining hours

Remaining hours are 

sent to Changepoint 

only when the 

resource completes 

the task and selects to 

update the planned 

hours for the 

completed task. Then 

remaining hours is set 

to 0 (zero).

To and From Creation and Update Remaining Work

 

Text 1 To and From Creation and Update Text 1

Text 2 To and From Creation and Update Text 2

Text 3 To and From Creation and Update Text 3
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Changepoint Field
Direction of 
Feed

During Creation 
and/or Update

Microsoft 
Project Column

Staffing level 

description

To and From Creation and Update Staffing level 

(Text 5)

Locked To and From Creation and Update Locked (Flag 7)

Location To and From Creation and Update Location (Text 10)

Functions To and From Creation and Update Functions 

(Text 11)

Allow work code 

override

To and From Creation Location Override 

(Flag 8)

Allow work location 

override

To and From Creation Work Code 

Override (Flag 9)

Code 1 To and From Creation and Update Text 6

Code 2 To and From Creation and Update Text 7

Code 3 To and From Creation and Update Text 8

Work code To and From Creation and Update Work Code 

(Text 9)

Resource Field Mappings

Changepoint Field
Direction of 
Feed

During Creation 
and/or Update

Microsoft Project 
Column

Indicate CP resource To Creation Flag 1 (Read-only 

in MSP)

Resource name To Creation and Update Resource

Hourly cost rate To Creation and Update Standard Rate

Effective date To Creation and Update Effective Date 
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About editing tasks and task assignments in linked MSP projects

Nonworking days settings

Changepoint Setting 
Level

Microsoft Project Setting

System level Project Calendar

Global Workgroup Personal Calendar

Workgroup

Resource

About editing tasks and task assignments in linked MSP projects
You can select the values for the following fields at the task level and at the task assignment 
level:

• Work

• Duration 

• Start 

• Finish 

• Code 1,2,3 (if used)

• Text 1,2,3 (if used)

• Forecast start

• Forecast finish

• Chargeable

• Staffing level

• Function

• Work code

• Work location

• Work location override

• Work code override
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• Locked

Tip: If the columns for the fields are not displayed, you can insert them. 

When creating a task in Microsoft Project, you can select the values for these fields in the task 
view. Task assignments that you create for tasks automatically have the same field values as 
the task and are transferred to Changepoint when you save the linked project. However, you 
can edit these values for tasks and specific task assignments.

Editing a task in a linked MSP project

1. Access the linked MSP project.

2.  Click the View tab.

3.  Click Gantt Chart > CP Gantt.

4.  Click Table > CPUsage.

5.  Make the necessary changes.

6.  If there are existing task assignments, a message displays, asking if you want to override 
this value for all assignments. Do one of the following:

• To replace the values for all existing task assignments with the new value, select Yes.

• To leave the values for existing task assignments unchanged, select No.

7.  Save the project.

Note: Changes to the Staffing level field are handled in a different way. Existing task 
assignments that were previously saved with or without a staffing level will not be 
updated. You must edit the task assignments accordingly. For more information, see 
"Editing a task assignment in a linked MSP project" on page 174.

Editing a task assignment in a linked MSP project

1. Access the linked MSP project.

2.  Click the View tab.

3.  Click Task Usage > Task Usage.

4.  Click Table > CPUsage.

5.  Make the necessary changes.
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About setting baselines in linked MSP projects

6.  Save the project.

About setting baselines in linked MSP projects
In Microsoft Project, you can set up to 11 baselines. However, only the information from the 
first baseline option in the list (Baseline, without a number), is transferred to Changepoint. 
You can set this baseline multiple times; however, each time you set the baseline, the new 
baseline information replaces the previous baseline information in Changepoint.

Note: Changes that you make to project and task assignment baselines in Microsoft Project 
are not transferred to Changepoint.

For information about setting a baseline, see the Microsoft Project help.

About saving interim plans in linked MSP projects
The use of interim plans is solely for the purpose of project tracking in Microsoft Project. The 
interim plan fields have no effect on the Changepoint project dates. That is, this information is 
not transferred back to Changepoint. 

To view an interim plan after it has been saved, insert the interim baseline field columns into 
the table. For example, if you selected the Start1 and Finish1 fields when saving the interim 
plan, then you would add these fields to the table.

For information about saving an interim plan, see the Microsoft Project help.

Setting up multiple baselines in a linked MSP project

To display both the active and original baselines in Microsoft projects, each Microsoft Project 
user must configure a specific bar style for each of the baselines in their local Microsoft 
Project settings. You only have to perform this procedure once for each installation of 
Microsoft Project.

Note: It may be possible to have one user perform this procedure and then email the 
Global.mpt file to the other Changepoint users at the organization. For more information, 
see the Microsoft Project online help.

1. In Microsoft Project, click Format > Bar Styles. 

2.  The Bar Styles dialog box appears.

3.  Insert a new row and different color bar for each for the active and original baselines. For 
more information about configuring bar styles, see the Microsoft Project online help.
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9. Microsoft Project Integration

4.  Click OK to close the dialog box.

5.  Click the View tab.

6.  Select Additional View > More Views.

The More Views dialog box appears.

7.  Click the Organizer button.

The Organizer dialog box appears.

8.  Select CP Gantt in the list to the right that displays the name of the current project. 

9.  Click the Copy button.
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About saving interim plans in linked MSP projects

The CP Gantt entry is copied to the Global.mpt list (added to the Global.mpt template file).

10.  When prompted to replace the existing file, click Yes.

11.  Click Close to close the Organizer dialog box.

12.  Click Close to close the More Views dialog box.

After you save the settings, the two new baseline fields are displayed in Microsoft Project for 
all projects in the CP Gantt chart view, and you can do the following with or without 
Changepoint:

• Show the Baseline and Interim Baseline on the CP Gantt view.

• Export the Interim baseline to the Start1 and Finish1 fields.
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10. Project Management Troubleshooting
Scenarios for saving baselines

This topic provides project scenarios with different combinations of settings for rolling up 
subtasks and saving task baselines, and details the expected results of saving baselines on the 
different levels of projects and tasks within those scenarios. 

The scenarios are based on the following project structure:

Project level 1 Project level 2 Project level 3 Project level 4

Project 1    

 – Task 1   

  – Project 1.1  

   Task 1.1.1

   Task 1.1.2

 Task 2   

Scenario 1

The following conditions exist:

• Project 1 is not configured to roll up planned information from subprojects to parent task

• Resources do not have the option to save task baselines without affecting upper-level 
tasks, OR

• Resources have the option to save task baselines without affecting upper-level tasks, but 
when saving a task baseline, the resource selects the option to roll up and baseline
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Project or 
task

Rollup Baseline

Project 1 Roll up Task 1 and Task 2 to 

Project 1

Task 1, Task 2, Project 1

No baseline in Project 1.1

Task 1* Roll up to Project 1 Task 1, Project 1 

Project 1.1* No roll up to the parent task Task 1.1.1, Task 1.1.2, Project 1.1

Task 1.1.1* Roll up to Project 1.1 Task 1.1.1, Project 1.1

Task 1.1.2* Roll up to Project 1.1 Task 1.1.2, Project 1.1

Task 2* Roll up to Project 1 Task 2, Project 1

* When saving a task baseline, the system uses the previous (most recent) baseline values for 
the other project tasks when they are required to calculate summary task and project baselines.

Scenario 2

The following conditions exist:

• Project 1 is not configured to roll up planned information from subprojects to parent task

• Resources have the option to save task baselines without affecting upper-level tasks option

• When saving a task baseline, the resource selects the option to baseline the task and lower 
tasks only

Project or 
task

Rollup Baseline

Project 1 Roll up Task 1 and Task 2 to 

Project 1

Task 1, Task 2, Project 1 

No baseline in Project 1.1

Task 1 No roll up to the Project 1 Task 1 

Project 1.1 Roll up Task 1.1.1 and 1.1.2 to 

Project 1.1. No rollup to the Task 1

Project 1.1, Task 1.1.1, Task 1.1.2 

(Project 1 baseline rules apply)
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Scenarios for saving baselines

Project or 
task

Rollup Baseline

Task 1.1.1 No roll up to the Task 1 Task 1.1.1

Task 1.1.2 No roll up to the Task 1 Task 1.1.2

Task 2 No roll up to the Project 1 Task 2

Scenario 3

The following conditions exist:

• Project 1 is configured to roll up planned information from subprojects to parent task

• Resources do not have the option to save task baselines without affecting upper-level tasks, 
OR

• Resources have the option to save task baselines without affecting upper-level tasks, but 
when saving a task baseline, the resource selects the option to rollup and baseline

Project or 
task

Rollup Baseline

Project 1 Project 1 All projects and tasks

Task 1* Roll up to Project 1 Task 1, Project 1

Project 1.1, Task 1.1.1, Task 1.1.2 

Project 1.1* Roll up to Task 1, Project 1 Project 1.1, Task 1.1.1, Task 1.1.2 

Task 1, Project 1, Task 2 (old 

baseline value)

Task 1.1.1* Roll up to Project 1.1, Task 1, 

Project 1

Task 1.1.1, Project 1.1, Task 1, 

Project 1 

Task 1.1.2* Roll up to Project 1.1, Task 1, 

Project 1

Task 1.1.2, Project 1.1, Task 1, 

Project 1 

Task 2* Roll up to Project 1 Task 2, Project 1 
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* When saving a task baseline, the system uses the previous (most recent) baseline values for 
the other project tasks when they are required to calculate summary task and project baselines. 

Scenario 4

The following conditions exist:

• Project 1 is configured to roll up planned information from subprojects to parent task

• Resources have the option to save task baselines without affecting upper-level tasks

• When saving a task baseline, the resource selects the option to baseline the task and lower 
tasks only

Project or 
task

Rollup Baseline

Project 1 Project 1 All projects and tasks

Task 1 Roll up to Task 1

No rollup to Project 1

Task 1

Project 1.1, Task 1.1.1, Task 1.1.2 

Project 1.1 * † Rollup to Task 1, Project 1 Project 1.1, Task 1.1.1, Task 1.1.2 

Task 1, Project 1, 

Task 2 (old baseline value)

Task 1.1.1 * † Rollup to Project 1.1, Task 1 Task 1.1.1, Project 1.1, Task 1

Task 1.1.2 * † Rollup to Project 1.1, Task 1 Task 1.1.2, Project 1.1, Task 1

Task 2 No Rollup to Project 1 Task 2

* When saving a task baseline, the system uses the previous (most recent) baseline values for 
the other project tasks when they are required to calculate summary task and project baselines. 

† Baselines are saved for higher level tasks because the rolling up of planned information from 
subprojects to parent task takes precedence even when the resource saves a task baseline and 
selects the option to baseline the task and lower tasks only.

Troubleshooting projects
This topic provides troubleshooting information for the project profile and project dialog box.
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Troubleshooting projects

Chargeable project check box is not available

The Chargeable project check box is available only if the option to allow project managers to 
override the Chargeable status check box has been selected in the initiative dialog box. For 
the project to display as a selection in the cross charge dialog box, the project must be 
chargeable.

Cannot change the Chargeable status of a project

You cannot change the setting of the Chargeable project check box when the Split charges 
check box has been selected on the Cross Charge information tab of the initiative, and either 
of the following conditions exist:

• Cross charges exist for an initiative or phantom initiative that is in Draft, Pending 
Approval, Pending Second Approval or Approved status.

• All cross charges are committed, but there is time and/or expenses for the initiative or 
phantom initiative that have not been fully cross charged.

Project ID field is not available

The field has not been enabled by your organization.

Fiscal Periods field: cost structure is not available

The Fiscal periods field lists only cost structures that have defined fiscal periods.

Cross Charge Contact field is not available

This field is available only if the option to allow project managers to specify the charge contact 
check box has been selected for the initiative. The address type (main, charge, shipping or 
another as configured by your System Administrator) for the contact is selected at the initiative 
level.

CP Project Type field is not available

The CP project type field has not been enabled by your organization.

Alternate Name field is not available

The field has not been enabled by your organization.

Request field is not available

The project did not originate from a request.
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Enable project time approval check box is not available

This field is available only if the option to allow project managers to specify the time approver 
field has been enabled for the initiative associated with this project. 

Project Plan editor cannot take ownership of a project
Project plan editor cannot create or delete tasks
Resource does not appear in project plan editor list

These issues are most likely related to access rights. See "Managing projects" in the Security 
Access Reference Guide.

“Baseline only” option selected when saving a baseline, but parent task is being 
rolled up and baselined

If the option to roll up planned information from subprojects to parent task is selected on the 
Access tab of the parent project, it takes precedence over the option to save a baseline without 
affecting higher level tasks.

Project Team section does not appear

In order for the Project Team section to appear, both of the following conditions must exist:

• resource requests must be enabled on the cost structure

• resource requests must be enabled at the project level on the Projected Resources dialog 
box of the initiative

Fiscal Year Breakdown section does not appear

The section displays only if fiscal periods have been specified for the cost structure that is 
associated with the project. 

Allow users to override the [Chargeable] status on expenses entered for this 
project check box is not available in the Access section of the project dialog box

This option is available only if the initiative and project are chargeable, and the option for the 
project manager to override this status has been enabled on the initiative. 

Troubleshooting linked MSP projects

Project is not available for linking from Microsoft Project

If your organization uses resource requests, all mandatory configurable fields on resource 
requests must be completed on the project editing and task editing views before the project 
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Troubleshooting tasks

will be available for linking from Microsoft Project.

Troubleshooting tasks
This topic provides troubleshooting information for the task profile and task editing view.

A resource is not available to be assigned to a task

Resources require the Track Project-Related Time feature to be assigned to a task.

Open task field not available

If resource requests have been enabled for projects or tasks on the initiative, then the Open 
task check box is disabled on the task editing view.

Cross Charged to fixed-fee portion of the initiative field is not available

This option is available only if the initiative uses fixed-fee cross charging.

Fixed Fee field is not available

This field is available only if the initiative is cross charged under some variation of a fixed-fee 
method.

Cross charge rate field is not available

This field is available only if you have the View Cross Charge and Cost Rates in Task 
Assignment Section feature. Also, the first time that you access a task in the system, you must 
right-click on the grid and select Show cross charge rates to view this field.

Cost rate field (Staffing level cost rate or Resource-based cost rate) is not 
available

The Cost rate field is a non-editable field that displays the staffing level-based or resource-
based cost rate that is applicable to the task assignment. It is only available to resources who 
have the View Cross Charge and Cost Rates in Task Assignment Section feature. 

The cost rate that is displayed is determined by the settings for the cost structure in 
Changepoint Administration:

• If the cost structure for the task is configured to use staffing level cost rates, then this field 
is called Staffing level cost rate.
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• If the cost structure is configured to use resource cost rates, then the field is called 
Resource-based cost rate and you additionally require the View Costs feature for it to 
display.

The first time that you access a task in the system, you must right-click on the table and 
select Show cost rates to view this field.

Soft-booked field is not available

This field is available only if soft-booking has been enabled for the cost structure.

Status update section is not available

The Status update section appears only on tasks that are assigned to you.

Troubleshooting Project Worksheet

Time-based assignment appears on different dates in Service Scheduler and 
Project Worksheet

If the time zone for the resource is changed after the time-based task is assigned to the 
resource, the task assignment is displayed according to the new time zone in Service 
Scheduler, but according to the original time zone in Project Worksheet. This limitation 
applies only to task assignments that exist at the time that the time zone is changed.

Dependency link does not appear in Gantt chart

Check if the predecessor task has been hidden by a filter, which will result in the dependency 
link not appearing in the Gantt chart.

Actual effort in past periods is evenly distributed after changing the loading 
method

If you change the loading method from one that does not replace planned effort in past periods 
with actual effort (3,4) to one that does (0,1,2), the actual effort in the past periods is 
distributed evenly and not according to the dates and amounts when the actual effort was 
originally entered. 

To see the exact distribution of actual hours in the past, you must save the project and then 
refresh Project Worksheet. Saving the project saves the daily distribution of the assignment 
(including the actual effort in past periods) and initiates a project rollup.
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Troubleshooting Project Worksheet

Task field values not inherited when assigning tasks in task view
Field values not copied when copying  tasks or replacing assigned resources

Configurable field values (and a few standard fields) are not inherited when assigning tasks in 
a task view unless the fields on the task and task assignment have been displayed in Project 
Worksheet. 

Similarly, field values are not copied when copying or reassigning tasks unless the fields on 
the task and task assignment have been displayed in Project Worksheet.

To ensure that  field values are  inherited or copied, do the following:

1. Create a task view  that contains the desired fields.

2.  Create a  task assignment view that contains the desired fields. Make the task assignment 
view your default view so that it appears each time you access Project Worksheet.

3.  Switch to the task view to add or change data.

You cannot insert a task or make any modifications in Project Worksheet and the 
"Save" and "Apply" buttons are missing.  

Check that you have locks on the tasks that you want to work with. If they are locked by other 
resources, you must wait until the tasks have been unlocked before you can lock them. Note 
that the project manager can take locks from other resources,  which can cause the other 
resources to lose their changes. To view who has the locks, point to the lock icon in the Project 
Worksheet view.

Summary task managers can see only their summary tasks in Project Worksheet

To view all of the tasks in Project Worksheet, summary task managers must be granted view 
project access to the project by the project manager. 

Rolled up amounts for the project are incorrect in Project Worksheet

Only the tasks that are currently displayed in the worksheet are rolled up after changes have 
been made. 

Therefore the rolled up amounts can be lower than the project totals for the following reasons:

• filter has been applied to limit the tasks that are displayed

• you are a summary task manager and do not have view project access to the project
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Cannot edit planned start, planned finish, and planned hours in a task view

If one or more task assignments for a task has a manual loading method, then you cannot edit 
the planned start, planned finish, or planned hours for the task in a task view.

Planned effort totals for daily distribution amounts are incorrect in Project 
Worksheet

Daily distribution amounts are calculated and stored using five decimal places, but are rounded 
to three decimal places when displayed in Project Worksheet. Therefore due to rounding, the 
daily distribution amounts for a task assignment might add up to a slightly different amount 
than the total planned effort that is displayed for a task assignment.

"Select/Deselect tasks for activation" icon does not appear in Project Worksheet

The Select/Deselect tasks for activation icon  is available in a task view only when no sort 

criteria has been specified in the view and no filter has been applied.

Cannot add effort to a resource in the "Assign/Replace Resources" dialog box

When the default loading method is manual, you must use a task assignment view to allocate 
effort to daily or fiscal periods.
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Changepoint MSP COM Add-in, 
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baselines, scenarios  179
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completing  21
copying to update a project  42
copying, about  41
creating  18
creating methods  13
creating, about  14
deleting  40
deleting, about  40
editing  40
editing, about  39
expenses, allowing resources to 

submit  30
fiscal periods, using  17
icons  14
ownership, taking  46
phases, about  16
progress reporting  143
project plan editors, specifying  27
project plan editors, specifying, 

about  27
quick plan, creating based on projected 

resources  152
quick plan, project options  149
quick plan, task options  151
quick plans  145
reassigning  46
rolling up  49
rolling up, about  48
setting up split charges  25
statuses, about  15
subprojects, creating  32
summary task managers, granting pro-

ject access  28

task status updates, about  16
time approvers, specifying  22
troubleshooting  182
view access, granting  26
work codes and locations, 

specifying  24
work codes and locations, specifying, 

about  24

Q

quick plans
project, defining  148
tasks, defining  150

R

reporting
project progress  143

reports
quick plan, initiative option  145
Task Status Compliance Report  143

resource leveling, about  12

resource requests
submitting from tasks  66

resources
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checking available hours  61
checking available hours, about  61
checking available hours, example  62
task assignments, deleting from  67

rolling up
projects from profile  49
projects from profile, about  48
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soft-bookings  12

split charges
setting up for projects  25

status updates
about  16

subprojects
creating  32
creating, about  32
granting access to  29
rolling up  49
rolling up, about  48

summary task managers
project access, granting  28

summary tasks
about  51

T

task assignments
checking available hours  61
checking available hours, about  61
checking available hours, examples  62
cross charge rates, viewing, about  64
planned hours, allocating automatically  65
planned hours, allocating automatically, 

about  64
resource requests, submitting  66
resources, assigning  58
resources, deleting  67

task editing view
accessing  74
General section options  53
General section, completing  57

Task Status Compliance report  143

tasks
about  51
activating in Project Worksheet  135
applications, linking to  57
assign multiple resources  117
assign multiple resources in Project Work-

sheet  115
assign resources  117
baseline, saving without affecting higher 

tasks  69
baseline, saving without affecting higher 

tasks, about  69
baselines, saving  69
baselines, saving, about  67
baselines, saving, example  68
Chargeable status, editing  74
creating  56
creating, about  52
deleting  76
dependencies, creating  72
dependencies, creating, about  70
dependencies, removing  73
dependency options  71
editing configurable fields  75
icons  52
indenting and outdenting in Project Work-

sheet  87
linking in Project Worksheet  112
open, about  51
open, restricting access to  70
profiles, accessing  52
reopening  77
reopening, about  77
resources, assigning to  58
resources, selecting, about  60
sorting  78
staffing level, changing  75
summary, about  51
troubleshooting  185
validating in Project Worksheet  134
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work codes, setting  76
work locations, setting  76

tasks, Project Worksheet
copying  114
creating  111
editing  137
moving  87

time approvers, specifying  21

troubleshooting
MSP projects  184
projects  182
tasks  185
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