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1. Changepoint Administration Introduction
About Changepoint Administration

Changepoint Administration is the  application that you use to configure and maintain the 
Changepoint applications. 

You use Changepoint Administration to set up:

• Changepoint licenses

• The organizational structure (global workgroups and workgroups) and resources within 
your organization

• Financial, taxation, and charging information

• System defaults for terminology, permissions, and option lists

• System defaults for time and expense management, candidate management, request 
management, knowledge management, and reporting

• Data export and archiving

• Workflow processes

About accessing Changepoint Administration
You access Changepoint Administration by clicking the user menu > Administrator view. 
The menu option appears only if you have been assigned at least one administration security 
feature. 

The navigation menu changes color when the Changepoint Administration menu is 
displayed.

To return to the user view, click user menu > Exit Administrator view.
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2. Administration Tools

Accessing system metrics
The sections in the Tools > System Metrics view display information about Changepoint 
usage:

• User activity – displays the number of users currently in the system, the average number 
of sessions, and the duration of each session.

• Client Portal user activity – displays the number of activated Client Portal users, the 
number of open sessions, and the average number of Client Portal sessions per day.

• Database metrics – provides statistics on Changepoint entities in the database.

• Version management – displays the Changepoint version number and updates.

To access system metrics

Click Tools > System Metrics.

About license management
You must import the license file that contains the security features that are assigned to 
resources in order to grant them access to Changepoint.

When you import a license file, the license information is displayed, which includes the list 
of security features, and the total number of licenses that have been purchased, assigned to 
resources, and are available to be assigned. 

The Base User security feature is automatically assigned to each user account (resource 
profile), and provides access to sign in to the Changepoint applications. The total number of 
Changepoint users is based on the number of base user licenses that have been assigned. 

Viewing license information

1. Click Tools > License Management.

The License Management view appears. displays the following information:
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2. Administration Tools

Column Description

Category field Category of the security feature.

Feature field Security feature names.

Feature code Code that controls the licenses and their related security 

access.

Total field Total number of licenses that have been purchased.

Used licenses field Number of licenses that have been assigned to resources 

either directly, or indirectly by assigning the feature to a role, 

which is then assigned to resources.

Available licenses field Number of licenses that have not been assigned to resources.

Importing a Changepoint license

1. Click Tools > License Management.

2.  In the Import new license file field, click Browse, and then open the Changepoint license 
file (*.lic).

3.  Click Import.

Locking Changepoint
You can lock Changepoint to prevent users from accessing the application for example, during 
system maintenance. When Changepoint is locked, only Changepoint system administrators 
can sign in, and only the configuration settings menu is available, unless the option to allow 
the system administrators full access has been selected.

1. Click Tools > Lock Changepoint.

2.  Select the Lock Changepoint and prevent users from signing in check box.

3.  To lock Changepoint immediately, select Lock Changepoint immediately.

4.  To lock Changepoint at a specific time:

a. Select Lock Changepoint on the following date and time. 

b. Enter the date and time.
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About transferring records between resources

5.  To allow Changepoint administrators to have full access to Changepoint while it is locked, 
select the Allow administrators full access when Changepoint is locked check box.

6.  To automatically sign out all users when Changepoint is locked, select the Sign out all 
users before Changepoint is locked check box.

7.  To display a warning message to users:

a. Select the Warn users that Changepoint is about to be locked check box.

b. In the Time before the warning message displays (in minutes) field, enter the 
number of minutes before Changepoint is locked that the warning message is to be 
displayed. The default is 30 minutes.

c. In the Message displayed when Changepoint is about to be locked field, enter the 
message that is displayed to resources when Changepoint is about to be locked.

d. In the Message displayed when users attempt to sign in while Changepoint is 
locked field, enter the message that is displayed when resources try to sign in to 
Changepoint while it is locked.

8.  Click Save.

About transferring records between resources
You can do the following with records for the standard fields and configurable fields for which 
a resource can be selected:

• Transfer records from one resource to another. For example, you can transfer the requests 
that are assigned to a resource to a different resource.

• Copy records from one resource to another, provided that the records can be assigned to 
multiple resources. For example, you can copy view access for a project from a resource to 
another resource.

• Remove records from a resource. For example, when a resource leaves the organization, 
you can remove the resource from being a time approver  for other resources.

Transferring or copying a record between resources

1. Click Tools > Transfer Records.

2.  In the Folders view, expand the entity and then select the record type.

3.  In the From resource type-ahead field, enter the name of the source resource. 
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2. Administration Tools

4.  In the To resource type-ahead field, enter the name of the target resource. 

5.  Click Load list.

A list of the records for the record type appears. The grayed-out records cannot be 
transferred or copied between the resources. 

Warning: For configurable fields that have conditional properties or values, you must 
verify that the target resource meets the conditional properties or values.

6.  Do one of the following:

• To transfer records to the target resource, select the records and then click Transfer.

• To copy records to the target resource, select the records and then click Copy.

Removing a record from a resource

1. Click Tools > Transfer Records.

2.  In the Folders view, expand the entity and then select the record type.

3.  In the From resource type-ahead field, enter the name of the source resource. 

4.  Click Load list.

A list of the records for the record type that can be removed from the resource appears.

5.  Select the records, and then click Remove.

6.  Click OK to confirm.

Unlocking a record manually
If a Changepoint session ends unexpectedly (for example, the computer crashes) while a 
record is being edited, the record may remain locked until a system update is run, which is 
typically overnight at the latest. However, you can unlock records manually.

1. Click Tools > Unlock Records. 

The Unlock Records view displays all of the records that are currently locked.

2.  In the Select column, select the check boxes for the records that you want to unlock.

3.  Click Unlock.
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3. Resources
About global workgroups and workgroups

Global workgroups and workgroups represent your organization’s business structure. Global 
workgroups represent the highest levels within the structure, and workgroups represent the 
lower levels. A workgroup can be associated with another workgroup to create a parent-child 
relationship.

You must have at least one global workgroup. At the global workgroup level, you define 
settings such as the default cost center and currency to be used for rollup reports.

Note: It is recommended that you create your organization’s cost centers before creating 
the global workgroups and workgroups.

Resources are assigned to workgroups. The number of workgroups or child workgroups that 
are associated with a global workgroup depends on how you want to structure your resources 
in Changepoint.

Global workgroup and workgroup inheritance rules

When you set up a  global workgroup or a workgroup, the settings are applied and access 
rights to child workgroups and workgroup resources are inherited as follows:

• Settings for a global workgroup are inherited by all of its subworkgroups.

• Settings for a workgroup apply only to the workgroup itself unless the option to include 
all child workgroups is selected.

• When you grant access to global workgroups and workgroups, the following rules apply:

• If you grant access to a global workgroup, all workgroups and resources under the 
global workgroup are granted access.

• If you grant access to a workgroup, all resources within the workgroup are granted 
access.

Accessing a global workgroup
1. Click Resources > Global Workgroups.

2.  In the Folders view, select the global workgroup. 
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Creating a global workgroup

1. Click Resources > Global Workgroups.

2.  In the Folders view, select a global workgroup. 

3.  Click New.

4.  Complete the fields as required. For more information, see "Global Workgroup view 
options" on page 28.

5.  Click Save.

Global Workgroup view options

Option Description

Global workgroup field Name of the global workgroup.

Description field Description of the global workgroup.

Default currency list Default currency of the global workgroup.

Cost center list Cost center of the global workgroup.

Default profile page field Read-only. URL for the default profile page of the global 

workgroup in Changepoint.

Custom profile page field URL for a custom profile page that replaces the default 

profile page of the global workgroup.

Maximum size of 
attachments (MB) field

Maximum size of the files that resources of the global 

workgroup can attach to entities (such as knowledge items 

and requests) in Changepoint. The default maximum is 

40 MB.

Modifying a global workgroup

You can delete a global workgroup  only if there are no active workgroups under it, or active 
resources associated with it. You must first unassign the resources from the workgroups and 
then delete the workgroups.

1. Click Resources > Global Workgroups.
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2.  In the Folders view, select the global workgroup. 

3.  To edit the global workgroup:

a. Make the necessary changes.

b. Click Save.

4.  To delete the global workgroup, click  Delete.

Accessing a workgroup
1. Click Resources > Workgroups.

2.  In the Workgroups view, expand the global workgroups to locate the workgroup.

3.  Click the workgroup.

The workgroup settings appear.

Creating a workgroup

Workgroup settings apply to the resources who are assigned to the workgroup.

1. Click Resources > Workgroups.

2.  In the Folders view, expand a global workgroup, and then select any workgroup.

3.  Click New.

4.  In the General tab, complete the fields as required. For more information, see "Workgroup 
view, General tab options" on page 30.

5.  Click Save.

6.  Complete the remaining tabs. For more information, see:

• "Configuring financial settings for a workgroup" on page 32

• "Granting access rights to a workgroup" on page 35

• "Setting up cross charge batch printing" on page 35

• "Configuring workgroup settings for Resource Planner" on page 36

• "Setting planning units options for a workgroup" on page 37
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Workgroup view, General tab options

Option Description

Workgroup field Name of the workgroup.

Alternate name field Name of the workgroup in a different language or alphabet.

Description field Description for the workgroup.

Workgroup ID field Identifier for the workgroup, which is used for custom 

reporting and integrations.

Select a global workgroup 
or a parent type-ahead field

Global workgroup or workgroup that is directly above this 

workgroup in your organization’s hierarchy.

Global workgroup field Global workgroup of the workgroup.

Parent workgroup field Parent workgroup of the workgroup, if the parent 

workgroup is not a global workgroup.

Workgroup type list Workgroup types are configured by your organization and 

can be configured at the system and global workgroup 

level. Examples include Finance, Consulting, and 

Administration.

Workgroup level list Workgroup levels are configured by your organization and 

can be configured at the system and global workgroup 

level. Levels are typically geographic, for example: Global, 

National, or Regional.

Country list Country where the workgroup is located.

Default currency list Default currency for the workgroup.

Default profile page field Default URL for the workgroup in Changepoint.

Custom profile page field Custom URL that replaces the default URL for the 

workgroup in Changepoint.
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Option Description

Percent available for 
planned work field

Percentage of time that resources in this workgroup are 

available for planned work.

Prevent project managers 
from overbooking 
resources check box

When selected, project managers in the workgroup cannot 

save task assignments that result in resources being 

overbooked. Available only when resource leveling is 

enabled.

Warn project managers if 
task assignments result in 
overbooking of resources 

check box

When selected, a warning message appears if a project 

manager in the workgroup tries to save a new task 

assignment that results in resources being overbooked. 

However, project managers can still save the task 

assignment. Available only when resource leveling is 

enabled.

Enable start time capture in 
time sheet check box

When selected, the Start time field is available on the time 

sheet of the workgroup resources.

Enable mandatory start 
time capture in time sheet 
check box

When selected, workgroup resources must specify the 

start time when entering time in the time sheet.

Maximum number of 
decimal places  in the time 
sheet field

Maximum number of decimal places that can be displayed 

for values in the time sheet.

Maximum time allowed per 
day in the time sheet field

Maximum number of time in hours and days that resources 

can enter for a day. This maximum includes both regular 

hours and overtime hours. A value of 0 means no limit.

Include in candidate-
related portlets check box

When selected, the workgroup is included in candidate-

related portlets.

Include in service-related 
portlets check box

When selected, the workgroup is included in the services-

related portlets.

About configuring financial settings for a workgroup

You can specify the financial settings for a workgroup, such as the default GL account code, 
cost center and time and expense approvers.
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Threshold approvers

You can set up an additional level of approval for expenses that exceed a threshold amount 
and specify a threshold approver for a workgroup. Threshold approval occurs after the line 
manager or initiative manager approves the expense report, but before the final expense 
approval.

Revenue transfer settings

You can override the default revenue transfer settings for a workgroup. If revenue is 
recognized based on cost rates, then transfers cannot be calculated based on cross charge rates. 
If the default revenue transfer setting for the organization is based on the labor multiplier, and 
you select the revenue transfer based on revenue percentage for the workgroup, the system 
uses the total revenue recognized per hour instead of the resource cross charge rate to calculate 
the transfer amount.

Configuring financial settings for a workgroup

1. Access the workgroup.

2.  Expand the Financial Settings section.

3.  Complete the fields as required. For more information, see "Financial Settings section 
options" on page 33.

4.  To set up approvals for expenses that exceed a threshold amount:

a. Select the Enable threshold expense approval check box.

b. In the Threshold expense amount field, enter the amount over which expense reports 
must be approved.

c. In the Threshold expense approver field, select the role that resources require to 
approve the expense reports that exceed the threshold amount. 

5.  Click Save.
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Financial Settings section options

Option Description

Default GL account code 

list

GL account code for cross charge distribution. Cross 

charges automatically distribute revenue for time to this 

GL account.

Cost center type-ahead field Cost center for the workgroup.

Default time approver list Default time approver for the workgroup resources.

Default expense approver 
list

Finance approver and default expense approver for the 

workgroup resources.

Note: If you do not specify a default expense approver, the 

expense reports for the workgroup resources are approved 

automatically after the initial approval and threshold 

approval (when applicable).

Default cost structure type-

ahead field

Default cost structure for the workgroup. Time entry cutoff 

dates that are configured for the cost structure apply to 

workgroup resources when they enter non-project time in 

their time sheet.

Use revenue recognition 
defaults check box

When selected, the default revenue transfer settings that 

are configured for revenue recognition are used. 

Transfer revenue based on 
labor multiplier option

When selected, revenue transfers to this workgroup are 

based on the specified percentage of resource cost rates. 

For more information, see "Overriding the default revenue 

transfer settings for a workgroup" on page 34.

Transfer revenue based on 
revenue percentage option

When selected, revenue transfers to this workgroup are 

based on the specified revenue percentage.

Enable threshold expense 
approval check box

When selected, expense reports that exceed the threshold 

amount must be approved by the threshold expense 

approver. 

Threshold expense amount 
field

Monetary limit for the threshold. Expense reports that are 

over this limit must be approved.
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Option Description

Threshold expense 
approver list

Role that a resource requires to approve the expense 

reports that are over the threshold limit.

Roles required for the final 
approval of expense 
reports list

Roles required by a resource to give final approval to 

expense reports after a resource’s line manager or 

initiative manager has approved the report.

Overriding the default revenue transfer settings for a workgroup

1. Access the workgroup.

2.  Expand the Financial settings section.

3.  Clear the Use revenue recognition defaults check box.

4.  Do one of the following:

• To base revenue transfers on resource cost rates, select the Transfer revenue based 
on labor multiplier check box, and then enter the percentage.

• To base revenue transfers on resource cross charge rates, select the Transfer revenue 
based on revenue percentage check box, and then enter the percentage.

5.  Click Save.

About granting workgroup access and assigning resource managers

By default, resources can access data that is related to their own workgroup, for example, in 
service portlets, reports, and in the resource scheduling calendar. 

You can grant access to the workgroup data, either directly or through roles, to resources that 
do not belong to the workgroup.

Assigning resource managers

You can specify the resources and roles that will be resource managers for the workgroup and 
handle resource requests from other workgroups. If you specify a role, then the resources who 
are assigned the role are automatically resource managers for the workgroup.

Resource managers can access the workgroup resources in the resource management view, and 
are responsible for processing resource requests for a workgroup.
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Viewing the members of a workgroup

1. Access the workgroup.

2.  Expand the Access rights section.

The members of the workgroup are listed in the Resources belonging to this workgroup 
list.

Granting access rights to a workgroup

1. Access the workgroup.

2.  Expand the Access rights section.

3.  In the Resources allowed to access this workgroup list, select the resources to be granted 
access.

4.  In the Roles allowed to access this workgroup list, select the roles to be granted access.

5.  Click Save.

Specifying a resource manager for a workgroup

1. Access the workgroup.

2.  Expand the Access rights section.

3.  In the Resource managers for this workgroup, who will receive resource requests 
from other workgroups list, select the resource manager.

4.  In the Roles required to be resource manager for this workgroup and receive resource 
requests from other workgroups list, select the roles required by a resource to be a 
resource manager for the workgroup.

5.  To extend the resource management responsibility to all subworkgroups of the current 
workgroup, select the Include children check box. 

6.  To allow only the resource managers of the workgroup to view workgroup resources in 
search results, select the Restrict view access of members check box.

7.  Click Save.

Setting up cross charge batch printing

1. Access the workgroup.

2.  Expand the Cross charge batch printing section.
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3.  Complete the fields as required. For more information, see "Cross charge batch printing 
options" on page 36.

4.  Click Save.

Cross charge batch printing options

Option Description

Batch print directory 

field

Directory where the cross charges print files are placed.

Print server name field Name of the printer server used by the workgroup.

Default printer field Name of the printer used by the workgroup.

Header left, center, and 
right fields

Text that appears in the left, center, or right section of the 

header.

Footer left, center, and 
right fields

Text that appears in the left, center, or right section of the 

footer.

Format link Format to apply to the header or footer. Options include: 

custom, date, file, file path, page and page number.

Delete print files from 
batch print directory 
after printing check box

When selected, the print files are purged from the system after 

printing. If the print files are not deleted, the cross charges are 

reprinted each time the print job runs.

Allow users to override 
the deletion of print files 

check box

When selected, resources can override the deletion of the 

print file from the system. 

Configuring workgroup settings for Resource Planner

You can require resource managers for the workgroup to have one or both of the following 
access requirements when working in Resource Planner:

• view access to demand items in order to view, create, and edit the demand items

• create and edit access to demand items in order to commit the changes to the demand 
items 
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Note: When create and edit access to demand items is required and resource requests are 
enabled, resources who have edit access to resource requests through workflow can edit 
and commit changes to task assignments or project team entries that are associated to 
resource requests. Therefore these resources do not require edit access to the task 
assignments or project team entries.

1. Access the workgroup.

2.  Expand the Resource Planner section.

3.  To require that resource managers have create and edit access in order to commit the 
changes to the demand items, select the Resource managers require create and edit 
access to demand items check box.

4.  To require that resource managers have view access in order to view, create, and edit the 
demand items, select the Resource managers require view access to demand items 
check box.

5.  Click  Save.

Setting planning units options for a workgroup

You can set values for the daily capacity and daily conversion factor, and restrict the planning 
units that are available to the workgroup resources. The values that you set on the workgroup 
override the system-level default values. Values can also be set on individual resources in user 
setup, which override the workgroup values.

1. Access the workgroup.

2.  Expand the Planning units section.

3.  To apply the settings in this section to all subworkgroups of the current workgroup, select 
the Include children check box.

4.  In the Daily capacity field, enter the number of hours in a working day.

5.  In the Daily conversion factor, enter the number hours to be used to convert records from 
hours to days or FTE, and back.

6.  To further restrict the planning units that are available to resources, clear the corresponding 
check boxes in the Available planning units table.

7.  Click Save.
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Modifying a workgroup

You cannot delete a workgroup if it has subworkgroups. You must first unassign the 
subworkgroup resources, and then delete the subworkgroups.

Warning: Deleting a workgroup can affect reporting. For example, if time was entered by 
workgroup resources, and the access checking on a report is enabled, the time records for 
the workgroup resources will not be included in the report after the workgroup is deleted. 
Access is tracked and stored only for the workgroups that are currently active.

1. Access the workgroup.

2.  To edit the workgroup:

a. Make the necessary changes.

b. Click Save.

3.  To delete the workgroup, click  Delete.

About role and feature mapping
In Changepoint, a role is a set of  features that are required for a specific job or type of work. 
For example, you can create a project manager role that includes all of the features related to 
managing projects. You can then assign the role to resources who are project managers.

Note: A feature that is mapped to a role is counted as a license only when the role is 
assigned to a resource.

Roles are also used to configure workflows or designate access permissions, and do not 
necessarily require features for workflow purposes. For example, a role is required to commit 
cross charges of a specific cost structure.

Creating a role

1. Click Resources > Role and Feature Mapping.

2.  In the Folders view, select any role.

3.  Click New.

4.  In the Role field, enter the name of the role.

5.  In the Description field, enter a brief description for the role.

6.  In the Features assigned to this role list, select the features:
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a. To search for an item, enter the search text and then click Search.

b. To display the tree view, clear the Show selected items only check box, ensure that 
the search field is empty, and then click Search. 

c. Select one or more items.

d. To display the selected items only, select the Show selected items only check box, 
ensure that the search field is empty, and then click Search. 

7.  Click Save.

Modifying a role

1. Click Resources > Role and Feature Mapping.

2.  In the Folders view, select the role.

3.  To edit the role:

a. Make the necessary changes.

b. Click Save.

4.  To delete the role:

a. Click Delete

b. Click OK to confirm.

About qualifications and competencies
You can create a set of categories, qualifications, and competencies to assign to resources. This 
information helps project managers and resource managers to select the best resource for a 
task. 

Qualification category

A general set of qualifications, for example Microsoft technologies or foreign languages. You 
can use categories for other information, such as travel preferences, or industries.

Qualification

A specific skill, for example, "SQL Server programming" or "French". Other examples include 
travel locations such as North America, Europe, and Asia, or specific industries such as 
wireless communications or mining.
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Competency

The level of accomplishment for a specified qualification. Examples include product versions, 
or levels such as beginner, intermediate, and expert.

Creating a qualification category

1. Click Resources > Qualifications.

2.  In the Folders view, select any qualification category.

3.  Click New.

4.  In the Category field, enter the name for the qualification category.

5.  In the Description field, enter a description for the qualification category.

6.  Click Save.

Modifying a qualification category

If you delete a qualification category, the qualifications and competencies under it are also 
deleted.

1. Click Resources > Qualifications.

2.  In the Folders view, select the qualification category.

3.  To edit the qualification category:

a. Make the necessary changes.

b. Click Save.

4.  To delete the qualification category:

a. Click Delete.

b. Click OK to confirm.

Creating a qualification

You add qualifications to a qualification category. 

1. Click Resources > Qualifications.

2.  In the Folders view, select the qualification category that you want to add the qualification 
to.
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3.  Click New qualification.

4.  In the Qualification field, enter the name for the qualification.

5.  In the Description field, enter a description for the qualification.

6.  Click Save.

Modifying a qualification

1. Click Resources > Qualifications.

2.  In the Folders view,  select the qualification.

3.  To edit the qualification:

a. Make the necessary changes.

b. Click Save.

4.  To delete the qualification:

a. Click Delete.

b. Click OK to confirm.

Creating a competency

You add competencies to a qualification.

1. Click Resources > Qualifications.

2.  In the Folders view,  select the qualification.

3.  In the Competencies table, right-click and then select Insert.

4.  In the Competency field, enter the name of the competency.

5.  In the Description field, enter the description of the competency.

6.  Click Save.

Modifying a competency

1. Click Resources > Qualifications.

2.  In the Folders view,  select the qualification.

3.  To edit the competency:
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a. Make the necessary changes.

b. Click Save.

4.  To delete the competency:

a. Click Delete.

b. Click OK to confirm.

c. Click Save.

About functions
Functions define the type of work that can be performed by a resource and can contain a set of 
specific qualifications and competencies. For example, the Senior Developer function can 
include the following qualifications and competencies:

• Software Development

• .NET

• XML

• Database Administration

• SQL Server

• Oracle

Primary functions are assigned to each resource to identify their main job duties within your 
organization, which helps project managers and resource managers to select the best resources 
for a project. 

Creating a function

When you create a function, you select the qualifications and competencies for it.

1. Click Resources > Functions.

2.  In the Folders view, click any function.

3.  Click New.

4.  In the Function field, enter the name for the function.

5.  In the Description field, enter a description for the function.
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6.  To select qualifications and competencies:

a. To search for an item, enter the search text and then click Search.

b. To display the tree view, clear the Show selected items only check box, ensure that 
the search field is empty, and then click Search. 

c. Select one or more items.

d. To display the selected items only, select the Show selected items only check box, 
ensure that the search field is empty, and then click Search. 

7.  Click Save.

Modifying a function

If you delete a function, the function is removed from all resources to which it has been 
assigned.

1. Click Resources > Functions.

2.  In the Folders view, select the function.

3.  To edit a function, make the necessary changes, and then click Save. 

4.  To delete a function:

a. Click Delete.

b. Click OK to confirm.

About user setup
You create resource profiles for the users that require access to Changepoint.

Resources are created from a workgroup and inherit some of the workgroup settings. You can 
also create generic resources to be used as placeholders when creating and planning initiatives, 
projects, and tasks.

Accessing a resource in User Setup

1. Click Resources > User Setup.

The User Setup tree view appears. 

2.  In the Folders view, do one of the following:

• Expand the workgroups to locate the resource.
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• To search for a resource by name, click Options > View > Search.

3.  Click the resource.

The User Setup dialog box appears.

Creating a resource

You create a resource from a global workgroup or workgroup.

1. Click Resources > User Setup.

The User Setup tree view appears. 

2.  Expand the tree view to locate the global workgroup or workgroup for the new resource.

3.  Right-click the global workgroup or workgroup and click Create resource.

The User Setup dialog box appears.

4.  Complete the fields as required. For more information, see "User Setup dialog, Resource 
information tab options" on page 45.

5.  Click Save.

6.  To continue completing the resource profile, see the following topics:

• "Specifying user-managed information for a resource" on page 47

• "Specifying payroll information for a resource" on page 48

• "Specifying confidential information for a resource" on page 50

• "Adding a new cross charge or cost rate for a resource" on page 52

• "Specifying qualifications and functions for a resource" on page 53

• "Specifying security access for a resource" on page 54

• "Specifying organizational information for a resource" on page 54

• "Copying values from a resource profile" on page 57
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User Setup dialog, Resource information tab options

Field Description

First name field First name of the resource.

Middle name field Middle name of the resource.

Last name field Last name of the resource.

Alternate name field Name of the resource in a different language or alphabet.

Description field Description of the job function for the resource.

License list Type of license for the resource. Options include:

• Changepoint user for regular Changepoint resources.

• Undefined user for generic resources.

Resource type list Type of resource. Options include:

• Contractor
• Full time
• Part time
• Temporary

Hire date field Date that the resource begins work.

Resource ID field Alphanumeric identifier for the resource.

SSO credential field Network logon name or single sign-on (SSO) credential, as 

required.

Email field Business email address of the resource. 

An email address is required if:

• your organization uses Microsoft Exchange server-side 

synchronization

• the resource is to receive email notifications.

Web password field Password for signing in to Changepoint.
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Field Description

Time zone list Time zone used by the resource.

The time zone is required for calendar synchronization 

between the Changepoint SQL server database and the 

Microsoft Exchange server.

Daily start time option

Daily end time option

Daily start and end time for use with Service Scheduler.

Allow user to create or 
modify personal 
dashboards check box

When selected, the resource can create and modify personal 

templates.

Exempt from resource 
request check box

When selected, the resource can be assigned to tasks and 

project team entries even when resource requests are 

enabled for a project or initiative. 

Note: These resources cannot be assigned to tasks using the 

Task view.

Fore more information, see "About exempting resources from 

resource requests" on page 46

About creating generic resources

You can create generic resources to be used as placeholders for planning purposes. You can 
enter qualifications and resource rates for generic resources so that resource managers and 
project managers can do searches and assign tasks to them. 

You create a generic resource the same as a regular resource, but with the following settings 
on the Resource information tab:

• In the License list, select Undefined user

• Leave the Email and Web password fields blank

About exempting resources from resource requests

When resource requests have been enabled, there is an option in User Setup to exempt the 
resource from resource request process. This option allows you to assign tasks to generic or 
placeholder resources that are created for planning purposes, or to any resource who you do 
not want to include in the resource request process.
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When resource requests are enabled for the initiative or project, you can create project team 
entries for exempt resources in the Edit Project dialog box, and task assignments for exempt 
resources in Project Worksheet. You can also create project team entries and task assignments 
indirectly in Resource Planner when you reassign them.

When resource requests are enabled for tasks, you can create task assignments for exempt 
resources in Project Worksheet and indirectly in Resource Planner when you reassign task 
assignments. However, you cannot create task assignments for exempt resources in the Task 
view.

When you copy projects, if resource requests are required for the target project, the task 
assignments for the resources that are exempt from resource requests can be copied to the 
target project.

When you create a project from an candidate, you can create tasks for resources that are 
exempt from resource requests.

Removing the exempt from resource request setting from a resource 

If you remove the exempt setting for a resource, then the regular resource request rules apply 
when you edit a task assignment for the resource. 

If there are existing task assignments for the resource, you can create resource requests for the 
task assignments manually.

Specifying user-managed information for a resource

User-managed information can be edited by resources in the Preferences view.

1. Access the resource in User Setup.

2.  Click the User-managed information tab.

3.  Complete the fields as required. For more information, see "User Setup dialog, User-
managed information tab options" on page 48.

4.  Click Save.
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User Setup dialog, User-managed information tab options

Field Description

Country list Name of the country for the business address.

Address field The street name and number, unit or suite number, and floor 

number.

City field Name of the city.

State/Province list The state or province.

ZIP/Postal code field The ZIP or postal code.

Job title field Job title of the resource.

The job title is displayed in the My contact info section of the 

Preferences view, but is read-only.

Effective date of job title 

field

Date that the job title of the resource takes effect.

This option is not displayed in the My contact info section of 

the Preferences view in Changepoint.

Location list Location of the resource from the organizational perspective 

for example, the geographical or sales region. 

Office phone field Business phone number.

Ext field Business phone number extension.

Home phone field Home phone number.

Mobile field Mobile phone number.

Fax field Business fax number.

Pager field Pager number.

Specifying payroll information for a resource

1. Access the resource in User Setup.

2.  Click the Payroll information tab.
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3.  Complete the fields as required. For more information, see "User Setup dialog, Payroll 
information tab options" on page 49.

4.  Click Save.

User Setup dialog, Payroll information tab options

Field Description

Base currency list The currency in which the resource is paid.

Payroll group field Name of the payroll group to which the resource belongs.

Cost center field Cost center to which the resource is assigned.

First payroll end date 

field

The date that the first payroll period ends. 

This is also the first date that time submission rules apply. 

If the resource has been rehired or on an extended leave, you 

can change the payroll end date to a date in the future so that 

the resource does not have to enter time in the weeks they 

were away.

Pay schedule list The payroll schedule for the resource. Options include:

• Bi-weekly
• Monthly
• Semi-monthly
• Weekly

Payroll lag field Number of days after the payroll end date during which 

resources can enter or adjust time on their time sheets before 

the processing cutoff date.

Daily capacity field Number of hours in a working day, which is used for demand 

and capacity calculations. The initial value is inherited from 

the workgroup. A value between 0 and 24 overrides the 

workgroup setting. When frequent changes to the workgroup 

setting are expected, delete the value (leave the field blank) to 

always use the workgroup setting.
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Field Description

Daily conversion factor 
field

Number of hours to be used to convert time records from 

hours to days or FTE, and back. Default value is 0, which 

means no value is set for the resource. A value greater than 0 

overrides the system and workgroup settings.

Submission cycle list Frequency in which the resource must submit the time sheet.

• Daily
• Not applicable – no regular time sheet submission is 

required

• Weekly

Submission hours field Minimum number of hours that the resource can submit at one 

time.

Allow daily time to be 
submitted out of 
sequence check box

When cleared, the resource must submit daily time sheets in 

chronological order.

When selected, the resource can submit daily time sheets in 

any order. 

Nonworking days check 

boxes

When selected, indicates that the day is a nonworking day for 

the resource. Nonworking days are exempt from daily 

submission rules and are excluded from the resource’s 

availability.

Specifying confidential information for a resource

Confidential information is not displayed in the resource profile.

1. Access the resource in User Setup.

2.  Click the Confidential tab.

3.  Complete the fields as required. For more information, see "User Setup dialog, 
Confidential tab options" on page 51.

4.  Click Save.
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User Setup dialog, Confidential tab options

Field Description

Vacation hours field Number of vacation hours per year allocated to the resource.

Vacation carry over field Number of unused vacation hours that the resource can carry 

over from the previous year to the next year.

Annual target hours field Number of hours the resource is expected to work each year.

Time in-lieu field Number of hours given to the resource in compensation for 

overtime.

Termination date field Last day of employment for the resource. The resource is 

automatically unassigned from the workgroup on this date.

Cross charge and Cost Rates section

Historical rates list Effective dates of the different rates that have been set up for 

the resources since the hire date.

Hourly cross charge 
rate field

Amount that your organization cross charges for each hour 

the resource works for a client.

Hourly cost rate field Amount that it costs your organization for each hour the 

resource works.

Daily cross charge rate 

field

Amount your organization cross charges for each full day the 

resource works for a client.

Daily cost rate field Amount that it costs your organization for each full day the 

resource works.

Overtime cross charge 
rate field

Amount that your organization cross charges for each 

overtime hour the resource works for a client.

Overtime cost rate field Amount that it costs your organization for each overtime hour 

the resource works.
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Field Description

Rate 1
Rate 2
Rate 3 fields

Additional fields for custom reporting purposes.

Currency list Currency for the cross charge rate.

Effective date field Date that the rates take effect.

Active check box When selected, indicates that the rates are in use. When 

cleared, the rates are not used in any calculations.

Comment field Comments about rates or confidential information.

Comments history field List of the comments and dates they were entered.

Accessing cross charge or cost rates for a resource

You can view the different cross charge or cost rates that have been set up for a resource.

1. Access the resource in User Setup.

2.  Click the Confidential tab.

3.  In the Historical rates list, select the effective date of the rate. 

The rate information is displayed in the rate fields.

Adding a new cross charge or cost rate for a resource

Only one cross charge or cost rate can be active for a given date. 

1. Access the resource in User Setup.

2.  Click the Confidential tab.

3.  In the Historical rates list, select Add new rate.

4.  In the Cross charge rates section, complete the fields as required. For more information, 
see "User Setup dialog, Confidential tab options" on page 51.

5.  In the Effective date field, enter the date that the rate becomes effective.

6.  To make the rate active on the effective date, select the Active check box.

7.  Click Apply (beside the Historical rates list). 
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8.  Click Save. 

Specifying qualifications and functions for a resource

You can specify the qualifications and the functions of the resource. The qualifications are 
grouped by qualification category, and the functions that are available for selection are specific 
to your organization. 

1. Access the resource in User Setup.

2.  Click the Qualifications and functions tab.

3.  In the Primary function list, select the primary function of the resource.

4.  In the Effective date field, enter the date that the primary function becomes effective.

5.  Expand the Qualification category and select the qualification for the resource.

6.  To specify the level of competency for the qualification:

a. Select the check box of the competency.

b. In the Years of experience field, enter the number of years.

c. In the Last used field, enter the date that the qualification was last used by the 
resource.

7.  In the Functions section, select the functions of the resource.

8.  Click Save.

About security access settings for resources

The security access that a resource has to Changepoint is controlled by a combination of the 
following:

• Security features – provide access rights to view and edit data and perform various tasks 
in Changepoint. 

• Roles – are groups of security features that correspond to a specific job function or role. 
For example, a project manager role would include all the security features that a resource 
requires to create, edit, delete, and manage projects in Changepoint.

• Workgroup access – provides access to workgroups other than the workgroup that the 
resource belongs to. The access rights to a workgroup also extend to the child workgroups 
of the workgroup.
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• Cost structure access – provides access to initiatives, clients and cross charges that are 
associated to the cost structure.

Note: Changepoint licenses are applied when the corresponding security features are 
assigned to a resource, either directly or through a role, and the resource profile is saved. If 
the effective date is in the future, then the Changepoint licenses are applied on the 
effective date.

Specifying security access for a resource

1. Access the resource in User Setup.

2.  Click the Security access tab.

3.  In the Roles section, select the roles you want to assign to the resource.

4.  In the Features section, select the features you want to assign to the resource.

5.  In the Workgroup Access section, select the workgroups that the resource can access.

6.  In the Cost Structure Access section, select the cost structure access rights for the 
resource.

7.  Click Save.

Specifying organizational information for a resource

When you create a new resource profile from a workgroup or from an existing resource 
profile, the name of the selected workgroup or the workgroup of the existing resource is 
automatically applied to the new profile. If no global workgroup or workgroup is specified, the 
new resource is saved as an unassigned resource. 

1. Access the resource in User Setup.

2.  Click the Organizational information tab.

3.  Complete the fields as required. For more information, see "User Setup dialog, 
Organizational information tab options" on page 55.

4.  Click Save.
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User Setup dialog, Organizational information tab options

Field Description

Effective date field Date when the settings specified in the Organizational 
information section come into effect. After the settings are 

saved, you can view the corresponding effective dates in the 

Resource history.

Note:  The resource cannot be assigned to any demand items 

until the effective date of the initial workgroup. If no effective 

date is specified, then the current date is used.

Global workgroup type-

ahead field

Global workgroup to which the resource is assigned.

Workgroup type-ahead 

field

Workgroup to which the resource is assigned.

Reports to field Manager for the resource.

Changepoint 
Administration access 

field

Indicates if the resource is a Changepoint administrator.

• No Access (default setting)

• System Administrator (if the resource has been 

assigned the Changepoint Administrator feature)

Current time approver 
field

Resource who approves the time sheets submitted by the 

resource. Default time approver comes from the resource’s 

workgroup.

Original time approver 
field

Name of the original time approver, which appears only when 

the time approval rights have been delegated.

Delegated check box When selected, indicates that original time approver resource 

has delegated their time approval rights to the current time 

approver. 

Current expense 
approver field

Resource who approves the expense reports submitted by 

the resource. Default expense approver comes from the 

resource’s workgroup.
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Field Description

Original expense 
approver field

Name of the original expense approver, which appears only if 

the expense approval rights have been delegated.

Delegated check box When selected, indicates that the original expense approver 

has delegated their expense approval rights to the current 

expense approver. 

Restricting the resources that a resource manager can manage in Resource 
Planner, Service Scheduler, Workforce Planning

By default, resource managers can manage the demand for all resources in their workgroup. 
For Resource Planner, Service Scheduler, and Workforce Planning, you can limit the resources 
that a resource manager can manage to a subset of the workgroup resources. You can use this 
functionality to control resource management without using resource requests.

Note: This restriction applies only to Resource Planner and not to resource requests. 

1. Access the resource in User Setup.

2.  In the Resource Planner/Service Scheduler/Workforce Planning section, select the 
Restrict ability to manage resources in Resource Planner/Service 
Scheduler/Workforce Planning to the selected resources only check box.

3.  To specify the resources that the resource can manage:

a. To search for an item, enter the search text and then click Search.

b. To display the tree view, clear the Show selected items only check box, ensure that 
the search field is empty, and then click Search. 

c. Select one or more items.

d. To display the selected items only, select the Show selected items only check box, 
ensure that the search field is empty, and then click Search. 

4.  To include all resources for a workgroup, select the workgroup.

5.  To include all the workgroups below a selected workgroup in the hierarchy, click the 
Include children check box. 

6.  To include all resources that are exempt from resource requests, select the check box.

7.  Click Save.
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Attaching a picture to a resource profile

1. Access the resource in User Setup.

2.  Click Attach Picture.

The Attach Picture dialog box appears.

3.  Click Browse, choose a GIF or JPG file, then click Open.

4.  Click Upload.

5.  Click OK to confirm.

About copying values from a resource profile

You can copy values from a source resource profile to a new or existing target resource profile. 
Copying values ensures that consistent information is entered for resources.

You can select which of the following information is copied:

• All configurable fields – all configurable field values from all of the tabs. 

Note: If any of the tabs that you want to copy includes configurable fields, then you must 
select the All configurable fields check box.

• Resource information tab – resource type and time zone

• User-managed information tab – address information, work location, job title, office 
phone number, and fax number

• Payroll information tab – all field values

• Confidential tab – vacation carry-over and annual target hours

• Qualifications and functions tab – primary function, qualifications, and functions

• Security access tab – all information

• Organizational information tab – global workgroup, workgroup, resource reported to, 
cost center, and the current time and expense approvers of the existing resource 

Copying values from a resource profile

1. Access the target resource profile by doing one of the following:

• Create a new resource profile

• Access the resource in User Setup
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2.  In the User Setup dialog box, click Copy values.

The Resource List dialog box appears.

3.  Select the source resource.

The Copy from <source resource> dialog box appears. 

4.  Select the check boxes for the information that you want to copy to the target resource 
profile. 

5.  Click OK.

6.  Complete the remaining fields. For more information, see "Creating a resource" on page 
44.

7.  Click Save.

About editing resources

You can edit most of the information in a resource profile. Some of the changes are recorded 
in the resource history. Some changes require that you specify an effective date, which can be 
a date in the future. You can view the resource history, and view and cancel pending changes.

About resource history

Changes to the following fields are recorded in the resource history as of the date that they are 
changed:

• Job title

• Cost and cross charge rates fields

• Qualifications and functions 

Changes to the following fields are recorded in the resource history as of the effective date:

• Hire date (if left blank, the date that the resource profile is created is recorded)

• Termination date

• Global workgroup and Workgroup

• Reports to

• Current time approver

• Current expense approver
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Editing a resource

1. Access the resource in User Setup.

2.  Make the necessary changes. 

3.  Click Save.

Managing a resource's preferences

From the User Setup dialog box, you can access the Preferences view for the current resource 
and edit the settings. For example, you can delegate the resource's approval rights for time, 
expenses, cross charges, and workflow. 

You can edit all of the preferences for the resource in this view except for changing their 
password, which can be done in the User Setup dialog box.

1. Access the resource in User Setup (Resources > User Setup).

2.  Click Preferences.

3.  Expand the section that includes the preferences to be managed.

4.  Make the required changes. For more information, see "Changing Personal Preferences" in 
the User Basics User Guide or Changepoint help.

5.  Click Save in the section that includes the changes.

Viewing pending changes for a resource

You can view the changes to a resource profile that have effective dates set in the future. The 
pending changes are grouped under workgroup changes and other changes.

1. Access the resource in User Setup.

2.  Click View pending changes.

The Pending Resource Changes dialog box appears.

Canceling a pending change for a resource

You can cancel the pending workgroup or other change that has the latest effective date. 

1. Access the resource in User Setup.

2.  Click View pending changes.

The Pending Resource Changes dialog box appears.
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3.  To cancel the workgroup change that has the latest effective date, click Actions > Delete > 
Latest workgroup change.

4.  To cancel the change other than a workgroup change that has the latest effective date, click 
Actions > Delete > Latest other change.

About transferring a resource to another workgroup

To transfer a resource to another workgroups you must have access to both workgroups. The 
resource loses the security access rights of the source workgroup, and acquires the security 
access rights of the target workgroup as of the effective date of the change. 

Note: If the resource has been assigned specific roles within the workgroup or in 
workflow processes, consider the areas that may be affected by the change.

Transferring a resource to another workgroup

1. Access the resource in User Setup.

2.  Click the Organizational information tab.

3.  In the Global workgroup and Workgroup lists, select the global workgroups and 
workgroups. 

4.  In the Effective date field, select the date. 

5.  Click Save.

About terminating resources

You terminate a resource on their resource profile. On the termination date, the resource is 
unassigned from their workgroup and moved to the Unassigned Resources workgroup folder. 
All of the resource information and a history of related actions and activities are maintained 
for reports and historical purposes.

If the resource has one or more of the following roles, you are prompted to specify 
replacement resources before the resource can be terminated:

• time or expense approver

• project manager of an active project

• client manager for an active candidate

• operations center manager
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• initiative  manager responsible for request workflow – If the request workflow uses the 
system-defined participant Initiative manager, you must reassign the role in all initiatives 
to ensure that requests are routed to an active resource

• initiative  manager for a chargeable initiative

• Second-level cross charge approver for a chargeable initiative

• Second-level approver for a cost structure

Terminating a resource

1. Click Resources > User Setup.

2.  In the Folders view, search for the resource.

3.  Click Terminate.

The Terminate Resource dialog box appears.

4.  In the Termination date field, enter the last day of employment for the resource.

5.  Click Terminate.

6.  Click Save.

Deleting a resource

When you delete a resource, all of the resource information and the history of related actions 
and activities are permanently deleted. You can only delete resources that are terminated. 

1. Terminate the resource. 

2.  In the User Setup tree view, expand the Unassigned Resources folder.

3.  Click the resource.

The User Setup dialog box appears.

4.  Click Delete.

5.  Click OK to confirm.

Unlocking a resource’s account

If a resource exceeds the allowed number of sign in attempts, their account is locked and they 
can no longer sign in. You can unlock the resource’s account in User Setup.

1. Access the resource in User Setup.
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2.  Click Unlock account.

About the "Forgot your password?" functionality

When a user—either a resource or a Client Portal user—forgets their password, they can click 
the Forgot your password? link in the Changepoint sign-in dialog box.

Note: If the user has been locked out of Changepoint, they must contact their Changepoint 
administrator to have their account unlocked. Resetting their password will not unlock 
their account.

When a user enters their email address into the Forgot your password? dialog box and clicks 
Reset Password, a message confirms that password reset information has been sent. The 
message appears for security reasons regardless of whether the email address is valid or not.

If the email address is a valid resource ID (email address in the Resource ID field) or contact 
email address, an email that includes a temporary password is sent to the email address. The 
user must use the temporary password within 24 hours or they will have to start the process 
again.

If the email address is not a valid resource ID or contact email address, then no email is sent 
and no error message appears. 

About setting up default planning units
You must specify the system-level default values for daily capacity and daily conversion 
factor. You also specify the planning units (hours, days, or FTEs) that are available for use by 
resources for each entity, and the default planning units for each entity. 

Note: Resources can only enter time in either hours or days, and not FTEs.

The daily capacity and daily conversion factor values can also be set on workgroups and on 
individual resources. The value set on the resource takes priority, followed by the value set on 
the workgroup, and then the system-level default.

The planning units that are available to resources can be further restricted at the workgroup 
level. 

Setting up planning units at system level

1. Click Resources > Planning Units Setup.

2.  In the Daily capacity field, enter the number of hours in a working day.
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3.  In the Daily conversion factor field, enter the number of hours to be used to convert 
records from hours to days or FTEs, and back.

4.  In the Available planning units table, do the following for each entity row:

a. Select the check boxes for the planning units to be available for use by resources.

b. In the Default planning units column, click the cell to select the default planning unit 
from the list.

5.  Click Save.

Restricting or granting user setup access to a workgroup
There are two types of access to User Setup:

• Full access – resources who have full access to User Setup can create and access resources 
in all workgroups. However, you can restrict a resource's access to only the resources in 
one or more specific workgroups. 

• Restricted access – resources who have restricted access must be granted access to a 
workgroup in order to access its resources in User Setup.

You restrict or grant access by  selecting one or more workgroups for the resource. If the 
resource has full access, then their access is restricted to the selected workgroups. Conversely, 
if the resource has restricted access, they are granted access to the selected workgroups.

Note: If you select a global workgroup, access to all of the resources in  its subworkgroups 
is restricted or granted, depending on the type of access.

1. Click Resources > User Setup Restrictions.

2.  Expand the workgroups to locate the resource, and then select the resource.

3.  To select a workgroup:

a. To search for an item, enter the search text and then click Search.

b. To display the tree view, clear the Show selected items only check box, ensure that 
the search field is empty, and then click Search. 

c. Select one or more items.

d. To display the selected items only, select the Show selected items only check box, 
ensure that the search field is empty, and then click Search. 
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4.  Click Save.

Tracking security access changes for resources
Changes that are made to  resources’s security access can be tracked. You can then view the 
history of changes on the resource’s profile.

1. Click Resources > Security Access Tracking.

2.  Select the Security access history tracking check box.

3.  Click Save.

To view the history of security access changes for a resource

1. Access the resource profile in User Setup (Resources > User Setup).

2.  Click Resource history.

3.  In the [Resource name] History dialog box, click Actions > Filter history.

4.  In the Filter Criteria dialog box, click Security functionalites.

5.  (Optional) Specify the start date and end date for the period you want to view.

6.  Specify the sort order.

7.  Click Go.

About nonworking days
You can configure nonworking days by specifying weekend days or by creating custom 
nonworking days such as official holidays. The nonworking days are displayed in resources' 
personal calendars and the resource scheduling calendar. Nonworking days are included in 
various areas of Changepoint, such as: resource demand analysis, closed period setup, 
budgeting, financial analysis summary, Project Worksheet, Project Worksheet, and project 
resource leveling.

You can configure nonworking days that apply to the system level, global workgroup, or 
workgroup. 

You can set up the time for nonworking days to be automatically added to resources' time 
sheets by selecting a non-project time item to be added to the time sheets for this purpose. The 
amount of time that is automatically entered for nonworking days is the daily capacity amount 
for the resource. Users can manually edit these time entries and add additional time entries for 
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the same day provided that the daily maximum amount of time is not exceeded. The time for 
system-level nonworking days is added to all resources' time sheets. The time for global work-
groups is added for resources who are members of its subworkgroups. The time for work-
groups is added for resources who are members of the workgroups.

Nonworking days can also be set for individual resources in resource profiles and personal 
calendars.

Configuring a nonworking day

1. Click Resources > Nonworking Days.

2.  In the Folders view, do one of the following: 

• To configure a system-level nonworking day that applies to all workgroups, select 
System.

• To configure the nonworking day at the global workgroup or workgroup level, select 
the workgroup. 

3.  To apply the settings to all subworkgroups of the selected workgroup, select the Include 
children check box.

4.  To add time for the nonworking days automatically to time sheets:

a. In the Automatic Time Entry section, select the Automatically enter time into time 
sheets check box.

b. Select the non-project time to be used for the time entries in the time sheet.

5.  To configure a weekly nonworking day:

a. In the Weekly nonworking days section, select the nonworking day.

b. Click Save.

6.  To configure a specific date as a nonworking day:

a. Right-click in the Nonworking days table, and then select Insert.

b. In the Date field, enter the date. 

c. In the Description field, enter the description.

7.  Click Save.
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Modifying a nonworking day

You must modify and delete nonworking days at the system, global workgroup or workgroup 
level in which they were configured.

1. Click Resources > Nonworking Days.

2.  In the Folders view, do one of the following: 

• To modify a system-level nonworking day, select System.

• To modify a nonworking day at the global workgroup or workgroup level, select the 
workgroup.

3.  To edit a weekly nonworking day:

a. In the Weekly nonworking days section, select the check boxes to enable, or clear the 
check boxes to disable the days. 

b. Click Save.

4.  To edit a nonworking day:

c. In the Nonworking days table, make the necessary changes.

d. Click Save.

5.  To delete a nonworking day:

a. In the Nonworking days table, right-click the row, and then select Delete.

b. Click OK to confirm.

c. Click Save.

Setting up resource leveling
When resource leveling is enabled, the amount of planned work that has been already been 
assigned to a resource is taken into account when effort is being allocated to the resource. 

When you enable resource leveling, you must also specify how overbooking is handled for 
each workgroup. There are options to warn when a resource is overbooked, or to prevent 
overbooking entirely.

1. Click Resources > Resource Leveling Setup.

2.  Select the Enable resource leveling check box.
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3.  Click Save.

4.  For each workgroup, select the option to warn when a resource is overbooked, or to 
prevent overbooking entirely.

About setting up resource demand analysis
Resource demand analysis settings can be set up for the following entities:

• Calendar entry

• Candidate

• Initiative

• Project

• Project team

• Request type (Request types must be enabled to be included in resource demand analysis)

For each entity status, you can specify whether the demand items are:

• committed

• included in demand in Resource Planner and the histogram data in resource demand 
scenarios

• approved or unapproved demand for funding, or excluded from funding source totals 
entirely (for projects, candidates, and request types only)

Preventing double counting of demand items for funding

When configuring approved and unapproved demand items for funding, ensure that statuses are 
selected and workflows are configured to prevent double counting. For example, when you 
create a project from a candidate, the following sequence of events ensures that funds are not 
counted twice. 

1. Configure a candidate status that indicates that a project has been created from a candidate, 
for example, Project created.

2.  When a resource creates a project from a candidate, ensure that either the resource or 
workflow sets the candidate status to Project created.

3.  Configure candidates with the Project created status to be excluded from funding totals. 

4.  Configure the relevant project statuses to be included in the funding totals. 
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The same precautions concerning double counting also apply to creating a candidate from a 
planning request.

Setting up resource demand analysis

1. Click Resources > Resource Demand Analysis Setup.

2.  In the Entity type field, select the entity type.

3.  In each demand item row, select the options as required. 

4.  To specify the demand items as committed, select the Committed check box.

5.  To include the demand items in Resource Planner and histogram data, select the Included 
in demand check box.

6.  For demand items for projects, candidates, and request types, do one of the following:

• Select the option to include the demand item as approved or unapproved demand for 
funding.

• To exclude the demand item from funding totals, clear both the Approved demand 
for funding and Unapproved demand for funding check boxes. 

7.  Click Save.
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Performance management overview

The Changepoint performance management functionality allows you to track and monitor the 
performance of individuals and projects in your organization.

• Individual Performance Management (IPM) – Monitor individual and team performance 
to ensure that the processes and business objectives of your organization are followed. 
Evaluate individual and team performance through graphical summaries.

• Project Portfolio Management – Measure the business value of projects and identify 
underperforming projects. Evaluate project and portfolio performance through graphical 
summaries such as score cards. Use the what-if analysis to create different scenarios and 
determine how the changes affect existing projects. Project portfolios (collection of 
projects) and rollup portfolios (collection of portfolios) can be used.

• Survey Management – Use peer and client feedback obtained through surveys in the 
performance evaluation process of individuals and projects. 

About individual and team performance

Performance can be measured for both individuals and teams using IPM metrics. Metrics are 
created from metric templates and inherit the threshold and target values from these 
templates. When assigning metrics to resources, you can change these values, if needed. 

Metric results are generated in one of the following ways: 

• System-generated – The results are generated from data within Changepoint.

• User-entered – The results are manually entered by resources (for example, the number 
of training sessions performed by a resource in a period) or generated from data entered 
or selected in configurable fields.

Managing individual and team performance involves the following steps:

1. Defining IPM reporting periods

2.  Creating metric templates

3.  Creating and assigning IPM metrics

4.  Viewing and analyzing results
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About portfolio performance

The project portfolio functionality allows you to categorize, manage and evaluate a collection 
of projects to determine how each project is performing in relation to defined performance 
targets. 

You can evaluate portfolio performance by:

• using metrics to track results

• setting targets for the performance and monitoring variances

• using survey results to assess client or peer satisfaction for a project

The analysis highlights which projects are performing well and which are underperforming. 
This information helps managers to make decisions about the ongoing viability of certain 
projects, and to redirect resources towards projects that better fit their business objectives. 

Metrics are the criteria by which the performance of project portfolios and rollup portfolios are 
measured. Several predefined metric calculations are provided for tracking project 
performance based on cost, effort, and schedule. You can also create custom metric 
calculations to track the health and performance of projects by virtually any criteria.

Warning: Custom metric calculations are not supported by your Changepoint support 
agreement. If you require assistance, contact your Service Delivery Group representative 
or client manager to arrange for consulting services.

Managing portfolio performance includes the following steps:

1. Defining metric templates

2.  Creating portfolio categories

3.  Creating portfolios and assigning metrics

4.  Adding projects to the portfolio

5.  (Optional) Create rollup portfolios 

6.  Viewing and analyzing results

About using survey results for performance evaluation

You can use the results of rating questions in surveys to assess the performance of resources 
and projects. Survey recipients rate the resource or the project identified in a rating question 
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and submit their feedback. The results are collected against a metric and analyzed.

Note: You can use other types of questions in custom calculations to collect performance 
data. For more information about custom calculations, contact your Service Delivery 
Group representative or sales representative to arrange for consulting services.

To assess performance using survey results:

1. Create a survey that includes rating questions and prompt tags and activate the survey. 

2.  Create a metric template with a Client feedback, Peer feedback, or Project template 
category.

3.  Do one of the following:

• To assess the performance of a resource, create an individual performance metric and 
assign it to the resource.

• To assess the performance of a project, create a project portfolio with the specified 
project metric template and assign it to the project.

Performance management terminology

The following table lists the main concepts and terms used in the performance management 
modules.
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Term Definition

Targets Targets are the values that an individual resource, team or project must 

achieve or work to achieve within a specified period of time. Some 

examples are:

• the number of training sessions each resource is expected to complete 

every year

• the revenue to be generated by a sales team

• the satisfaction rating of a client

The target can be over or under a specified value. For example, if you want 

to generate a revenue that exceeds expectations, the target for a revenue 

metric would be above a specified value. Conversely, if you want to keep 

costs as low as possible, the target for a cost metric would be under a 

specified amount.

Target 

Duration

The target duration is the time interval (in days) against which the variance 

is measured. For example, if the target date is December 31, 2014, the 

target duration is 100 days and the current date is January 15, 2015, then 

the variance is 15 days. 

Thresholds The threshold is the boundary line between ranges of values that indicate 

acceptable and unacceptable performance. Thresholds are defined to 

measure variances in performance. The performance status is color-coded 

as follows:

• Green, when the result reaches or exceeds the target.

• Yellow, when the result is between targets and requires attention.

• Red, when the result does not reach the target.

Actuals Actuals is the data that is generated automatically or entered by resources.

Variance The variance is the gap between actual data and targets. This value is 

compared against the threshold to determine the performance status 

(green/yellow/red).

This variance is divided by the target duration to get a percentage, in this 

case 15%. This percentage is compared to the over/under values to 

determine the green/yellow/red status of an item.
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Term Definition

Absolute 

value

The absolute value of the variance is compared to the under and over 

values to determine the green/yellow/red status for the metric. When the 

Absolute value check box is selected, any variance over or under the 

thresholds is considered undesirable.

For example:

A budgeted cost metric is set up where the target is 100 and the actual 

is 80. 

Threshold = Under

Under (green) threshold = 20%

Over (red) threshold = 10%

If the Absolute value check box is cleared, the performance indicator is 

green (-20/100 = -20%).

If the Absolute value check box is selected, the performance indicator is 

red (20/100 = 20%).

When using an absolute value, you cannot enter a negative value in the 

Over or Under fields.

Weighting The percentage that represents the weighting of each metric in comparison 

to the other metrics. The total weighting for all metrics in a grouping must 

add up to 100%.

The metrics in a group are automatically assigned an equal percentage, or 

different percentages can be assigned manually, provided they add up 

to 100%.

 

About metric calculations setup
Setting up metric calculations includes defining IPM default settings and reporting periods, and 
creating the metric calculations.

About IPM default settings

Individual Performance Management (IPM) calculations use the following information defined 
in the IPM Default view:

• Reporting currency – Currency to be used in metrics and metric results. All monetary 
amounts will be converted to this currency.

Changepoint Administration | 73



4. Performance Management

• Approval lag – The maximum time allowed for approval in order to recalculate the 
previous reporting period (if submitting time in one reporting period and approving it in 
the next reporting period). If the approval time is longer than the specified approval lag, 
the previous period is not recalculated.

If the approval time is less than the approval lag, only the last period is recalculated.

Example: The approval lag is 5 days. If a resource submits time in Q1 and the manager 
approves the time 3 days in the following Q2, the past period is recalculated. If the 
resource submits time in Q1 and the manager approves the time 6 days in the 
following Q2, the past period is not recalculated.

Note: Reporting years cannot overlap. If a previous reporting period has already been 
defined, the start date of your new period must be the day that immediately follows the 
end date of the previous reporting period.

Once the reporting periods have been saved, you can no longer change the Start date or 
End date. To change the reporting period duration, you must delete the reporting year and 
then re-create it.

Defining IPM default settings

1. Click Resources > Performance Management.

The Performance Management tree view appears.

2.  Expand the General folder.

3.  Click IPM Defaults.

The IPM Default view appears.

4.  In the Default currency list, select the currency to be used in metrics and metric results.

5.  In the Approval lag field, enter the number of lag days allowed to recalculate the 
utilization.

6.  Click Save.

Defining an IPM reporting period

IPM reporting periods are consistent time intervals used for metric calculations. For example, 
if you define a fiscal year that begins September 1 and ends August 31, and then divide that 
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year into quarters, all metrics will be assigned, tracked and calculated within those reporting 
periods.

1. Click Resources > Performance Management.

The Performance Management tree view appears.

2.  Right-click Reporting Periods and select Create period.

The Reporting Period view appears.

3.  In the IPM year field, enter the year of the reporting period.

4.  In the Start date field, click , and select the first day of the reporting year.

The End date field automatically displays the date one year after the start date.

5.  Click Actions > Save.

The Actions menu for the IPM periods section becomes available.

6.  In the Actions menu, do one of the following time intervals:

• To set up monthly reporting periods, select Create Fiscal Period > Monthly.

• To set up quarterly reporting periods, select Create Fiscal Period > Quarterly.

• To set up semi-annual reporting periods, select Create Fiscal Period > Semi-
annually.

7.  Click Actions > Save.

Editing IPM periods

1. Click Resources > Performance Management.

The Performance Management tree view appears.

2.  Expand the Reporting Periods folders and select the period you want to edit.

The Reporting Period view appears.

3.  In the IPM periods section, click the row of a reporting period.

4.  Make the necessary changes:

• To rename the period, place your cursor in the IPM period column and enter a new 
name.
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• To change the start or end dates, click  and select a new date, ensuring there are no 

gaps or overlaps between the IPM periods.

5.  Click Actions > Save.

About metric calculations

Individual and project performance metrics can include the following types of calculations:

• Standard calculations – Changepoint provides predefined calculations to track people and 
project performance. Standard calculations cannot be modified. For more information, see 
the Performance Metric Calculations Reference Guide, which is available from the 
Customer Success Center (https://success.planview.com/Planview_Changepoint).

• Custom calculations – You can create custom calculations required by your organization. 

• Custom stored procedures – You can create custom stored procedures to calculate the 
health of the items in a portfolio and the overall health of the portfolio. 

Warning: Custom stored procedures and calculations are not supported by your 
Changepoint support agreement. If you require assistance, contact your Service Delivery 
Group representative or sales representative to arrange for consulting services.

All calculations are associated with a metric type defined in Changepoint. You cannot edit the 
metric types or create new metric types.

About metric types and categories

Metrics are grouped into types and categories. All metric calculations, including custom 
calculations, must be associated with one of the metric types (Adoption, Results, Customer 
feedback, Peer feedback and Projects). Each metric type can include one or more metric 
categories which determine the calculations used in metric templates. 

For more information, see:

• "Adoption metric type" on page 77

• "Results metric type" on page 77

• "Client Feedback metric type" on page 78

• "Peer Feedback metric type" on page 78

• "Project metric type (project portfolio metrics only)" on page 78
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Adoption metric type

Adoption metrics allow you to monitor if and how resources in your organization conform to 
internal processes. For example, you can use an Adoption metric to ensure that resources 
actively and consistently submit their time sheets by the specified submission deadline.

Adoption metrics are used for individual and team performance only.

Category Calculation

Process Conformance • Approval Lag - Expenses

• Approval Lag - Cross Charges

• Approval Lag - Time 

• Approval Lag - Requests 

• Time Submission Conformance 

• Task Status Compliance 

• User-Entered Calculation (Actual) 

• User-Entered Calculation (Average)

• User-Entered Calculation (Sum) 

Results metric type

Results metrics allow you to measure the end result or decision of objectives set within your 
organization for sales and utilization. For example, you can use a Results metric that defines a 
minimum revenue amount expected to be generated per financial quarter.

Results metrics are used for individual and team performance only.

Category Calculation

Revenue • Candidate Approved Result 

• Candidate Approved Result (Floating Target) 

Utilization • Utilization Percent (Chargeable by Hours/Day)

• Utilization Percent (Chargeable, by Period Hours)

• Utilization Percent (by Hours/Day)

• Utilization Percent (by Period Hours)

For Utilization calculations, the full day settings and the 

annual target hours must be specified in the resources’ 

profiles.
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Client Feedback metric type

Client feedback metrics allow you to measure resources and projects based on the feedback 
received from clients through surveys. These metrics use survey rating questions related to the 
resources or projects being evaluated.

Category Calculation

Resource feedback Client satisfaction in regard to resources (used for individual 

or team performance)

Project feedback Client satisfaction in regard to projects (used for project 

portfolio performance)

Peer Feedback metric type

Peer feedback metrics allow you to measure resources and projects based on the feedback 
received from internal resources through surveys. These metrics use survey rating questions 
related to the resources or projects being evaluated.

Category Calculation

Resource feedback Peer satisfaction in regard to resources (used for individual or 

team performance)

Project feedback Peer satisfaction in regard to projects (used for project 

portfolio performance)

Project metric type (project portfolio metrics only)

Project metrics allow you to evaluate the performance of projects within portfolios.
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Category Metric Calculation

Project Budgeted Charge/

Revenue 

• Budgeted charge

• Budgeted charge vs. estimate-to-complete charge

• Budgeted charge vs. estimate-to-complete charge with 

(with request charge)

• Budgeted charge vs. recognized revenue

Project Budgeted Cost • Budgeted cost

• Budgeted cost (with request cost)

• Budgeted capital cost

• Budgeted non-capital cost

• Budgeted cost vs. estimate-to-completion cost

Project Budgeted Effort • Budgeted effort

• Budgeted effort (with request effort)

• Budgeted effort vs. estimate-to-complete effort

Project Budgeted 

Schedule 

• Budgeted schedule

Project Planned 

Charge/Revenue

• Planned charge

• Planned charge vs. estimate-to-complete charge

• Planned charge vs. estimate-to-complete charge (with 

request charge)

• Planned charge vs. recognized revenue

Project Planned Cost • Planned cost

• Planned cost (with request cost)

• Planned cost vs. estimate-to-complete cost

Project Planned Effort • Planned effort

• Planned effort (with request effort)

• Planned effort vs. estimate-to-complete effort

Project Planned Schedule • Planned schedule

Project User-Entered • User-entered calculation (actual)

• User-entered calculation (average)

• User-entered calculation (date)

• User-entered calculation (sum)
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Viewing a metric calculation

1. Click Resources > Performance Management.

The Performance Management tree view appears.

2.  Expand the Calculations folder.

Calculations are grouped by metric types: Adoption, Results, Client feedback, Peer 
feedback, and Projects.

3.  Expand the metric type folder to locate the calculation you want to view.

The calculation profile appears.

Note: To view a list of available calculations for a metric type, click the name of the 
metric type.

Creating a metric calculation

Calculations appear in the Performance Management tree view under their metric type.

1. Click Resources > Performance Management.

The Performance Management tree view appears.

2.  Right-click the Calculations folder and select Create calculation.

The Calculation view appears.

3.  In the Calculation field, enter a name for the metric.

4.  In the Type list, select the metric type associated with the calculation.

5.  In the Category list, select the calculation category.

The categories listed depend on the selected metric type.

6.  In the Raw calculation field, enter the name of the stored procedure that calculates the 
initial metric data.

7.  In the Code field, enter a unique code or abbreviation for the calculation.

8.  In the Rollup calculation field, enter the name of the stored procedure that calculates 
individual/team (IPM) or project (portfolio) data.
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9.  In the Rollup portfolio calculation field, enter the name of the stored procedure that 
calculates the formula for the rollup portfolio. This calculation is performed after the 
calculations for the included project portfolios is done.

10.  Select the User-entered check box if the data must be entered by users.

11.  In the Unit list, select the unit of measurement for the metric data.

12.  Click Actions > Calculation > Save.

Editing a metric calculation

You can only edit calculations that have not been used in an assigned metric.

1. Click Resources > Performance Management.

The Performance Management tree view appears.

2.  Expand the Calculations folder.

3.  Click the calculation you want to edit.

The Calculation view appears.

4.  Make the necessary changes.

5.  Click Actions > Calculation > Save.

About metric templates
Metric templates define the criteria against which performance is measured. They contain 
information such as the calculation used to evaluate the performance of employees and 
projects, the targets and thresholds, or the rollup method for the data. 

You must define metric templates before creating and assigning metrics to individuals, teams 
and projects. Metric assignments inherit the thresholds and targets from the metric template, 
thus ensuring a consistent assessment.

Metric results are generated in one of the following ways: 

• System-generated – the results are generated from data within Changepoint.

• User-entered – the results are manually entered by resources (for example, the number of 
training sessions performed by a resource in a period) or generated from data entered or 
selected in configurable fields.
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Metrics are further grouped into types and categories. For more information, see "About metric 
types and categories" on page 76.

Accessing a metric template

Metric templates are grouped by metric type in the Performance Management tree view.

1. Click Resources > Performance Management.

The Performance Management tree view appears.

2.  Expand the Metric Templates folder.

3.  Expand the metric type folder.

4.  Click the metric template you want to view.

The metric template profile appears.

Creating a metric template

1. Click Resources > Performance Management.

The Performance Management tree view appears.

2.  Right-click Metric Templates and select Create template.

The Create Metric Template dialog box appears.

3.  In the Name field, enter the name of the metric template.

4.  In the Description field, enter a description for the metric template.

5.  Complete the required fields for the type of metric you are creating:

• Results – For more information, see "Creating a Results metric template" on page 83.

• Adoption – For more information, see "Creating an Adoption metric template" on 
page 83.

• Client feedback – For more information, see "Creating a Client Feedback metric 
template" on page 84.

• Peer feedback – For more information, see "Creating a Peer feedback metric 
template" on page 85.

• Project – For more information, see "Creating a Projects metric template" on page 86.
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6.  Click Save.

Creating an Adoption metric template

Adoption metrics allow you to monitor if and how resources in your organization conform to 
internal processes.

1. Access the Create Metric Template dialog box.

2.  In the Type list, select Adoption.

3.  In the Category list, select the metric category.

4.  In the Calculation list, select the metric calculation.

If you chose a user-entered calculation, the User-entered metric check box is 
automatically selected and cannot be cleared.

5.  In the Rollup method list, select the metric rollup method.

6.  Do one of the following:

• If the metric template is intended to evaluate teams, select the Team metric check 
box.

• If the metric template is intended to evaluate individual resources, clear the Team 
metric check box.

7.  Select the Active check box to activate the metric template.

To store the metric template without making it available to other resources, clear the 
Active check box.

8.  Enter the target and threshold values. For more information, see "Entering target and 
threshold values" on page 88.

9.  Click Save.

Creating a Results metric template

Results metrics allow you to measure the end result or decision of objectives set within your 
organization for sales and utilization.

1. Access the Create Metric Template dialog box.

2.  In the Type list, select Results.

3.  In the Category list, select the metric category.
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4.  In the Calculation list, select the metric calculation.

5.  In the Rollup method list, select the metric rollup method.

6.  Do one of the following:

• If the metric template is intended to evaluate teams, select the Team metric check 
box.

• If the metric template is intended to evaluate individual resources, clear the Team 
metric check box.

7.  Select the Active check box to activate the metric template.

To store the metric template without making it available to other resources, clear the 
Active check box.

8.  Enter the target and threshold values. For more information, see "Entering target and 
threshold values" on page 88.

9.  Click Save.

Creating a Client Feedback metric template

Client feedback metrics allow you to measure resources and projects based on the feedback 
received from clients through surveys. These metrics use survey rating questions related to the 
resources or projects being evaluated.

1. Access the Create Metric Template dialog box.

2.  In the Type list, selectClient feedback.

3.  In the Category list, select the metric category.

4.  In the Calculation list, select the metric calculation.

5.  In the Survey list, select the survey used for this metric template.

The list displays all active surveys.

6.  To include only the most recent survey results, specify the number of days to retrieve 
survey data for the metrics in the Results from last days field. For example: enter “30” 
for the last 30 days, including today.

7.  In the Rollup method list, select the metric rollup method.

8.  If the metric template is for evaluating teams, select the Team metric check box.
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9.  To make the metric template available for use by other resources, select the Active check 
box.

10.  Enter the target and threshold values. For more information, see "Entering target and 
threshold values" on page 88.

11.  Click Save.

Creating a Peer feedback metric template

Peer Feedback metrics allow you to measure resources and projects based on the feedback 
received from internal resources through surveys. These metrics use survey rating questions 
related to the resources or projects being evaluated.

1. Access the Create Metric Template dialog box.

2.  In the Type list, select Peer feedback.

3.  In the Category list, select the metric category.

4.  In the Calculation list, select the metric calculation.

5.  In the Survey list, select the survey used for this metric template.

The list displays all active surveys.

Note: Use the Shift and Ctrl keys according to the standard Windows conventions for 
multiple selections.

6.  To include only the most recent survey results, specify the number of days to retrieve 
survey data for the metrics in the Results from last days field. For example: enter “30” for 
the last 30 days including today.

7.  In the Rollup method list, select the metric rollup method.

8.  Do one of the following:

• If the metric template is intended to evaluate teams, select the Team metric check 
box.

• If the metric template is intended to evaluate individual resources, clear the Team 
metric check box.

9.  Select the Active check box to activate the metric template.
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To store the metric template without making it available to other resources, clear the 
Active check box.

10.  Enter the target and threshold values. For more information, see "Entering target and 
threshold values" on page 88.

11.  Click Save.

Creating a Projects metric template

Projects metrics allow you to evaluate the performance of projects within portfolios.

1. Access the Create Metric Template dialog box.

2.  In the Type list, select Projects.

3.  In the Category list, select the metric category.

4.  In the Calculation list, select the metric calculation.

If you chose a user-entered calculation, the User-entered metric check box is 
automatically selected and cannot be cleared.

5.  If you create a template that uses a project budget calculations, the Revision type list is 
displayed. Do one of the following:

• To use the latest budget revision regardless of type, do not select a revision type.

• To use the latest budget revision of a specific type when calculating a target, select the 
budget revision type. 

6.  Select the Active check box to activate the metric template.

To store the metric template without making it available to other resources, clear the 
Active check box.

7.  Enter the target and threshold values. For more information, see "Entering target and 
threshold values" on page 88.

8.  Click Save.

Creating a user-entered metric template

User-entered metrics use the data manually entered by resources in the system, instead of data 
generated by the system. For example, you can use a user-entered metric to record the number 
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of training sessions an employee has attended. Only Adoption and Projects metrics accept user-
entered data.

1. Access the Create Metric Template dialog box.

2.  In the Type list, select Adoption or Projects.

3.  In the Category list, select the metric category.

The category is associated to the type selected in the previous field.

4.  In the Calculation list, select the calculation associated to that metric.

5.  In the Rollup method list, select the metric rollup method.

6.  If creating an Adoption metric, do one of the following:

• If the metric template is intended to evaluate teams, select the Team metric check 
box.

• If the metric template is intended to evaluate individual resources, clear the Team 
metric check box.

7.  If you create a template that uses a project budget calculations, the Revision type list is 
displayed. Do one of the following:

• To use the latest budget revision regardless of type, do not select a revision type.

• To use the latest budget revision of a specific type when calculating a target, select the 
budget revision type. 

8.  Select the Active check box to activate the metric template.

To store the metric template without making it available to other resources, clear the 
Active check box.

9.  Enter the target and threshold values. For more information, see "Entering target and 
threshold values" on page 88.

10.  Click Save.

Creating a user-entered metric template for configurable fields

You can create user-entered metrics that use the data specified in configurable fields.

1. Access the Create Metric Template dialog box.

2.  In the Type list, select Projects.
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3.  In the Category list, select the metric category.

4.  In the Calculation list, select the calculation for the configurable field.

5.  In the Rollup method list, select Average or Sum to determine how the data is calculated.

6.  In the Target section, enable the Project field check box and select the configurable field 
that will be used as the target value from the drop-down list.

If the check box is disabled, users assigned to the metric must enter a target date or 
number.

7.  In the Actual section, enable the Project field check box and select the configurable field 
that will be used as the actual value from the drop-down list.

If the check box is disabled, users assigned to the metric must enter a target date or 
number.

8.  Select the Active check box to activate the metric template.

To store the metric template without making it available to other resources, clear the 
Active check box.

9.  Enter the target and threshold values. For more information, see "Entering target and 
threshold values" on page 88.

10.  Click Save.

Entering target and threshold values

1. Access the Create Metric Template dialog box.

2.  Complete the field and options for the metric template.

3.  In the first Target list, do one of the following:

• To set the target over a specified value, select Over.

• To set the target under a specified value, select Under.

4.  In the second Target field, specify the target value.

The unit used depends on the value that is calculated: Units, Days, Percent, Rating, or 
Currency.

5.  In the field below the green indicator, enter the minimum value that must be reached for 
the result to be considered as “on target” and acceptable.
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6.  In the field below the red indicator, enter the value starting where results will be 
considered as “off target” and unacceptable.

7.  Click Save.

Editing a metric template

You can edit any field of a metric template if no metric has been created from this template 
and assigned to a resource or project. Once a metric has been created and assigned, you can 
only edit the name, description, activation status and thresholds of the metric template.

1. Access the metric template. 

2.  Click Actions > Edit template.

The Create Metric Template dialog box appears.

3.  Make the necessary changes.

4.  Click Save.

Deleting a metric template

You cannot delete a metric template if a metric has been created from this template and 
assigned to a resource or project.

1. Access the metric template. 

2.  Click Actions > Edit template.

The Create Metric Template dialog box appears.

3.  Click Delete.

4.  Click OK to confirm.

Deactivating a metric template

To preserve historical data, you can deactivate metric templates that are no longer needed, 
rather than deleting them.

1. Access the metric template. 

2.  Click Actions > Edit template.

The Create Metric Template dialog box appears.

3.  Clear the Active check box.
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4.  Click Save.

Rollup method examples

The following examples show how metrics are calculated using each rollup method:

Sum

Adds the metric data of each resource’s total.

Example: Candidate Approved Value

Raw Metric Data

 Value  SUM

Resource 1 $200 Resource 1 $500

Resource 1 $300   

Resource 2 $250 Resource 2 $250

   $500 + $250

  SUM $750

Average

Averages the metric data of each resource’s total. The raw data is summed up and then 
averaged at summary level.

Example: Candidate Approved Value

Raw Metric Data

 Value  SUM

Resource 1 $200 Resource 1 $500

Resource 1 $300   
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Raw Metric Data

Resource 2 $250 Resource 2 $250

   $750/2 resources

  AVG $375

Weighted average

Averages the raw metric data of each resource’s data.

For example: One member of a candidate review team has a large number of approved 
candidates. Using a weighted average calculation, you can view more accurate average results 
for the team. The calculation takes into account the number of approved candidates, instead of 
the resource who reviewed the candidates.

Example: Candidate Approved Value

Raw Metric Data

 Value  SUM

Resource 1 $200 Resource 1 $500

Resource 1 $300   

Resource 2 $250 Resource 2 $250

   $750/3 records

  W.AVG $250

 

About IPM metrics
In IPM metrics, you define performance measurements and targets for an individual or a team. 
When the metric has been defined, including targets, you can assign it to resources and/or 
workgroups.
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About accessing IPM metrics

You can access an IPM metric from the following locations:

• From an IPM metric template. For more information, see "Accessing an IPM metric from 
a metric template" on page 92.

• From the portlets. For more information, see "Performance management portlets" in the 
User Basics User Guide.

Accessing an IPM metric from a metric template

1. Access the metric template.

2.  In the Assigned metrics section, click the name of the metric you want to view.

The metric profile appears.

About creating IPM metrics

You can create a metric from the following locations:

• From the New icon in the navigation bar. For more information, see "Creating an IPM 
metric from the New menu" on page 93.

• From a metric template. For more information, see "Creating an IPM metric from a metric 
template" on page 92

Creating an IPM metric from a metric template

When you create a metric from a metric template, the metric type, category, calculation, target 
and threshold values defined in the metric template are automatically added to the metric.

1. Access a metric template.

2.  Click Actions > Assign metric.

The Create Metric dialog box displays the General tab.

3.  Complete the fields as required. For more information, see "Create/Edit Metric dialog, 
General tab options" on page 93.

4.  For information about completing the metric, see:

• "Adding a target to an IPM metric" on page 94

• "Assigning an IPM metric to a resource" on page 94
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5.  Click Save.

Creating an IPM metric from the New menu

When you create a metric from the New menu, no metric template information is added to the 
metric. To include template information, create the metric from a metric template. For more 
information, see "Creating an IPM metric from a metric template" on page 92.

1. Click New, and then select Metric from the list.

The Create Metric dialog box displays the General tab.

2.  Complete the fields as required. For more information, see "Create/Edit Metric dialog, 
General tab options" on page 93.

3.  For information about completing the metric, see the following topics:

• "Adding a target to an IPM metric" on page 94

• "Assigning an IPM metric to a resource" on page 94

4.  Click Save.

Create/Edit Metric dialog, General tab options

Field Description

Metric field Name of the metric.

Description field Description of the metric.

Metric data list Type of metric data.

Category list Category of the metric. The values in the list depend on the 

selected metric type.

Metric template list Template used for the metric.

Team metric check box When selected, makes the metric a team metric.

Carry forward to the next 
period check box

When selected, the metric assignment applies to the 

current and all future reporting periods. When cleared, the 

metric assignment only applies for one period. 

Days, Currency, Rating, or 

Units fields

Unit in which the thresholds and the targets are defined, 

depending on the selected metric template.
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Adding a target to an IPM metric

You can define multiple targets in one metric, each for a specific reporting period.

1. Access the metric. 

2.  Click Actions > Edit metric.

The Edit Metric dialog box appears.

3.  Click the Targets tab.

4.  Click an empty row in the targets table.

The Add Target dialog box appears.

5.  Complete the fields as required. For more information, see "Add Target dialog box 
options" on page 94.

6.  Click Save.

The dialog box closes and the target is added to the table.

7.  Click Save.

Add Target dialog box options

Field Description

Period list Reporting period for the target.

Original target field The original target values from the metric template.

Unit field The original target units from the metric template.

Current target field New target value.

Comment field Any relevant comment.

Assigning an IPM metric to a resource

You must define targets before assigning the metric to a resource. For more information, see 
"Adding a target to an IPM metric" on page 94.

1. Access the metric. 

2.  Click Actions > Edit metric.
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The Edit Metric dialog box appears.

3.  Click the Assignments tab.

4.  In the Metric period list, select the reporting period for the metric assignment.

5.  In the Assigned to metric section, expand the workgroups and do one of the following:

• To assign the metric to a resource, select the check box beside the resource.

• To assign the metric to all resources in a workgroup, select the check box beside the 
workgroup. If resources are transferred (either leaving or joining the workgroup), you 
must manually add them to or remove them from the metric assignment.

6.  Click Save.

About team metrics

Team metrics evaluate the results of a group of individuals. When you assign a team metric to 
resources, you specify both the resources assigned to the metric, and the resource whose results 
are used to evaluate the performance of the assigned resources.

The resources assigned to the metric are the resources who are evaluated based on the results 
of the team. The resources selected as inputs to the metric are the resources whose results are 
used as input to evaluate the assigned resources. 

For example, the manager of a development department is evaluated on the overall client 
satisfaction rate for the development department. The manager is assigned to the metric, 
whereas the individual developers are selected as inputs to the metric.

Note: The resources assigned to the metric can view the metric in the My performance 
portlet.

Assigning an IPM team metric

You must define targets before assigning a metric to a team. For more information, see 
"Adding a target to an IPM metric" on page 94.

1. Access the team metric.

2.  Click Actions > Edit metric

The Edit Metric dialog box appears.

3.  Click the Assignments tab.
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4.  In the Metric period drop-down list, select the reporting period for the metric assignment.

5.  In the Assigned to metric section, expand the workgroups and do one of the following:

• To assign the metric to a resource, select the check box beside the resource’s name.

• To assign the metric to all resources in a workgroup, select the workgroup. 

6.  In the Inputs to metric section, select the resources or workgroups whose results will be 
used to evaluate the assigned resources.

7.  Click Save.

Editing an IPM metric assignment

Managers can edit metrics for individuals or teams that they manage.

1. Access a metric. 

2.  Click Actions > Edit metric.

The Edit Metric dialog box appears.

3.  Make the necessary changes. For more information, see "Create/Edit Metric dialog, 
General tab options" on page 93 and "Add Target dialog box options" on page 94.

4.  Click Save.

Adjusting the weighting of IPM metrics for a resource

When several metrics are assigned to a resource, each metric is assigned an equal weighting 
value. You can edit each weighting provided that the total of all weightings is 100%.

1. Access the My Performance portlet from a resource profile or dashboard that includes it. 

2.  Select a different reporting period, if required. 

3.  In the portlet, click . 

The Weightings view appears.

4.  In the Weightings fields, enter the weighting percentage of each metric. 

5.  Click Actions > Save. 
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About GL account codes

General ledger (GL) account codes are used when configuring taxes, and when entering 
expenses and setting up cross charges in Changepoint. Only the GL account codes and their 
descriptions are displayed in Changepoint.

If Changepoint is integrated with a third-party financial or accounting application, you must 
add the GL account index from the third-party application to the GL account codes in 
Changepoint. 

GL account types

GL account type Description

Expense balance Used for custom interfaces only.

Expense distribution Used for expense distribution on expense reports. This type of 

GL account is used when setting up expense settings.

Expense tax Used for recoverable taxes on expense reports.

Cross charge balance Used for custom interfaces only.

Cross charge distribution Used for revenue distribution on cross charges, if cross 

charge distribution is enabled.

Cross charge tax Used for the tax portion of revenue on cross charges, if cross 

charge distribution is enabled.

Revenue account Used to track revenue debits, and credits as part of the 

revenue recognition process.

Creating a GL account code

1. Click Finance > GL Account Codes.

2.  Right-click in the table, and then select Insert.

A new row appears.

3.  In the GL account code field, enter the GL account number.
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4.  In the Description field, enter the description of the GL account.

5.  In the Type list, select the GL account type. For more information, see "GL account types" 
on page 97.

6.  In the GL account index field, enter the GL account index of the third-party application.

7.  Click Save.

Modifying a GL account code

1. Click Finance > GL Account Codes.

2.  Make the necessary changes in the table cells.

3.  To delete a GL account code:

a. Right-click the GL account code, and then select Delete.

b. Click OK to confirm.

4.  Click Save.

About cost centers
In Changepoint, cost centers are associated with workgroups, global workgroups, cost 
structures, and initiatives. It is recommended that you create your organization’s cost centers 
before creating the workgroups, global workgroups and cost structures.

The first cost center that you create automatically becomes the default cost center. Once you 
have created several cost centers, you can select another cost center as the default cost center, 
which will be automatically associated to workgroups for which no cost center was specified.

During the revenue recognition process, revenue transfers between cost centers may be 
required. For more information, see "About revenue transfers" on page 156.

You can configure a burden rate for a cost center. For more information, see "About 
configuring burden rates for cost centers" on page 100.

Creating a cost center

1. Click Finance > Cost Centers.

2.  In the Folders view, click any cost center.

3.  Click New.         
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4.  Complete the fields as required. For more information, see "Cost Center view, General 
section options" on page 99.

5.  Configure a burden rate, if required. For more information, see "Configuring a burden rate 
for a cost center" on page 100.

6.  Click Save.

Cost Center view, General section options

Option Description

Cost center field Name of the cost center.

Description field Description of the cost center.

Segment 2 field Additional customer-specific segment for the cost center, 

typically used for integration purposes.

Segment 3 field Additional customer-specific segment for the cost center, 

typically used for integration purposes.

Current default cost 
center field

Default cost center. Changepoint requires a default cost 

center to run revenue recognition. 

Set as default cost 
center check box

When selected, the cost center is the default cost center for 

workgroups.

Modifying a cost center

You cannot delete cost centers that are associated with workgroups, global workgroups, cost 
structures, or initiatives.

1. Click Finance > Cost Centers.

2.  In the Folders view, select the cost center.

3.  To edit the cost center:

a. Make the necessary changes.

b. Click Save.

4.  To delete the cost center:
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a. Click Delete.

b. Click OK to confirm.

Changing the default cost center

1. Click Finance > Cost Centers.

2.  In the Folders view, select the cost center that you want to set as the default cost center.

3.  In the General section, select the Set as default cost center check box.

4.  Click Save.

About configuring burden rates for cost centers

You can configure burden rates for a cost center. Burden rates are applied to resource-based 
and staffing level-based cost rates used for initiatives, budgets and candidate services to 
calculate the burdened cost rate. 

Once a burden rate has been saved, you cannot edit it. To correct an error in a burden rate, you 
must create a new burden rate and deactivate the incorrect one. Burden rates cannot be deleted, 
but only deactivated if they are no longer used. For more information, see "Deactivating a 
burden rate" on page 101.

At least one burden rate per cost center must be active but you cannot have more than one 
active burden rate with the same effective date.

Configuring a burden rate for a cost center

1. Click Finance > Cost Centers.

2.  In the Folders view, select the cost center. 

3.  Expand the Burden rates section.

4.  Right-click the table, and select Insert.

5.  In the Burden rate (%) cell, enter the percentage of the burden rate.

6.  In the Effective date cell, enter the date the burden rate will be applied.

7.  To activate the burden rate, select the Active check box.

8.  Click Save.
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Deactivating a burden rate

After a burden rate has been saved, you cannot delete it. If the burden rate is no longer used, 
you can deactivate it.

1. Click Financial Management  > Cost Centers.

2.  In the Folders view, select the cost center. 

3.  Expand the Burden rates section.

4.  Click the row of the burden rate.

5.  Clear the Active check box.

6.  Click Save.

About currencies and exchange rates
Changepoint comes with most country currencies by default. You must enable a currency 
before it is available for use, except for the Canadian and US currencies. You can also add a 
currency if the one you want is not available.

Changepoint uses the standard ISO 3166-1 three-character currency code for currencies. If 
Changepoint is integrated with a third-party financial or accounting application that does not 
use the standard ISO currency code, you must add the currency index used in the third-party 
application for each currency that you enable.

Setting up exchange rates

You can set up exchange rates for each currency pair. Each exchange rate is for a specific date 
range. There cannot be a gap or overlap between consecutive exchange rates. 

To ensure that there is always an exchange rate in effect, you can omit the end date of the 
current exchange rate. You can also omit the start date of the first exchange rate. If an 
exchange rate is not available for a currency pair, the conversion value  is zero.

Adding a currency

You can enable an existing currency to make it available for use, or add a new currency.

1. Click Finance > Currencies.

2.  To make the currency available for use, select the Currency enabled check box.

3.  To add a currency:

Changepoint Administration | 101



5. Financial Setup

a. Right-click in the table, and then select Insert

b. In the Currency field, enter the currency name.

c. In the Description field, enter a description.

d. In the ISO currency code field, enter the  ISO 3166-1 three-character currency code.

e. In the Currency index field, enter the currency index of the third-party application, if 
applicable.

4.  Click Save.

Accessing an exchange rate

1. Click Finance > Exchange Rates.

The Exchange Rates view appears. 

2.  Select the source and target currencies.

The exchange rates are displayed.

Configuring an exchange rate

1. Select Finance > Exchange Rates. 

The Exchange Rates view appears.

2.  In the Source currency field, choose the source currency.

3.  In the Target currency field, choose the target currency.

To add a new current exchange rate

1. Enter an end date for the current exchange rate.

2.  Right-click below the table, and then click Insert.

3.  In the Start date field, enter the start date for the exchange rate.

4.  In the End date field, enter the end date for the exchange rate.

5.  In the Exchange rate field, enter the exchange rate.
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To add an exchange rate between existing rates

1. Change the end date for the exchange rate that is immediately before the new exchange 
rate.

2.  Right-click the row below the exchange rate, and then click Insert.

The new exchange rate is added.

3.  In the Exchange rate field, enter the exchange rate.

4.  If necessary, adjust the end date for the new exchange rate and start date of the following 
exchange rate.

5.  Click Save.

Editing an exchange rate

You can edit exchange rates, including the start and end dates, provided that there is no gap or 
overlap between consecutive exchange rates.

1. Click Finance > Exchange Rates. 

The Exchange Rates view appears.

2.  Select the source and target currencies.

The exchange rates are displayed.

3.  Click in the cells to make the necessary changes.

4.  Click Save.

About taxation setup
You can define:

• Different tax calculations and tax combinations according to the location where work is 
performed or expenses are incurred, the cross charge address of the client, and the service 
type or non-labor item provided.

• Different tax schedules that allow for an unlimited number of taxes to be applied to 
services and expenses, including support for multiple recoverable taxes.

• Work locations and a set of work codes or services that describe the type of work being 
performed.
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Once the information is defined, the way it is applied can be controlled at the initiative, 
project, task, time, expense or cross charge level.

Some IT departments charge internal and external clients for their services, non-labor items 
and other expenses. Taxes are added on cross charges that are issued to clients.

Taxation setup process

To perform initial Taxation setup, follow these steps:

1. Define taxes and tax rates used in your organization, and combine them into tax schedules.

2.  Define work codes that describe the type of work performed by your organization and use 
these work codes in tax calculations. 

3.  Define work locations that describe where work is performed or where expenses are 
incurred and use these work locations in tax calculations.

4.  Define recoverable taxes for expenses. Link the expense types to the tax schedules and 
work locations in order to capture recoverable taxes.

5.  Define expense taxation and link expenses to work locations and tax schedules for cross 
charging purposes.

6.  Define service (work) taxation and link services to work codes, work locations and tax 
schedules for cross charging purposes.

7.  Define non-labor item taxation and link non-labor items to work locations and tax 
schedules for cross charging purposes.

About tax rates and tax schedules

You must define all of the taxes that are applicable to your organization as tax rates. You then 
create tax schedules, which consist of one or more tax rates. For example, you can create a tax 
schedule that includes a federal tax and a regional (state or provincial) tax.

You use tax schedules to set up the taxation rules for services, expenses and applications that 
are cross charged to clients.

Once a tax rate record has been saved, you can no longer edit it except to change its activation 
status.
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To change a tax rate (for example, to change the percentage rate), you copy an existing tax rate 
record, modify the appropriate fields, and set the effective date of the new rate. The new 
percentage takes effect on the effective date in all tax schedules that include the rate.

Accessing a tax rate

When you access a tax rate, you can also view the tax schedules that the rate is included in, 
and the history of the tax rate.

The Tax rate history table contains tax rate records. For any date, only one record for a tax 
rate can be active.

1. Click Taxation > Tax Rates.

2.  In the Folders view, click the tax rate that you want to view.

The Tax Rates view appears.

Creating a tax rate

1. Click Taxation > Tax Rates.

2.  In the Folders view, click any tax rate.

The Tax Rates view appears.

3.  Click New.

4.  Complete the fields as required. For more information, see "Tax Rate Setup options" on 
page 105.

5.  Click Save.

Tax Rate Setup options

Field Description

Active check box When selected, activates the tax rate on the effective date.

Effective date field Date that the tax rate comes into effect. When you create a 

new tax rate, the field displays today’s date  by default. 

Tax rate field Name of the tax.
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Field Description

Percentage field Percentage value of the tax.

Registration number 
field

Registration number for the tax. This number is usually 

assigned by the government and displays on cross charges.

Expense GL account 
code list

Expense GL account number for the tax. Displayed on an 

expense report for the recoverable tax amount entered.

Cross Charge GL 
account code list

Cross charge GL account number associated with the tax. 

Displayed on cross charge distributions of tax amounts.

Tax rate ID field Unique identifier for the tax that is used for interfacing with 

other systems.

Show taxes separately 
on cross charge check 

box

When selected, the individual tax amounts are displayed 

separately on a cross charge. When cleared, the tax amounts 

are grouped and summarized on the cross charge.

Activating and deactivating a tax rate

1. Click Taxation > Tax Rates.

2.  In the Folders view, click the tax rate whose status you want to change.

The Tax Rates view appears.

3.  Expand the Tax rate history section.

4.  In the Tax rate history table, click the tax rate record whose status you want to change.

5.  Expand the Tax rate details section.

6.  Set or clear the Active check box.

7.  Click Save.

Editing a tax rate

To edit a tax rate you copy an existing tax rate record and make the changes in the copy. All 
of the information is copied to the new tax rate record, except for the effective date. The 
copied Tax rate and Tax rate ID fields cannot be edited. 
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To use the same effective date for the new tax rate record, you must deactivate the old tax rate 
record before you activate the new one.

1. Click Taxation > Tax Rates.

2.  In the Folders view, click the tax rate that you want to edit.

The Tax Rates view appears.

3.  To edit the tax rate:

a. Expand the Tax rate details section.

b. Expand the Tax rate history section.

c. In the Tax rate history table, select the tax rate record.

To use the same effective date for the new tax rate record, first select and deactivate 
the existing active tax rate record for that date.

d. Click Copy.

e. In the Effective date field, enter the date that the tax rate becomes effective.

f. Complete the other fields as required.

g. Click Save.

The new tax rate appears in the Tax rate history table.

4.  To delete the tax rate:

a. Click Delete.

b. Click OK to confirm. 

Accessing a tax schedule

When you access a tax schedule, you can also view the tax  rates that are included in the 
schedule, and the history of the schedule.

The Tax schedule history table contains tax schedule records. For any effective date, there can 
be only one tax schedule record.

1. Click Taxation > Tax Schedule.

2.  In the Folders view, click the tax schedule you want to access.

The Tax Schedule Setup view appears.
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Creating a tax schedule

You add tax rates to the tax schedule in the order in which the taxes are applied. The first tax 
rate applies to the base amount only, while subsequent tax rates can be applied to the base 
amount and/or previous tax rates. You can choose from the tax rates that are active and in 
effect on or before the effective date of the tax schedule.

1. Click Taxation > Tax Schedule.

2.  Click any tax schedule.

3.  Click New.

4.  In the Status field,  select the status for the tax schedule.

5.  In the Tax schedule field, enter a name for the tax schedule.

6.  In the Description field, enter a description for the tax schedule.

7.  In the Tax schedule ID field, enter the unique identifier for the tax schedule. This ID is 
used for interfacing with other systems.

8.  Expand the Tax schedule history section.

9.  Right click in the Tax schedule history table and select Insert.

10.  In the Effective date field, enter the date the tax schedule comes into effect.

11.  Expand the Tax rates section.

12.  To add the initial tax rate  that is to be applied to the base amount only:

a. Right click in the Tax rates table, and then select Insert.

b. In the Tax rate list, select the tax rate.

c. In the Applies to list, select Applies to base amount.

13.  Click Save.

You can add more tax rates to the tax schedule. For more information, see "Adding a tax rate 
to a tax schedule" on page 108.

Adding a tax rate to a tax schedule

1. Click Taxation > Tax Schedule.

2.  Click the tax schedule.
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3.  Expand the Tax rates section.

4.  To add a tax rate:

a. In the Tax rate history table, select the appropriate entry.

b. Right click in the Tax rates table, and then select Insert.

c. In the Tax rate list, select the tax rate that is to be applied.

d. In the Applies to list, select either Applies to base amount or a tax rate.

5.  Click Save.

Copying a tax schedule

You can create a new tax schedule by copying data from an existing tax schedule. All of the 
information is copied from the source to the target tax schedule, except for the effective date. 

1. Click Taxation > Tax Schedule.

2.  Click the tax schedule.

3.  To copy the tax schedule:

a. Right click in the Tax schedule history table, and then select Copy.

b. In the Effective date field, enter  the date the tax schedule comes into effect.

4.  Click Save.

Removing a tax rate from a tax schedule

You cannot remove a tax rate from a tax schedule if the tax schedule is active, or if it is the 
only tax rate in the tax schedule.

1. Access the tax schedule.

2.  In the Tax schedule history table, select the tax schedule whose rate you want to remove.

3.  In the Tax rate table, select the tax rate you want to remove.

4.  Right click the tax rate, then select Delete. 

About editing tax schedules

Once a tax schedule is active, the only change you can make is to change its status to Inactive. 
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To effectively edit a tax schedule, you must create a new tax schedule with a different 
effective date.

Activating or deactivating a tax schedule

You cannot edit an active tax schedule, except to change its status to Inactive.

1. Access the tax schedule.

2.  Expand the Tax schedule detail section. 

3.  Do one of the following:

• To activate the tax schedule, in the Status list, select Active. 

• To deactivate the tax schedule, in the Status list, select Inactive

4.  Click Save.

Deleting a tax schedule

You can only delete a tax schedule that has the Draft or Inactive status. 

1. Access the tax schedule.

2.  Click Delete.

3.  Click OK to confirm.

About work codes and work locations

Work codes define the type of work performed by your organization. Different types of work 
can have different taxation rules. For example, consulting work may be nontaxable. It is 
recommended that you create a work code for each taxation rule. Work codes are grouped 
under work code categories. 

Work locations define where the work is performed or charged to, or where expenses are 
incurred. Depending on taxation rules, a work location can be a country, region or specific 
address. You must set up a work location for each location that has a specific taxation rule and 
where your organization performs work. Work locations are grouped under work location 
groups.

Creating a work code category

1. Click Taxation > Work Codes.

2.  In the Filters view, select a work code category.
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The Work Code Category Setup view appears.

3.  Click New.

4.  In the Work code category field, enter a name for the work code category.

5.  In the Description field, enter a description for the work code category.

6.  In the Work code category ID field, enter the unique identifier for the work code category 
that is used for interfacing with other applications.

7.  Click  Save.

Editing a work code category

1. Click Taxation > Work Codes.

2.  In the Filters view, select the work code category.

3.  To edit the work code category:

a. Make the necessary changes.

b. Click Save.

4.  To delete the work code category:

a. Click Delete.

b. Click OK to confirm.

Creating a work code

You must create a work code under a work code category.

1. Click Taxation > Work Codes.

2.  In the Filters view, select the work code category.

3.  The Work Code Category Setup view appears.

4.  In the Work codes table, right-click and then select Insert.

5.  In the Work code field, enter a name for the work code. 

6.  In the Description field, enter additional information about the work code.

7.  In the Work code ID field, enter the unique identifier for the work code that is used for 
interfacing with other systems.
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8.  Click Save.

Editing a work code

1. Click Taxation > Work Codes.

2.  In the Filters view, select the work code category or work code.

3.  To edit the work code, make the necessary changes in the Work codes table.

4.  To delete the work code:

a. Right-click the row and then select Delete.

b. Click OK to confirm.

5.  Click Save.

Creating a work locations group

Work locations are grouped under work location groups. You must first create a work location 
group before creating work locations.

1. Click Taxation > Work Locations. 

2.  Click a work location group folder.

The Work Locations Group Setup view appears.

3.  Click New.

4.  In the Work location group field, enter a name for the work location group.

5.  In the Description field, enter a description.

6.  In the Work location group ID field, enter the unique identifier for the work location 
group that is used for interfacing with other applications.

7.  Click Save.

Editing a work location group

1. Click Taxation > Work Locations. 

2.  Click the work location group.

The Work Locations Group Setup view appears.

3.  To edit the work location group, make the necessary changes.
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4.  To delete the work location group:

a. Click Delete.

b. Click OK to confirm.

5.  Click Save.

Creating a work location

You must create a work location under a work location group.

1. Click Taxation > Work Locations. 

2.  Click the work location group.

The Work Location Group Setup view appears.

3.  In the Work locations table, right-click and then select Insert.

4.  In the Work location field, enter the name for the work location.

5.  In the Description field, enter the description.

6.  In the Work location ID field, enter the unique identifier that is used for interfacing with 
other applications.

7.  To enter the address for the work location:

a. Click in the Address field. The Address dialog box appears.

b. Enter the address, and then click Save.

8.  Click  Save.

Editing a work location

1. Click Taxation > Work Locations. 

2.  Click the work location group or work location.

The Work Locations Group Setup view appears.

3.  To edit a work location, make the necessary changes in the Work locations table.

4.  To delete a work location:

a. Right-click the row and then select Delete.

b. Click OK to confirm.
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5.  Click  Save.

About taxation rule settings

After you set up work codes, work locations, tax rates and tax schedules, you use them to set 
up taxation rules for expenses, cross charging and recoverable taxes.

You set up taxation rules in the following components:

• Expense taxation – rules for taxes on expenses. 

• Service taxation – rules for taxes on services (both chargeable time and fixed fees).

• Non-labor item taxation – rules for taxes on non-labor items.

• Recoverable tax – rules for recovering taxes on expenses.

Order of setup

You set up the general taxation rules first, and then set up the exceptions for specific 
situations. For example, if all expenses except for rail travel have a value-added tax applied, 
you set up all expense categories with the value-added tax schedule, and then set up the rail 
travel expense type with no tax schedule. 

The most specific matching setup is used

When cross charging is processed, if more than one setup could apply, the most specific 
matching setup is used and the appropriate taxation setup is applied to the expense, service or 
non-labor item. 

Taxation rules apply only to the components currently in the category

When you set up or modify taxation rules for a component category (for example, an expense 
category), and for All components (expenses), the rules apply only to components that are in 
the category at the time. If you add a component  later you must set up new taxation rules for 
it.

Selecting a tax schedule

In the Tax schedule list in the Tax schedule table, only tax schedules that have an effective 
date on or before the effective date entered are available for selection.
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Example of taxation for expenses

In the following example, USA and Canada are work location groups, and each state and 
province is a work location within its group.

Expense Category 
and Type 

Incurred-in 
Location 

Charge-to Location 
Tax 
Schedule

All categories and 

types

All work location 

groups

All work location groups TS1

All categories and 

types

Canada work 

location group

USA work location group TS2

Meals and 

entertainment 

category / Meals

California work 

location

California work location TS3

All categories and 

types

USA work location 

group

USA work location group TS4

• For meal expenses that are incurred in California and cross charged to California, tax 
schedule TS3 is used.

• For accommodation expenses that are incurred in California and cross charged to 
California, tax schedule TS4 is used.

• For meal expenses that are incurred in Maine and cross charged to Canada, tax schedule 
TS1 is used.

Creating a recoverable tax

A recoverable tax setup specifies the tax schedules for tax on a type of expense that is 
recoverable at a work location.

1. Select Taxation > Recoverable Taxes.

The Recoverable Taxes tree view appears. 

2.  Click any folder.

3.  Click New.
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4.  Complete the Expense category, Expense type, Work location group, and Work 
location fields as required. For more information, see "Recoverable Tax Setup options" on 
page 116.

5.  In the Tax Schedules table, right-click and then select Insert.

6.  Complete the Effective date and other fields in the table as required. For more 
information, see "Recoverable Tax Setup options" on page 116.

7.  Click Save.

Recoverable Tax Setup options

Field Description

Expense category list Category of the expenses for which taxes can be recovered.

Expense type list Expense type for which taxes can be recovered.

Work location group list Work location group that includes locations where taxes can 

be recovered. 

Work location list Work location where taxes can be recovered.

Tax Schedule section

Effective date field Date that the recoverable tax becomes effective.

Tax schedule list Tax schedule that includes the taxes that can be recovered. 

Enabled check box When selected, resources can manually enter tax amounts 

when creating expenses, even if the Auto-calculate tax 

check box is also selected.

Auto-calculate check box When selected, taxes are automatically calculated based on 

the expense amount and the recoverable tax percentage.

Active check box When selected, activates the recoverable tax on the effective 

date.

Editing a recoverable tax setup

You can only edit the values in the Tax Schedules table. 
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Because a recoverable tax consists of a tax schedule that is applied to a specific combination of 
expense type and work location , if you change the expense type or work location, you are 
adding a new recoverable tax. 

Note: You cannot delete a recoverable tax after it has been saved.  

If the tax you want to edit is active, you can do one of the following:

• add a new tax with a different effective date

• to retain the effective date of  the tax ,  you can do one of the following:

• deactivate the tax , then edit it, then reactivate it

• deactivate the tax , then add a new tax with the same effective date, then activate the 
new tax

1. Select Taxation > Recoverable Taxes.

The Recoverable Taxes tree view appears. 

2.  Expand the tree view and select the tax.

The  taxation criteria and the tax schedule table appear. 

3.  To add a new tax, right-click in the Tax schedule table, and then select Insert. 

4.  To deactivate a tax:

a. Select the tax.

b. Clear the Active check box.

c. Click Save. 

5.  In the Tax schedule section, make the necessary changes. For more information, see 
"Recoverable Tax Setup options" on page 116.

6.  Click Save.

Creating an expense taxation setup

An expense tax specifies the tax schedules for a type of expense that is incurred at a work 
location  and charged to the same or a different location.

1. Select Taxation > Expense Taxation.

The Expense Taxation tree view appears. 
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2.  Click any folder.

3.  Click New.

4.  Complete the Cross charge-to location group and Cross charge-to location, Incurred-
in location group and Incurred-in location, Expense category and Expense type fields 
as required. For more information, see "Expense Taxation Setup options" on page 118.

5.  In the Tax Schedules table, right-click and then select Insert.

6.  Complete the Effective date and other fields in the table as required. For more 
information, see "Expense Taxation Setup options" on page 118.

7.  Click Save.

Expense Taxation Setup options

Area/Field Description

Charge-to location 
group list

Work location group that applies to the client being cross 

charged. 

Charge-to location list Work location of the client being cross charged.

Incurred-in location 
group list

Work location group that applies to the location where 

expenses are incurred.

Incurred-in location list Work location where expenses are incurred.

Expense category list Expense category that the taxation applies to. 

Expense type list Expense type that the taxation applies to.

Tax Schedule section

Effective date field Date that the taxation becomes effective for the expense.

Tax schedule list Tax schedule associated with this expense taxation setup.

If the expense is nontaxable, select blank. 

Active check box When selected, activates the expense taxation on the 

effective date.
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Area/Field Description

Strip matching check 

box

When selected, recoverable taxes that match the cross 

charge tax schedule are removed from the expense amount.

Strip all check box When selected, all recoverable taxes are removed from the 

expense amount.

Recalculate check box When selected, discards the recoverable tax amounts that are 

removed from the expense amount and calculates a new tax 

amount. 

When cleared, the recoverable tax amounts that were 

removed from the expense are included in the tax total on the 

cross charge.

Editing an expense taxation setup

An expense tax setup specifies the tax schedules for taxes  for a type of expense that is incurred 
at a work location and charged to the same or a different location.

You can only edit the values in the Tax Schedules table. 

Because an expense taxation setup is a specific combination of charge-to and incurred-in 
options, if you edit the charge-to or incurred-in options, you would be creating a new expense 
taxation setup.

Note: You cannot delete an expense taxation setup after it has been saved.

If the tax you want to edit is active, you can do one of the following:

• add a new tax with a different effective date

• to retain the effective date of  the tax ,  you can do one of the following:

• deactivate the tax , then edit it, then reactivate it

• deactivate the tax , then add a new tax with the same effective date, then activate the 
new tax

1. Select Taxation > Expense Taxation

The Expense Taxation tree view appears. 

2.  Expand the tree view and select the tax.
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The  taxation criteria and the tax schedule table appear. 

3.  To add a new tax, right-click in the Tax schedule table, and then select Insert. 

4.  To deactivate a tax:

a. Select the tax.

b. Clear the Active check box.

c. Click Save. 

5.  In the Tax schedule section, make the necessary changes. For more information, see 
"Expense Taxation Setup options" on page 118.

6.  Click Save.

Creating a service taxation setup

A service tax specifies the tax schedules for a type of service (work code) that is carried out at 
a work location   and charged to the same or a different location.

1. Select Taxation > Service Taxation.

The Service Taxation tree view appears. 

2.  Click any folder.

3.  Click New.

4.  Complete the fields as required. For more information, see "Service Taxation Setup 
options" on page 121.

5.  In the Tax Schedules table, right-click and then select Insert.

6.  Complete the Effective date and other fields in the table as required.  For more 
information, see "Service Taxation Setup options" on page 121.

7.  Click Save.
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Service Taxation Setup options

Field Description

Charge-to location 
group list

Work location group that applies to the client being cross 

charged.

Charge-to location list Work location of the client being cross charged.

Incurred-in location 
group list

Work location group that includes the locations where the 

services are performed.

Incurred-in location list Work location where the services are performed. If you select 

All, then the taxation rule applies to every location in the work 

location group.

Work code category list Work code category that includes the services.

Work code list Work code that includes the services.

Tax Schedule section

Effective date field Date that the tax schedule becomes effective for service 

taxation.

Tax schedule list Tax schedule associated with this service taxation.

If the service is nontaxable, select blank as the tax schedule. 

Active check box When selected, activates the service taxation on its effective 

date.

Editing a service taxation setup

You can only edit the values in the Tax Schedules table. 

If the tax schedule has been activated, you create a new tax schedule with a different effective 
date. To use the same effective date for the new tax schedule, you must deactivate the existing 
tax schedule before activating the new tax schedule.

Note: You cannot delete a service taxation setup after it has been saved.

If the tax you want to edit is active, you can do one of the following:

• add a new tax with a different effective date
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• to retain the effective date of  the tax ,  you can do one of the following:

• deactivate the tax , then edit it, then reactivate it

• deactivate the tax , then add a new tax with the same effective date, then activate the 
new tax

1. Select Taxation > Service Taxation

The Service Taxation tree view appears. 

2.  Expand the tree view and select the tax.

The  taxation criteria and the tax schedule table appear. 

3.  Expand the Tax schedule section.

4.  To add a new tax, right-click in the Tax schedule table, and then select Insert. 

5.  To deactivate a tax:

a. Select the tax.

b. Clear the Active check box.

c. Click Save. 

6.  In the Tax schedule section, make the necessary changes. For more information, see 
"Service Taxation Setup options" on page 121.

7.  Click Save.

Creating a non-labor item taxation setup

A non-labor item tax specifies the tax schedule for a type of non-labor item that is produced at 
a work location  and charged to the same or a different location.

When you set up taxation rules for a non-labor item category, the taxation rules apply only the 
non-labor items that are in the category at the time. You must set up new taxation rules for any 
non-labor items added later.

1. Select Taxation > Non-labor item Taxation.

The Non-labor item Taxation tree view appears. 

2.  Click any folder.

3.  Click New.

122 | Changepoint PPM 2021



About taxation setup

4.  Complete the fields as required. For more information, see "Non-Labor Item Taxation 
Setup options" on page 123.

5.  In the Tax Schedules table, right-click and then select Insert.

6.  Complete the Effective date and other fields in the table as required. For more 
information, see "Non-Labor Item Taxation Setup options" on page 123.

7.  Click Save.

Non-Labor Item Taxation Setup options

Field Description

Charge-to location 
group list

Work location group that applies to the client for which non-

labor items are cross charged.

Charge-to location list Work location of the client for which non-labor items are cross 

charged.

Ship-to location group 

list

Work location group where the non-labor items are shipped.

If you select All, then the taxation setup applies to all work 

location groups.

Ship-to location list Work location where the non-labor items are shipped.

Non-labor item category 

list

Category of the non-labor item.

Only non-labor items located directly in the non-labor item 

category are considered. Subcategories and their contents 

are excluded.

Non-labor item list non-labor items.

Tax schedule section

Effective date field Date when the tax schedule becomes effective for the taxation 

setup.

Tax schedule list Tax schedule for the taxation setup. If the non-labor items are 

nontaxable, select blank as the tax schedule.

Active check box When selected, activates the taxation setup on the effective 

date.
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Editing a non-labor item taxation setup

You can only edit the values in the Tax Schedules table. 

Note: You cannot delete a non-labor item taxation setup after it has been saved.

If the tax you want to edit is active, you can do one of the following:

• add a new tax with a different effective date

• to retain the effective date of  the tax ,  you can do one of the following:

• deactivate the tax , then edit it, then reactivate it

• deactivate the tax , then add a new tax with the same effective date, then activate the 
new tax

1. Click Taxation > Non-Labor Item Taxation.

The Non-Labor Item Taxation tree view appears.

2.  Expand the tree view and select the tax.

The  taxation criteria and the tax schedule table appear. 

3.  To add a new tax, right-click in the Tax schedule table, and then select Insert. 

4.  To deactivate a tax:

a. Select the tax.

b. Clear the Active check box.

c. Click Save. 

5.  In the Tax schedule section, make the necessary changes. For more information, see 
"Non-Labor Item Taxation Setup options" on page 123.

6.  Click Save.

Troubleshooting taxation setup

The tax schedule is not available for selection in the taxation setup view

Only the tax schedules that have an effective date that is on or before the effective date of the 
taxation setup are available for selection.
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About fiscal years and periods
You can create a single fiscal period setup, or different fiscal periods for different cost 
structures. At least one cost structure must be created before you can set up fiscal years and 
fiscal periods. 

You first create and save a fiscal year, and then divide the year into fiscal periods. The default 
length of a fiscal year is one year, but you can make it shorter. The fiscal period intervals can 
be weekly, monthly, quarterly, or semi-annually. For weekly fiscal periods only, you can select 
the day of the week that the fiscal periods start on. 

Accessing a fiscal year

1. Select Finance > Fiscal periods.

2.  Expand the cost structure folders to locate the fiscal year that you want to view.

3.  Select the fiscal year.

The Fiscal Period Setup view appears.

Creating a fiscal year and periods 

You must create and save the fiscal year before you can add fiscal periods to it.

1. Select Finance > Fiscal Periods.

The Fiscal periods tree view appears. 

2.  Click any cost structure folder.

The Fiscal Period Setup view appears.

3.  In the Cost structure list, select the cost structure for which you want to create the fiscal 
year.

4.  In the Fiscal year field, enter a name for the fiscal year.

5.  In the Start date field, enter the date when the fiscal year starts.

6.  Change the end date to an earlier date, if necessary.

7.  Click Save.

8.  To create fiscal periods:
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a. To specify a different day than Sunday for weekly fiscal periods to start on, select the 
day in the Start day (weekly periods only) field.

b. Right-click in the Fiscal periods table, and then select the fiscal period interval.

c. The fiscal periods appear.

d. You can edit the names and start and end dates of the fiscal periods, except for the 
dates that coincide with the start and end dates of the fiscal year.

9.  Click Save.

Editing a fiscal year and periods

Before a fiscal year has been divided into fiscal periods, you can change any of the field 
values. 

After a fiscal period interval has been selected, then you cannot change the start or end date 
for the fiscal year. However, you can change the names and start and end dates for the fiscal 
periods, provided that there is no gap or overlap between fiscal periods.

Note: You cannot delete a fiscal period or change the fiscal period intervals. Instead, you 
must delete the fiscal year and create a new one. Also, you cannot delete a fiscal year once 
it has been used in Changepoint.

1. Access the fiscal year. 

The Fiscal Period Setup view appears.

2.  Make the necessary changes.

3.  To delete the fiscal year, click Delete.

4.  Click Save.

About closed periods
You can configure closed periods to prevent resources from performing actions (such as 
create, edit, submit, approve, and commit) on entity records within that period. Closed periods 
prevent changes to revenue recognition and financial results after a specific date. 

A closed period consists of a cutoff date and an optional grace period. The cutoff date is the 
last date that resources can perform actions on the entity records that are dated on or prior to 
the cutoff date. The grace period is the number of working days after the cutoff date that 

126 | Changepoint PPM 2021



About closed periods

resources can continue to perform the actions on entity records that are dated on or prior to the 
cutoff date. 

Note: Unlike nonworking days that are set up at the system level or for workgroups, 
nonworking days that are set up in user setup or the resource calendar are counted as 
working days in the grace period. 

You can configure closed periods at the system level, or for specific cost structures. Closed 
periods for cost structures override the system-level closed periods.

The entities for which you can configure closed periods are:

• expenses

• cross charges and credit notes

• materials

• revenue recognition records 

• time (includes task time, request time, and time adjustments)

You can set up different closed periods for the different entity types, and different cutoff dates 
and grace periods for each action.

Accessing a closed period

1. Select Finance > Closed Periods. 

The Closed Periods view displays the closed periods defined at system level.

2.  To access the closed periods for a cost structure:

a. In the Level list, select Cost structure.

b. In the Cost structure type-ahead field, enter the cost structure.

The closed period table displays the closed periods for the cost structure. 

Configuring a closed period

1. Click Finance > Closed Periods.

2.  To set up a closed period for all of Changepoint, select System in the Level list.

3.  To set up a closed period for a specific cost structure:

a. In the Level list, select Cost structure.
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b. In the Cost structure type-ahead field, select the cost structure. 

4.  If there are no rows in the table, right-click in the table, and then click Insert. 

5.  In the Cutoff date cell, enter the date that the closed period begins.

6.  For each action of each entity type that the closed period applies to, do one of the 
following:

• To set up a cutoff date without a grace period, enter 0.
• To set up a cutoff date with a grace period, enter the number of days for the grace 

period.

7.  Click Save.

Editing a closed period

1. Click Finance > Closed Periods

2.  In the Level list, select System or the Cost structure.

3.  Make the necessary changes.

4.  To delete a closed period:

a. Right-click the closed period, and then select Delete.

b. Click OK to confirm.

5.  Click Save.

6.  Click OK to confirm.

About cost structures
Cost structures set the basic rules for all associated initiatives and business transactions. The 
rules define, for example, the default cost center, cross charge rates and cost rates for resources 
or staffing levels, cross charge approval process, and so on. 

Some of these default settings can be overridden in Changepoint when creating initiatives or 
cross charges. However, you can restrict the changes that can be made in Changepoint.

About specifying cost centers for cost structures

When a resource creates an initiative, that resource can select either the cost center of the cost 
structure, or the cost center associated with the workgroup of the initiative manager, to be the 
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cost center for the initiative. When revenue is recognized, it is assigned to the cost center 
selected on the initiative, unless revenue transfers are enabled.

Accessing a cost structure

1. Click Finance > Cost Structures.

2.  In the Folders view, select the cost structure.

The Cost Structure view appears.

Creating a cost structure

You can also create a cost structure by copying all the information from an existing cost 
structure. For more information, see "Copying a cost structure" on page 145.

1. Click Finance > Cost Structures.

2.  In the Folders view, click any cost structure.

3.  Click New.

4.  Expand the General section.

5.  Complete the fields as required. For more information, see "Cost Structures view, General 
section options" on page 130.

6.  Complete the remaining sections. For more information, see:

• "Configuring cost structure settings" on page 131

• "Configuring cross charge approval settings" on page 137

• "Creating a staffing level" on page 138

• "Configuring cross charge numbering" on page 138

• "Configuring the initiative workflow" on page 142

• "Granting access to a cost structure" on page 142

• "Creating a reason for a write-off or a write-up" on page 143

• "Specifying default project plan editors" on page 144

7.  Click Save.
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Cost Structures view, General section options

Option Description

Cost structure name field Name for the cost structure.

Base currency list Default currency for the cost structure, which is used for 

triangulation and aggregate reports.

Cost center list Default cost center for the cost structure.

Remit-to address list Default remit-to address, which appears on all cross 

charges for initiatives under the cost structure.

Payment terms list Payment terms for cross charges of initiatives under the 

cost structure. The payment terms are printed on all 

cross charges associated with the cost structure.

Available for selection when 
creating/editing an initiative 
or a candidate check box

When selected, the cost structure is available for 

selection when creating or editing initiatives and 

candidates.

Configuring logos for  cross charges

For each cost structure, you can configure a logo to appear on the cross charges for the cost 
structure.

Note: If you later change the logo settings, the change will be applied only to new cross 
charges and cross charges in draft status.

1. The image file for the logo must be placed on the Changepoint web server. For more 
information, see the Changepoint Installation Guide.

2.  Access the cost structure.

3.  Expand the Settings section.

4.  In the Logo path field (in the Cross charge logo subsection), enter the path and filename 
for the logo, but exclude the default folder. For example, if the image file is located at: 
C:/Changepoint/Images/crosschargelogo.jpg, enter: /Images/crosschargelogo.jpg.

5.  Select the horizontal alignment option for the logo.

6.  Select the vertical alignment of the logo in the cross charge.
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7.  Click Save.

Configuring cost structure settings

You can configure settings to control certain actions that resources can perform on initiatives 
associated with the selected cost structure or on cross charges related to these initiatives.

1. Access the cost structure.

2.  Expand the Settings section.

3.  Select the options for the cost structure. For more information, see "Cost Structures view, 
Settings section options" on page 132.

4.  Click Save.

Setting default time entry restriction settings for all projects in a cost structure

1. Ensure that time entry restrictions have been enabled (Time and Expenses > Time 
Control).

2.  Access the cost structure for editing.

3.  Click the Settings tab, and go to the Time entry restrictions section.

4.  To prevent resources from entering time entries that are not within the planned dates for 
the project, task, and/or task assignment, in the Restrict time entries to within the 
planned dates for option, select the applicable entity check boxes.

5.  To prevent resources from entering time entries when the planned effort for the project, 
task, and/or task assignment is exceeded, in the Restrict time entries to within the 
planned effort for option, select the applicable entity check boxes.

6.  Click Save.
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Cost Structures view, Settings section options

Financial settings

Option Description

check box

Allow revenue to be recognized 
for this cost structure check box

When selected, revenue recognition is enabled for 

initiatives.

Allow revenue recognition to 
calculate negative amounts for 
PPC-based items check box

When selected,  negative revenue amounts are 

allowed for the Physical Percent Complete 

revenue recognition methods. Negative revenue 

amounts typically occur when the percent complete 

drops, due to either inaccurate project plans or an 

increase in scope that requires an increase in 

planned effort.

Prevent resources from 
desubmitting time entered for 
initiatives under this cost 
structure  check box

When selected, resources cannot desubmit time 

entered for initiatives and the Lock desubmitted 
time check box is not displayed on initiatives.

Prevent resources from 
transferring expenses between 
initiatives under this cost 
structure  check box

When selected, resources cannot transfer or 

reassign expenses from one initiative to another 

and the Lock time and expense transfer check 

box is not displayed on initiatives.

Prevent resources from 
transferring time between 
projects check box

When selected, resources cannot transfer time 

between projects of initiatives and the Lock time 
and expense transfer check box is not displayed 

on initiatives.

Prevent resources from 
transferring time between tasks 
on the same project check box

When selected, resources cannot transfer time 

from one task to another within the same project.

Prevent time adjustments when 
time has been invoiced for 
contracts under this billing office 

check box.

When selected, resources cannot adjust time 

entries for time records that have been invoiced. 

Time adjustments that have been submitted but not 

approved are automatically rejected when the 

original time records are invoiced.
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Resource management

Option Description

Allow soft-bookings check box When selected, soft-bookings are enabled for 

resources for initiatives under this cost structure. 

Enable resource requests and 
restrictions for all initiatives under 
this cost structure  check box

When selected, resource requests are enabled for 

all initiatives under this cost structure. Project 

managers cannot assign resources directly to 

tasks, but must submit a resource request that will 

be reviewed by a resource manager.

Allow the task assignment 
restrictions to be overridden at 
initiative-level check box

When selected, the resource manager of the 

initiative's staffing workgroup can override task 

restrictions and allow users to assign tasks to 

resources other than the initiative’s projected 

resources.

Initiative settings

Option Description

Allow resources to create 
chargeable initiatives  under this 
cost structure  check box

When selected, resources can create chargeable 

initiatives.

Prevent resources from entering 
discounted or negotiated rates for 
initiatives created under this cost 
structure  check box

When selected, resources cannot enter discounted 

or negotiated rates for initiatives and must use 

standard rates.
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Option Description

Display the [Force fixed fee 
selection] option on initiatives 
created under this cost structure  

check box

When selected, the Force fixed fee selection 

check box is available on initiatives and selected by 

default when creating fixed-fee initiatives. This 

ensures that resources specify a fixed fee when 

creating tasks for projects of fixed-fee initiatives, 

and when creating a fixed fee request processing 

rule for the initiative.

If your organization plans to use the Effort 
expended method for revenue recognition, the 

Force fixed fee selection check box must be 

selected so that chargeable time on tasks can be 

linked to fixed-fee deliverables.

Allow initiatives created under 
this cost structure to be enabled 
for audit  check box

When selected, resources can enable auditing for 

initiatives.

Cross charge settings

Option Description

Cross charge format list Format used for cross charges.

Draft cross charge message field Standard message to appear on all draft cross 

charges. For example, “Draft only”.

Enable cross charge approval 
check box

When selected, approval levels can be configured 

for cross charges. 

Enable two-level approval check 

box

When selected, a second-level approver can be 

specified.

Enable two-level approval on 
contract overage check box

When selected, the second-level approval is 

restricted to cross charges that exceed the 

approved amount set for the initiative.
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Option Description

Enable two-level approval for 
write-offs/ups check box

When selected, the second-level approval is 

restricted to cross charges that include write-offs 

on chargeable time.

Prevent override of two-level 
cross charge approval at initiative 
level  check box

When selected,  resources are prevented from 

changing the second-level cross charge approval 

setting on initiatives.

Second-level approver list Resource selected as the second-level approver.

Prevent resources from entering 
tax adjustments on cross charges 

check box

When selected, the option to prevent tax changes 

on cross charges is displayed on initiatives. The 

creator of the initiative can select this option to 

prevent resources from adjusting tax amounts on 

cross charges.

Prevent resources from writing up 
amounts on cross charges check 

box

When selected, resources cannot create write-ups 

for time, expenses, or non-labor items on cross 

charges.

Prevent resources from entering 
total adjustments on cross 
charges  check box

When selected, resources cannot adjust cross 

charges.

Prevent resources from changing 
cross charge dates  check box

When selected, resources cannot edit cross 

charge dates after those cross charges have been 

saved.

Prevent resources from 
distributing cross charges to GL 
accounts check box

When selected, resources cannot distribute cross 

charge amounts to GL accounts.

Prevent resources from adding 
additional items to cross charges  

check box

When selected, resources cannot include 

additional items on cross charges.
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Option Description

Allow resources to select different 
cross charge formats from the 
cross charge profile check box

When selected, resources can select different 

cross charge formats on the cross charge profile.

Prevent resources from changing 
the payment due dates check box

When selected, resources cannot edit payment 

due dates in cross charges of initiatives.

Allow resources to override the 
cross charge posting date on 
cross charges that are not in draft 
status check box

When selected, resources can change the posting 

date on cross charges associated with this cost 

structure, provided that these cross charges are 

not in draft status.

Allow resources to change item 
description on cross charges 

check box

When selected, resources can edit the description 

for time, expenses, requests and non-labor items 

oncross charges associated with this cost 

structure.

Automatically select the 
associated time records when 
invoicing fixed fees manually 

check box

When selected, when a fixed fee is selected for 

cross charging manually, the time records that are 

associated with the fixed fee are automatically 

selected. This option does not apply to batch cross 

charging.

Project settings

Option Description

Force the entry of the project 
value on the Project dialog box 
once a project is completed check 

box

The project value is an optional search criteria for 

resources. When selected, resources must specify 

a project value (greater than zero) in order to mark 

a project as completed.

Allow resources to create material 
records using applications that 
are not in initiatives check box

When selected, resources can create materials 

using applications or non-labor items that are not 

specified on the initiative.
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Time entry restrictions

Option Description

Restrict time entries to within the 
planned dates for [project, task, 
task assignment] check boxes

Prevents resources from entering time for dates 

that are outside of the planned start and planned 

finish dates of the selected options. 

The selected options become the default settings 

for the projects created under the initiatives for the 

cost structure.

Restrict time entries to within the 
planned effort for [project, task, 
task assignment] check boxes

Prevents resources from entering time when the 

total time entered for the selected options exceeds 

the planned effort. 

The selected options become the default settings 

for the projects created under the initiatives for the 

cost structure.

About cross charge approval settings

You can set up an approval workflow for cross charges of initiatives associated with a specific 
cost structure.

You can have Initiative managers approve the cross charge related to their initiatives. 

You can also add a second-level approver and configure restrictions for this approval.

Resources selected as second-level approvers must have access rights to the cost structure. For 
more information, see "Granting access to a cost structure" on page 142.

Configuring cross charge approval settings

1. Access the cost structure.

2.  Expand the Settings section.

3.  To enable approval for all cross charges, in the Cross charge settings section, select the 
Enable cross charge approval check box.

4.  To configure two-level approvals:

a. Select the Enable two-level approval check box.

b. In the Second-level approver field, select an approver.
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5.  To restrict the second-level approval to cross charges that exceed the approved amount set 
for the initiative:

a. Select the Enable two-level approval if approved amount is exceeded check box.

b. In the Second-level approver field, select an approver.

6.  To restrict the second-level approval to cross charges that include write-offs on chargeable 
time:

a. Select the Enable two-level approval on write-offs check box.

b. In the Second-level approver field, select an approver.

7.  To prevent resources from changing the second-level cross charge approval setting on 
initiatives, select the Prevent override of two-level cross charge approval at initiative 
level check box.

8.  Click Save.

Creating a staffing level

The function selected for a staffing level becomes the default function for projected resources 
in initiatives in Changepoint.

1. Access the cost structure.

2.  Expand the Staffing Levels section.

3.  Right-click in the table, and then select Insert.

4.  In the Staffing level cell, enter a name for the staffing level.

5.  In the Function cell, select the function to be associated with the staffing level.

6.  Click Save.

Configuring cross charge numbering

You define the numbering scheme for the cross charge number that replaces the temporary 
draft cross charge number when an cross charge is committed.

1. Access the cost structure.

2.  Expand the Cross charge numbering section.

3.  Select one of the following options:
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• To create a numbering scheme, select the Use numbering scheme option and define 
the numbering scheme. For more information, see "Cost Structure Details, Cross 
charge numbering options" on page 139.

• To use a stored procedure created for cross charge numbering, select the Use custom 
stored procedure option and select the appropriate custom stored procedure in the 
Auto-numbering stored procedure list. For more information, see "Requirements for 
auto-numbering stored procedures" on page 295.

4.  Click Save.

Cost Structure Details, Cross charge numbering options

You can choose to leave one or more of the part A, part B, or part C fields blank. For an 
example of cross charge numbering, see the "Cross charge numbering example" section on 
page 140.

Field Description

Starting value field Initial value for part A, B or C of the number. Starting values 

are limited to five characters. Only numeric values can be 

incremented. The maximum value is determined by the 

number of digits.

For example, if you enter “000,” the maximum value is “999.” 

When the maximum value has been reached, the value is 

reset to the starting value.

Separator text fields and 

options

Character or space that separates the parts of the number.

• No separator

• Use space

• Character
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Field Description

Increment options Increments the starting value. Options are:

• Never – The value remains constant.

• Every time – The value increases by one each time a 

cross charge is committed.

• Annually – The value increases by one on the date 

selected.

• On part B rollover – When the value in part B reaches its 

maximum value, part B is reset to its starting value, and 

part A increases by one.

• On part C rollover – When the value in part C reaches its 

maximum value, part C is reset to its starting value, and 

part B increases by one.

Reset numbering on 
rollover of previous part 
check box 

When selected, causes the part to be reset when the previous 

part reaches its maximum value. 

Note: If either On part B rollover or On part C rollover 
options is selected, the Reset numbering on rollover of 
previous part setting is ignored.

Next rollover date field Date on which the part number is set to change annually. This 

is usually the first day of the new fiscal year.

Draft cross charge 
number string field

Alphanumeric text that is the prefix for the draft cross charge 

number printed on all draft cross charges.

Allow cross charge 
number override list

If Yes is selected, cross charge numbers can be overwritten 

manually for the cost structure.

Cross charge numbering example

The following settings generate cross charge numbers that always begin with CAN and the 
current year, and end with a number based on the sequence in which cross charges are 
committed. A hyphen is used to separate the number parts.

For example: CAN-2014-00001, CAN-2014-00002, CAN-2014-00003, and so on.
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Example 2: Resetting numbering on rollover of previous part

If part A is “CAN”, part B has the starting value “2014” and increments annually, part C is set 
at 00000 and the next rollover date is set to 1/1/2015, then on January 1, 2015 the record 
number resets to CAN-2015-00000.

About initiative workflows

Initiatives go through a process workflow that is defined for each cost structure.

You can do the following:

• Specify the status options to be used in the workflow

• Change the sequence of status options in the workflow

• Specify at what stage in the workflow cross charges can be generated for chargeable 
initiatives

• Specify the roles that are allowed to change the status of an initiative in the workflow.

Changepoint Administration | 141



5. Financial Setup

Note: If you select more than one role, only one of the roles is required to commit cross 
charges and credit notes.

Configuring the initiative workflow

1. Access the cost structure. 

2.  Expand the Workflow section.

3.  In the Roles allowed to commit cross charges and credit notes section, select one or 
more roles that a resource must be assigned in order to commit cross charges and credit 
notes.

4.  The workflow statuses are listed in order in the Initiative workflow status and sequence 
table. To change the workflow sequence, select the status row and then click the up or 
down arrow.

5.  To allow the cross charges to be created  for chargeable initiatives that are in the selected 
status, select the Chargeable check box.

6.  To exclude a status from the initiative workflow, select the Not used check box.

7.  Select one or more required roles that resources must have to assign the selected status to 
an initiative. If no role is selected, all resources can assign the status.

8.  Click Save.

Granting access to a cost structure

You must grant resources specific access to cost structures either directly or through roles. 
Resources must have access to a cost structure to access the initiatives, clients, and cross 
charges that are associated to the cost structure, generate cross charges in batches, and view 
data from the cost structure in reports.

1. Access the cost structure.

2.  Expand the Cost structure access section.

3.  To grant access to roles, select the roles in the Roles required to access the cost 
structure, generate cross charge in batches, and view data in reports list.

4.  To grant access to resources,  in the Resources allowed to access this cost structure, 
including batch cross charge processing, data entry, reporting and visibility list:

a. To search for an item, enter the search text and then click Search.
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b. To display the tree view, clear the Show selected items only check box, ensure that 
the search field is empty, and then click Search. 

c. Select one or more items.

d. To display the selected items only, select the Show selected items only check box, 
ensure that the search field is empty, and then click Search. 

5.  Click Save.

About creating reasons for write-offs and write-ups

You can define reasons for writing off or writing up amounts on cross charges for initiatives 
associated with the cost structure.

You can also specify if the reason affects the calculation of resource utilization in Changepoint 
(such as in portlet or  reports). For example, if a resource has entered 40 chargeable hours and 
8 hours are written off using a reason that affects utilization, then the number of utilized hours 
for the resource is 32.

Creating a reason for a write-off or a write-up

1. Access the cost structure.

2.  Expand the Write-Offs/Ups section.

3.  Right-click in the table, and then select Insert.

4.  Enter the reason.

5.  To adjust the resource utilization amount for the write-off or write-up, select the Affects 
utilization check box.

6.  Click Save.

Modifying a reason for a write-off or write-up

1. Access the cost structure.

2.  Expand the Write-Offs/Ups section.

3.  To edit the reason:

a. Make the necessary changes.

b. Click Save.

4.  To delete the reason:
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a. In the table, right-click the reason, and then click Delete.

b. Click OK to confirm.

c. Click Save.

Specifying default project plan editors

You can specify individual resources or all resources in a workgroup as default project plan 
editors for projects that are created under the cost structure. 

1. Access the cost structure. 

2.  Expand the Project plan editors section.

3.  To select a resource:

a. To search for an item, enter the search text and then click Search.

b. To display the tree view, clear the Show selected items only check box, ensure that 
the search field is empty, and then click Search. 

c. Select one or more items.

d. To display the selected items only, select the Show selected items only check box, 
ensure that the search field is empty, and then click Search. 

4.  Click Save.

Modifying a cost structure

Revenue recognition is not automatically enabled for existing initiatives under a cost structure 
and must be enabled in the Initiative dialog box.

1. Access the cost structure.

2.  To edit the cost structure:

a. Make the necessary changes.

b. Click Save.

3.  To delete the cost structure:

a. Click Delete.

b. Click OK to confirm.
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Copying a cost structure

You can create a new (target) cost structure by copying all the information from an existing  
(source) cost structure. Once the target cost structure is saved, you can make the necessary 
edits.

1. Access the source cost structure.

2.  Click Copy cost structure.

3.  Enter the name of the target cost structure.

4.  Make the necessary changes.

5.  Click Save.

About cross charge rates for cost structures

You create cross charge rates for a cost structure to be used in initiatives and candidates 
associated with the cost structure, and for tasks assignments of projects associated with the 
initiatives. These rates can be overridden on the initiatives.

You must first create the required staffing levels, and then configure the cross charge rates for 
them.

You can set up cross charge rates in different currencies for a staffing level. You can also set 
up several cross charge rates in the same currency for a staffing level, but only one rate per 
currency can be active at the same time.

Creating a cross charge rate for a cost structure

You can create cross charge rates grouped by currency or by staffing level.

1.  Click Finance > Cost structure.

2.  Expand the cost structure, and then click Rates.

3.  In the Staffing level section, select either Use the staffing level cost rate or Use the 
resource cost rate. 

4.  To configure the rates by currency:

a. In the View by list, select Currency.

b. In the Currency list, select the currency for the staffing level.

The existing rates for the selected currency are displayed.
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5.  To configure the rates by staffing level:

a. In the View by list, select Staffing level.

b. In the Staffing level list, select the staffing level.

The existing rates in all currencies for the selected staffing level are displayed.

6.  Right-click in the table, and then select Insert.

7.  Complete the fields as required. For more information, see "Rates view, Staffing level 
section options" on page 147.

8.  Click Save.

About staffing level-based and resource-based cost rates

On initiatives,  cross charge rates and cost rates can be set up for pairs of staffing levels and 
resources, staffing levels only, and/or resources only. When the staffing level and resource on 
a task assignment match a staffing level and resource pair on the initiative, then the initiative 
cost rate specified for the pair is used for cross charging and reporting on the task assignment. 

The staffing level-based or resource-based option determines which cost rate to use when there 
is no matching pair on the initiative. 

If the staffing level-based option is enabled:

• the cost rate of the matching staffing level on the initiative is used

• if there no staffing level specified on the initiative nor on the task assignment, but there is 
a matching resource, then the cost rate for the resource on the initiative is used

• if neither the staffing level nor the resource matches, then the cost rate is 0 because there is 
no staffing level-based cost rate available.

If the resource-based option is enabled:

• the cost rate of the matching resource on the initiative is used

• if there is no matching resource on the initiative, then the resource's cost rate from user 
setup is used.
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Rates view, Staffing level section options

Option Description

Use the staffing level 
cost rateoption

Use the resource cost 
rate option

Specifies whether the cost rates for staffing levels or the cost 

rates for resources are used for cross charging and reports if 

there is no matching staffing level and resource pair on the 

initiative.

View by list Specifies whether the cross charge rates are listed by staffing 

level or currency.

Staffing level list Staffing level for the rates. Available only when Staffing level is 

selected in the View by list.

Currency list Currency for the rates. Available only when Currency is 

selected in the View by list.

Hourly cross charge 
rate column

Standard hourly rate at which your organization charges a client 

for a resource assigned the associated staffing level. The 

standard rate can be overridden with a negotiated rate on an 

initiative.

Hourly cost rate field Amount per hour it costs your organization to provide a 

resource.

Daily cross charge 
rate field

Standard daily rate at which your organization charges a client 

for a resource assigned the associated staffing level. 

Daily cost rate field Amount per day it costs your organization to provide a resource, 

if not specified elsewhere.

Effective date field Date that the cross charge rate is effective.

Active check box When selected, the cross charge rate is active and available for 

selection.

Comments field Comments.
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Option Description

Update initiatives list Statuses of initiatives that are updated when a cross charge rate 

is updated.

Update candidates list Option for selecting whether all unlocked candidates are 

updated when a cross charge rate is updated, or just the ones 

for which no decision has been selected. 

About editing cross charge rates for cost structures

Creating or editing a cross charge rate can affect data in initiatives and candidates. If you 
activate a new cross charge rate, which deactivates the previously active rate, an email 
notification is sent to the initiative managers and client managers. The following rules apply:

• You can edit and delete cross charge rates until they are copied into an initiative.

• The options for automatically updating cross charge rates must be selected in the initiative.

• Only unlocked records are updated. An exception report appears if there are locked records 
that are not updated.

• If the negotiated cross charge rate for a candidate is different from the standard rate, the 
standard rate is not updated.

• If a cross charge rate is changed to inactive, another rate is used that has the same 
currency, staffing level, cost structure and the closest effective date.

Editing a cross charge rate for a cost structure

1.  Click Finance > Cost structure.

2.  Expand the cost structure, and then click Rates.

3.  In the Staffing level section, select either Use the staffing level cost rate or Use the 
resource cost rate. 

4.  To configure the rates by currency:

a. In the View by list, select Currency.

b. In the Currency list, select the currency for the staffing level.

The existing rates for the selected currency are displayed.

5.  To configure the rates by staffing level:
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a. In the View by list, select Staffing level.

b. In the Staffing level list, select the staffing level.

The existing rates in all currencies for the selected staffing level are displayed.

6.  Make the necessary changes. For more information, see "Rates view, Staffing level section 
options" on page 147.

7.  Click Save.

Setting up daily rate conversions 

You can cross charge clients in days instead of hours by setting up time intervals in hours that 
correspond to fractions of a day. For example, to cross charge clients to the nearest quarter 
day, you can divide an eight hour day into four time periods of two hours each.

initiative managers and client managers are notified by email as soon as new rates are saved.

1.  Click Finance > Cost structure.

2.  Expand the cost structure, and then click Rates.

3.  In the Daily Rate Conversion Table section, right-click in the table and then click Insert.

4.  In the Rate from (hour) cell, enter the minimum number of hours for the time interval. 
The zero in the initial time interval cannot be changed.

5.  In the Rate to (hour) cell, enter the maximum number of hours for the time interval.

6.  In the Day cell, enter the fraction of a day in decimal format, that is to be cross charged for 
hours that fall within the time interval.

7.  Click Save.

Modifying daily rate conversions

You cannot delete time intervals that are used in initiatives.

1.  Click Finance > Cost structure.

2.  Expand the cost structure, and then click Rates.

3.  Expand the  Daily Rate Conversion Table section.

4.  To edit a daily rate conversion, make the necessary changes in the table.

5.  To delete the conversion rate:
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a. Right-click the row, and then select Delete.

b. Click OK to confirm.

6.  Click Save.

About cross charge setup

Creating a remit-to address

Remit-to addresses are available for selection when you create or edit cost structures, and 
when resources create or edit initiatives, and cross charges.

1. Click Finance > Remit-to Addresses.

2.  In the Folders view, select an existing address.

The remit-to address appears.

3.  Click New.

4.  In the Location name field, enter the name of the office or location.

5.  In the Address fields, enter the address.

6.  In the Description field, enter a description.

7.  Click Save.

Modifying a remit-to address

1. Click Finance > Remit-to Addresses.

2.  In the Folders view, select the address.

3.  To edit the address:

a. Make the necessary changes.

b. Click Save.

4.  To delete the address:

a. Click Delete.

b. Click OK to confirm.
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Creating a payment term statement for cross charges

You can set up the payment term statements that appear on cross charges, and the number of 
days for the due date calculation.

1.  Click Finance > Payment Terms.

2.  Right-click in the table, and then select Insert.

3.  In the Payment terms field, enter the payment terms. 

4.  In the Days to due date field, enter the number of days after the cross charge date that the 
payment is due.

5.  Click Save.

Modifying a payment term statement

1.  Click Finance > Payment Terms.

2.  To edit the payment term:

a. Make the necessary changes.

b. Click Save.

3.  To delete the payment term:

a. Click Delete.

b. Click OK to confirm.

Adding a custom cross charge format

1.  The cross charge format file must first be created and then saved to the Changepoint web 
server. For more information, see the Changepoint Installation Guide.

2.  Click Finance > Cross charge Formats.

3.  Right-click in the table, and then select Insert.

4.  In the Format field, enter the name of the cross charge format.

5.  In the ASP path field, enter the path, excluding the Changepoint root portion, but 
including the file name. For example:

/core/report/<file name.asp>

6.  Click Save.
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Modifying a custom cross charge format

You cannot delete a custom a cross charge format if it has been selected in the settings of a 
cost structure. You must first select a different format for the cost structure.

1.  Click Finance > Cross charge Formats.

2.  To edit the format:

a. Make the necessary changes.

b. Click Save.

3.  To delete the format:

a. Click Delete.

b. Click OK to confirm.

Setting up batch cross charging

1. Click Finance > Batch Cross Charging Setup.

2.  Select the statuses that resources can choose from when they generate cross charges in 
batches.

3.  Click Save.

Funding and scenario setup
You can set up demand analysis to show a total picture of demand, from an effort, cost or 
revenue perspective. The settings affect the outcome of the scenario comparison calculations 
and funding information in Changepoint.

1. Click Finance > Funding and Scenario Setup.

2.  Select the options as required. For more information, see "Funding and scenario setup 
view options" on page 153.

3.  Click Save.
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Funding and scenario setup view options

Option Description

Cost structure list Cost structure whose fiscal periods are used when 

precalculating and storing scenario comparison and funding 

information. Once amounts have been calculated for the 

default fiscal periods for scenario comparison purposes or for 

funding source allocation (source budget or distribution of 

entity amounts), the default fiscal periods can no longer be 

changed.

Data to use for revenue 
and cost information 

option

Data that is used when calculating revenue and cost 

information for scenario comparisons and funding 

information. Options are:

• Planned

• Forecast

• Budgeted

Note: The budget revision and the budget revision type that 

are used for the calculations are specified in the budget 

settings. For more information, see "About budget settings" on 

page 157.

Multiply candidate 
budget by probability 

check box

When selected, revenue for candidates is calculated based 

on the service budget revenue, multiplied by the probability 

set on the candidate.

Chart template list List of the scenario comparisons chart templates that can be 

deleted.

About revenue recognition
The revenue recognition process identifies and records revenue for completed work. The 
completed work may be for projects that are still in progress as well as for completed projects 
and initiatives.

To enable revenue recognition, you must complete the following steps.

1. Configure revenue type GL account codes for each type of revenue to be recognized.

2.  Configure cost centers for revenue recognition.
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3.  Configure revenue recognition.

4.  Create adjustment reason codes to be used when making adjustments to recognized 
revenue.

5.  Configure revenue recognition batch numbering.

6.  Enable revenue recognition for cost structures. 

You can set up departments to share revenue. Revenue transfers are initiated when resources 
work on projects with a default cost center other than their own. The default calculations for 
revenue transfers are set in the Revenue Recognition view, but can be overridden at the global 
workgroup or workgroup level.

Revenue recognition options are specified in initiatives in Changepoint. Each initiative can use 
a combination of revenue recognition methods.

Configuring revenue recognition

1. Click Finance > Revenue Recognition.

2.  Select the revenue recognition options. For more information, see "Revenue Recognition 
view options" on page 155.

3.  Click Save.
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Revenue Recognition view options

Option Description

Enable revenue transfer 
check box

When selected, enables revenue transfers between cost 

centers during the revenue recognition process.

Options are:

• Transfer labor multiplier – Revenue transfers are based 

on the specified percentage of resources’ cost rates. 

• Transfer revenue percentage – Revenue transfers are 

based on the specified percentage of the revenue. 

Allow override of GL 
accounts in initiative 

check box

When selected, resources can override the default GL 

accounts that are specified on initiatives for revenue 

recognition.

When cleared, all initiatives must use the default GL accounts. 

For more information, see "Configuring default GL accounts 

for revenue types" on page 157.

Time and expense 
cutoff option

Cutoff for recognizing revenue for time and expenses. 

Options are when the time and expense revenue exceeds the 

maximum recognizable revenue for time or expenses, or both. 

The cutoff is based on the maximum values set on the 

initiative.

Revenue cost center 
option

Cost center to be used for comparison for revenue 

recognition. Options are the cost center for the initiative 

manager or the cost structure. 

Exchange rate date for 
currency conversion 

option

Date to determine the exchange rate for currency 

conversions. Options are:

• Date of the tentative run
• End of week

Last currency exchange 
calculation performed 
on field 

Date of the last currency exchange calculation for revenue 

recognition.

Last tentative revenue 
recognition performed 
on field

Date of the last tentative revenue recognition process.
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About revenue transfers

You can set up revenue transfers between cost centers as part of the revenue recognition 
process. Revenue transfers are automatically initiated when the cost center for a resource’s 
workgroup is different from the cost center of the initiative on which the resource is working.

You can select one of the following revenue transfer options:

• Transfer labor multiplier – Revenue transfers are based on the specified percentage of 
resources’ cost rates (labor multiplier). For example, if the hourly cost rate for a resource 
is $75 and the percentage is 110%, the transfer amount is calculated as follows:

(75 * 1.1) * Number of recognizable hours

• Transfer revenue percentage – Revenue transfers are based on a percentage of the 
revenue, which is based either on the cross charge rate or the cost rate, depending on what 
is specified on the initiative. 

For example:

• The initiative uses cross charge rates for revenue recognition. If the hourly cross 
charge rate for a resource is $150 and the labor multiplier is 110%, the transfer amount 
is calculated as follows:

(150 * 1.1) * Number of recognizable hours

• The initiative uses cost rates for revenue recognition. If the hourly cost rate for a 
resource is $75, the initiative labor multiplier is 115%, and the transfer labor multiplier 
is 110%, the transfer amount is calculated as follows:

((75 * 1.15) * 1.1) * Number of recognizable hours

Note: If the Labor multiplier field on the Revenue tab of the Initiative dialog box is 
selected, all revenue for the initiative is calculated based on cost rates and therefore 
revenue transfers cannot be based on cross charge rates. Transfer amounts will be 
calculated as follows: Cost rate * Labor multiplier for the initiative

You can override the default revenue transfer settings for individual workgroups, if required. 
For more information, see "Overriding the default revenue transfer settings for a workgroup" 
on page 34.
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Configuring default GL accounts for revenue types

You can set up the default GL debit and credit account for each revenue type. The default GL 
accounts appear in the revenue recognition options of initiatives. If GL accounts cannot be 
overridden on initiatives, then default GL accounts must be set up.

1. Click Finance > Revenue Type GL Account Codes.

2.  In each revenue type row, select the default GL debit and credit accounts.

3.  Click Save.

Creating the list of adjustment reasons

You can create the list of reasons that resources can select from when adjusting recognized 
revenue in Changepoint.

1. Click Finance > Adjustment Reason Codes.

2.  Right-click in the table, and then select Insert.

3.  In the Adjustment reason column, enter the reason.

4.  Click Save.

Modifying the list of adjustment reasons

1. Click Finance > Adjustment Reason Codes.

2.  To edit a reason, make the necessary changes.

3.  To delete a reason:

a. Right-click the row, and then select Delete.

b. Click OK to confirm.

4.  Click Save.

About budget settings
Budget settings are used to configure the following:

• request types and fields for budget contingency amounts

• default budget item types
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• budget revision and budget revision type to be used when funding source calculations are 
budget-based

• default dates for budget exchange rates for budget items and actual amounts

• default setting for replacing past amounts with actual amounts

About budget item types

Budget item types are used to categorize budget items (fixed fees, non-labor items, services, 
and expenses) for reporting purposes. For example, you can categorize budget items as capital 
or non-capital costs, or as internal labor or contractor work.

You can exclude budget item types from budget totals, for example, to separate the cross 
charged amounts from the revenue recognition amounts. If a budget item type is excluded 
from budget totals, the budgeted cost, effort and revenue amounts of budget items of that type 
are displayed in Changepoint, but the amounts are excluded from the totals. 

Creating a budget item type

1. Click Finance > Budget Item Types.

2.  Right-click in the table, and then select Insert.

3.  In the Description field, enter a description for the budget item type.

4.  To exclude the amounts for budget items of this type from budget totals, select the 
Exclude from budget totals check box.

5.  Click Save.

Modifying a budget item type

When a budget item type is used in a budget, you cannot change the option to include or 
exclude it from budget totals. You cannot delete budget item types that are used in budgets or 
that are defined as default budget types.

1. Click Finance > Budget Item Types.

2.  To edit the budget item type, make the necessary changes.

3.  To delete a budget item type:

a. Right-click the row, and then select Delete.

b. Click OK to confirm.
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4.  Click Save.

Configuring default budget item types

You can specify default budget item types for budgets items. 

Note: Changing a default budget item type applies only to new budget items created after 
the changes are saved. 

1. Click Finance > Budget Settings.

2.  Expand the Default budget item types section.

3.  For each budget item:

a. Select the budget item type to be used as the default.

b. To allow resources to select a different budget item type, select the Allow override 
check box. 

4.  Click Save.

Configuring request types for budget contingency

You can specify the type of requests that resources can associate with budget items for budget 
contingency.

Note: Planning requests cannot be associated with budget items.

Changes to these settings apply only to budgets, budget revisions, and request selections that 
are created after the changes are saved.

1. Click Finance > Budget Settings.

2.  Expand the Contingency section. 

3.  In the Request type for budget contingency list, select the request type that is used to 
determine budget contingency.

4.  In the Request field for budget contingency list, select the request field that determines 
the amount of the budget contingency.

5.  Click Save.
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Specifying the budget revision for calculations

You can specify the revision type to be used for calculations and whether the amounts from 
the latest budget revision or latest frozen budget revision are used to calculate the following 
amounts:

• earned value

• funding source demand/actual amounts

• physical percent complete (only when the Physical percent complete - Cost revenue 
recognition method is selected)

Note: Changes to the revision type and revision option apply only to calculations 
performed after the changes are saved.

1. Click Finance > Budget Settings.

2.  Expand the Revision type for calculations section.

3.  In the Revision type list, select the revision type to be used for calculations.

4.  In the Revision to use section, do one of the following:

• To use the latest budget revision, select Latest revision.

• To use the latest frozen budget revision, select Latest frozen revision.

5.  Click Save.

Configuring the default date for budget exchange rates

You can specify default date options (current date, record date or specific date) for the budget 
exchange rates for budget item types and actual amounts. 

Note: Changes to these settings apply only to new budgets that are created after the 
changes are saved. 

1. Click Finance > Budget Settings.

2.  Expand the Default dates for budget exchange rates section.

3.  For each exchange rate, select the date option to be used as the default.

4.  Click Save.
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Configuring the default setting for replacing past amounts with actuals

Changes to these settings apply only to new budgets that are created after the changes are 
saved. 

1. Click Finance > Budget Settings.

2.  Expand the Default setting for replacing past amounts with actuals section.

3.  Select the option to be set as the default option for all budgets.

4.  Click Save.
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Changing the standard Changepoint terminology

Variables for the following standard terms are used throughout the Changepoint application 
interfaces and in system messages:

• Application

• Application category

• Client

• Cross Charge

• Global workgroup

• Initiative

• Resource

• Workgroup

You can change the values for the variables to the terms that are used by your organization. 
For example, you can change the term Resource to Employee, or the term Workgroup to 
Department. There are singular and plural versions of each term, and the first letter of each 
term is in uppercase.

Note: This procedure applies to English only. To change the terminology for the other 
supported languages, you must edit the PCIDs. For more information, see "About user 
interface strings and PCIDs" on page 196.

1. Click User Interface > Terminology.

2.  In the Category list, select SingularTitle.

3.  In the Field label field, enter the new term.

4.  Click Save.

5.  Repeat this procedure for the term in the PluralTitle category.

Changing the default address types for clients and contacts

You can change the field labels for the default address types (Main, Cross Charging, 
Shipping) for clients and contacts.
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Note: This procedure applies to the English field labels only. To change the labels in the 
other supported languages, see "About user interface strings and PCIDs" on page 196.

1. Click User Interface > Terminology.

2.  In the Category list, select Address.

3.  In the Field label field, enter the new label.

4.  Click Save.

About configurable fields
Configurable fields are user-defined fields that you can add to entity dialog boxes and profiles. 
There is a default set of code, text, and lookup fields for each entity type in Changepoint 

You can create additional configurable fields, over and above the default configurable fields, 
for the following entities:

• applications

• budgets and budget items (for more information, see "About configurable fields for 
budgets and budget items" on page 165.) 

• candidates

• clients

• initiatives (for more information, see "About configurable fields for initiatives" on page 
166)

• expenses and expense reports

• funding sources

• projects

• requests

• resources

• resource requests

• tasks 
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Warning: Regarding the task configurable fields, do not change the field type for task text 
1, 2, or 3 fields, and do not use entity records for the values for task code 1, 2, or 3 fields. 
These fields are used by the Microsoft Project integration.

You can create configurable fields that are code (drop-down list), text, numeric, date, or 
calculated fields.

By default, configurable fields display in the Configurable fields tab or section on the entity 
profile and dialog boxes, but you can set them up to display in any tab or section.

Code fields (drop-down lists)

Code fields are used to create drop-down lists. Before you enable a code field, you must define 
the values to be available in the drop-down list. You can add values manually, or base them on 
the values from other fields (entity-based).

Text fields

By default, text fields accept alphanumeric values. However, you can configure text fields to 
be date or numeric fields in metadata. 

Calculated fields

You can create calculated fields, whose values are based on formulas. You can set up a 
calculated field to display survey rating results.

Lookup fields

Lookup fields are the standard Changepoint drop-down lists. You can change the label of a 
lookup field and its values, but not its other properties. 

About configurable fields for budgets and budget items

If configurable fields are created for budgets, budget items, candidates, or projects, note the 
following information, and advise your users as required.

Parent entity triggers for conditional properties or values

For the budget entity only, you can create parent entity (budget level) triggers for conditional 
properties or values for budget item configurable fields. For example, you can create a 
condition for a budget services configurable field called "Reason for change" that makes the 
field mandatory when the budget revision type is "Change request."
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Validation of conditional values and properties on budget item 
configurable fields

In order to avoid negatively affecting performance, conditional values and properties for 
budget item configurable fields are not validated when the budget items are initially displayed 
in the budget dialog box. Only the rows that are subsequently selected or edited by a resource 
are validated. For example, if a budget item configurable field has a condition to hide it, the 
value will be displayed when the budget item tab is initially accessed. However, the value will 
disappear if a resource selects (clicks) or edits a budget item that meets the condition. 

Similarly, if a resource changes a budget level configurable field value, which causes a budget 
item field to become mandatory, be hidden, or display different values, only the rows that a 
resource selects or edits will be revalidated for the new condition.

When budget item fields fail validation based on conditional values and properties, resources 
can filter the view to display only the affected budget items in the budget tab by clicking the 

 icon.

Shared configurable field values are not copied into budgets

The values for configurable fields that are shared between budgets and other entities are not 
copied into a budget when the entity is copied into the budget. Resources must enter values for 
configurable fields manually under the following circumstances:

• When the budget is created from an candidate or project.

• When a budget service configurable field is shared with a task assignment configurable 
field, and the task assignment is copied to the budget. 

About configurable fields for initiatives

Configurable fields for initiatives are different from configurable fields for the other entities. 

The starting point for creating a configurable field for an initiative is from a cost structure. The 
configurable field then appears on all initiatives for the cost structure.

When you create a code or text configurable field for a cost structure, the numbering of the 
configurable fields starts at Code 1 or Text 1 and increments by one for each subsequent 
configurable field that is created. When you create a configurable field for a different cost 
structure, the numbering also starts at Code 1 or Text 1. 

Warning: The configurable fields that have the same number behave as separate fields in 
their respective cost structures, but the metadata settings are shared. Some of the metadata 
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settings, such as Field type, cannot be changed once a value has been saved for the 
configurable field. The other metadata settings can be changed from any cost structure, but 
the change will apply to all of the configurable fields with the same number.

To create a configurable field for initiatives

1. Click Finance > Cost Structures.

2.  Expand the cost structure.

3.  Select a configurable field.

4.  Click New code field or New text field. Complete the code or text configurable field as 
per the instructions for the configurable fields for the other entities.

About the default configurable fields

The following entities have only default configurable fields with limited options:

• activities

• contacts

• knowledge items

• portfolios

• portfolio items

• time (code fields only)

Each of these entities has only three configurable text fields and three configurable code fields, 
except for time, which has three configurable code fields only. When enabled, these fields 
display in the Configurable fields tab or section on the entity profile pages and dialog boxes. 
You cannot create additional configurable fields for these entities.

Enabling a default configurable field
Note: Create the drop-down list values for configurable code fields before you display the 
fields in the interface.

1. Click User Interface > Configurable Field Settings.

2.  In the Category list, select the entity for the configurable field, and then click Load List.

3.  Select the default text or code field. 
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4.  To specify the field label, do one of the following:

• In the Field label field, enter the field label.

• In the PCID field, enter the PCID. When you enter a PCID, its text string appears in 
the Field label field.

5.  To display the field on the interface, clear the Not used check box.

6.  To make the field a required field, select the Mandatory check box.

7.  To allow multiple values to be selected (code fields only), click the Multi-selection 
enabled check box.

8.  To set a default value, in the Default values field, enter the value. 

9.  Click Save.

Creating a configurable text field

1. Click User Interface > Configurable Field Settings.

2.  In the Category list, select the entity that you are creating the field for, and then click 
Load List.

3.  Select a configurable field.

4.  Click  New text field.

5.  Complete the fields as required. For more information, see "Configurable Field Settings 
view options" on page 169.

6.  To make the text field a calculated field, see "About creating calculated fields" on page 
184.

7.  Click Save.

Creating a configurable code field

1. Click User Interface > Configurable Field Settings.

2.  In the Category list, select the entity that you are creating the field for, and then click 
Load List.

3.  Select a configurable field.

4.  Click  New code field.
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5.  Complete the fields as required. For more information, see "Configurable Field Settings 
view options" on page 169.

6.  To use entity records for the drop-down values:

a. Select the Entity-based check box. The Entity-Based Settings section appears.

b. In the Entity type list, select the entity. A SQL statement that selects records for the 
entity appears.

c. To filter the entity records, in the Filter field, enter the SQL clause for the filter 
criteria. 

Note: It is preferable to use WHERE clauses rather than JOIN clauses in the SQL clause. 
WHERE clauses are removed when the values are displayed in the user interface, which 
permits the values to be displayed (for example, in profile pages) regardless of the filter 
conditions. JOIN clauses are not removed and therefore the filter conditions will apply to 
the values.

d. To apply conditional properties or values to the fields, click Conditional 
Properties/Values. The Conditional Properties/Values dialog box appears. For more 
information, see "Setting up conditions to control the values of a configurable field" on 
page 179.

e. To allow resources to view and select from all entity records, clear the Perform access 
checks on values check box.

7.  Click Save.

8.  To specify the drop-down values manually, see "Creating drop-down list values for 
configurable code fields" on page 178.

Configurable Field Settings view options

For information about the Access section, see "Restricting access to a configurable field" on 
page 175.
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Shared Fields section

Option Description

Use field properties 

check box

When selected, the current field is a shared field. The field 

label and other settings from the source field that is specified 

in the Field name list are copied to the current field.

Entity type list Available for shared fields only. The entity of the source field.

Field name list Available for shared fields only. Source field whose settings 

are used for the current field.

Field label field The name of the field that appears on the user interface.

PCID field PCID whose translated strings are used instead of the field 

label.

Settings section

Option Description

Not used check box When selected, the field is not displayed on the user interface, 

and cannot be used in calculated field formulas.

Mandatory check box When selected, the resource must enter a value for the field.

History tracking check 

box

When selected, changes to the field are tracked and can be 

viewed in the history view of the entity profile.

Show by default on 
expense report check 
box

Available for expense entity fields only. When selected, the 

expense configurable fields are displayed (not hidden) by 

default on expense reports.

Available for candidate 
analysis check box

Available for candidate entity fields only. When selected, the 

field is available for candidate analysis. 

Multi-selection enabled 

check box

Available for code fields only. When selected, resources can 

select more than one value for the field.
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Option Description

Entity-based check box Available for code fields only. When selected, the field values 

come from the specified entity.

Conditional 
properties/values check 

box

Available when the Entity-based check box is selected.  

When selected, indicates that conditional properties or values 

apply to the configurable field.

Referenced in 
conditional expressions 

check box

Read-only field that when selected, indicates the configurable 

field is used in a conditional expression of another 

configurable field.

Entity-Based Settings

Note: This section is displayed only when the Entity-based check box is selected.

Option Description

Entity type list The entity whose values are used for the field values.

Basic SQL statement 
field

SQL statement that selects the entity records that are used for 

the field values. 

Filter field SQL clause that filters the entity-based field values.

Perform access checks 
on values check box

By default, access checks  are performed so that the user can 

select from only the entity records that they have access to. 

To allow resources to select from all entity records, you can 

clear the check box.

Default value list The values that appear in the field by default, but can be 

changed by resources. To select more than one default value, 

you must first select the  Multi-selection enabled check box.

Note: For a default value to be saved, the field must be 

displayed in the user interface (that is, not hidden), and the 

resource must have access to the configurable field.
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Metadata Settings

Option Description

Minimum field For text fields, the minimum number of characters for the field.

For numeric and date fields, the minimum value for the field.

Maximum field For text fields, the maximum number of characters.

For numeric and date fields, the maximum value for the field.

Field type options Available for text fields only. Options are: 

• Text

• Numeric

• Date

Note: The field type cannot be changed after a value has 

been saved in the field in Changepoint.

Number of rows 
displayed in edit mode 

field

Available for text fields that have the Text field type. Number 

of rows of text that are displayed in the field. If the maximum 

number of characters for the field is greater than 255, then the 

number of rows must be greater than 1. The maximum 

number of rows is 20. In all cases, if there is more text than 

can be displayed in the rows, a scroll bar appears.

Field is hidden from the 
user check box

Available for text fields only. When selected, the field is not 

displayed on the user interface, but can be used in calculated 

field formulas.

Calculated Field Settings

Note: This section is displayed only when the Numeric field type is selected.
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Option Description

Calculated check box When selected, a value is calculated for this field based on 

settings that you specify.

Survey responses 
within the last [ ] days 

field

Available only when the Calculated check box is selected. 

The survey results from only the last specified number of days 

are included.

Formula field Formula for the calculated field.

Calculate every [ ] days 

option

When selected, the value is calculated at the interval 

specified.

Calculate only if the 
entity has been changed 

option

When selected, the value is calculated when the entity has 

been changed.

Calculate each time the 
entity is saved option

When selected, the value is calculated when the entity record 

is saved.

Request Settings

Option Description

Available for planning 
request screening check 

box

Available for request entity fields only. When selected, the 

field is included in planning request screening when the 

request type is selected. 

This field will be 
available for the 
following request types 

list

Available for request entity fields only. Request types that the 

field appears on. If no request types are specified, the field 

appears on all requests.

Creating a shared configurable field to be used for multiple entities

If you want to use the same configurable field on more than one entity, you first create the 
configurable field for one entity (source field). You then create a configurable field for each of 
the other entities (target fields), but for each target field you select the option to base the target 
field on the source field.
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The following settings from the source field are copied to the target field:

• Field label

• Use configurable field label

• Not used

• Field type (text, number or date)

• Multi-selection enabled

• Entity-based

• Entity type 

• Security access

Note: To change these settings, you must edit the source field.

1. Create and enable the source configurable field on one of the entities.

2.  For each of the remaining entities:

a. Create the target configurable field. 

b. Select the Use field properties (entity type and field name) check box.

c. In the Entity type list, select the entity type for the source configurable field.

d. If the entity is an initiative, in the Cost structure list, select the cost structure.

e. In the Field list, select the source field. 

f. Complete the remaining fields as required.

About restricting access to configurable fields

By default, all resources who have view access to an entity that contains a configurable field 
can view the field, and all resources who have edit access to the entity can view and edit the 
field. However, you can restrict view and/or edit access to a configurable field to specific 
resources, workgroups, or roles. 

If you restrict view access and do not restrict edit access, then the selected resources, 
workgroups or roles have view-only access to the configurable field. Other resources can still 
edit and view the configurable field.
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If you restrict edit access and do not restrict view access, then the selected resources, 
workgroups or roles can edit and view the configurable field. Other resources can only view 
the configurable field.

If you restrict both view access and edit access, then:

• resources, workgroups and roles selected for view access can view the configurable field

• resources, workgroups and roles selected for edit access can view and edit the configurable 
field

• the field is hidden from all other resources, workgroups and roles

For request-related configurable fields, you can also specify whether Client Portal users have 
view and edit access to the fields.

Restricting access to a configurable field

1. Click User Interface > Configurable Field Settings.

2.  In the Category list, select the entity type of the configurable field, and then click Load 
List.

3.  Select the configurable field.

4.  Expand the Access section.

5.  To restrict view (or edit) access, click the Restrict view (or edit) access to the selected 
workgroups, resources, and/or roles check box.

a. To search for an item, enter the search text and then click Search.

b. To display the tree view, clear the Show selected items only check box, ensure that 
the search field is empty, and then click Search. 

c. Select one or more items.

d. To display the selected items only, select the Show selected items only check box, 
ensure that the search field is empty, and then click Search. 

6.  To include all the workgroups below a selected workgroup in the hierarchy, click the 
Include children check box. 

7.  For request-related configurable fields, the following options are also available:
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• To enable Client Portal users to view the configurable field, select the Allow view 
access for Client Portal users check box.

• To enable Client Portal users to edit the configurable field, select the Allow select 
access for Client Portal users check box.

8.  Click Save.

To allow specific resources to edit a configurable field while all other resources can only 
view the field

1. Restrict edit access to the specific resources, workgroups and roles as required.

2.  Ensure that view access is not restricted.

To allow specific resources to edit a configurable field and prevent all other resources 
from viewing the field

You can restrict edit access to a configurable field so that only the selected resources, 
workgroups and roles can view and edit the field, and the field is hidden from all other 
resources.

1. Create a “dummy” role, which is a role without any features assigned to it.

2.  Restrict edit access to the specific resources, workgroups and roles as required.

3.  Restrict view access to the dummy role, which effectively prevents all other resources 
from viewing the field. 

Editing a configurable field

Configurable fields cannot be deleted, but you can hide them so that they no longer appear on 
the user interface.

Note: After data has been saved for a configurable field, some options cannot be changed, 
for example, the field type.

1. Click User Interface > Configurable Field Settings.

2.  In the Category list, select the entity of the configurable field, and then click Load List.

3.  Select the configurable field.

4.  Make the necessary changes.

5.  Click Save.
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About using entity records as values for drop-down lists

You can use entity name records as values for configurable code fields. For example, you can 
set up project names as the values for a configurable field. By default, all of the entity name 
records are included. However, you can filter the records by entering an SQL statement. In all 
cases, only the records that the resource has view or edit access to are displayed in the drop-
down list for the configurable code field.

The following guidelines for SQL statements apply:

• Column names must be fully qualified, that is, they must include the table names. For 
example: TableName.ColumnName (Resources.ResourceId).

• Only one complete SELECT statement is allowed in the filter. You cannot use a UNION 
followed by a new SELECT statement. 

Note: After a value for the configurable code field has been saved in Changepoint, you 
cannot change the entity type or filter for the field. 

You can also apply conditional logic to the values. For more information, see "Setting up 
conditions to control the values of a configurable field" on page 179.

About modifying values for standard drop-down (lookup) lists

You can create, modify, and delete the values for the standard Changepoint lookup lists. For 
more information, see "Creating drop-down list values for configurable code fields" on page 
178.

Creating project types

You can configure project types by creating values for the standard CPProjectType field that 
is in the Project lookups category.

To change the field label, click User Interface > Configurable Field Settings.

Creating project phases

If project workflow has been enabled, you must configure project phases. The Project phase 
field is in the Task lookups category. You configure project phases by creating them as drop-
down list values for the standard Project phase field.

The current project phase is determined for each project based on a numeric prefix in the 
project phase name. Therefore, you must add a prefix consisting of a number and a period 
before the phase name, for example:
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• 01. Design

• 02. Code

• 03. Test

Tip: Ensure that all numeric prefixes include the same number of digits as the highest 
phase number so that the project phases sort correctly. 

Creating drop-down list values for configurable code fields

You can manually create values for configurable code fields. The values can apply to the 
system level, global workgroup, or workgroup. 

If the configurable code field is for an entity that is included in performance metrics (client, 
candidate, non-labor items, project, requests and task fields), then you must specify a number 
for the numeric equivalent, which is used as part of the metric calculations of a project’s 
overall score or health assessment. The same number can be used for more than one code 
value.

1. Click User Interface > Configurable Field Values.

2.  In the Level type-ahead field, do one of the following:

• To make the values available to all resources, select System.

• To make the values available to resources in a global workgroup or workgroup, select 
the workgroup.

3.  In the Category list, select the entity that the code field belongs to.

4.  In the Code type list, select the code field. 

5.  Right-click in the table, and then select Insert.

6.  In the Value field, enter the value.

7.  In the Numeric equivalent field, enter the number that is to be used for metric 
calculations for the code value. 

8.  To set a value as the default value, select the Default check box.

9.  Click Save.

10.  You can set up conditional values and properties for additional configurable fields (not 
default configurable fields). For more information, see "Setting up conditions to control 
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the values of a configurable field" on page 179 and "Setting up conditions to control the 
properties of a configurable field" on page 180.

Modifying drop-down list values

You can modify or delete the values in the standard Changepoint lookup lists or for 
configurable code fields. When you delete a value, it is removed from the table, but the history 
of the value is retained.

Changes and additions to the values in drop-down lists can be applied at the system level, or to 
a specific global workgroup or workgroup.

1. Click User Interface > Configurable Field Values.

2.  In the Level type-ahead field,  select the level that the values apply to (system or the 
workgroup).

3.  In the Category list, select the entity type or lookup.

4.  In the Code field list, select the code field. 

5.  To edit the values:

a. Make the necessary changes.

b. Click Save.

6.  To delete a value:

a. Right-click the row and then select Delete.

b. Click OK to confirm. 

c. Click Save.

Setting up conditions to control the values of a configurable field

You can set up conditions to control the values of a configurable code field. For example, you 
can set up a condition that determines the values that are available for a configurable field 
based on the resource who is editing the field.

Warning: If your organization uses Microsoft Project Integration functionality, do not 
apply conditional values to TaskCode1, 2, or 3.

1. Do one of the following to access the configurable code field values:
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• If the drop-down list values were created manually, access the configurable field in 
User Interface > Configurable Field Values.

• If the drop-down values are entity-based, access the values in User Interface > 
Configurable Field Settings.

2.  Click Conditional Properties/Values. 

The Conditional Properties/Values dialog box appears.

3.  To create a formula, click Conditional formulas. For more information, see "Creating a 
conditional formula for a configurable field" on page 181.

4.  In the Conditional values section, right-click in the table, and then select Insert.

5.  In the Conditional formula list, select the formula.

6.  In the Selected values cell, select the values that are available when the condition in the 
formula is met. 

a. To search for an item, enter the search text and then click Search.

b. To display the tree view, clear the Show selected items only check box, ensure that 
the search field is empty, and then click Search. 

c. Select one or more items.

d. To display the selected items only, select the Show selected items only check box, 
ensure that the search field is empty, and then click Search. 

7.  To change the order of the formulas, select the formula and then click the up or down 
arrows.

8.  Click Save.

Setting up conditions to control the properties of a configurable field

You can set up conditions to control the properties of a configurable field (whether the 
configurable field is required, read-only, or hidden) based on the value of a trigger field. For 
example, you could set up a condition on a configurable text field called Description so that it 
becomes a required field when a value of High is selected for a configurable code field 
(trigger field) called Risk.

1. Do one of the following to access the configurable field:

• For a configurable text field, click User Interface > Configurable Field Settings.
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• For a configurable code field that uses entity records for its values, click User 
Interface > Configurable Field Settings.

• For a configurable code field that has values that were created manually, click User 
Interface > Configurable Field Values. 

2.  Click Conditional Properties/Values.

The Conditional Properties/Values dialog box appears.

3.  To create a new formula, click Conditional formulas. For more information, see "Creating 
a conditional formula for a configurable field" on page 181. 

4.  In the conditional properties table, right-click and then select Insert.

5.  In the Conditional formulas list, select the formula.

6.  Select the check boxes for the properties to be applied to the configurable field when the 
condition in the formula is met. 

7.  To change the order of the formulas, select the formula and then click the up or down 
arrows.

8.  Click Save.

Creating a conditional formula for a configurable field

You must first create one or more expressions, and then use the expressions to create a 
conditional formula. For some entities, there are resource-based variable fields that you can use 
to specify resources, for example:

• Editor – resource who is editing the entity

• Initiator – resource who initiated the request

• Project Manager

• Account Manager

When you use a resource-based field in an expression, you can filter resources based on 
resources, roles, or workgroups.

1. Access the configurable field.

2.  Click Conditional Properties/Values.

3.  Click Conditional formulas. 
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The Conditional Formulas dialog box appears.

To create an expression

1. In the Step 1 section of the dialog box, in the Expression field, enter the name of the 
expression.

2.  In the Field name list, select the trigger field to use in the expression. 

3.  If the trigger field is a resource-based variable, in the Filter type list, select Resource, 
Role or Workgroup.

4.  In the Condition list, select the condition for the selected field or filter type. 

5.  In the Value field, enter the value that will be tested against the condition. 

6.  To select an entity-based value:

a. To search for an item, enter the search text and then click Search.

b. To display the tree view, clear the Show selected items only check box, ensure that 
the search field is empty, and then click Search. 

c. Select one or more items.

d. To display the selected items only, select the Show selected items only check box, 
ensure that the search field is empty, and then click Search. 

7.  Click the Save button that is below the Value field. 

To create a conditional formula

1. In the Step 2 section of the dialog box, in the Formula name field, enter the name of the 
formula.

2.  To add an expression to the formula, double-click the expression in the expressions table.

3.  To insert an operator, spaces, or brackets, click the corresponding buttons.

4.  To use an existing conditional formula, select one in the Existing formulas list. 

5.  To view the entire formula, click the Display expanded formula check box.

6.  To test the formula, click the Test Formula button.

7.  Click Save.

8.  To create another formula, click New formula.
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Modifying the conditions for a configurable field

1. Do one of the following to access the configurable field:

• For a configurable text field, click User Interface > Configurable Field Settings.

• For a configurable code field that uses entity records for its values, click User 
Interface > Configurable Field Settings.

• For a configurable code field that has values that were created manually, click User 
Interface > Configurable Field Values. 

2.  Click Conditional Properties/Values. 

The Conditional Properties/Values dialog box appears.

3.  Make the necessary changes. 

4.  To change the order in which the conditional formulas are applied, select the formula, and 
then click the up or down arrow.

5.  To clear all settings and start over

a. Click Remove all. 

b. Click OK to confirm

6.  Click Save.

To edit a conditional formula

1. Click Conditional formulas.

The Create Conditional Formula dialog box appears.

2.  To edit an expression:

a. In the expressions table, select the expression.

b. In the Step 1 section, make the necessary changes.

c. Click the Save button that is below the Value field.

3.  To edit the formula:

a. In the Existing formulas list, select the formula.

b. To expand the formula, select the Display expanded conditional formula check box.
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c. Make the necessary changes.

4.  Click Save.

About creating calculated fields

A calculated field is a configurable text field whose field type you change to numeric, and to 
which you add a formula to display data or survey results. Calculated fields appear as read-
only fields in Changepoint.

Warning: If you create a formula in a calculated field that results in a divide by zero 
error, the error does not appear on the user interface, but is listed in the SQL server log 
and the value (if any) is deleted.

About calculated fields in Resource Planner

If you plan to use (Resource Planner), do not use the option that calculates the value when the 
entity is saved for calculated fields based on effort. The values for calculated fields are not 
calculated when demand is edited manually or reassigned in Resource Planner.

About displaying survey results in a calculated field

You can set up a calculated field to display survey results. To be available for selection for a 
calculated field, the survey must be active, include ratings, and be associated with the same 
entity as the calculated field. You associate a survey with an entity by specifying the entity in 
a prompt tag when you send the survey.

You can include only the most recent survey responses by specifying the number of days 
before the current date that survey responses are to be included. However, if there are no 
survey results during this period, then the field value will be zero (0). In case this happens, 
consider creating another field for which no limit is set so that you can compare the results of 
the two fields.

When you select a survey for a calculated field, the survey name appears beside the field in 
Changepoint.

Creating a calculated field

1. Create a configurable text field.

2.  For the Field type option, select Numeric.

3.  Select the Calculated check box.
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4.  To include only recent survey responses, in the Survey responses within the last [ ] days 
field, enter the number of days.

5.  In the Formula field, enter the formula. To add a field, stored procedure, or survey, right-
click in the Formula field, and then select the item.

For more information, see "Rules for formulas for calculated fields" on page 185.

6.  Select an option to specify when the field value is to be calculated:

• Calculate every x days, and then enter the number of days

• Calculate only if the entity has been changed

Note: For the previous two options, the calculations are performed by a scheduled job. 
Therefore the values are not immediately available.

• Calculate each time the entity is saved – Calculates the field value each time the 
entity record is saved.

Note: Use this option only when the data that is being calculated is based on the data fields 
from the same entity. Keep in mind that frequent and/or complex calculations can 
adversely affect system performance.

7.  Click Save.

Rules for formulas for calculated fields

The rules for creating formulas for calculated fields are:

• You can use the following items in the formula:

• numeric fields associated with the selected entity type

• code fields that have numeric equivalents defined

• other calculated fields

• surveys

• stored procedures

• Ensure that there is only one numeric result after the formula is executed.

Note: “Candidates” are called “Opportunities” in all formulas.
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• All operands in the formula must be from the same entity. The exception is for candidate, 
for which you can also use operands from OpportunityDetails or OpportunityServices 
child entities, configurable code or text fields, or a survey.

• No aggregation functions are allowed against parent entities. However, you must aggregate 
child entities such as OpportunityDetails or OpportunityServices.

• Pure numbers or calculation expressions must combine both numbers and operands from 
the menu.

• No current configurable text fields are allowed in the formula.

• If the formula includes other calculated fields, ensure that the field name for the calculated 
field comes after the field names in the formula. Calculated fields are processed in order, 
based on a string comparison of the field names.  For example, these calculated fields 
would be calculated in the following order: RequestText1,RequestText123, 
RequestText35, RequestText4.

Note: Do not use the WorkingDays field in calculations for fields in the projects or tasks 
entities. The WorkingDays field is no longer used in rollup calculations and therefore will 
not provide accurate results.

All entity fields example

RequestText11+(RequestCode6+RequestText3)/2

You can create simple math formulas by selecting a field and then adding operators.

Candidate fields, example 1

SUM(OPPORTUNITYDETAILS.AdjustedPrice*OPPORTUNITYDETAILS.Qty)

Candidate fields, example 2

SUM(OPPORTUNITYSERVICES.NegotiatedCostRate*Opportunityservices.Qty) *

TITLEDEFINITION.OpportunityCode1

If you use fields from OpportunityDetails or OpportunityServices, then you must also use an 
aggregation function. However, you cannot use both tables in the same formula. Instead, you 
do the following:

1. Create a calculated field for OpportunityDetails.

2.  Create a calculated field for OpportunityServices.

3.  Create a third calculated field that uses both calculated fields.
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Using a SQL statement in a calculated field formula

While it is possible to use a SQL statement in a formula for a calculated field, note the 
following warning.

Warning: SQL statements in formulas for calculated fields are not supported within the 
terms of your Changepoint support agreement. If you require assistance, contact your 
Changepoint Canada ULC account manager to arrange for chargeable consulting services.

About using a stored procedure in a calculated field formula

The following rules apply to stored procedures for calculated fields: 

• The stored procedure name must begin with CPCALC_.

• The stored procedure must have at least two parameters: 

• input: entityid

• output

• Only one output parameter of a numeric datatype (int, decimal) is allowed.

• The entityid must be the first parameter. The entity IDs are: Budget – use RevisionId (see 
below), CustomerId, EngagementId, OpportunityId, ProductId, ProjectId, RequestId, 
ResourceId, ResourceRequestId, TaskId.

Note: For budgets, configurable fields are specific to a budget revision, and therefore you 
must use RevisionId instead of the entityid.

• The output parameter must be the last parameter.

The following rules apply to creating the formula:

• Only the custom stored procedures that comply with the rules are available in the formula 
menu for selection.

• There is no restriction on the number of custom stored procedures in a formula. 

• Stored procedures in a formula must be enclosed in parentheses ().

• All parameters except for entityid and output must be replaced with actual data before 
saving the formula.
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Stored procedure example

The following is a simple stored procedure to calculate the number of requests associated with 
a project:

CREATE PROCEDURE [dbo].[CPCALC_project1]

@PROJECTID UNIQUEIDENTIFIER,

@PARA_VAR INTEGER output

AS

select @PARA_VAR =count(1) FROM RequestEntity Where EntityId=@PROJECTID

GO

GRANT EXECUTE ON [CPCALC_project1] TO [CPACCESS]

GO

Configurable field layout
By default, configurable fields are displayed on the Configurable fields tab of the edit dialog 
box of the relevant entity. Configurable fields and the default Configurable fields tab appear 
on the entity profile only after a value has been saved for the configurable field.

However, you can control the layout of configurable fields as follows:

• change the order of fields in the Configurable fields tab or section

• create groups for configurable fields, and add the groups to any of the default tabs or 
sections for the relevant entity

• change the order and layout of fields in a group

• change the order of the groups (although all groups appear at the top of the tab or section)

There are separate formats for the edit dialog box or view and profile. Therefore, if you want a 
group to appear in both, you have to create the group in both formats.

Note: Only the configurable fields that are configured to be displayed in the user interface 
are available to be added to a group.

Creating a configurable field group

You can create configurable field groups for arranging the configurable fields for an entity.

Note: You can create configurable field groups on the main Budget entity only and not the 
budget sub-items (Budget expenses, fixed fees, non-labor items, and services).

1. Click User Interface > Configurable Field Layout.

2.  Expand the entity, and then do one of the following:
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• To add the group to the entity profile, expand Profile.

• To add the group to the edit dialog box or view, expand Edit screen.

3.  Expand the section that you want to add the group to, and then select any configurable 
field group.

4.  Click New.

5.  To specify the group name, do one of the following:

• Enter the name of the group in the Group name field.

• To use a PCID for the group name, enter the PCID in the PCID field. 

6.  Expand the Layout section.

7.  In the Layout style option, select either Single column or Two columns.

8.  To add configurable fields to the group, drag the fields from the Display in the 
configurable field section list to the Display in this group list.

9.  To change the order that the fields are displayed in the group, drag the fields to the desired 
positions in the Display in this group list.

10.  To add a header to the group, see "Adding a header to a configurable field group" on page 
189.

11.  Click Save.

About headers for configurable field groups

You can add a header to a configurable field group. The header can include text, for example, 
to explain the configurable fields in the group. You can also insert a link to a website or to 
files on a network drive. The supported protocols are http://, https://, ftp://, and file://. 

Note: Only Internet Explorer supports links to network folders.

In Changepoint, an icon appears, which resources click to expand or collapse the header. 

When a resource clicks a link in the header, the link opens in a new window.

Adding a header to a configurable field group

1. Click User Interface > Configurable Field Layout.

2.  Expand the entity to locate and then select the configurable field group.
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3.  Expand the Group header section. 

4.  In the Group header field, enter the text for the header. 

5.  To insert a link in the header text:

a. In the Group header field, place the cursor in the text where you want to insert the 
link.

b. Click Add Link button. The text “ÿLINKÿ” is inserted.

c. Replace ÿLINKÿ with:

 ÿlink text=URLÿ

For example:

  ÿChangepoint website=http://www.changepoint.comÿ

6.  In the Number of lines to display field, enter the number of lines to allow for the header 
text on the user interface. The maximum number is 20, but if the header text exceeds the 
number of lines, a scroll bar appears.

7.  To display the header as expanded by default, select the Show when the section is loaded 
check box. 

8.  Click Save.

Rearranging the configurable field groups in a tab or section

1. Click User Interface > Configurable Field Layout.

2.  Expand the entity and then select Edit screen or Profile.

3.  To move a group, drag the group to the desired position within a section, or to a different 
section.

4.  Click Save. 

Rearranging the configurable fields in the Configurable Fields tab or section

You can change the order of the configurable fields in the default Configurable Fields tab or 
section of an edit dialog box or entity profile.

1. Click User Interface > Configurable Field Layout.

2.  Expand the entity, format type, section, and then select any configurable field group.
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3.  In the Display in the configurable fields section list, drag the fields  to the desired 
positions.

4.  Click Save.

About metadata settings for fields
You can configure metadata settings on fields, including:

• making fields required, editable, and/or hidden

• specifying the minimum and maximum number of characters or values for fields

• specifying how duplicate values are handled

Note: For system read-only fields, the only settings the only settings that can be changed 
are the page content ID, and the option to hide the field. Also, you cannot configure 
metadata settings for password fields. 

Note for IT Organizations

The Entity Type field does not display or convert to Information Technology Department 
(ITD) terminology. The following table lists the ITD terms and provides the corresponding 
entity type in the metadata.

ITD term Entity Type in Metadata

application Product

application category ProductCategory

candidate Opportunity

client Customer

cross charge Invoice

initiative Engagement

staffing request Requisition

For example, to configure metadata settings for an initiative field, you must locate the field in 
the Engagement entity type.
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Configuring metadata settings

1. Click User Interface > Metadata.

2.  In the Folders view, expand the entity and then select the field.

3.  Complete the fields as required. For more information, see "Modify Metadata Settings 
section options" on page 192.

4.  Click Save.

Modify Metadata Settings section options

Option Description

Entity type field The entity of the field.

Field name field The name of the field.

Field label field Text string for the PCID.

PCID field PCID containing the strings used in the metadata 

checking message.

Field is required and the user 
must enter data check box

When selected, the field is mandatory.

If the field is a check box, it is displayed as selected 

and noneditable.

Field is not editable check box When selected, the field is displayed, but is 

noneditable.

Field is not editable once the 
initial value has been saved 

check box

When selected, the field becomes noneditable after a 

value has been saved.

Locked after first check check 

box

Available for check boxes only. When selected, the 

check box becomes noneditable after it has been 

selected and saved.
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Option Description

Field is hidden from the user 
check box

When selected, the field is not displayed in 

Changepoint. 

Note: Do not hide a required field unless there is a 

default value for it.

If you hide a required check box, the check box 

becomes selected by default.

System maximum field Maximum number of characters that you can set for 

the field in the Maximum field. Zero (0) means a limit 

has not been set, or is not applicable.

Minimum field Depending on the field type, either the minimum 

number of characters that can be entered in the field, 

or the minimum value for the field.

Maximum field Depending on the field type, either the maximum 

number of characters that can be entered in the field, 

or the maximum value for the field. For configurable 

text fields, the maximum number of characters 

is 20,000.

Check for duplicates option Options include:

• Do not check for duplicates
• Warn if duplicates exist – if the current value is 

the same as an existing value, a warning 

message appears, but the record can be saved

• Warn if match on similar entry – if the current 

value has a few of the same characters or values 

as an existing value, a warning message appears, 

but the record can be saved

• Reject entry if duplicates exists – if the current 

value is the same as an existing value, a message 

appears, and the record cannot be saved. 
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Option Description

Duplicate check performed on 

field

Database table that is checked for duplicate values.

Number of rows displayed in 
edit mode field

Available for configurable text fields only. Number of 

rows of text that are displayed in the field. If the 

maximum number of characters for the field is greater 

than 255, then the number of rows must be greater 

than 1. The maximum number of rows is 20. In all 

cases, if there is more text than can be displayed in 

the rows, a scroll bar appears.

About hiding elements on the Changepoint user interface

You can hide standard and configurable fields, rows of fields, tabs/sections of entity dialog 
boxes, cards in entity profiles, and in some cases, entire dialog boxes by configuring them as 
hidden in Metadata. 

For information about hiding entity profile cards, see "Hiding entity profile cards" on page 
196.

The general guidelines for hiding fields and tabs are as follows:

• To hide a standard or configurable field, you must set the field as hidden. For more 
information, see "Hiding a field" on page 195.

Note: You can also hide configurable fields by setting the field as hidden on the 
configurable field itself. For more information, see "Editing a configurable field" on page 
176.

• To hide a row of fields, you must set all fields that are displayed on the same row as 
hidden, including fields that may not currently be displayed based on conditional logic.

• To hide a section or tab:

• Check if there is a field name that corresponds to the tab name that has "(tab)" after it.  
For example, for the budget entity, there are field names for each of the budget dialog 
box tabs, such as Fixed fees (tab), each of which hides the corresponding tab or 
section.

194 | Changepoint PPM 2021



About metadata settings for fields

• If there is no such field for the tab you want to hide, you must set all standard and 
configurable fields on the tab as hidden. This includes fields that are currently hidden 
based on conditional logic.

Note: Supplemental text that provides additional information in a section or tab is not 
controlled by metadata, but is hidden automatically when the section or tab is hidden.

• To hide a configurable field group, you must set all configurable fields in the group to 
hidden. The header for a configurable field group is displayed only when the group is 
displayed.

• Hiding certain fields hides all fields on a related dialog box. For example, hiding the 
Contingency field for budgets hides the Contingency dialog box.

• Hiding fields on a dialog box that have a create new icon beside them hides the create new 
icon. 

Warning: Make sure to carefully test the results of your settings in the Changepoint user 
interface. 

About hiding mandatory fields

If you hide a mandatory field, note the following:

• you must define a default value for the field, otherwise resources will not be able to save 
the associated record

• if the field is a check box, it will be set as selected by default

• if the field is a configurable field, you must use the setting on the configurable field to set 
it as mandatory

Hiding a field

This procedure applies to both standard Changepoint fields and configurable fields.

1. Click User Interface > Metadata.

2.  Expand the entity and then select the field. 

3.  Select the Field is hidden from the user check box.

4.  Click Save.
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Hiding entity profile cards

For cards on entity profiles, there are field labels that are prefixed with "Card."  For example, 
to hide the Revenue rules card on the budget profile, you would configure the 
CardRevenueRules metadata item under Budget to be hidden. 

Note: The summary section at the top of each profile cannot be hidden. 

1.  Click User Interface > Metadata.

2.  In the Metadata tree view, expand the entity folder and then select the entity card item.

3.  Select the Field is hidden from the user check box.

Warning: Do not change any other settings. Changing other settings can have unintended 
results.

4.  Click Save.

About user interface strings and PCIDs
The user interface strings  for Changepoint and  are available in the supported languages. Each 
string and all of the translated versions of the string are mapped to a unique identifier called a 
PCID (page content ID).

The PCIDs and the translated versions of the strings in the supported languages are stored in 
the Changepoint database, and can be edited. 

The language that is displayed in the user interface is controlled by the browser application, 
unless Changepoint has been configured to display in only one of the supported languages. 

For a list of supported languages and browsers, see the Changepoint Software Compatibility 
Matrix. 

You can do the following:

• Enter translated versions of new strings in the supported languages.

• Edit the default text in the user interface strings to match the terminology that is used by 
your organization.

• Create custom PCIDs for custom items, such as configurable fields, reports, sections, and 
so on.

You must obtain the PCIDs for text strings from your database administrator or whoever is 
administering the PCIDs in your organization.
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Entering a translated user interface string

1. Click User Interface > Strings and PCIDs.

2.  In the Search by list, select PCID.

3.  In the Search for field, enter the PCID of the translated string.

4.  In the Language list, select All languages. 

5.  Click Search.

6.  In the String field, enter the text for the Changepoint PSA string.

7.  If the Changepoint string is different, in the ITD String field, enter the text for the 
Changepoint string.

8.  In the Context field, enter the location of the string in the user interface.

9.  Click Save.

Editing a user interface string

You can edit the user interface strings for all of the standard Changepoint fields and 
configurable fields that have a PCID. 

Warning: Do not edit PCID 90898 because it a system placeholder.

1. Click User Interface > Strings and PCIDs.

2.  To search by PCID:

a. In the Search by list, select PCID.

b. In the Search for field, enter the PCID.

3.  To search by a text string:

a. In the Search by list, select String text.

b. In the Search for field, enter the text.

4.  Click Search.

5.  Make the necessary changes.

6.  Click Save.
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Creating a custom PCID

You can create custom PCIDs, which you can use for configurable fields, in custom report 
fields, and so on. Custom PCIDs are automatically assigned numbers in the range from 300000 
to 399999.

When you create a custom PCID, you first enter the string text in one language only. The same 
text is saved for all of the supported languages. After you save the custom PCID, you can then 
enter the translated strings for the other supported languages.

By default, the text in the String field is used for both the Changepoint PSA and PPM 
versions of the interface strings. However, you can enter a different text string for the 
Changepoint PPM version, if required.

1. Click User Interface > Strings and PCIDs.

2.  Right-click in the table, and then select Insert.

3.  In the String field, enter the text for the Changepoint PSA string.

4.  If the Changepoint PPM string is different, enter it in the ITD String field.

5.  In the Context field, enter the location of the string in the user interface.

6.  Click Save.

The custom PCID does not automatically appear in the list. You must search for it to view 
it.

7.  You can enter the text strings for the other languages. For more information, see "Entering 
a translated user interface string" on page 197.

About custom sections and section items
Changepoint has a set of default sections and section items that are displayed in the menu bars 
in Changepoint and Changepoint Administration.

You can do the following:

• create custom sections and section items

• change the order of the sections in the menu bar

• change the order of section items in a section

• edit the section and section items, except for the default section names
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About editing a default section or section item name

The best practice is to edit the default user interface strings for the corresponding PCIDs of the 
default section or section item name. You can obtain the PCIDs for the default sections and 
section items in the Custom Sections view (User Interface > Custom Sections). For more 
information, see the "Editing a user interface string" section on page 197.

Creating a custom section

1. Click User Interface > Custom Sections.

2.  Depending on where you want to add the custom section, in the Folders view expand either 
Changepoint or System administration and select any section.

3.  Click New.

4.  To enter the name of the custom section, do one of the following:

• If you created a PCID for the custom section name, enter the PCID in the PCID field.

• Enter the name in the Section name field. 

5.  In the Section key field, enter a code for the section.

6.  Click Save.

Modifying a custom section

You can change the name of a custom section only. 

1. Click User Interface > Custom Sections.

2.  In the Folders view, select the custom section.

3.  To edit the section:

a. In the Section name field, enter the new name.

b. Click Save.

4.  To delete the section:

a. Click Delete.

b. Click OK to confirm.
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Adding a custom section item

You can add a custom section item to a default section or custom section. 

1. Click User Interface > Custom Sections.

2.  In Folders view, select the section that you want to add the section item to.

3.  Click New section item.

4.  To enter the name of custom section item, do one of the following:

• If you created a PCID for the custom section item, enter the PCID in the PCID field.

• Enter the name in the Section item name field. 

5.  In the Section item key field, enter a code for the section item.

6.  In the URL field, enter the URL for the section item.

7.  To open the section item in a new window, select the Open in new window check box.

8.  Click Save.

Modifying a custom section item

You can edit custom section items except for the section item key.

1. Click User Interface > Custom Sections.

2.  In the Folders view, expand the sections and then click the custom section item.

3.  To edit the section item:

a. Make the necessary changes.

b. Click Save.

4.  To delete the section item:

a. Click Delete.

b. Click OK to confirm.

Changing the order of sections and section items

You can change the order of sections in the menu bars, and the order of the section items 
within a section. The order can be alphabetical or you can specify the order.
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1. Click User Interface > Custom Sections.

2.  In the Folders view, select any section.

3.  Click Reorder.

The Reorder Sections dialog box appears.

4.  Select the sort order for the sections and section items, and then click OK.

If you selected Custom, a second Reorder Sections dialog box appears.

5.  To move a section or section item, click the item and then click the up or down arrow until 
the item is in the desired position.

6.  Click Save.

Controlling access to a custom section item

You control access to a custom section item by selecting one or more security features and 
specifying whether one or all of the selected security features are required to access the custom 
section item.

1. Click User Interface > Custom Sections.

2.  In the Folders view, select the custom section item.

3.  Expand the Access control section.

4.  In the Security features required to access this section item section, select the option to 
specify whether one or all of the features are required to access the custom section item.

Note: Only two security features maximum can be selected for the All of the following 
selected features option.

5.  Expand the security feature categories, and then select the check boxes of the features that 
are required.

6.  Click Save.

About portlets
Portlets are typically added to a dashboard and can contain data, charts, reports, and links to 
entities or web sites. Portlets are organized into the following categories:
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• system-defined – Portlets installed with Changepoint. You cannot delete system-defined 
portlets.

• user-defined – Portlets created by users (system administrators or resources).

• Changepoint-wide – User-defined portlets that have been made available to all resources.

Changepoint portlets and other specifically-enabled pages can be rendered directly in a 
browser or third-party dashboard solutions such as IBM WebSphere, CA CleverPath, and 
Microsoft SharePoint. For more information, see the Changepoint Installation Guide.

Creating a portlet

You can create a user-defined portlet.

1. Click User Interface > Portlet Management.

2.  In the Category list, select the category and click Search.

3.  In the Folders view, click any portlet.

4.  Click New.

5.  Do one of the following:

• In the Portlet name field, enter the name of the portlet.

• To use a PCID, enter the PCID for the label in the PCID field.

6.  In the General tab, do one of the following:

• In the URL field, enter the URL of the content that you want to include in the portlet.

Warning: Do not use URLs that contain a target="_top" property. This property opens 
the link in the Details view in Changepoint, which unloads the home page and terminates 
the session.

• To include a Changepoint Analytics report or other content, in the Changepoint 
Analytics report list, select the Changepoint Analytics report or other content for the 
portlet.

The URL field displays the URL of the portlet content.

7.  To show (or hide) the Cognos toolbar in the Changepoint Analytics report when displayed 
in the portlet, select (or clear) the Display Cognos toolbar check box.
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8.  To display the portlet closed by default in the dashboard, select the Closed by default 
check box.

9.  To make the portlet available to all resources, select the Changepoint-wide check box.

10.  To make the portlet refresh automatically:

a. Select the Auto-refresh check box. 

b. In the Refresh interval field, enter the number of minutes after which the portlet is 
refreshed.

11.  To set the portlet as mandatory, select the Mandatory in personal dashboards check box.

Note: The portlet is made mandatory on new dashboards only. Existing dashboards are not 
affected. 

12.  In the Security access tab, select the roles, features or workgroups that can access the 
portlet. For more information, see "Controlling access to a portlet" on page 203.

13.  Click Save.

About controlling access to a portlet

You can control access to portlets as follows:

• system-defined portlets – All resources can access system-defined portlets by default, but 
you can restrict access to specific workgroups.

• user-defined portlets – Only the resource who creates a user-defined portlet can access it 
by default. However, you can make a user-defined portlet available to all resources by 
making it a Changepoint-wide portlet.

• Changepoint-wide portlets – All resources can access these portlets by default, but you can 
restrict access to specific roles, features, and/or workgroups.

Controlling access to a portlet

1. Click User Interface > Portlet Management.

2.  In the Category list, select the category and click Search.

3.  In the Folders view, select the portlet.

4.  To grant access to a user-defined portlet, in the General tab, select the Changepoint-wide 
check box.
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5.  Expand the Security Access section.

6.  To restrict access to specific roles, in the Restrict access to the following roles section, 
select the roles.

7.  To restrict access to specific features, in the Restrict access to the following features 
section, select the features.

8.  To restrict access to specific workgroups, in the Restrict access to the following 
workgroups section, select the workgroups.

9.  Click Save.

Modifying a portlet

1. Click User Interface > Portlet Management.

2.  In the Category list, select the category of the portlet, and click Search.

3.  In the Folders view, select the portlet.

4.  To edit the portlet:

a. Make the necessary changes.

b. Click Save.

5.  To delete the portlet:

a. Click Delete.

b. Click OK to confirm.

About dashboards
Dashboards are views that contain one or more portlets and are displayed on the home page in 
Changepoint. Dashboards that are created in Changepoint Administration are classified as 
system-defined. Resources cannot edit system-defined dashboards, but they can use them as a 
starting point to create personal dashboards with different portlets and layouts. There is an 
option on the resource profile to control whether a resource can create personal dashboards.

You can make a dashboard the default dashboard for all resources, or restrict access to a 
dashboard to specific resources, roles, and/or workgroups. You can also prevent users from 
replacing or removing a default dashboard by setting it as mandatory.

You can set up Cognos content to be displayed in a dashboard.

204 | Changepoint PPM 2021



About dashboards

Creating a dashboard

1. Click User Interface > Portal Management.

2.  In the Folders view, select a dashboard.

3.  Click New.

4.  Do one of the following:

• In the Portal name field, enter a name for the dashboard.

• If you have created a PCID for the dashboard name, enter it in the PCID field.

5.  To make the dashboard the default dashboard for all resources who have access to it, select 
the Default for users check box.

6.  To prevent resources from replacing or removing the default dashboard, select the 
Mandatory check box.

7.  To display a Changepoint Analytics report or other content in the dashboard, select it in the 
Cognos item list.

8.  To show (or hide) the Cognos toolbar in the Cognos item when displayed in the dashboard, 
select (or clear) the Display Cognos toolbar check box.

9.  To add portlets:

a. Expand the Portlets section.

b. Select the check boxes for the portlets.

c. To display the portlet as closed by default in the dashboard, select the Closed by 
default check box.

10.  Click Save.

Restricting access to a dashboard

By default, dashboards are available to all resources. However, you can restrict access to a 
dashboard to specific resources, global workgroups, workgroups, and/or roles. 

1. Click User Interface > Dashboard Management.

2.  Select the dashboard.

3.  Expand the Access section.
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4.  Select the Restrict access to the following Changepoint resources check box.

5.  To restrict access to a global workgroup or workgroup:

a. Expand the Resources folder, and then select the check box for the workgroup.

b. To extend the access rights to all workgroups under the workgroup, select the Include 
children check box.

6.  To restrict access to a resource, expand the Resources folder, and then select the check 
box for the resource.

7.  To restrict access to a role, expand the Roles folder, and then select the check box for the 
role.

8.  Click Save.

Modifying a dashboard

1. Click User Interface > Dashboard Management.

2.  Select the dashboard.

3.  To edit the dashboard:

a. Make the necessary changes.

b. Click Save.

4.  To delete the dashboard:

a. Click Delete.

b. Click OK to confirm.

About prioritizing default dashboards

The order in which default dashboards are created determines their priority values. The first 
default dashboard is assigned the highest priority value of 1, and additional default dashboards 
are assigned incremented priority values that decrease in priority. However, you can change 
the priority values.

The mandatory default dashboard with the highest priority automatically becomes the default 
dashboard of the resources who have access to the dashboard. 
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If there are no mandatory default dashboards, then the default dashboard with the highest 
priority automatically appears in the home page of the resources who have access to the 
dashboard.

Prioritizing default dashboards

1. Click User Interface > Dashboard Management.

2.  In the Folders view, select any dashboard.

3.  Click  Prioritize default dashboards.

The Prioritize Default Dashboards dialog box appears. 

4.  Drag the dashboards into the order of priority that you want. The highest priority is at the 
top of the list.

5.  Click Save.

Configuring the dashboard layout

By default, the portlets are displayed in a single pane layout, but you can chose another layout 
from a list of custom layouts that include two to four panes. After you select a new layout, you 
can move the portlets to the various panes.

1. Click User Interface > Dashboard Management.

2.  Select the dashboard.

3.  Click Arrange layout.

The Dashboard Layout window appears.

To change the pane layout

1. Click Custom layout.

The Custom Layout dialog box appears.

2.  Click the desired layout design.

3.  Click Save.

To rearrange the portlets

Drag the portlets to another position within a pane, or to another pane. An orange outline 
appears when you point to a position where the portlet can be dropped.

Changepoint Administration | 207



6. User Interface Management

To sort portlets into alphabetical order

Click  Alphabetical. If the dashboard includes multiple panes, the portlets are sorted 
alphabetically in each of the panes.

To resize the panes in a dashboard

1. Point to the space between the panes until the cursor changes to a double-ended arrow.

2.  Drag the arrow to the desired position.

To revert to the default layout

Click Default layout. 

Setting a default language for the user interface
By default, resources can select which of the supported languages is displayed in the user 
interface by specifying their language preference in their browsers. 

However, you can set up the user interface to display in only one of the supported languages, 
regardless of the language preference that resources select. The language setting applies to 
Changepoint, and Changepoint Administration.

Note: For a list of supported languages and browsers, see the Changepoint Software 
Compatibility Matrix.

1. Click User Interface > Language Setup.

2.  In the list of languages, select the language.

3.  Click Save.

Configuring display options for Changepoint

Configuring the new interface options

By default, the new user interface design for project and client profiles is not enabled. You can 
make the new the new interface design available to users. There is also an option to make the 
new interface design mandatory.

1.  Click User Interface > Display options.

2.  To enable the new interface for users,   in the New interface options section, select the 
Allow users to switch to new interface check box. Users can switch to the new interface 
and back using the New look option on the  project and client profiles.
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3.  To force users to use the new interface, select the Make new interface mandatory check 
box. The new interface is displayed without the New look option to switch back.

4.  Click Save. You must sign out of Changepoint and sign back in to view the changes.

Configuring whether dialog boxes or inline forms are displayed

By default, the create and edit functionality in Changepoint is displayed in tabbed dialog 
boxes. You can change the dialog boxes of most entities to views that are displayed inline with 
sections that can be expanded and collapsed. You can also allow resources to override the 
setting and set their own display preferences.

1. Click User Interface > Display Options.

2.  For each entity type in the General section, do one of the following:

• To display dialog boxes, select Tabbed.

• To display inline views, select Inline.

3.  To allow users to change the settings in Changepoint, select the Allow users to override 
the display options in their Preferences view check box.

4.  Click Save.

Configuring the number of decimal places to be displayed in Project 
Worksheet and Resource Planner

By default, the numeric values for standard fields in Project Worksheet and Resource Planner 
are displayed to three decimal places. You can change the number of decimal places to 0, 1, 2, 
or 3. 

Note: The setting applies only to how the values are displayed and has no effect on how 
the values are edited or calculated. All values are calculated using three decimal places and 
can be edited to three decimal places regardless of the number of decimal places that are 
displayed. Values for configurable fields are calculated and edited to four decimal places. 

1. Click User Interface > Display Options.

2.  In the Project Worksheet/Resource Planner section, specify the number of decimal 
places in the Number of decimal places to display field.
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About setting up links to custom help
You can set up links from entity profiles and dialog boxes to custom documents or online help 
(custom help) that has been developed by your organization. These links are in addition to the 
standard Changepoint online help.

The links are available on:

• Entity profiles:

• at the top of the profile (entity level) 

• on each section of the profile

• Dialog boxes and inline views for creating/editing entities (edit screens):

• at the top of the edit screen (entity level) 

• on each dialog box tab or inline view section

To set up the link, you must specify the following:

• URL of the custom help, including the protocol. The supported protocols are: http://, 
https://, ftp://, mailto://, and file://. 

• Tool tip text to be displayed when a resource points to the custom help icon. You can 
enter text or a PCID if a PCID has been created for the tooltip.

Setting up a link to custom help

1. Click User Interface > Custom Help.

2.  In the row that contains the entity, format type, and section, select the Configured check 
box.

3.  To enter the tooltip text, do one of the following:

• Enter the PCID in the PCID field. 

• Enter the text in the Title field.

4.  In the URL field, enter the URL to the custom help. 

5.  Click Save.
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Modifying a link to custom help

You can only edit the PCID, tooltip text, or URL of a custom help link. If a link is no longer 
used, you must disable it.

1. Click User Interface > Custom Help.

2.  Make the necessary changes directly in the cells.

3.  To disable a link, clear the Configured check box.

4.  Click Save to confirm.

About adding items to the Actions menu
You can add submenu headers and items to those headers to the Actions menu of the profile 
page of the following entities:

• Candidate

• Client

• Contact

Cross charge

• Initiative

• Non-labor item

• Objective

• Project

• Project portfolio

• Request

• Resource requests

• Resources

• Source

• Support item

You configure the submenu item to perform some actions such as: open a web page, or 
specified files or documents in an application. Initially all resources have access to the 
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submenu item but you can restrict access to the submenu item by resources, roles, workgroups, 
or security features. By default the submenu headers and items appear at the bottom of the 
View section of the Actions menu in the order that they are created. You can change the order 
in which the submenu headers and items appear, but you cannot move them from the bottom 
of the Actions menu.

Adding a submenu header to the Actions menu

1. Click User Interface > Actions Menu Integration.

2.  Select the entity.

3.  If the Reorder Submenu Headers view appears, click New submenu header.

4.  Do one of the following:

• In the PCID field, enter the PCID for the submenu header. The string for the PCID 
appears in the Name field.

• In the Name field, enter the name of the submenu header.

5.  Click Save.

Rearranging the order of submenu headers

By default, the submenu headers appear at the bottom of the Actions menu in the order that 
they were created. You can put them in a specific order or sort them in alphabetical order.

1. Click User Interface > Actions Menu Integration.

2.  Click the entity.

If at least one submenu header exists for the entity, the Reorder Submenu Headers view 
appears.

3.  To specify the order:

a. In the Sort by field, click Custom.

b. In the Submenu headers field, drag the submenu headers to the desired position.

c. Click Save.

4.  To rearrange the submenu headers in alphabetical order:

a. In the Sort by field, click Alphabetical.
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b. Click Save.

Note: The submenu headers are not rearranged in the current view, but are rearranged into 
alphabetical order in the Actions menu.

Editing a submenu header in the Actions menu

You can edit the PCID or name of a submenu header, but you cannot change the entity that it 
belongs to. You can change the order of the submenu items under a header. 

When you delete a submenu header, all of its action items are also deleted.

1. Click User Interface > Actions Menu Integration.

2.  Expand the entity and then select the submenu header.

3.  Make the necessary changes.

4.  Click Save.

5.  To delete the submenu header:

a. Click Delete.

b. Click OK to confirm.

Adding a submenu item to a submenu header

1.  In Changepoint Administration, click User Interface > Actions Menu Integration.

2.  Expand the entity and then select the submenu header.

3.  Click New submenu item. For more information, see "Submenu Item view, General 
options" on page 214.

4.  Complete the fields as required.

5.  For Intelligent Forms, in the Parameter field, you must enter the ID of the form project, 
which you obtain from the initial view of the form project in Infiniti Manage.

a. To search for an item, enter the search text and then click Search.

b. To display the tree view, clear the Show selected items only check box, ensure that 
the search field is empty, and then click Search. 

c. Select one or more items.

Changepoint Administration | 213



6. User Interface Management

d. To display the selected items only, select the Show selected items only check box, 
ensure that the search field is empty, and then click Search. 

e. To automatically include the sub-items of the selected items, select the Include 
children check box.

6.  Click Save.

Submenu Item view, General options

Option Description

PCID field PCID for the submenu item.

Name field Name of the submeu item.

URL field Location of the application or web 

page.

Parameter field Parameters for the URL.

Open in new window check box When selected, the submenu item 

opens in a separate browser 

window.

Specifying the URL and parameters for a submenu item

The following entity-based parameters are available:

• Entity ID

• Entity Name

• Resource ID

• Resource Name

• Session ID

The information in the URL and Parameters fields is concatenated to form the URL for the 
submenu item. Therefore, no spaces are allowed in either of the fields except in the parameter 
placeholder names. When using parameters, note the following:

• you must add a question mark (?) to the URL as required by the protocol
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• you must use an ampersand (&) to separate the parameters

Example URL:

http://www.xyz.xyz?

Example parameters:

id=885c076d-86ee-4458-9299-d5b754a7b0c8&Gen=true&CPGUID=ÿEntity IDÿ&sno=ÿSession 

IDÿ&rid=ÿResource IDÿ&NW=false&portal=1

Note: The URL is not validated when you enter it. You must test the URL by accessing 
the submenu item from the Actions menu of the entity.

Rearranging the order of submenu items

By default, the submenu items appear in Actions menu under the submenu header in the order 
that they were created. You can put them in a specific order  or sort them in alphabetical order.

1. Click User Interface > Actions Menu Integration.

2.  Expand the entity, and then select the submenu header.

3.  To specify the order of submenu items:

a. In the Sort by field, click Custom.

b. In the Submenu item field, drag the submenu items to the desired position.

c. Click Save.

4.  To rearrange the submenu items in alphabetical order:

a. In the Sort by field, click Alphabetical.

b. Click Save.

Editing a submenu item in the Actions menu

1. Click User Interface > Actions Menu Integration.

2.  Expand the entity and submenu header, and then select the submenu item.

3.  Make the necessary changes.

4.  Click Save.

5.  To delete the actions item:
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a. Click Delete.

b. Click OK to confirm.
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Specifying when time records become actual time

You can specify when time records are considered to be actual time in availability 
calculations and reports. The options are:

• when time is entered in the time sheet

• when time is submitted for approval

• when time has been approved

You can change the setting either before any time records have been entered, or after all 
existing time records have been approved.

1. Click Time and Expenses > Time Control.

2.  From the Actual time options, select one of the options.

3.  Click Save.

Allowing time submissions at month end
You can allow resources to submit their time sheet at month end when the regular time 
submission is weekly. The required number of hours is based on the prorated value for each 
day up to and including the last day of the month. 

For example, if the weekly amount for a five-day week (Monday to Friday) is 40 hours, then 
resources must submit at least eight hours (40 / 5) per day for each day of the month during 
the week that includes the month end. In this case, if the month end is on Wednesday, then 
resources must submit 24 hours total for Monday, Tuesday, and Wednesday (and Sunday, if 
it is the first day of the week).

Note: This option applies to all resources, system wide.

1. Click Time and Expenses > Time Control.

2.  Select the Allow time submission at month end of prorated time for weekly time 
submissions check box.

3.  Click Save.
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About restricting time for projects
You can restrict resources to entering time only when the time entry complies with one or both 
of the following conditions:

• date of the time entry is within the planned start and planned finish dates of the project, 
task or task assignment

• total amount of time entered for the task or task assignment is within the total planned 
effort of the project, task or task assignment 

You can set default settings for the time entry restrictions on the following entities:

• cost structures –  for the projects for the cost structure initiatives 

• projects – for the tasks and task assignments for the project

• tasks – for the task assignments for the task

The default settings are automatically applied to new entities, but can be overridden on 
individual projects, tasks, and task assignments. The options selected on task assignments take 
priority over task settings, which take priority over the project settings.

About setting or changing time entry restrictions when there are existing 
projects

The time entry restriction settings are not automatically applied to projects, tasks, and task 
assignments that exist when you enable or change the settings. Therefore you must manually 
apply the settings to existing entities as follows:

• To restrict time entries based on project planned data, enable the setting on each project.

• To restrict time entries based on task planned data, enable the setting on each task.

• To restrict time entries based on task assignment planned data, enable the setting on each 
task assignment.

You must first enable time entry restrictions in Time and Expenses > Time Control and then 
specify the settings on the entities.

Enabling time entry restrictions

1. In Changepoint Administration, click Time and Expenses > Time Control.

2.  Select the Enable time entry restrictions check box.
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3.  Click Save.

You set the default options for these settings on cost structures for all projects for the 
initiatives of the cost structure. 

About non-project time
You can create non-project time items for tracking time that is not related to requests or project 
tasks, such as vacation, legal holidays, sick leave, administrative tasks, and training.

You can create non-project time items that are available to all resources (system level), or to 
the resources in a specific global workgroup, or workgroup.

You can specify if the non-project time is included in personal vacation time or resource 
utilization. You can also specify a second level time approver for the time item, which is in 
addition to the resource's time approver. In this case, you must also specify an approver for the 
second level time approver.

Creating a non-project time item

1. Click Time and Expenses > Non-Project Time.

2.  In the Folders view, do one of the following:

• Select System.

• Select the global workgroup or workgroup that contains the non-project time item.

3.  Right-click in the table, and then select Insert.

4.  Complete the fields as required. For more information, see "Non-Project Time section 
options" on page 219.

5.  Click Save.

Non-Project Time section options

Option Description

Non-project time field Name of the item.

Description field Description of the item.
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Option Description

Non-project date field Specific date that resources are restricted to enter time on for 

the item.

Personal vacation check 

box

When selected, the item is counted as personal vacation time 

and is included in the Personal Vacation Time report.

Utilization eligible check 

box

When selected, the time for this item is included in resource 

utilization. 

For example, work-related training.

Include children check 

box

When selected, resources that belong to subworkgroups of 

the selected workgroup can enter time.

Enable second level 
approval check box

When selected, the resource specified in the Time approver 
field must approve time records for the time item in addition to  

the resources' time approver (specified in User Setup).

Time approver type-

ahead field

Resource who approves the time records for the time item.

Secondary approver 
type-ahead field

Resource who approves the time records for the time item for 

the resource specified in the Time approver field.

Modifying a non-project time item

If you delete a non-project time item, it is no longer available in the time sheet, but existing 
time records are not affected.

1. Click Time and Expenses > Non-Project Time.

2.  In the Folders view, do one of the following:

• Select System.

• Select the global workgroup or workgroup that contains the non-project time item.

3.  To edit the non-project time item:

a. Make the necessary changes. For more information, see "Non-Project Time section 
options" on page 219.

b. Click Save.
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4.  To delete the non-project time item:

a. Right-click the item row, and then select Delete.

b. Click OK to confirm.

c. Click. Save.

About setting up expenses
You set up expenses by completing the following steps:

1. Create the general categories for expenses, for example, meals, travel, and telephone. For 
more information, see "Creating an expense category" on page 221.

2.  Add GL account codes to each expense category. For more information, see "Adding GL 
account codes to an expense category" on page 222.

3.  Within each category, create the types of expenses. For example, within the "Automobile" 
category, you could create types for "Mileage" and "Car rentals". For more information, 
see "Creating an expense type" on page 223.

Creating an expense category

1. Click Time and Expenses > Expenses.

2.  In the Folders view, click any Expenses folder.

3.  Click New.

4.  Complete the fields as required. For more information, see "Expense Category view, 
General section options" on page 222.

5.  Click Save.

6.  Add GL account codes to the expense category. For more information, see "Adding GL 
account codes to an expense category" on page 222. 
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Expense Category view, General section options

Option Description

Expense category field Name of the expense category.

Description field Description of the expense category.

Reimbursable check box When selected, expenses are reimbursable.

Segment 1 of revenue 
recognition GL debit 
account list

Default debit GL account code to use when recognizing 

revenue

Segment 1 of revenue 
recognition GL credit 
account list

Default credit GL account code to use when recognizing 

revenue.

Budget burden rate field Total percentage for the default burden rate for budget 

expense items.

For example, to add 18%, enter 118.

Allow override check box When selected, resources can change the default burden rate 

on budget expense items.

Adding GL account codes to an expense category

You can associate GL accounts with specific workgroups for both chargeable and 
nonchargeable expenses.

When setting up an initiative, resources can choose to have the expenses associated with the 
expense GL account of the workgroup associated with the  initiative manager, project manager, 
or resource.

The expense GL account is displayed on expense reports, and can be used to export expense 
information for use in third-party accounting applications.

1. Click Time and Expenses > Expenses.

2.  In the Folders view, click the expense category.

3.  Click GL accounts.

4.  Right-click in the GL Accounts table, and then select Insert.
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5.  In the Workgroup cell, select the workgroup to associate with the GL account codes.

6.  In the Chargeable cell, select the GL account code associated with chargeable expenses 
for the workgroup.

7.  In the Nonchargeable cell, select the GL account code associated with nonchargeable 
expenses for the workgroup. 

8.  Click Save.

Modifying an expense category

1. Click Time and Expenses > Expenses.

2.  In the Folders view, click the expense category.

3.  To edit the expense category:

a. Make the necessary changes.

b. Click Save.

4.  To delete the expense category:

a. Click Delete.

b. Click OK to confirm.

Creating an expense type

You can further classify expenses by creating expense types within expense categories. You 
can specify expense limits that are applied to expenses of the same type on an expense report. 
For each expense type, you can configure whether attachments are mandatory, based on a 
threshold amount.

1. Click Time and Expenses > Expenses.

2.  In the Folders view, click the expense category for the new expense type.

3.  Click New expense type.

4.  Complete the fields as required. For more information, see "Expense type view, General 
section options" on page 224.

5.  Click Save.
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Expense type view, General section options

Option Description

Expense category list Category of the expense type.

Expense type field Name of the expense type.

Default currency list Default currency. If you do not select a default currency, the 

resource's base currency is used.

Enable currency check 

box

When selected, resources can change the currency.

Default quantity field Default quantity.

Fixed quantity check box When selected, prevents resources from changing the default 

quantity. For example, an expense type for car rentals 

typically have a fixed value of "1".

Default unit cost field Default unit cost. For example, a standard amount per mile or 

kilometer for car mileage.

Fixed unit cost check 

box

When selected, prevents resources from changing the default 

unit cost.

Expense limit list Limit type. The options are:

• Average daily limit – The total amount for all line items in 

the expense report, divided by the number of days that 

the expenses were incurred on. 

• Daily limit – The total amount for all line items in the 

expense report for one day.

• Per line limit – The line item total.

• Per report limit – The total amount for all line items in the 

expense report for that expense type.

• Per unit limit – The charge per unit entered for the line 

item.

Maximum amount field Limit amount. If no amount is specified, there is no limit on the 

amount.
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Option Description

When the expense limit 
has been reached field

Determines what happens when an expense report is 

submitted that contains an expense that exceeds the limit:

• warn the resource, but allow the expense to be submitted. 

The expense report is flagged to indicate that the expense 

limit has been reached.

• reject the expense report

Attachment threshold 

field

When an expense for the expense type exceeds the value in 

this field, an attachment is mandatory.

Attachment threshold 
currency list

Currency of the attachment threshold amount.

Attachment required 

check box

When selected, attachments are mandatory for the request 

type.

Modifying an expense type

1. Click Time and Expenses > Expenses.

2.  In the Folders view, expand the expense category.

3.  Click the expense type.

4.  To edit the expense type:

a. Make the necessary changes.

b. Click Save.

5.  To delete the expense type:

a. Click Delete.

b. Click OK to confirm.

Enabling expense attachments

You can  allow resources to add attachments to expense items and/or expense reports. 

1. Click Time and Expenses > Expense Attachments.

2.  To enable attachments on expense items, select the Expenses check box.
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3.  To enable attachments on expense reports, select the Expense reports check box.

4.  Click Save.

About creating expense advances
You can create expense advances for expenses. The advances directly integrate with the 
resource’s expense reports for approvals and workflow.

If the advance amount is higher than the incurred expense, the resource can return the 
difference. If the advance amount is less than the incurred expense, the finance department 
reimburses the difference to the resource. After you save an advance, you can only either edit 
the comments, or delete the advance.

Creating an expense advance

1. Click Time and Expenses > Expense Advances.

The Expense Advances view appears.

2.  Right-click in the table, and then select Insert.

3.  In the Resource list, select a resource.

4.  In the Date field, select the date of the advance.

5.  In the Currency field, select the currency of the advance.

6.  In the Amount field, enter the advance amount.

7.  Click Save.

Viewing expense advances

You can view all of the expense advances that are currently issued for all resources.

1. Click  Time and Expenses > Expense Advances.

The Expense Advances view appears.

Editing an expense advance

You can edit the comment for an advance, or delete an advance provided that it has not been 
added to an expense report.

1. Click Time and Expenses > Expense Advances.
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The Expense Advances view appears.

2.  Edit the comment directly in the cell.

3.  To delete an advance:

a. Right-click the row, and then select Delete.

b. Click OK to confirm.

4.  Click Save.

 

About transferring time and expenses
If time entries or expense records have been entered for the wrong project or task and have 
already been approved, you can transfer the records to the correct project or task so that they 
can be cross charged to the appropriate client. 

You can only transfer time or expense records that have been approved but have not yet been 
included in a cross charge. If an initiative is locked for revenue recognition, you cannot 
transfer the time and expense records associated with the initiative.

Expense transfer rules

• You can only transfer expenses between projects.

• You cannot transfer expense records for which revenue has been recognized or that are in 
closed periods for editing.

• If the revenue recognition process is running, the expense transfer is locked.

Warning: Transferring expenses can result in inaccurate information in cross charge and 
project reports. Therefore, you should only transfer expenses in critical cross charging 
situations.

Time transfer rules

After a time record has been transferred, it is visible in the Time Sheet under the task it was 
transferred to and it displays in all relevant reports and views of this task. When you transfer 
time records, the following rules apply:

• You can only transfer project time records between tasks.
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• You can only transfer time entries of a resource to a task that the resource is assigned to, 
including open tasks. 

• You cannot transfer non-project time entries to a non-project time item that has a specific 
date. For example, you can transfer non-project time to a generic item such as "Training 
and development" that can take place any day, but you cannot transfer it to a specific item 
such as "New Year’s Eve", which takes place on a specific date.

• You cannot transfer adjusted time records, time records for which revenue has been 
recognized, or time records that are in closed periods for editing.

The resource whose time has been transferred and the project managers of both the source 
project and the target project are notified by email about the transfer. For non-project time, 
only the resource whose time was transferred is notified.

Split charge condition

The transferred effort or expense amounts are split according to how split charges are set up on 
the target project. If split charges have been set up on the target project, it takes precedence 
over the setup on the initiative. If split charges are not set up on the initiative, then entire 
amount is cross charged to the one client.

Transferring time and expenses

You can transfer time entries of a resource to another task that is assigned to the same 
resource, or expenses to another project. 

1. Click Finance > Transfer Time and Expenses.

The Transfer Time and Expenses view appears.

2.  In the Records to transfer list, select the type of records you want to transfer.

3.  Enter the date range for the records in the date fields.

4.  In the Transfer from section, specify the records to be transferred:

a. Search for the source entity of the records, that is, the clients, initiatives, projects, 
tasks or resources. The data that matches your filter criteria appears in the Transfer 
from section and Transfer to sections.

b. Select the check boxes for the time entries or expenses to be transferred.

5.  In the Transfer to list, select the target destination for the selected records:
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• You can reduce the number of destinations by entering filter criteria into the text field 
and then clicking Filter.

• To transfer a time entry for a project task, select a project, task or resource

• To transfer a time entry for a non-project time item, select a non-project time item

• To transfer an expense, select a project

6.  Click the right arrow button.

The record is transferred to the selected target destination.

7.  To undo the transfer, select the record in the Transfer to list and then click the left arrow 
button.

8.  Click Save.

Troubleshooting transfer time and expenses

You cannot transfer time and expenses

If you cannot transfer time and expenses because the time entries or expenses do not appear in 
the Transfer Time and Expenses view, check the following:

• initiative – check if the Lock time and expense check box is selected on the initiative. 
This option can be selected manually by a resource or automatically when revenue 
recognition process is in progress and then cleared automatically after the recognized 
revenue is committed.

• cost structure – check if any of the financial settings that prevent users from transferring 
time have been enabled.
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About knowledge management

Resources can store and share information by saving files or links to repositories as 
knowledge items. Knowledge items are grouped into knowledge categories and 
subcategories. 

You can set up check-in and checkout controls and/or legal disclaimers on the category that 
apply to its knowledge items. You can also restrict access to knowledge item attachments by 
setting up the knowledge item approval workflow.

Configuring a legal disclaimer for knowledge items
You can configure a legal disclaimer so that resources have the option in Changepoint to 
enable a legal disclaimer on individual knowledge items. 

1. Click Knowledge > Legal Disclaimer.

2.  Select the Enable legal disclaimer check box.

3.  In the Legal disclaimer text field, enter the message to be displayed.

4.  Click Save.

About knowledge categories
Knowledge categories and subcategories allow resources to group knowledge items of the 
same type and therefore facilitate searches in the knowledge database. You can define an 
unlimited number of knowledge categories and subcategories. 

For each knowledge category, you can do the following:

• Enable version control – You can enable version control for a knowledge category. Each 
time that a knowledge item in the category is updated, a new version of a knowledge 
item is saved.

• Limit the number of versions that are kept – By default, there is no limit to the number 
of versions of knowledge items that are stored, but you can set a limit.

• Enable check-in and checkout controls – you can enable controls that ensure that only 
one resource at a time can edit the knowledge item.

• Create subcategories – the settings for a parent category apply to the knowledge items in 
the subcategories.
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Creating a knowledge category

1. Click Knowledge > Knowledge Categories.

2.  In the Folders view, select an existing category. 

3.  Click New.

4.  In the Category field, enter the name of the category.

5.  To enable version control:

a. Select the Enable version control check box.

b. In the Number of versions retained field, enter the number of knowledge item 
versions you want to keep. The default value for this field is 0, which means that there 
is no limit.

6.  To enable check-in/checkout control, select the Enable check-in/checkout controls check 
box.

Modifying a knowledge category

1. Click Knowledge Management > Knowledge Categories.

2.  Select the knowledge category.

3.  To edit the knowledge category:

a. Make the necessary changes.

b. Click Save.

4.  To delete the knowledge category:

a. Click Delete.

b. Click OK to confirm.

Creating a knowledge subcategory

1. Click Knowledge > Knowledge Categories.

2.  Select the knowledge category.

3.  In the Subcategories table, right-click and then select Insert.

4.  In the Subcategory cell, enter the name of the subcategory.
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5.  Click Save.

Modifying a knowledge subcategory

1. Click Knowledge > Knowledge Categories.

2.  Select the knowledge category.

3.  To edit a knowledge subcategory, make the necessary changes.

4.  To delete a knowledge subcategory:

a. Right-click the subcategory row, and then select Delete.

b. Click OK to confirm.

5.  Click Save.

About knowledge subscriptions
Knowledge subscriptions are groups of knowledge categories and subcategories and roles that 
control access to knowledge items. Resources who have the roles specified for a subscription 
automatically have access to, and can create and post knowledge items in, the knowledge 
categories and subcategories that are specified in the subscription.

If you do not set up subscriptions, then all resources can post knowledge items and access all 
knowledge items in Changepoint.

Changepoint is shipped with one default subscription that is accessible to all resources.

Configuring a knowledge subscription

1. Click Knowledge > Knowledge Subscriptions.

2.  In the Folders view, select any existing subscription.

3.  Click New.

4.  In the Subscription field, enter a name for the subscription.

5.  In the Description field, enter a description for the subscription.

6.  In the Knowledge categories included in the subscription list box, expand the categories 
and select the subcategories.

7.  In the Roles required to automatically receive this subscription section, select the roles. 

8.  Click Save.
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Modifying a knowledge subscription

1. Click Knowledge > Knowledge Subscriptions.

2.  Select the knowledge subscription.

3.  To edit the knowledge subscription, make the necessary changes, and then click Save.

4.  To delete the knowledge subscription, click Delete.

About approval workflow for accessing knowledge item 
attachments

You can set up a restrictions so that resources must request approval before they can download 
a knowledge item attachment. You must enable the restrictions and then specify the approvers 
(participants). Participants can be resources, system-defined participants (creator of the 
knowledge item) or roles.

You can set up any number of participants for the workflow, and specify the order in which 
approvals are sent to participants. 

When all participants have approved the request, a notification appears in the My Reminders 
portlet of the resource, who can then download the attachment from there. If an access request 
is rejected, the workflow is stopped, and a notification appears in the My Reminders portlet 
of the resource. 

Setting up the approval workflow for knowledge item attachments

You can set up an approval workflow for resources to access knowledge items attachments. 
You must specify the participants in the workflow, and the order in which the approval request 
is sent to the participants. 

1. Click Knowledge > Knowledge Item Workflow.

2.  Select the Restrict access to knowledge item attachments check box.

3.  Right-click in the table, and then select Insert.

4.  In the Participant type-ahead field, select the resource, system-defined participant, or role 
that will approve the access to the knowledge item attachment.

5.  In the Dependent column, specify the number that represents the order in the approval 
workflow for the participant.

6.  Click Save.
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Modifying the approval workflow for knowledge items

1. Click Knowledge > Knowledge Item Workflow.

2.  To edit a participant, make the necessary changes in the table cells.

3.  To delete a participant:

a. Right-click the row, and then select Delete row.

b. Click OK to confirm.

4.  Click Save.

Configuring team folders
You can do the following with team folders:

• change the team leader to any resource who is a team member of the team folder

• close a team folder, so that it cannot be accessed in Changepoint

• reopen a closed team folder

1. Click Knowledge > Team Folders.

2.  To change the team leader, select a new team leader in the Team leader list.

3.  To close a team folder, select the Closed check box.

4.  To reopen a closed team folder, clear the Closed check box.

5.  Click Save.
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About candidate status

You can configure the statuses of candidates in your organization’s evaluation cycle. For 
each candidate status, you configure the probability (as a percentage) of the candidate being 
approved when it reaches the status. The probability increases as the candidate advances in 
the evaluation cycle.

If candidate workflow is enabled, the statuses that are available in the candidate evaluation 
cycle are determined by the workflow definitions. If workflow is not enabled, all of the 
statuses are available in the candidate evaluation cycle.

Creating an candidate status

1. Click User Interface > Candidate Status Setup.

2.  Right-click in the table, and then select Insert.

3.  In the Candidate status field, enter the status.

Tip: To make the status list appear in the order of the candidate evaluation cycle, enter a 
prefix before the status name (for example, A-, B-, C-, or 1., 2., 3.).

4.  To automatically update the probability value when an candidate reaches the status, 
select the Update probability check box.

5.  To allow resources to change the probability value, select the Override allowed check 
box.

6.  In the Probability (%) field, enter the percentage of the probability of the candidate 
being approved when it reaches the status.

7.  Click Save. 

Modifying an candidate status

1. Click User Interface > Candidate Status Setup.

2.  To edit a status:

a. Make the necessary changes.

b. Click Save.

3.  To delete a status:
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a. Right-click the row, and then select Delete.

b. Click OK to confirm.
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About request management

The Changepoint request management functionality allows your organization to effectively 
track, route and manage various requests submitted by external contacts or internal staff. Use 
request types, request categories, approval workflow, and assignment queues to route 
requests to resources for action and resolution. 

Resources who work on a request can enter time against the request, and the request time can 
then be cross charged to the client for whom the request was initiated.

To set up the request management process:

1. Create the required operations centers. For more information, see "Creating an operations 
center" on page 240.

2.  Create additional request types, if required. For more information, see "Creating a 
request type" on page 244.

3.  Create the request categories and subcategories for the request types. For more 
information, see the "Creating a request category or subcategory" section on page 248.

4.  Create the request priorities. Request priorities are defined in the Configurable Field 
Values view where you can create drop-down list values for the Request priority code 
type of the Request lookups category. For more information, see "Creating drop-down 
list values for configurable code fields" on page 178.

5.  Configure the queues and request routing criteria for operations centers. For more 
information, see the "Creating a request queue" section on page 250.

6.  Create configurable fields for requests if required. For more information, see "About 
configurable fields" on page 164.

7.  Configure additional user interface fields for requests if required. For more information, 
see "Setting up the display of additional information on the Request dialog box" on page 
252.

8.  Configure request workflows. For more information, see "About workflow management" 
on page 371.
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About operations centers
Requests are organized and tracked through operations centers. When you create a operations 
center, you can set up the following:

• Select the operations center manager who is responsible for support items, the escalation 
of requests, and request approvals depending on how the request workflow is configured. 
Operations center managers can view all requests in the Open Requests tree view in 
Changepoint.

• Specify a grace period for clients for when support is provided beyond the time limit 
specified in the initiative service level agreement (SLA) in Changepoint.

• Set up the cross charging increments in minutes that will be cross charged to a client, even 
if the entire period of time has not been used. 

• Enable a warning message that displays when the resource who is assigned to a request is 
not available. The warning summarizes the total time of the resource’s appointments and 
task assignments entered in the resource’s calendar for the current day.

• Set up the numbering scheme for requests created under an operations center. For more 
information on request numbering, see "Setting up the request numbering scheme" on page 
241.

• Restrict view and/or edit access to requests created under an operations center. For more 
information, see "Restricting access to operations center requests" on page 241.

Creating an operations center

1. Click Requests > Operations Centers.

2.  In the Folders view, select any operations center.

3.  Click New.

4.  In the Operations center field, enter the name of the operations center.

5.  In the Operations center manager list, select the resource who is responsible for 
managing the operations center.

6.  In the Grace period field, enter the number of minutes of free support time that is given to 
the client if the provided support continues beyond the time limit specified in the initiative 
SLA. 
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7.  In the Minimum increment field, enter the minimum number of minutes that is cross 
charged to the client, even if the entire amount of time has not been used. 

8.  To display a warning message when the resource who is assigned to a request is not 
available, select the Display warnings about the availability of resources when 
assigning requests check box.

9.  Configure the request numbering scheme. For more information, see "Setting up the 
request numbering scheme" on page 241.

10.  Set up the security access for the operations center. For more information, see "Restricting 
access to operations center requests" on page 241.

11.  Click Save.

Setting up the request numbering scheme

When a request is created, it is assigned a number that is unique to the operations center. You 
can define the numbering format for requests, or you can use custom stored procedures for 
request numbering. 

1. Click Requests > Operations Centers.

2.  In the Folders view, select the operations center.

3.  Expand the Request numbering section.

4.  Select one of the following options:

• To create a numbering scheme, select the Use numbering scheme option and enter the 
appropriate information in the numbering scheme section. For more information, see 
"Numbering scheme options" on page 296. 

• To use a custom stored procedure, select the Use custom stored procedure option and 
select the appropriate stored procedure in the Auto-numbering stored procedure list. 
For more information, see "Requirements for auto-numbering stored procedures" on 
page 295.

5.  Click Save.

Restricting access to operations center requests

By default, all resources have view and edit access to an operations center request. However, 
you can restrict view and edit access to specific resources, roles, and/or workgroups.
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1. Click Requests > Operations Centers.

2.  In the Folders view, select the              operations center

3.  Expand the Security access section.

4.  To restrict view access:

a. Select the Restrict view access to the following resources check box.

b. To select resources, expand the Resources folder and select the global workgroup, 
workgroups and/or resources who will have view access. 

c. To select roles, expand the Roles folder and select the roles who will have view 
access.

d. To extend access rights to the workgroups under the selected workgroup, select the 
Include children check box.

5.  To restrict edit access:

a. Select the Restrict edit access to the following resources check box.

b. To select resources, expand the Resources folder and select the global workgroup, 
workgroups and/or resources who will have edit access. 

c. To select roles, expand the Roles folder and select the roles who will have edit access.

d. To extend access rights to the workgroups under the selected workgroup, select the 
Include children check box.

6.  Click Save.     

Restricting both view and edit access to operations center requests

When you restrict edit access to      resources and workgroups, any view access restrictions that 
you may have set are automatically removed. Similarly, when you restrict edit access to roles, 
all view access restrictions for roles are removed. The result is that all resources by default still 
have view access.

To restrict both edit and view access to the same resources and workgroups, you can use this 
workaround.   

1. Create a dummy role without any features assigned to it.

2.  Restrict edit access to the resources and workgroups.         
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3.  Restrict view access to the dummy role, which effectively prevents all resources with view 
access only from accessing the operations center             requests. The result is that only the 
resources who have edit access can view the              operations center. 

Modifying an operations center

1. Click Requests > Operations Centers.

2.  In the Folders view, select the operations center.

3.  To edit the operations center:

a. Make the necessary changes.

b. Click Save.

4.  To delete the operations center:

a. Click Delete.

b. Click OK to confirm.

About the standard request types
Request types are used to identify the different kinds of requests that can be created and 
processed in Changepoint. Changepoint is installed with a standard set of request types but you 
can create additional request types.

Request type Description

Bug report

Problem or defect found in an application.

Example:

• Error message in an application

• Application failure

Change request

Change to an application, a project, a process, a resource 

assignment, and so on.

Example:

• Upgrade to new release

• Increase security access to a shared application

Feature request
New feature or enhancement for an existing application, for 

example to improve software or hardware functionality.
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Request type Description

Planning request

Request to initiate the first step in demand management 

request screening.

Example: Enhancement to existing systems that may or may 

not be selected for further consideration

Support request

Request for support.

Example: 

• Set up access rights for a new employee

• Increase space on a network location

Work request
Request to initiate new work. 

Example: Create a custom application

Creating a request type

1. Click Requests > Request Types.

2.  In the Folders view, click a request type.

3.  Click New.

4.  Expand the General section.

5.  In the Unique identifier field, enter a unique identifier (maximum of three alphanumeric 
characters) for the request type.

6.  In the Description field, enter the name of the request type. 

7.  To allow Client Portal users to create requests of this type in Client Portal, select the 
Allow Client Portal users to create requests check box.

8.  To display the Resource demand information tab in the Request dialog box for this 
request type and allow users to include the request effort in the capacity calculations in 
resource demand scenarios, select the Enable resource demand information check box.

9.  To force users to add at least one entry in the Resource demand information tab in the 
Request dialog box for this request type, select the Resource demand information is 
mandatory check box.
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10.  To enable time entry in the time sheet in Changepoint for the requests, complete the Time 
control section. For more information, see "About restricting time entry for request types" 
on page 245.

11.  To restrict edit access to the requests, complete the Security access section. For more 
information, see the "Restricting edit access to a request type" section on page 247.

12.  Click Save.

About restricting time entry for request types

When you create a new request type, by default all resources can enter time that they worked 
on a request of the request type in the time sheet.

You can restrict time entry for the request type to specific statuses. You can further restrict 
time entry to a combination of one or more request statuses, and workgroups, resources, and/or 
roles. If you select such a combination, a resource will be able to enter time for the request 
type if any of the following conditions is true:

• resource is a member of a selected workgroup

• resource is selected

• resource has a role that is selected

Restricting time entry for request statuses

You can restrict time entry for a request type to specific request statuses.

1. Click Requests > Request Types.

2.  In the Folders view, select the request type.

3.  Expand the Time control section.

4.  To restrict time entry to requests with specific statuses:

a. Select the Restrict time entry to the following statuses check box.

b. Select the request statuses. 

5.  To allow time entry for all request statuses, clear the Restrict time entry to the following 
statuses check box. 

6.  Click Save.
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Restricting time entry for request types to specific resources or roles

You can restrict time entry for a request type for all statuses or o specific resources or roles.

1. Click Requests > Request Types.

2.  In the Folders view, select the request type.

3.  Expand the Time control section.

To restrict time entry for a selected request status to workgroups, resources or 
roles

1. Select the Restrict time entry to the following statuses check box and request statuses.

2.  Click the name of a request status to highlight it.

3.  In the Restrict time entry to the following resources and roles section, select the For 
the selected request status option.

4.  To select workgroups or resources, expand the Resources folder, and then select the 
workgroups and/or resources. 

5.  To select roles, expand the Roles folder, and then select the roles.

6.  To include all workgroups under the selected workgroups, select the Include children 
check box.

7.  Click Save. 

To restrict time entry for all request statuses to resources or roles

1. In the Restrict time entry to the following resources and roles section, select the For all 
request statuses option.

2.  To select workgroups or resources, expand the Resources folder, and then select the 
workgroups and/or resources. 

3.  To select roles, expand the Roles folder, and then select the roles.

4.  To include all workgroups under the selected workgroups, select the Include children 
check box.

5.  Click Save. 
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Restricting edit access to a request type

By default, before any restrictions are applied to a request type, all resources have full access. 
However, you can restrict edit access to specific resources, roles, and/or workgroups.

1. Click Requests > Request Types.

2.  In the Folders view, select the request type.

3.  Expand the Security access section.

4.  Select the Restrict edit access to the following resources check box. 

5.  To select resources that are allowed to create or edit requests of this type, expand the 
Resources folder and select the global workgroup, workgroups and/or resources. 

6.  To select roles that are allowed to create or edit requests of this type, expand the Roles 
folder and select the roles.

7.  To extend the access rights to all workgroups under the selected workgroups, select the 
Include children check box.

8.  Click Save.

Modifying a request type

If you disable time entry for a request type after a resource has already entered time, the 
resource can edit and submit the existing time record, but they cannot enter a new time record. 
The controlling factor is the status of the request at the time of the entry and not the status of 
the request for the date entered.

When you delete a request type, existing requests in Changepoint are not affected.

1. Click Requests > Request Types.

2.  In the Folders view, select the request type.

3.  To edit the request type:

a. Make the necessary changes.

b. Click Save.

4.  To delete the request type:

a. Click Delete.
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b. Click OK to confirm.

Creating a request category or subcategory
Request categories and subcategories are used with the request type to automatically assign 
approved requests to specific queues or resources for action or resolution. For each request 
type, you can define an unlimited number of request categories and subcategories. Request 
categories and subcategories appear on the request dialog boxes and can be used as routing 
criteria to ensure that requests are assigned to appropriate queues and resources.

Note: You cannot create categories for planning requests.

1.  Click Requests > Request Categories.

2.  In the Folders view, select the request type.

3.  In the Category field, enter the name of the category.

4.  To create a request subcategory:

a. In the Subcategories table, right-click, and then select Insert.

b. In the Subcategory column, enter the name of the subcategory.

5.  Click Save.

Modifying a request category or subcategory

When you delete a request category, all subcategories of the category are also deleted.

1. Click Requests > Request Categories.

2.  In the Folders view, select the request category.

3.  To rename the category:

a. In the Category field, enter the new name.

b. Click Save.

4.  To delete the category:

a. Click Delete.

b. Click OK to confirm.

5.  To rename a subcategory:
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a. In the Subcategory field, enter the new name.

b. Click Save.

6.  To delete a subcategory:

a. Right-click the subcategory, and then select Delete.

b. Click OK to confirm.

About request queues
You can create request queues for a request type, and then set up routing criteria to determine 
which requests are sent to the various queues. The routing criteria is based on one or more of 
the following criteria:

• Initiator

• Application

• Application category

• Request category

• Request priority

• Operations center

In order for requests to be routed to request queues, the following is also required:

• The Auto Dispatch Request to Queues scheduled job that routes requests to queues 
must be  configured. For more information, see the Changepoint Installation Guide.

• The request workflow process must be completed, and the request cannot have a request 
status of: Closed, Canceled, or Rejected.

By default, all resources who have view access to requests also have access to request queues. 
However, you can restrict access to a request queue to specific resources or by workgroups. 

Setting the priority for request queues

You can set the order of priority when there are multiple request queues for a request type. 
Requests are sent to the first request queue in the list whose criteria matches the information in 
the request. Therefore, ensure that you set the order so that the queue with the most specific 
criteria is at the top of the list and the queue with the least specific criteria (the default queue) 
is at the bottom.
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Creating a request queue

1. Click Requests > Request Queues.

2.  Select the request type.

3.  In the Queue name field, enter the name of the queue.

4.  Click Save.

5.  If there are multiple queues in the Priority list, do the following:

• To move a queue higher in the priority order, select the queue and click Move Up.

• To move a queue lower in the priority order, select the queue and click Move Down.

6.  To define routing criteria, do the following:

a. Expand the Criteria section.

a. Right-click in the table, and then select Insert.

b. In the Criteria list, select the criteria.

c. In the Value list, select the value for the criteria.

7.  Click Save.

Modifying a request queue

1. Click Requests > Request Queues.

2.  Expand the request type and then select the request queue.

3.  To edit the request queue:

a. Make the necessary changes.

b. Click Save.

4.  To delete the request queue:

a. Click  Delete.

b. Click OK to confirm.
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Restricting access to a request queue

You can restrict access to the requests in a queue to specific resources or all of the resources in 
a workgroup. 

Note: Resources who have the access to manage operations centers can access all queues 
even if access is restricted.

1. Click Requests > Request Queues.

2.  Expand the request type and then select the request queue.

3.  Expand the Security access section.

4.  Select the Restrict access to the following resources check box.

5.  To select a resource:

a. To search for an item, enter the search text and then click Search.

b. To display the tree view, clear the Show selected items only check box, ensure that 
the search field is empty, and then click Search. 

c. Select one or more items.

d. To display the selected items only, select the Show selected items only check box, 
ensure that the search field is empty, and then click Search. 

6.  To select all of the resources in a workgroup:

a. Display the tree view.

b. Expand the workgroup.

c. Right-click the workgroup, and then select Select all below. The workgroup resources 
that are displayed are automatically selected.

7.  Click Save.

Restricting access to project requests

You can set up a system-level restriction so that only the resources that have been granted 
access to a project can view the requests for the project. However, this restriction can be 
overridden on individual projects as required by the project managers.

1. Click Requests > Project Request Access.
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2.  Select the Restrict view access  for project requests check box.

3.  Click Save.

About displaying additional information on the Request dialog box
You can specify additional fields to be displayed on the request dialog box. These fields are 
for information only and cannot be edited.

When you specify additional fields, an   icon appears in the top right corner of the request 

dialog box and the fields are displayed when the icon is clicked.

The additional fields can pertain to various entities selected on the request. For example, you 
can set up an informational field that displays the office phone number of the resource 
assigned to the request. The fields reflect the current data entered.

You can specify additional fields to be displayed on all requests types or to specific request 
types only.

Note: Additional fields are not available to Client Portal users.

Setting up the display of additional information on the Request dialog box

You can select the additional fields to be displayed on the Request dialog box and configure 
the order they are displayed.

1. Click Requests > Additional UI Fields.

2.  In the Folders view, click a request type or click All request types.

3.  In the Available fields list, expand the entity folder.

4.  To include a  field, select its check box.

5.  To change the display order of the selected fields:

a. Select the Show selected items only check box.

b. Select the field.

c. Click the up or down arrows to move the field to a new position.

6.  Click Save.
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About assets
You can create a repository of your organization’s assets that can be referenced in a request, if 
required. To configure assets, do the following:

1. Create asset types. For example, monitors.

2.  Create asset type options. For example, the size of the monitors.

3.  Create values for the asset options. For example, 19 inches and 23 inches for the monitor 
size.

Creating an asset type
1. Click Requests > Asset Types.

2.  In the Folders view, select an asset type.

3.  Click New.

4.  In the Asset type field, enter the name of the asset.

5.  To assign asset options to the asset type, see "Assigning an option to an asset type" on 
page 254.

6.  Click Save.

Modifying an asset type

1. Click Requests > Asset Types.

2.  Select the asset type.

3.  To edit the asset type, make the necessary changes and click Save.

4.  To delete the asset type:

a. Click Delete.

b. Click OK to confirm.

Creating an asset option
You can define asset options that display as either text fields or drop-down lists in the Asset 
dialog box in Changepoint.

1. Click Requests > Asset Options.
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2.  Right-click in the table, and then select Insert.

3.  In the Asset option column, enter a name for the asset option.

4.  In the Type column, do one of the following:

• To display the field as a text field, select Text field.

• To display the field as a drop-down list, select Lookup list. For more information 
about lookup values, see "Creating an asset option lookup" on page 255.

5.  Click Save.

Modifying an asset option

You cannot delete an asset option that is assigned to an asset type. To delete an option that is 
assigned to an asset type, you must first unassign it from the asset type. For more information, 
see "Assigning an option to an asset type" on page 254.

1. Click Requests > Asset Options.

2.  Make the necessary changes directly in the table cells.

3.  To delete an asset option:

a. Select the row.

b. Right-click and select Delete.

4.  Click Save.

Assigning an option to an asset type

1. Create an asset option.

2.  Click Requests > Asset Types.

3.  In the Folders view, select the asset type.

4.  Do one of the following:

• To assign an asset option to the asset type, select the option in the Available asset 
options list and click the up arrow that is above the list.

• To unassign an asset option, select the option in the Assigned asset options list and 
click the down arrow that is below the list.

5.  To define the sort order of the asset options:
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a. Select the option in the Available asset options list.

b. Click the up or down arrows to move the option to the desired position. 

6.  To make the asset option field mandatory in Changepoint, select the Force users to 
specify a value for this asset type option check box.

7.  Click Save.

Creating an asset option lookup
If you created asset options that display as drop-down lists in Changepoint, you must define 
the values that will be available for selection in the drop-down list. You can define as many 
lookup values as required for the asset option. 

1. Click Requests > Asset Option Lookups.

2.  In the Asset option list, select the asset option.

3.  Right-click in the table, and then select Insert.

4.  In the Lookup code field, enter a unique identifier (up to three alphanumeric characters) 
for the asset option lookup.

5.  In the Description field, enter a description. 

6.  Click Save. 

Modifying an asset option lookup

After an asset option lookup is saved, you can edit only its description. To edit the lookup 
code, you must first delete the asset option lookup and then create a new one with the correct 
code.

1. Click Requests > Asset Option Lookups.

2.  In the Asset option list, select the asset option.

3.  Make the necessary changes directly in the table cells.

4.  To delete an asset option lookup:

a. Select the row.

b. Right-click and select Delete.

5.  Click Save.
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About configuring reports

You can configure standard Changepoint reports as follows:

• organize reports within standard categories or create new report categories

• add custom ASP reports

• grant access to reports to specific roles or resources

There are two basic types of reports:

• ASP reports - include standard Changepoint reports and revenue recognition reports, and 
custom ASP reports

For information about configuring Changepoint Analytics reports, see "About configuring 
Changepoint Analytics reports in Changepoint Administration" on page 258.

Changing the category of a report

1. Click Reporting > Report Setup.

2.  In the Folders view, expand the Standard reports report type and the report category.

3.  Select the report.

4.  In the Category list, select the report category.

5.  Click Save.

Creating a report category

You can create report categories to group reports, for example reports that have similar data 
or that are related to a specific entity.

1. Click Reporting > Report Setup.

2.  In the Folders view, expand  the report type.

3.  Select any report category.

4.  Click New.

5.  In the Category field, enter the name of the report category.

6.  Click Save.
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Modifying a report category

1. Click Reporting > Report Setup.

2.  In the Folders view, expand the report type.

3.  Select the report category.

4.  To edit the report category:

a. In the Category field, enter the name of the report category.

b. Click Save.

5.  To delete the report category:

a. Click Delete

b. Click OK to confirm.

About configuring Changepoint Analytics reports in Changepoint 
Administration

During the installation and configuration of the IBM Cognos Analytics software, the section 
items for Changepoint Analytics  are added as default sections to the Reports option in the 
menu bar in Changepoint.

About configuring access to Changepoint Analytics reports and other Cognos 
content

Access to Changepoint Analytics reports and other content is configured in the Analytics 
Portal. The report owner or the Cognos administrator specifies which users and groups have 
access to a specific report or item, and which actions (Read, Write, Execute, Set policy, and 
Traverse) they can perform on the content. For more information, see the IBM Cognos 
Analytics online help.

Showing and hiding the Cognos toolbar in reports

By default, the Cognos toolbar appears in reports, but it can be hidden.

1. Click Reporting > Report Setup.

2.  In the Folders view, click  Standard reports > Cognos.

3.  Select the report.

4.  To hide the Cognos toolbar, clear the Display Cognos toolbar check box.
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5.  To show the Cognos toolbar, select the Display Cognos toolbar check box.

Adding Changepoint Analytics reports and items to Changepoint
After a Cognos report or a other Cognos item has been created in Changepoint Analytics, you 
must perform a synchronization to add the report or item to Changepoint. The reports and 
items in the Team content folder in Cognos Analytics are synchronized with the Reports tree 
view in the Cognos report category in Changepoint. After the synchronization you can move 
the items to another report category.

You must perform the synchronization whenever you want to add newly created Cognos 
reports to, or remove deleted Cognos reports from, Changepoint.

To synchronize Cognos reports and other Cognos items

Click Reporting >Synchronize Cognos items. A message briefly appears when the 
synchronization is completed. 

About adding a custom ASP report
You can set up custom ASP reports that were created in another application, and make them 
available in Changepoint.

Warning: The development of custom ASP reports is not supported within the terms of 
your Changepoint support agreement. For more information, contact your Changepoint 
account manager.

The custom report file must first be added to the Changepoint web server. For more 
information, see the Changepoint Installation Guide.

If you define a report as an Internet website instead of an ASP page, you must include the 
protocol in the URL.

Adding a custom ASP report

1. Click Reporting > Report Setup.

2.  In the  Folders view, expand the report type and the report category.

3.  Click any report.

4.  Click New.

5.  In the Category list, select the report category.
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6.  In the Report name field, enter the name of the report.

7.  In the Description field, enter a description for the report.

8.  In the Report URL field, do one of the following:

• If the report is an ASP report that has been added to the Changepoint server, enter the 
URL, without the Changepoint domain, but including the file name (for example: 
/Core/Report/Custom/Reportname.asp).

• If the report is set up as an Internet website, enter the full path, including the protocol.

9.  Click Save.

Editing settings for an ASP report

You can edit only the name, description and URL of ASP reports. 

1. Click Reporting > Report Setup.

2.  In the  Folders view, expand the report type and the report category.

3.  Select the ASP report.

4.  Make the necessary changes.

5.  Click Save.

Removing an ASP report

You can remove an ASP report from the list of reports, but the report remains in the 
Changepoint application folder in which it is stored. Therefore, you can reinstate the report 
later, if required. 

1. Click Reporting > Report Setup.

2.  In the  Folders view, expand the report type and the report category.

3.  Select the ASP report.

4.  Click Delete.

5.  Click OK to confirm.
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About integrating reports into entity profiles
You can integrate an Changepoint Analytics report into an entity profile. You can select a 
report and integrate it into one or more entity profiles, or you can select an entity profile and 
integrate one or more reports into it. A report can appear as a section in the entity profile, or as 
an option in the Actions menu on the entity profile.

Depending on the report design, you can filter the report so that only the data that is specific to 
the entity appears. For example, the Project Budget report displays the budget information of 
projects, but also contains a project filter that is set up to display the budget information of a 
specific project. When you integrate the Project Budget report into a project profile, you can 
select the Project.ProjectName filter so that the report only displays the budget information 
of the selected project.

Integrating a  report into an entity profile

1. Click Reporting > Profile Page Integration.

2.  To integrate a report into one or more entity profiles:

a. In the Folders view, in the View by list, select Report.

b. To filter the reports, enter the filter text in the Filter by name field.

c. Click Search.

d. Expand the report category and select the report.

e. In the Entity column, locate the entity and proceed with step 4.

3.  To integrate one or more reports into an entity profile:

a. In the Folders view, in the View by list, select Profile page.

a. Select the profile page.

b. In the Report column, locate the report and proceed with step 4.

4.  To display the report as a section on the profile, select the Profile page check box. 

5.  To make the report accessible from the Actions menu of the profile, select the Actions 
menu check box.

6.  To filter the report so that only the data that is specific to the entity displays in the profile, 
select the filter field in the Link to filter column.
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7.  Click Save.
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About Client Portal management

Client Portal is the application that your organization’s clients can use to access Changepoint 
and view information that is related to their initiatives and projects. 

To set up Client Portal access:

1. Set up the Client Portal website. For more information, see the Changepoint Installation 
Guide.

2.  Enable the standard Client Portal email templates.  For more information, see "Enabling 
an email template" on page 276.

3.  Configure the options for accessing Client Portal. For more information, see 
"Configuring general Client Portal settings" on page 263.

4.  Resources create Client Portal users by granting access to client contacts. However, you 
can manage settings for individual Client Portal users. For more information, see 
"Managing Client Portal users" on page 265.

Configuring general Client Portal settings
You can configure the general settings for Client Portal, which include:

• a standard welcome message

• whether user access must be approved by the administrator

• access to resource profiles

• expiry periods

• email templates to be used for notifications

Note: You must select a standard Client Portal template in order for the corresponding 
notification to be sent.

1. Click Customer and Address > Client Portal Access.

The Client Portal Access view appears.

2.  Complete the fields as required. For more information, see "Client Portal Access view 
options" on page 264.
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Client Portal Access view options

Option Description

Enable Client Portal 
access check box

When selected, access to Client Portal is enabled.

Welcome text field Message text that is displayed when users sign in to Client 

Portal.

New  Client Portal users section

Approval of new users 

option

Specifies whether new Client Portal users are automatically 

approved, or must be approved by the administrator.

Default access period 
(days) field

Number of days after which the access to Client Portal 

automatically expires.

Invitation email list Email template for notifications that are sent to new Client 

Portal users.

Password reminder 
email list

Email template  for notifications that are sent to Client Portal 

users when their password is reset or a password reminder is 

sent.

Access resource 
profiles option

Determines the access that Client Portal users have to 

resource profiles. Options are:

• No access – users cannot access resource profiles.

• Sponsor’s profile only – users can access only the 

resource profile of their sponsor.

• Selected profiles – users can access the specified  

maximum number of resource profiles. The resource 

profiles must be specified for each Client Portal user. 

Note: If the maximum number is later reduced, the resource 

profiles that exceed the number (based on alphabetical 

order) are removed.

•  All profiles – users can access all resource profiles.

Expired Client Portal access section
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Option Description

Expiry period if not 
used (days) field

Number of days after a user last accesses Client Portal that 

their access will expire.

Closing email sent to 
Client Portal users list

Email template for notifications that are sent to  users when 

their Client Portal access expires.

Notify sponsor in 
advance (days) field

Number of days before a  user's access is about to expire that 

a notification is to be sent to the sponsor.

Expiry email sent to 
sponsor list

Email template for notifications that are sent to the sponsor 

when a Client Portal user's access is going to expire.

Sponsor notification emails section

Approved by 
administrator list

Email template for notifications that are sent to the sponsor 

when a user's access to Client Portal is approved by the 

administrator.

Rejected by 
administrator list

Email template for notifications that are sent to the sponsor 

when a user's access to Client Portal is rejected by the 

administrator.

Accessing a Client Portal user
1. Click Customer and Address > Client Portal User Management.

2.  In the Search by list, select Client Portal user or Client. 

3.  In the Search for field, do one of the following:

• Enter the first few letters of the user’s first name or the client name.

• Leave the field blank to display a list of all users.

4.  In the Status list, select a status or select All statuses. 

5.  Click Search.

6.  In the search results, select the Client Portal user.

Managing Client Portal users
You can  manage Client Portal users as follows:
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• reactivate access that has expired

• approve or reject access

• revoke access

• edit access settings – changes that you make override the settings on the contact profile

• reset passwords

• send password reminders

To edit a Client Portal user's access settings

1. Access the Client Portal user. 

2.  Make the necessary changes. For more information, see "Client Portal user view, General 
section options" on page 267 and "Client Portal user view, Security access section options" 
on page 268.

To reactivate  Client Portal user access 

1. Access the Client Portal user. 

2.  Select the Enable Client Portal access check box.

3.  In the Expiry date field, enter a new expiry date.

4.  Click Save.

To approve Client Portal user access

1. Search for Client Portal users that have Pending approval status. 

2.  In the search results, select a Client Portal user.

3.  Click Approve or Reject.

To revoke Client Portal access

If you revoke access for a Client Portal user, the sponsor must re-invite the Client Portal user 
in order to reactivate the access. 

1. Access the Client Portal user. 

2.  Click Revoke access
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To send a password reminder to a Client Portal user

1. Access the Client Portal user. 

2.  Click Send reminder.

Client Portal user view, General section options

Field Description

Enable Client Portal 
Access check box

When enabled, the user can access Client Portal (provided that 

the expiry date has not passed), and the security access fields 

become available.

User name Name of the Client Portal user.

Password Password assigned to the Client Portal user.

Email Email address of the Client Portal user.

Client Client organization of the Client Portal user.

Sponsor Name of the Changepoint resource who sponsored the Client 

Portal user. 

Current status Current status of the Client Portal user’s access.

Activated on Date that the Client Portal user was enabled.

Expiry date field Date that Client Portal access expires. If the access has 

expired, you can reactivate the access by changing the date to 

a date in the future.

Last access Date that the user last signed in to Client Portal.
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Client Portal user view, Security access section options

Option Description

Team folders check box When selected, the user can access team folders to which they 

have been added.

Project review check 

box

When selected, the users can review the projects related to 

their organization that have been enabled for Client Portal 

access. 

Cross Charge review 

check box

When selected, the user can view cross charges related to 

their organization.

Requests check box When selected, the user can create requests, view requests for 

their organization, and view the knowledge base.

Close request anytime 

check box

When selected, the user can close a request at anytime, 

regardless of the request workflow.

When cleared, the user can close a request only when the 

request workflow allows a transition to closed status. 

Workflow participant 
check box

When selected, the user can be assigned to a workflow step.

Access resource 
profiles check box

When selected, you can select or clear the Access all 
resource profiles and Restrict access to the following 
resource profiles check box.

Access all resource 
profiles check box

When selected, the user can access all resource profiles. 

Available only when access to all resource profiles is set up in 

the Client Portal Access view.

Restrict access to the 
following resource 
profiles check box and 

list

When selected, the user can only access the resource profiles 

that you select in the list. Available only when access to all 

resource profiles or selected profiles is set up in the Client 
Portal Access view.
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Setting up server integration

To launch applications from Changepoint, and enable other functionality, you must specify 
the URLs for each application.

1. Click General > Server Integration.

2.  Enter the URLs. The protocol is not required. If SSL is enabled, the system uses HTTPS.

3.  Click Save.

Server Integration view options

Option Description

Changepoint URL field Hosting site of the Changepoint application.

Enable Cognos integration 

check box

External dispatcher URI of the Cognos App Tier 

server. For more information, see the Changepoint 
Installation Guide.

Cognos application tier URL 

field

About setting up addresses
Most countries and their abbreviations are preloaded, but to make a country available for 
selection by users, you must enable it. You can add countries, states and provinces as 
required, and set up postal code formats. For more information, see the following topics:

• "Enabling a country " on the next page

• "Adding a country " on the next page

• "Adding states and provinces" on the next page

• "Modifying a state or a province" on the next page

• "Enforcing postal code formats" on page 271
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Enabling a country 

To make a country available for selection, you must enable it. You can also disable a country, 
provided that none of its states or provinces has been saved in a record 

1. Click Client and Address > Countries.

2.  In the country row, select the Enabled check box.

3.  Click Save.

Adding a country 

After you add a country, you can edit the name, but not the country codes. 

1. Click Client and Address > Countries.

2.  Right-click in the table, and then select Insert.

3.  To enable the country for use in Changepoint, select the Enabled check box.

4.  In the Country code field, enter the country code.

5.  In the Two-digit country code field, enter the two-digit code for the country.

6.  Click Save.

Adding states and provinces

1. Before you can create states or provinces for a country, you must enable the country.

2.  Click Client and Address > State/Province Lookups.

3.  Right-click in the table, and then select Insert.

4.  In the new row, select the country.

5.  In the State/Province column, enter the state or province name.

6.  In the Abbreviation column, enter the abbreviation for the state or province.

7.  Click Save.

Modifying a state or a province

You can change the name and abbreviation for a state or province. However, you cannot 
change the country. Instead, you have to delete the state or province and create a new one.

1. Click Client and Address > States/Province Lookups.
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2.  Make the necessary changes directly in the table cells.

3.  To delete a state or province:

a. Select the row.

b. Right-click and select Delete.

4.  Click Save.

Updating state and province information system-wide

You can change the name and/or abbreviation of a state or province and then automatically 
update all of the records that include the outdated information.

1. Create a state or province with the new name and/or abbreviation.

2.  In the row for the outdated state or province, select the name of the new state or province 
in the Map to column.

3.  Click Save.

Enforcing postal code formats

You can define formats for postal codes, and then enable validation to enforce the formats.

In postal code formats, X represents a letter and # represents a number. You can also enter 
spaces and dashes as part of the format. 

1. Click Client and Address > ZIP/Postal Code Validation.

2.  In the country row, select the Enabled check box.

3.  In the Format column, enter the format.

4.  Click Save.

Enabling client history tracking
You can enable history tracking for client-related information. When you enable history 
tracking, a History section displays on the profiles of contacts, candidates and other entities in 
Changepoint.

1. Click Client and Address > Client History Tracking.

2.  Select the Enable client history tracking check box.

3.  Click Save.
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About email notifications
There are two main types of email notifications that you can set up to notify users when a 
specific event occurs:

• entity-based email notifications – are based on conditions related to a specific entity

• trigger-based email notifications – are based on an event that is specified in a trigger or 
scheduled job

About setting up entity-based email notifications

1. Create and configure an email template, which includes the email subject and message 
body content. For more information, see "Creating an email template" on page 274.

2.  Create and configure the email notification, which includes the recipients and conditions 
for sending the email notification. For more information, see "Setting up an entity-based 
email notification" on page 281.

3.  Ensure that the Changepoint Email Notification Service and Changepoint Mail Service are 
installed and running. For more information, see the Changepoint Installation Guide.

About setting up trigger-based email notifications

1. A database administrator must create the trigger or scheduled job for the notification. For 
more information, see "Guidelines for creating triggers or scheduled jobs for email 
notifications" on page 281.

2.  Create and configure an email template, which includes the parameters for the merge fields 
and quick links and text for the email subject and message body. For more information, 
see "Creating an email template" on page 274.

3.  Ensure that the Changepoint Mail Service is installed and running. For more information, 
see the Changepoint Installation Guide.

About standard Changepoint email templates

There are different variations of email templates that are supplied with Changepoint:

• Internal Changepoint email templates are used internally in Changepoint and cannot be 
edited at all.
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• Standard email templates and Client Portal templates are predefined, but some settings are 
editable. For example, you can enable them for use in Changepoint, and edit the wording 
in the email subject and message. 

Warning: Do not rearrange, or add or delete parameters in any of the standard email 
template fields. If you do, the parameters will not be resolved properly in the email 
notifications.

Only the Client Portal templates can be selected from the Client Portal Access view, where 
you select the templates to be used for Client Portal notifications.

Email templates that support quick links

The following is a list of the standard email templates that support quick links.  

Note: Email recipients must be able to access the target entity record.

• Credit Notes to Approve

• Expense Reports to Approve

• Cross Charges to Approve 

• New Task

• Notification: Request Information to Initiator

• Project Reassigned to You

• Resource Demand Scenario Approval

• Resource Demand Scenario Rejection

• Resource Request Assigned to You

• Support Request is Closed

• Support Request Submitted Through the Client Portal

• Support Request Submitted Through the Client Portal is Closed

• Task Slippage

• Time Records to Approve

• Workflow Notification
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About email templates

Email templates contain the standard settings for the  related email notifications, which include 
the following:

• enabling the template for use

• specifying HTML format

• preventing resources from disabling the associated email notification

• grouping email notifications so that only one email is sent to each recipient

• specifying the text in the subject and message fields

• adding merge fields and quick links to the subject and message fields of an email template

• Merge fields – Merge fields consist of a parameter that is replaced with the actual 
values when the email notification is sent. For entity-based templates, the parameters  
are based on the entity fields.  Subentities inherit the parameters of the parent entity. 
For example, the ProjectTeam entity includes the parameters of the Project entity. 

Note: You must create custom parameters for trigger-based notifications.

• Quick links – Quick links are links that a resource can click in the email notification to 
access an entity page. Not all entity types have a quick link option.

About standard Changepoint email templates

The following types of email templates are supplied with Changepoint:

• system email templates – cannot be edited because they are used for internal Changepoint 
processes.

• standard email templates – you can enable or disable them, and edit the wording in the 
email subject line and message body. 

Note: All standard Changepoint email notifications are trigger-based.

Warning: Do not rearrange the order of the parameters, or add parameters to or remove 
parameters from, the standard email template fields. Otherwise the parameters will not be 
resolved properly in the email notifications. 

Creating an email template

1. Click General > Email Templates.

2.  In the Folders view, click an existing email template.
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3.  Click New.

4.  Complete the fields in the General section. For more information, see "Email Templates 
view, General section options" on page 275.

5.  In the Template information section specify the template details. For more information, 
see "Email Templates view, Template information section options" on page 276.

6.  To add merge fields to the subject or body of the message, see "Adding a merge field to an 
email template" on page 277.

Note: If the email template is to be used in a workflow, use only the quick link or merge 
field parameters  that contain name, description, or ID. The other types of merge fields 
cannot be processed in a workflow.

7.  Click Save.

Email Templates view, General section options

Option Description

General section

Enable this email 
template to be used in 
Changepoint check box

When selected, the template is available in Changepoint.

Enable HTML text check 

box

When selected, the body of the email message is in HTML 

format instead of plain text.

Changepoint email 
template provided for 
internal email 
notifications check box

When selected, indicates the template is an internal 

Changepoint email template or Client Portal email template.
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Option Description

Hide this email template 
in user preferences 

check box

When selected, the email template is not displayed in the 

Preferences view and resources cannot disable the 

corresponding email notification. 

Send only one email to 
each recipient check box 

When selected, all of the records that meet the condition of 

the email notification are sent together in one email instead of 

sending several emails to the same recipient. Available only 

when an entity type is selected in the Template information 

section. 

Email Templates view, Template information section options

Option Description

Entity type list When an entity type is selected, the email template is entity-

based. When the field is left blank, the email template is 

trigger-based.

Subtype list Available only when the Time entity is selected. Subtype for 

the entity.

Template name field Name of the email template.

Description field Description for the email template.

Subject field Text that appears in the subject line of the email.

Message field Text for the body of the email message.

Enabling an email template

You cannot disable email templates that are associated with an active email notification.

1. Click General > Email Templates.

2.  In the Folders view, select the email template. 

3.  Select the Enable this email template to be used in Changepoint check box.

4.  Click Save.
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Modifying an email template

You cannot edit system email templates.

1. Click General > Email Templates.

2.  Select the email template.

3.  To edit the template:

a. Make the necessary changes.

b. Click Save. 

4.  To delete the email template, click  Delete.

Adding a merge field to an email template

1. Click General > Email Templates.

2.  Select the email template.

3.  Create the parameters for the merge fields and quick link:

a. In the Template information section, right-click in the Subject or Message field and 
select Manage > Parameters. 

b. The Email Parameters dialog box appears.

c. Right-click in the table, and then select Insert.

d. In the Email parameter cell, do one of the following:

• To create a parameter for an entity-based notification, select the entity field for the 
parameter.

• To create a parameter for a trigger-based notification, enter the parameter.

e. In the Description cell, enter the description of the parameter.

f. Click  Save.

4.  To insert a merge field, right-click the subject or message at the location where you want 
to insert the merge field and then select the parameter or quick link. 

Note: If the email template is used for a trigger-based email notification, you must ensure 
that the order of the merge fields and quick link in the email template match the order in 
the trigger or scheduled job.
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5.  To remove a merge field from a subject or message, delete the entire merge field including 
the "ÿ" character.

Creating an email parameter

1. Click General > Email Templates.

2.  Select the email template.

3.  In the Template information section, right-click in the Subject or Message field and 
select Manage > Parameters. 

The Email Parameters dialog box appears.

4.  Right-click in the table, and then select Insert.

5.  In the Email parameter cell, do one of the following:

• To create a parameter for an entity-based notification, select the entity field for the 
parameter.

• To create a parameter for a trigger-based notification, enter the parameter.

6.  In the Description cell, enter the description of the parameter.

7.  Click  Save.

The new parameter is now available for selection when you right-click in the subject or 
message fields in the email template. 

Editing an email parameter

If you change the order or the order of appearance of the merge fields in an email template, 
you must modify the associated trigger.

1. Click General > Email Templates.

2.  Select the email template.

3.  In the Template information section, right-click in the Subject or Message field and 
select Manage > Parameters. 

The Email Parameters dialog box appears.

4.  To edit a parameter:

a. Make the necessary changes.

b. Click Save.
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5.  To delete a parameter:

a. Right-click the parameter and then select Delete. 

b. Click OK to confirm.

c. Click Save.

About grouping records for email notifications

You can group entity-based email notifications so that a single email that includes all entity 
records is sent to each recipient rather than a separate email for each entity record. 

You can group email notifications for system-defined participants or configurable field 
participants only, which you specify as recipients in the To field of the email notification. 

In the email template, you must do the following:

• Select the Send only one email to each recipient check box. 

• Add <REPEAT></REPEAT> tags around the parameters in the message body so that each 
record will be included in the email. If a parameter is outside of the REPEAT tags, only the 
first record is included in the email notification.

Note: Ensure that you capitalize the <REPEAT></REPEAT> tags, otherwise the template will 
not work.

Recipients in the Cc and Bcc fields are sent a copy of each email notification for which they 
have access to one or more of the entity records.

Warning: Data access checking is not performed on the message content of email 
notifications. Therefore, they can contain data to which the Cc and Bcc recipients may not 
otherwise have access. 

Example of grouping records for email notifications

In the email template, the option to send one email to each recipient is selected, and the 
Message field contains the following content:

 Some of your time has been rejected. 

 Here are the details:

 

 <REPEAT>

 Resource: ÿTime - Resourceÿ 

 Date of time record:  ÿTime - TimeDateÿ 

 Regular Hours:  ÿTime - RegularHoursÿ 

 Rejected by:  ÿTime - ApproverResourceÿ 

Changepoint Administration | 279



13. General Setup

 Reason for Rejection:  ÿTime - RejectReasonÿ 

</REPEAT>

Note: The resource name is included within the REPEAT tags because the time records 
for more than one resource may be contained in the same email notification. 

There are five rejected time records, all of which were entered by Resource C on behalf of 
Resource A and Resource B as outlined in the following table.

Time record Resource Project manager

1 Resource A Project Manager 1

2 Resource A Project Manager 2

3 Resource B Project Manager 2

4 Resource B Project Manager 2

5 Resource B Project Manager 1

To group by resource, resource who entered the time, and project manager, you add the 
following system-defined participants to the To field in the email notification:

• Time - Booked by resource

• Time - Resource

• Time - Project manager

The results are:

• Resource C, who entered the time, receives one email with time records 1, 2, 3, 4, and 5.

• Resource A receives one email with their own time records 1 and 2.

• Resource B receives one email with their own time records 3, 4, and 5.

• Project Manager 1 receives one email with time records 1 and 5, which are the time 
records for their own projects.

• Project Manager 2 receives one email with time records 2, 3, and 4, which are the time 
records for their own projects.
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However, if you instead add the Time - Project manager participant to the Cc or Bcc field, then 
both project managers would each receive three separate emails that contain the information as 
follows:

• time records 1, 2, 3, 4, and 5 (copy of email sent to the Resource C)

• time records 1 and 2 (copy of email sent to Resource A)

• time records 3, 4, and 5 (copy of email sent to Resource B)

Guidelines for creating triggers or scheduled jobs for email notifications

Before you can configure an email template for a trigger-based email notification, a database 
administrator must do the following: 

• Create a trigger or scheduled job to populate the EmailQueue table. The Changepoint Mail 
Service retrieves the entries from the EmailQueue table and sends the email notification for 
the enabled templates. 

• Modify the associated trigger or scheduled job that populates the EmailQueue table with 
the logic and formatting for embedded links if quick links are included in the subject or 
message. For more information, see "Sample code for embedded quick links" on page 288.

• Ensure that the names of the parameters for the merge fields of the email template match 
the associated field names in the Changepoint database. 

Note: If the number or the order of the merge fields in the email template is changed, you 
must also modify the associated trigger or scheduled job that populates the EmailQueue 
table accordingly.

• Test all trigger-based email notifications after installing any subsequent releases of the 
Changepoint software. Changes to the Changepoint database may require revisions to the 
triggers.

Setting up an entity-based email notification

You must create an email template before you can set up an email notification. 

1. Click General > Email Notifications.

2.  In the Entity type list, select the entity type of the email template, and then click Load 
list.

3.  Select any email template.
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4.  Click New.

5.  Complete the fields In the General section. In the From field, enter the email address to 
use as the From address on the email notification. If no address is specified, the default 
value from the Changepoint Mail Service is used.

6.  In the Email Recipients section, specify the email recipients. For more information, see 
"Adding recipients to an email notification" on page 282.

7.  In the Create Conditions section, set up the conditions for when the email notifications 
are to be sent, see "Setting up conditions for an email notification" on page 283. 

8.  Click Save.

Adding recipients to an email notification

1. Access the email notification. 

2.  Expand the Email Recipients section.

3.  In the From field, enter the email address or name of the sender. If you leave the field 
blank, the default value from the Changepoint Mail Service is used.

4.  Click To, Cc, or Bcc.

The Email Recipients dialog box appears.

5.  To add email recipients manually, in the Enter the email addresses of the recipients 
field, enter the email addresses separated by semicolons.

6.  To add resources, workgroups, roles, or system-defined participants as recipients:

a. To search for an item, enter the search text and then click Search.

b. To display the tree view, clear the Show selected items only check box, ensure that 
the search field is empty, and then click Search. 

c. Select one or more items.

d. To display the selected items only, select the Show selected items only check box, 
ensure that the search field is empty, and then click Search. 

7.  Click Save.
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About setting up conditions for an email notification

You create the conditions for sending an email notification by creating expressions based on a 
specific field value or on a change to a field value. You then use one or more expressions to 
build a conditional formula. You can also add additional conditions based on an SQL SELECT 
statement.

Conditions based on an SQL SELECT statement

After you create a conditional formula, you can configure additional conditions based on a 
SQL SELECT statement. The SQL SELECT statement is executed only if the conditions in the 
conditional formula are met.

The SQL statement must:

• Begin with SELECT

• Not contain UPDATE, DELETE, TRUNCATE or INSERT

• Return "1" (numeric) to indicate that the email notification should be sent or "0" to indicate 
that the email notification should not be sent.

• Use @Entityid as a parameter to represent the GUID of the entity in the SELECT 
statement. For example:

WHERE requestid = @entityid

To avoid creating deadlocks in the system, be sure to include "FROM table WITH (NOLOCK)” 
in your SELECT statement. 

The following is an example:

SELECT

CASE 

WHEN count (*) >=1 THEN 1

ELSE 0

END

FROM request WITH (NOLOCK)

WHERE customerid = @entityid AND requeststatus NOT IN ('clo','rej','can')

This SQL SELECT statement could be combined with a simple condition formula so that an 
email notification is sent to the operations center personnel when a client’s status changes to 
inactive and there are active requests so that work could be stopped on the requests.

Setting up conditions for an email notification

1. Create or access the email notification.
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2.  Expand the Configure Condition section.

To create an expression

1. Do one of the following:

• To define an expression based on when a field value changes from a specified value to 
another specified value, select the Condition based on field change option. 

• To define an expression based on when a field value meets a specified condition, 
select the Condition based on field value option. 

2.  In the Expression field, enter a name for the expression.

3.  In the Field name list, select the field to be used in the expression.

4.  If the condition is based on a field value, in the Condition list, select the condition. 

5.  If the condition is based on a field value change, in the From value and To value fields, 
select the values. Leave the field blank to specify that any value will meet the condition.

For request fields that relate to users, an Any condition is available to specify Changepoint 
users or Client Portal users.

6.  Complete the expression by entering values in the fields. 

To build the condition formula

1. To add an expression to the Formula expression field, double-click the expression in the 
table.

2.  To add an operator, bracket, or space, click the appropriate button.

3.  To test that the formula, click Test Formula. 

4.  To clear the formula and start over, click Clear Formula. 

5.  To view the expressions in the formula in expanded format, select the Display expanded 
conditional formula check box.

6.  To add an additional condition based on an SQL SELECT statement:

a. Select the Configure notification based on Select statement check box. 

b. In the SQL statement field, enter the SQL SELECT statement. For more information, 
see "About setting up conditions for an email notification" on page 283.
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7.  Click Save.

Modifying an entity-based email notification

1. Click General > Email Notifications.

2.  In the Entity type list, select the entity type of the email template.

3.  To filter the list of email templates, select the email template or the status of the email 
notification.

4.  Click Load list.

5.  Select the email notification.

6.  Make the necessary changes. 

7.  Click Save.

Sample trigger for trigger-based email notifications

The following code is provided only as a sample of how a trigger can be created to interact 
with the Changepoint business logic.

Note: The sample code is provided for reference purposes only. Custom triggers are not 
supported within the terms of your Changepoint support agreement. It is expected that an 
individual who is knowledgeable in both SQL code and your organization’s business 
practices be responsible for creating and maintaining custom triggers. Custom triggers can 
potentially degrade performance. If you require assistance, contact your account manager 
to arrange for chargeable consulting services. 

Sample code

The following is sample code for a trigger-based email notification to be sent to a resource 
who has been assigned as project plan editor of a project.

CREATE TRIGGER OnCoManagerAssignment ON [CoManageMember] 

FOR INSERT

AS

declare @EmailId id

declare @EmailAddress varchar(50)

declare @ProjectName varchar(50)

 

select @EmailId = EmailId from Email where Name = 'On Co-Manager Assignment' 

AND Enabled = 1

 

IF @EmailId is null
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RETURN

 

SELECT @EmailAddress = ra.EmailAddress FROM ResourceAddress ra, inserted i

WHERE ra.ResourceId = i.ResourceId

 

SELECT @ProjectName = p.Name from Project p, inserted i where p.ProjectId = 

i.ProjectId

 

Insert EmailQueue(emailqueueID, EMailId, ToEmail, CCEmail, BcEmail, 

SubjectParameters, BodyParameters) 

VALUES(newID(), @EmailId, @EmailAddress, NULL, NULL, NULL, @ProjectName) 

VALUES(@EmailId, @EmailAddress, NULL, NULL, NULL, @ProjectName)

Notes:

• Reference the email template name.

• The appropriate email template record is selected only if it is enabled.

• The email address is selected in the resource profile and the project name is selected in the 
project profile.

• The values are then inserted into the EmailQueue table.

• The values entered into the parameters field correspond to the tags in the email template 
and are separated with a pipe "|" character. They must be placed in the same order as the 
tags in the message body.

Sample scheduled job for trigger-based email notifications

The following code is provided only as a sample of how a scheduled job can be created to 
interact with the Changepoint business logic.

Note: The sample code is provided for reference purposes only. The creation of scheduled 
jobs is not supported within the terms of your Changepoint support agreement. It is 
expected that an individual knowledgeable in both SQL code and your organization’s 
business practices be responsible for creating and maintaining scheduled jobs. If you 
require assistance, contact your account manager to arrange for chargeable consulting 
services. 

Sample code

The following is sample code for a trigger-based email notification to be sent to managers of 
projects with expenses that have gone over budget. 
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The scheduled job runs every day at midnight. The parameters stored in the EmailQueue table 
are: ProjectName, ExpenseBudget and Overage. 

Stored Procedure:

/*********************************************

Name:ExpensesOverBudget

 

Description:Stored procedure retrieves all projects exceeding expense budget 

and sends emails to those managers

 

Used By:Changepoint scheduled job - 

 

Inputs:n/a

 

Change History:

DateNameChange

03.02.2000Rodney BotelhoInitial Version 

********************************************/

 

CREATE PROCEDURE ExpensesOverBudget /*%ENCRYPT%*/ AS

 

--Retrieve E addresses for all project managers

DECLARE @EmailTemplateId id

DECLARE @EmailAddress varchar(256)

DECLARE @ResId id

DECLARE @ProjectName varchar(256)

DECLARE @ExpenseTotals currency

DECLARE @ExpenseBudget currency

DECLARE @Overage currency

 

SELECT @EmailTemplateId = EmailId FROM Email WHERE Name = 'Project Expenses 

Over Budgeted Amount'

IF @EmailTemplateId is null

RETURN

 

DECLARE Email_Cur CURSOR FOR

SELECT ra.EmailAddress, m.ResourceId, p.Name, p.ExpenseBudget,  'ExpenseTotals' 

= sum(e.UnitPrice * e.Quantity) FROM ResourceAddress ra, ManageMember m, 

project p, Expense e

WHERE ra.ResourceId = m.ResourceId AND p.ProjectId = m.ProjectId AND 

e.ProjectId = m.ProjectId AND p.ExpenseBudget is not null AND

len(RTRIM(LTRIM(ra.EmailAddress))) > 0 GROUP BY

ra.EmailAddress, p.Name, p.ExpenseBudget, m.ResourceId

 

OPEN Email_Cur
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--Fetch first record

 

FETCH NEXT FROM Email_Cur INTO @EmailAddress, @ResId, @ProjectName, 

@ExpenseBudget, @ExpenseTotals

 

WHILE @@FETCH_STATUS = 0

 

BEGIN

IF @ExpenseTotals > @ExpenseBudget

BEGIN

SET @Overage = @ExpenseTotals - @ExpenseBudget   

INSERT EmailQueue(EmailId, ToEmail, BcEmail, CcEmail, SubjectParameters, 

BodyParameters) VALUES (@EmailTemplateId, @EmailAddress, NULL, NULL,

@ProjectName + ';' + cast(@ExpenseBudget as varchar(50)) + ';' + cast(@Overage 

as varchar(50)))

END

 

FETCH NEXT FROM Email_Cur INTO @EmailAddress, @ResId, @ProjectName, 

@ExpenseBudget, @ExpenseTotals

 

END

 

CLOSE Email_Cur

DEALLOCATE Email_Cur

/*********************************************

Sample code for embedded quick links

When you embed a quick link in an email template that is used for trigger-based email 
notifications, you must modify the triggers and scheduled jobs that populate the EmailQueue 
table to include the following logic for the embedded link.

The following is sample code for a trigger that includes an embedded quick link to a client 
record.

--Get the Language of the database.

set @dbLanguage = (select dbLanguage from Version)

 

--Get the “Please click on this link” text.

set @LinkText = (select ContentShort  from PageContent where PageContentId = 

70019 and Language = @dbLanguage)

 

set @QuickLinkURL = @ChangepointURL + '?entityId={' + convert(varchar

(38),@CustomerId) + '}&qlink=CUS'

 

if @HTML = 1 

set @QuickLinkText = '<a href="' + @QuickLinkURL + '">' + @LinkText + '</a>'
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else

set @QuickLinkText = @QuickLinkURL

Trigger notes for embedded quick links

Set @QuickLinkURL identifies the Changepoint server, and the entityId contains the GUID 
of the specific page that will be displayed when the user clicks the embedded link. The qlink 
parameter should be at the end of the link so that the closing bracket of the entity GUID is not 
dropped when it appears in an email. The following is a list of the qlink parameters for each 
entity type.

ENG Initiative

PRJ Project

TSK Task

REQ Request

OPP Candidate

PRD Application

KNI Knowledge Item

TIM Time Approval

EXP Expense Approval

INI Cross Charge

INC Credit Note

RRQ Request Workflow

RRT Resource Request Workflow

WRK Project Workflow

CCA Cross Charges to Approve

CNA Credit Notes to Approve

ATM Resource Demand 

VEX Expense Sheet

WFO Candidate Workflow

Setting up email integration
You can specify the URLs for the hyperlinks to Changepoint components that are in email 
notification messages.

Note: Quick Links use the Changepoint server URL that is specified in Server 
Integration.

1. Click General > Email Integration.

2.  In the Client Portal URL field, enter the URL for the Client Portal (format: 
http://server:port/fcElogin.asp). 
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3.  In the Survey response website URL field, enter the URL for resources to access the 
survey response website. 

4.  Click Save.

Enabling alternate names
You can set up a second field for names of clients, candidates, initiatives, workgroups, 
resources, and projects to be entered and displayed in another language or using another 
alphabet. When the option is enabled, the following occurs:

• The alternate name is displayed next to the entity name in the format: Entity name - 
Alternate name in the affected entity profiles and edit dialog boxes, Recently viewed lists 
and entity tree views. 

• Filter criteria in the entity tree views can be based on alternate names

Note: If the alternate name functionality is enabled and then subsequently disabled, the 
existing alternate names will continue to be displayed in titles of entity profiles and edit 
dialog boxes unless the alternate names are deleted first.

1. Click General > Alternate Name Setup.

2.  Select the Enable alternate names check box.

3.  Click Save.

Setting up name formatting
You can specify how the names for resources and contacts are displayed. There are separate 
formats for Asian and non-Asian languages. The default format is Last Name, First Name. 

The proper full name format for Chinese, Japanese, and Korean names is 
LastName FirstName.

If you change the format, the new name format is applied to existing names only after the 
record containing the name is subsequently edited. However, you can run the 
UpdateFullNames stored procedure to change all names to the new setting.

1. Click Resources > Custom Name Formatting.

2.  In the Default name format list, select the format to use for non-Asian names.

3.  In the Asian name format list, select the format for Asian language names.

4.  Click Save.
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Setting up sign in and password validation
You can set password rules and require resources to use passwords that follow specific 
requirements.

1. Click Resources > Sign in and Password Validation.

2.  Set the password rules. For more information, see "Sign in and Password Validation view 
options" on page 291.

3.  Click Save.

Sign in and Password Validation view options

Option Description

Force user to change password at first 

sign in

When set to Yes, resources must change their 

passwords when signing into Changepoint for the 

first time, and after their password has been reset.

Number of days until the password 

expires

Valid values: 

• 0 – no expiry

• 1 to 999

Number of days before the password 

can be changed

Valid values: 

• 0 – resources can change their passwords at 

anytime

• 1 to 31

Number of unsuccessful sign-in 

attempts before the account is locked

Valid values: 

• 0 – no limit

• 1 to 255

Default value: 10

Password complexity rules

Prevent the use of the user’s first 

name and/or last name as the 

password

When selected, the resource’s first name and/or 

last name as specified in Resource Setup cannot 

be used, regardless of case.

Force an alphabetic character in the 

first position

When selected, the first character in the password 

must be alphabetic.

Changepoint Administration | 291



13. General Setup

Option Description

Force an alphabetic character in the 

last position

When selected, the last character in the password 

must be alphabetic.

Minimum number of characters Valid values: 

• 0 – no minimum

• 1 to 50

Maximum number of characters Valid values: 

• 0 – no maximum

• 1 to 50

Maximum number of times the same 

character can be used consecutively

Valid values: 

• 0 – no maximum

• 2 to 50

Maximum number of characters that 

can be the same as in the previous 

password

Valid values:

• 0 – no maximum

• 1 to 50

Minimum number of uppercase 

characters

Valid values: 

• 0 – no minimum

• 1 to 50

Minimum number of lowercase 

characters

Valid values: 

• 0 – no minimum

• 1 to 50

Minimum number of numeric 

characters

Valid values: 

• 0 – no minimum

• 1 to 50
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Option Description

Minimum number of special 

characters

Valid values: 

• 0 – no minimum

• 1 to 50

Special characters are the following characters:
~!@#$%^&*()_=-+{}[]\:";'<>,.?/

Note: The pipe symbol ( | ) and spaces are not 

allowed in passwords. Leading and trailing spaces 

in passwords are removed.

Number of unique passwords 

required before a password can be 

reused

Valid values: 

• 0 – unique passwords are not required

• 1 to 100

Enabling secure socket layer support (SSL)
Enabling secure socket layer (SSL) support requests all internal ASP pages with HTTPS 
protocol to ensure a secure internal environment.

The IIS server must also be configured to support SSL.

1. Click General > Session Security.

2.  Select the Enable SSL support check box.

3.  Click Save.

Enabling enhanced session management

You can prevent active links from being sent by email to unauthenticated resources.

When enhanced session management is enabled,  Changepoint is locked and only one active 
session per browser container is supported. In order to manage two or more active browser 
sessions, the browser session must be launched from the Start menu bar and users have to sign 
on again, as opposed to reusing an open browser container. 

When using this feature, ensure that the server name does not contain an underscore, otherwise 
client workstations will have to connect to the server using the IP address instead of server 
name in order to sign in to Changepoint.
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Note: When enhanced session management is enabled, the browser must be set to accept 
cookies. Also, if the server name contains an underscore, resources must use the IP address 
instead of the server name to sign in to Changepoint.

1. Click General > Session Security.

2.  Select the Enhanced session management check box.

3.  Click Save.

About setting up auto-numbering
You can define the numbering format for the following entity types: client, initiative, projects, 
revenue recognition batch and resource request. You can also use a custom stored procedure 
for numbering.

When auto-numbering is enabled, the ID fields are disabled on the client and initiative dialog 
boxes and the project editing view in Changepoint. Also, metadata rules for these ID fields 
will not be applied. When auto-numbering is disabled, normal metadata rules apply to these ID 
fields in Changepoint.

Warning: If your organization has an integration between Changepoint and Microsoft 
Dynamics GP, auto-numbering cannot be used for clients in Changepoint. Microsoft 
Dynamics GP creates its own client IDs. The relevant ID field must be left empty in 
Changepoint before the export. For more information, see the Microsoft Dynamics GP 
Toolkit Administration Guide.

Setting up the auto-numbering scheme

The numbering options that are available depend on the selected entity type.

1. Click General > Auto-Numbering Setup.

2.  Expand the General section.

3.  In the Entity type list, select an entity type.

4.  Select one of the following options:

• To disable the auto-numbering functionality for the selected entity, select the Do not 
use auto-numbering option. Users can enter their own unique IDs for the entity in the 
entity dialog box in Changepoint.
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• To create a numbering scheme, select the Use numbering scheme option and enter the 
appropriate information in the numbering scheme section. For more information, see 
"Numbering scheme options" on page 296. 

• To use a custom stored procedure, select the Use custom stored procedure option and 
select the appropriate custom stored procedure in the Auto-numbering stored 
procedure list. All stored procedures with the prefix “AN_” display in the drop-down 
list. For more information, see "Requirements for auto-numbering stored procedures" 
on page 295.

Note: If you switch to using a stored procedure for resource requests, but decide to revert 
to the original numbering scheme, the request numbers will start at 1 again. 

5.  Click Save.

Requirements for auto-numbering stored procedures
Warning: Custom stored procedures are not supported within the terms of your 
Changepoint support agreement. It is expected that an individual knowledgeable in both 
SQL code and your organization’s business practices be responsible for creating and 
maintaining stored procedures. If you require assistance, contact your account manager to 
arrange for chargeable consulting services. Your Changepoint support analyst will be 
unable to assist you in this area.

The following are guidelines for creating custom stored procedures for the auto-numbering 
function:

• All custom stored procedure names must start with AN_ and the name cannot longer than 
30 characters.

• Custom stored procedures must not contain any of the INSERT/UPDATE/DELETE/TRUNCATE 
statement against any Changepoint table except for table AutoNumberUsed.

• The custom stored procedure object owner must be dbo, for example:

 CREATE PROCEDURE [dbo].AN_GetNextXXXNumber

• Inputs should be:

 @EntityCode char(3)

@ReferenceID uniqueidentifier 

The default values are null id

• Output should be:
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 @UserDefinedID  nvarchar(255) output

Sample custom stored procedure for auto-numbering:

CREATE PROCEDURE [dbo].AN_GetNextXXXNumber (@EntityCode char(3), 

@ReferenceID uniqueidentifier = '00000000-0000-0000-0000-000000000000', 

@UserDefinedID  nvarchar(50) output)

AS

DECLARE @LastNumber bigint

 

BEGIN TRANSACTION

SELECT @LastNumber = LastNumberUsed

FROM AutoNumberUsed (UPDLOCK)

WHERE EntityCode = @EntityCode and ReferenceID = @ReferenceID

IF @LastNumber is null 

BEGIN

set @LastNumber  = 1

Insert into AutoNumberUsed (EntityCode, ReferenceId, LastNumberUsed)

values( @EntityCode, @ReferenceID ,  @LastNumber+1)

END

ELSE

BEGIN /* increase LastNumberUsed by 1*/ 

UPDATE AutoNumberUsed SET LastNumberUsed = @LastNumber + 1

WHERE EntityCode = @EntityCode and ReferenceID = @ReferenceID

END

COMMIT TRANSACTION

 

Set @UserDefinedID = null

Set @UserDefinedID = 'Prj - ' + right( replicate(0, 5) + convert(varchar, 

@LastNumber), 5)

/* the new user defined id is "Prj - 00001" */

return

GO

SET QUOTED_IDENTIFIER OFF 

GO

SET ANSI_NULLS ON 

GO

GRANT  EXECUTE  ON [dbo].[AN_GetNextXXXNumber]  TO [CPACCESS]

GO

GRANT EXECUTE ON [dbo].[AN_GetNextXXXNumber] TO [Changepoint] 

GO

Numbering scheme options

The following numbering scheme options apply to auto-numbering, export batch numbering, 
and request numbering.
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Enter values in at least one of the parts (A,B, or C). For examples of how to set up this section, 
see "Numbering scheme examples" on page 298.

Option Description

Starting value fields Initial value for part A, B, or C of the number.  Only numeric 

values can be incremented. The maximum value is 

determined by the number of digits.

For example, if you enter “000”, the maximum value is “999”. 

When the maximum value has been reached, the value is 

reset to the starting value.

Increment options Increments the starting value. Options are:

• Never – The value remains constant.

• Every time – The value increases by one each time a 

record is created.

• Annually – The value increases by one on the selected 

rollover date.

• On part B rollover – When the value in part B reaches its 

maximum value, part B is reset to its starting value, and 

part A increases by one.

• On part C rollover – When the value in part C reaches its 

maximum value, part C is reset to its starting value, and 

part B increases by one.

Separator text fields and 

options

Character or space that separates the parts of the number.

• No separator
• Use space
• Character

Reset numbering on 
rollover of previous part 
check box 

When selected, causes the part to be reset when the previous 

part reaches its maximum value. 

Note: If On part B rollover is selected, the Reset 
numbering on rollover of previous part setting is ignored.

Next rollover date field Date on which the part number is set to change annually. This 

is usually the first day of the new fiscal year.
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Numbering scheme examples

Example 1

The following settings generate numbers that always begin with CAN and the current year, 
and end with a number based on the sequence in which records are created. A hyphen 
separates the number parts.

For example: CAN-2014-00001, CAN-2014-00002, CAN-2014-00003, and so on.

Example 2: Resetting numbering on rollover of previous part

If part A is “CAN”, part B has the starting value “2014” and increments annually, part C is set 
at 00000 and the next rollover date is set to 1/1/2015, then on January 1, 2015 the record 
number resets to CAN-2015-00000.

About setting up custom stored procedures for portfolio health
Changepoint provides a standard project and portfolio overall health calculation for the 
numeric equivalent of the red (3), yellow (2) or green (1) status of each metric multiplied by 
the metric weighting. You can replace the existing calculation and create custom stored 
procedures to generate the red/yellow/green status. If you create custom stored procedures, 
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they will be available for selection on the Health tab when creating or editing portfolios in 
Changepoint. The selected stored procedures will replace the health calculation for the items in 
the portfolio, and the overall health of the portfolio. It will also determine the color status for 
each item. 

Warning: Custom stored procedures are not supported within the terms of your 
Changepoint support agreement. It is expected that an individual knowledgeable in both 
SQL code and your organization’s business practices be responsible for creating and 
maintaining stored procedures. If you require assistance, contact your account manager to 
arrange for chargeable consulting services. Your Changepoint support analyst will be 
unable to assist you in this area.

The following are guidelines for creating custom stored procedures for portfolio item and 
portfolio overall health:

• The name of the custom stored procedure must begin with either PFHI_ (for portfolio 
health item) or PFHS_ (for portfolio health summary). The name is not case sensitive. The 
name cannot be longer than 30 characters.

• Custom stored procedures must not contain INSERT/UPDATE/DELETE/TRUNCATE commands.

• The custom stored procedure object owner must be dbo. 

• The four input parameters are:

ProjectID     GUID

FiscalYearID     GUID

FiscalPeriodID     GUID

ProjectStatus     varchar(3)

The ProjectID parameter can be used for both project and rollup portfolios. The SQL 
code itself should distinguish between the types of records, if necessary.

• The output parameter is:

ColourCode     varchar(1)

The custom stored procedure should return either R, G, Y, W or "". Any other return value will 
be treated as W by the portfolio pages.
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About survey management

Using Survey Management, you can create and send surveys, and analyze the survey 
responses. You can create entirely new surveys, or use a corporate or personal template as a 
starter. You can add images to the header of the survey (for example, a logo) and watermarks 
to the survey page.

You can create surveys that can be sent automatically when a specific trigger event occurs in 
Changepoint, such as an approved candidate, a completed project, or a closed request. 

You can include rating questions in your surveys to allow clients and resources to provide 
feedback on the performance of resources and projects. 

After a survey has been completed, you can view individual or combined survey results in 
reports. Survey results can also be exported as a tab-delimited file or as an XML file, for 
further analysis and review.

About accessing surveys

You can access surveys from the following areas in Changepoint:

• Surveys tree view.

• Dashboards – You can set up surveys to be displayed in the Survey Management portlet 
and then add the portlet to a dashboard.

• Client, contact, and resource profiles – You can view the list of surveys to which clients, 
contacts, and resources responded. For more information, see "Viewing survey results 
from a resource or contact profile" on page 328 and "Viewing surveys and ratings results 
that are associated with an entity" on page 328.

Survey status

Surveys are grouped in folders according to their status.
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Status Description

Draft Surveys that have been created and saved but not yet sent to 

respondents

Automated Surveys that are automatically sent to respondents when a 

trigger event occurs in Changepoint

Active Surveys that have been sent to respondents

Expired Surveys that have passed their expiry date

Completed Surveys that have been marked as completed

Accessing a survey
1. Click General > Surveys.

The Surveys tree view appears and displays the surveys grouped in folders according to 
their status. 

2.  Expand the status folder and click the survey.

The survey opens in a new window.

Surveys tree view options

By default, all surveys appear grouped by status in the Surveys tree view. Use the Options 
menu to filter or group the surveys in the tree view. The options are as follows:

• Filtering options

• All surveys – Displays all surveys.

• Pending – Displays only pending surveys.

• Responded – Displays only surveys to which respondents have responded.

• Group surveys options

• No grouping – Groups surveys by status (default setting).

• By creation date – Groups surveys within each status folder by the date they were 
created.
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• By author – Groups surveys within each status folder by the names of the resources 
who created them.

• Group respondents options

• No grouping – Groups the respondents of each survey by respondent name (default 
setting).

• By category – Groups the respondents of each survey by respondent category (Client, 
Resource, Unknown, or Non-categorized).

• By response date – Groups the respondents of each survey by the date that they 
responded to the survey.

• By sent date – Groups the respondents of each survey by the date that the survey was 
sent to them.

• Respondents options

• Show rejected respondents – Includes respondents that have been rejected from the 
survey.

• Hide rejected respondents – Hides respondents that have been rejected from the 
survey.

• Survey details options

• Show – Displays the creation date and author of the survey beside the survey name.

• Hide – Hides the additional information and displays only the survey name (default 
setting).

About creating surveys
When creating a survey, you can:

• make your survey anonymous so that the names of respondents are not revealed in the 
results

• enable prompt tags, which are placeholders that are replaced with specific entity values 
when the survey is sent

• set up the survey to be sent automatically when a trigger event occurs in Changepoint.
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After you create a survey, you can add images and additional text to the survey and edit the 
default messages for the survey.

About automated surveys

You can set up a survey to be sent automatically when a trigger event occurs in Changepoint. 
When you create an automated survey, you specify the trigger event. You can choose from the 
following trigger events:

• Approved candidate

• Completed project

• Closed request

• Custom – You can create up to ten additional custom trigger events. 

Each trigger event is associated with a specific type of predefined respondent. 

An automated survey is sent only to the respondents that the survey administrator approves.

Creating a survey

1. Click General > Surveys. The Create Survey view appears.

2.  Complete the fields as required. For more information, see "Create/Edit Survey view 
options" on page 305.

3.  Add questions to the survey. For more information, see "Adding a question to a survey" on 
page 306.

4.  Click Actions > Save. 

The survey is saved in the Draft folder in the Surveys tree view. 

5.  Before you send the survey to respondents, you can configure the appearance of the survey 
and the survey messages. For more information, see the following topics:

• "Adding text and images in header of a survey" on page 311

• "Adding a background image to a survey" on page 312

• "Configuring the email messages used in a survey" on page 313
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Create/Edit Survey view options

Option Description

Survey name field Name of the survey.

Description field Description.

Anonymous check box When selected, the names of the resources who respond to 

the survey are replaced, in the results, with Respondent 1, 

Respondent 2, and so on.

Use prompt tags check 

box

When selected, prompt tags can be used in the survey. 

Note: Prompt tags cannot be used in automated surveys 

because replacement values must be specified for prompt 

tags when the survey is sent.

Trigger event for 
automated survey list

If a trigger event is specified, the survey is automatically sent 

when the trigger event occurs. Default is None.

Options include:

• Approved candidate – When the status of the 

associated candidate is marked as approved, the survey 

is sent to the email address of the main contact of the 

client

• Completed project – When the project is marked as 

completed, the survey is sent to the email address of the 

main contact of the client organization. 

• Closed request – When the request is closed, the survey 

is sent to the email address of the initiator of the request. 

Start date field Start date.

Expiry date field Expiry date.

Creating a survey from a template

1. Click Resources > Performance Management. 

The Performance Management tree view appears.

2.  Expand the Survey Templates folder.

3.  Expand the appropriate templates folder, and then select the template.
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The survey template appears.

4.  Click Actions > Create survey from template.

A new window, Create survey from template, appears.

5.  Make the necessary changes. For more information, see "Create/Edit Survey view options" 
on page 305.

6.  Click Actions > Save. 

The survey is saved in the Draft folder in the Surveys tree view.

Adding a question to a survey

1. Access the survey.

2.  Click Actions > Edit survey.

The edit survey view appears.

3.  In the Question editor section, click New. 

4.  Complete the fields as required. For more information, see "Question editor options" on 
page 306.

5.  Click Save.

The question is added to the survey.

6.  Click Actions > Save.

Question editor options

Not all of the following options are available for all question types.

Option Description

Question type list Type of question to be added.

Question field Text for the question.

Mandatory check box When selected, the respondent must answer the 

question before the survey can be completed.
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Option Description

Display horizontally check 

box

When selected, the answer options display horizontally 

rather than vertically.

Answer choices field Text for the answers, separated by a return (press 

Enter).

Allow users to enter another 
answer check box

When selected, a question option is added with a text 

field for respondents to enter their own text. The default 

text for the question is Other. Please specify., but you 

can change it.

Question types

Question type Description

Instructions Displays instructions for the respondents to complete the 

survey.

Comment - One line Open-ended question format, with a text box for 

respondents to enter short answers.

Comment box Open-ended question format, with a text box for 

respondents to enter answers of several lines.

Multiple-choice (commented) Closed-ended question format, with a finite set of 

answers from which respondents choose. Also provides 

text boxes where respondents enter brief comments.

Multiple-choice Closed-ended question format, with a finite set of 

answers from which the respondents choose.

Rating question Question format where respondents rank something on a 

scale of 1 to 5. 

Single-choice Closed-ended question format, with a finite set of 

answers from which respondents choose only one.

True/False Respondents can only answer True or False.

Yes/No Respondents can only answer Yes or No.
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About rating questions

You use rating questions in a survey when you want respondents to rate something on a scale 
of 1 to 5. The order in which you enter the answer options in the Question Editor determines 
both the order in which the answer options are displayed on the survey, and the rating of the 
answer options starting with 1 and increasing to 5. However, the rating numbers do not display 
on the survey.

The rating numbers are used to measure performance on the client report card and from the 
client profile. Use the rating scale consistently for all rating questions. That is, if 1 is the most 
negative rating and 5 is the most positive rating for one question, use this rating scale for all of 
the rating questions. 

Note: Only rating questions without prompt tags are included on the client report card.

Editing or deleting a question in a survey

You can edit a question, move it up or down in the survey, or delete it.

1. Access the survey.

2.  Click the question.

3.  To move the question, right-click the question and select Move up or Move down.

4.  To edit the question, make the necessary changes in the Question editor.

5.  To delete a question, right-click the question and then select Delete question.

6.  Click Save

Previewing a survey

1. Access the survey.

2.  Click Actions > View > Survey preview.

The survey appears in a new window.

Editing a survey

Only draft surveys can be fully edited. For active, automated, and expired surveys, you can 
only change the expiry date.

1. Access the survey.
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2.  Click Actions > Edit survey.

The Edit Survey view appears.

3.  Make the necessary changes.

4.  Click Actions > Save.

Deleting a survey

1. Access the survey.

2.  Click Actions > Edit > Delete survey.

3.  Click OK to confirm.

About prompt tags

Prompt tags are placeholders that you replace with specific entity values when you send the 
survey. For example, to create a survey for evaluating the overall performance of a resource 
who worked on a project, you can insert a prompt tag that references the Resource entity and 
Resource name field into the survey question:

How do you rate the overall performance of [prompt@employee@Resource.Name] who 

managed your project?

When sending the survey, you specify the resource as “John Smith”. The question appears as 
follows to survey respondents:

How do you rate the overall performance of John Smith who managed your 

project?

You can evaluate more than one resource or entity in one survey. For example, the first 
question can be related to a specific project manager and the second question to a specific 
client manager. It is also possible to use multiple prompt tags in one question. For example:

How do you rate your overall satisfaction regarding the project 

[prompt@project@Project.Name] managed by [prompt@employee@Resource.Name]?

Inserting a prompt tag into a survey question

1. Access the survey.

The survey appears in a new window.

2.  Click Actions > Edit Survey.

The Edit Survey view appears.
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3.  Select the Use prompt tags check box.

4.  Do one of the following:

• In the Question Editor, add a new question.

• To insert the prompt tag into an existing question, click the question in the survey.

5.  In the Question field of the Question Editor, right-click in the text where you want to 
insert the prompt tag.

The Insert Prompt Tag dialog box appears.

6.  In the Description field, enter a description for the prompt tag.

7.  In the Entity type list, select the entity.

8.  In the Field list, select the entity field.

9.  Click Add.

The prompt tag is added to the question.

10.  In the Question Editor, click Save.

11.  Click Actions > Save.

Controling access to a survey

By default, only the creator of a survey and survey administrators can edit surveys and view 
survey results. However, you can grant view and edit access to other resources or prevent 
resources from viewing survey results of questions that include prompt tags that refer to other 
resources.

1. Access the survey.

2.  Click Actions > Edit > Access control.

The Access Control dialog box appears.

3.  Select the options for each resource as required. For more information, see "Access 
Control dialog box options" on page 311.

4.  Click Save.
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Access Control dialog box options

Option Description

Edit survey check box When enabled, the resource can edit the survey.

View results check box When enabled, the resource can view survey results.

Exclude results check box When enabled, the resource cannot view results of 

questions that include prompt tags that refer to other 

resources.

Configuring the layout of a survey

You can add images and text in the header of a survey, use images as the survey background 
or change the standard text of email messages. For more information, see:

• "Adding text and images in header of a survey" on page 311

• "Adding a background image to a survey" on page 312

• "Configuring the email messages used in a survey" on page 313

Adding text and images in header of a survey

You can add an image (such as a logo), or text (such as instructions for the respondents) in the 
header of a survey.

1. Access the survey.

2.  Click Actions > Edit > Configure theme.

The Configure Theme dialog box appears.

3.  To add an image to the survey header:

a. Click the Header image tab.

b. If necessary, add the image to the Image list. For more information, see "Adding an 
image to the list of images for a survey" on page 312.

c. In the Image list, select the image. The image appears.

d. Select the alignment option.

4.  To add text:
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a. Click the Header text tab.

b. Enter the text. For more information, see "Header text tab options" on page 314.

5.  Click Save.

6.  To preview the changes, click Actions > View > Survey preview.

Adding a background image to a survey

You can add an image as a background watermark to a survey.

1. Access the survey.

2.  Click Actions > Edit > Configure theme.

The Configure Theme dialog box appears.

3.  Click the Background image tab.

4.  If necessary, add the image to the Image list. For more information, see "Adding an image 
to the list of images for a survey" on page 312.

5.  In the Image list, select the image.

6.  Click Save.

7.  To preview the changes, click Actions > View > Survey preview.

Removing an image from a survey

You can remove an image from the header or the background of a survey.

1. Access the survey.

2.  Click Actions > Edit > Configure theme.

The Configure Theme dialog box appears.

3.  Click the Header image tab or Background image tab.

4.  Click Reset.

5.  Click Save.

Adding an image to the list of images for a survey

1. Access the survey.

2.  Click Actions > Edit > Configure theme.
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The Configure Theme dialog box appears.

3.  Click the Header image or Background image tab.

4.  In the Image list, click <Upload an image>.

The Upload Image dialog box appears.

5.  Click Browse to locate the file on your system.

6.  Click Upload.

The file is added to the Image list.

7.  Click OK.

8.  To add the image to the header or background, according to the tab you selected in step 3, 
click the image name.

9.  Click Save.

Configuring the email messages used in a survey

You can specify the standard text of the following message types in a survey: email message, 
reminder message, refill message, completion message, and closing message.

1. Access the survey.

2.  Click Actions > Edit > Configure theme.

The Configure Theme dialog box appears.

3.  Click the tab for the message.

4.  Complete the fields as required. For more information, see "Configure Theme dialog box 
options" on page 314.

5.  Click Save.
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Configure Theme dialog box options

Header image tab options

Field or option Description

Alignment option Alignment of the image

Image list Image to appear in the header of the survey page.

Background image tab options

Field or option Description

Image list Image to appear in the background of the survey page.

Header text tab options

The default header text includes variable tags that are replaced by actual values when you send 
the survey. You can edit the default text, and remove and insert tags as required. The 
following table includes a complete list of the tags.

Note: You must enter the tags exactly as they are listed here, including the square brackets 
and excluding spaces. 

Tag Replaced in the survey by:

[survey.sentto] Respondent’s name

[survey.name] Survey name

[survey.senttocompany] Client if the respondent is a contact, or workgroup if the 

respondent is a resource

[survey.description] Description of the survey

[survey.expiredate] Expiry date of the survey
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Tag Replaced in the survey by:

[reference.refname] Entity name (for example, project name, candidate name, 

request number), if the survey is associated to an entity

[reference.description] Text from the Short Description field (requests only) or 

Comments field of the entity

Email message tab options

Specifies the default text that appears in the following places:

• Submit Survey dialog box when you send a survey

• email in which the survey invitation is sent to respondents

Field Description

Subject field Name of the survey.

Sender field Email address from your resource profile.

This field is not available if your organization uses SQLMail for 

electronic mail.

Message text box Body text of the email.

Reminder message tab options

Specifies the default text that appears in reminder messages that are sent to respondents.

Field Description

Subject field Name of the survey.

Message text box Body text of the email

Refill message tab, Completion message tab and Closing message tab 
options

Specifies the default text that appears in the following messages:
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• Refill – message that appears when a respondent tries to access the survey after they have 
submitted it

• Completion – message that appears when a respondent submits the survey

• Closing – message that appears when a respondent tries to access the survey after it has 
expired or has been closed.

Field Description

Message text box Body text of the email

Adding a survey to the Survey Management portlet
1. Click General > Surveys.

The Surveys tree view appears.

2.  Expand the status folder to locate the survey. 

3.  Right-click the survey and click Add to portlet.

4.  To remove the survey, right-click the survey and click Remove from portlet.

About survey templates
Survey templates are surveys that have been created or saved for reuse in one of the following 
survey template folders:

• System templates – Standard Changepoint templates that cannot be edited, but can  saved 
as a corporate template or as a personal template, which you can then edit.

• Corporate templates – User-defined templates that can be used and edited by all 
resources. 

• Personal templates – User-defined templates that can be used and edited only by the 
resource who created them. 

In each survey template folder, templates are grouped into categories. There must be at least 
one category in a folder before you can save a survey template.

Creating a template category

1. Click Resources > Performance Management. 
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The Performance Management tree view appears.

2.  Expand Survey Templates.

3.  Click the Corporate Templates folder or Personal Templates folder, or an existing 
template category. 

4.  Click Actions > Create template category, or Actions >Edit > Create template 
category.

The Create Template Category dialog box appears.

5.  In the Template category field, enter the name of the template category.

6.  In the Description field, enter a description of the template category.

7.  Click Save.

Editing or deleting a template category

You can only edit or delete the template categories for corporate and personal templates.

1. Click Resources > Performance Management. 

The Performance Management tree view appears.

2.  Expand Survey Templates.

3.  Expand the Corporate Templates folder or Personal Templates folder, and then select 
the template category.

4.  To edit the template category:

a. Click Actions > Edit template category. 

The Edit Template Category dialog box appears.

b. Make the necessary changes.

c. Click Save.

5.  To delete the template category:

a. Click Actions > Delete template category.

b. Click OK to confirm.

Changepoint Administration | 317



14. Survey Management

Accessing a survey template

1. Click Resources > Performance Management. 

The Performance Management tree view appears.

2.  Expand the Survey Templates folder.

3.  Expand the folders to locate the survey template.

4.  Click the survey template.

The survey template appears.

Creating a corporate or personal survey template

1. Click Resources > Performance Management. 

The Performance Management tree view appears.

2.  Expand the Survey Templates folder.

3.  Do one of the following:

• To create a corporate template, expand the Corporate Templates folder, then right-
click a template category folder and select Create template.

• To create a personal template, expand the Personal Templates folder, then right-click 
a template category folder and select Create template.

The Create Survey Template dialog box appears.

4.  Complete the fields as required. For more information, see "Create/Edit Survey view 
options" on page 305.

5.  Click Actions > Save. 

Editing a survey template

You can only edit corporate and personal templates. However, you can save a system template 
as a corporate or personal template then edit the saved template.

1. Access the survey template.

2.  Click Actions > Edit template.

The Edit Survey Template view appears.
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3.  Make the necessary changes. For more information, see "Create/Edit Survey view options" 
on page 305.

4.  Click Actions > Save.

Deleting a survey template

You can only delete corporate and personal templates.

1. Access the survey template.

2.  Click Actions > Edit > Delete template.

3.  Click OK to confirm the deletion.

Saving a survey or a survey template as a corporate template

1. Access the survey or the survey template.

2.  Click Actions > Save as > Corporate template.

The Corporate Template dialog box appears.

3.  In the Corporate template category list, select the template category.

4.  Click Save.

Saving a survey or a survey template as a personal template

1. Access the survey or the survey template.

2.  Click Actions > Save as > Personal template.

The Personal Template dialog box appears.

3.  In the Personal template category list, select the template category.

4.  Click Save.

About sending surveys
You can send surveys that are in any status except Expired and Completed. However, you can 
reactivate an expired survey first and then send it.

When you send a draft survey, it is moved from the Draft folder to the Active folder, and the 
respondents are listed under the Active folder in the Surveys tree view. The names of 
respondents display in red until they respond to the survey, after which the names display in 
black. If respondents are rejected by the survey administrator, their names displays in blue.

Changepoint Administration | 319



14. Survey Management

You can select respondents for surveys from the Changepoint resources and contacts that have 
email addresses in their profiles, and you can enter email addresses directly. You can also set 
up distribution lists of respondents.

About sending surveys that include prompt tags

When you send a survey that includes prompt tags, you must select the specific entity names 
or records to replace the prompt tags. 

If a question contains multiple prompt tags, you do not have to select values for all prompt 
tags. If you skip a prompt tag, the prompt tag’s information is not displayed in the question. If 
you skip all prompt tags for a question, the entire question is not displayed. 

You can also associate the survey with an entity record. For example, if you associate a survey 
to a project, you can view the responses to the survey in the Survey Ratings view of the 
project profile. The project name also appears in the Reference field of the respondent’s 
survey profile.

About sending automated and non-automated surveys

You can send surveys by email to surveys respondents using the Actions > Send command.

When you send a non-automated survey, an invitation is sent by email to survey respondents.

When you send an automated survey, the survey moves from the Draft folder to the 
Automated folder. When the trigger event occurs, a notification appears in the My 
Reminders portlet of survey administrators. The survey invitation is not sent to respondents 
until the survey administrator reviews the survey, and then it is sent only to the respondents 
that the survey administrator approves. 

Sending a survey to respondents

1. Access the survey.

2.  If the survey is in the Draft folder, click Actions > Edit survey.

3.  Ensure that the expiry date allows the respondents enough time to respond to the survey.

4.  Do one or both of the following:

• Click the Distribution list link and then select a distribution list to add to the 
Respondents field.
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• In the Recipients field, enter the email addresses of the respondents, separated by 
semicolons.

5.  Click Actions > Send.

6.  If the survey includes prompt tags, the Prompt Tag Selection dialog box appears: 

a. In the Associate survey with entity list, select the entity type to be associated with the 
survey.

b. In the Associate survey with entity type-ahead field, enter the entity name. 

c. In the Prompt type-ahead field for each prompt tag description, enter a value.

The Display column shows how the value appears on the survey.

d. Click Go.

The Survey Email dialog box appears.

7.  Complete the fields as required. For more information, see "Survey Email dialog box 
options" on page 321.

8.  Click Send.

Survey Email dialog box options

Option Description

Subject field Subject line of the survey email.

Sender field Your email address. 

Note: The Sender field is not available if your organization 

uses SQLMail for email.

Message list Default email message as configured for the survey.
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Prompt Tag Selection dialog box options

Option Description

Associate survey with 
entity list

Entity type that is associated with the survey (that the survey 

references).

Associate survey with 
entity type-ahead field

Specific entity record to be associated with the survey. If the 

same entity that is associated to the survey is referenced in a 

prompt tag, then this entity record becomes the default value 

for the prompt tag.

Prompt type-ahead field Value to replace the prompt tag in the survey

Reactivating an expired survey

To reactivate an expired survey, you change the expiry date to a date in the future.

1. Access the expired survey.

2.  In the Expiry date field, change the date to a date in the future.

3.  Click Actions > Save.

The survey is activated and moved into the Active folder in the Surveys tree view.

Approving and rejecting respondents for an automated survey

Survey administrators approve or reject the sending of an automated survey to respondents. 

1. Access the survey. 

2.  In the Respondents section, click the number link in the Pending automated surveys 
field.

The Automated Survey Approval dialog box appears.

3.  Do one of the following:

• To accept all respondents and send the survey, select the Accept check box in the 
heading row of the table.

• To remove all respondents and cancel the survey, select the Reject check box in the 
heading row of the table.
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• To reject or accept individual respondent, select the Accept or Reject check boxes for 
each contact.

4.  Click Go.

5.  If you selected Accept for at least one respondent, the Survey Email dialog box appears.

6.  Edit the Subject, Sender and Message fields as required.

7.  Click Send.

About distribution lists

You can create distribution lists to use when sending surveys. 

You can select the distribution list members from resources and contacts that contain valid 
email addresses in their profiles. In addition to selecting from these categories, you can also 
add members manually to a distribution list. When you add a member manually, it is 
automatically added to the non-categorized group.

You can make your distribution lists available for other resources to use by making them 
public. Public distribution lists have an icon beside their name.

Accessing a survey distribution list

You can access the distribution lists from any survey profile.

1. Access a survey.

2.  Click Actions > View > Distribution lists.

The Distribution Lists view appears.

3.  In the Distribution list section, click a distribution list.

The distribution list members are displayed in the Member list section.

Creating a survey distribution list

1. Access a survey.

2.  Click Actions > View > Distribution Lists.

The Distribution Lists view appears.

3.  In the Distribution list section, click <New distribution list>.

The Distribution list fields and the Member list section are cleared.
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4.  In the Distribution list field, enter a name for the distribution list.

5.  To allow all resources to use the distribution list, select the Public check box.

6.  Add members to the distribution list. For more information, see:

• "Adding a member manually to a survey distribution list" on page 324

• "Selecting existing members for a survey distribution list" on page 325

7.  Click Save.

Adding a member manually to a survey distribution list

When you add a member manually to a survey distribution list, the member is automatically 
added to the Non-categorized group. The next time you select respondents for a survey, you 
can select the member from the Non-categorized group.

1. Do one of the following:

• Access the distribution list.

• Create a new distribution list.

2.  In the Member list section, click <New member>.

3.  In the New Member section, enter the first name, last name and email address of the new 
member.

4.  Click Save.

The member information displays in the pane.

5.  Click Update or Save.

Editing a member of a survey distribution list

You can only edit the members that were previously added manually. To edit a contact or 
resource, you must access the contact or resource profile.

1. Access the distribution list.

2.  In the Member list section, click the member.

3.  Make the necessary changes.

4.  Click Update.
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Selecting existing members for a survey distribution list

You can select existing members for a distribution list from the following categories:

• Clients – contacts that have email addresses in their profiles

• Resources – resources that have email addresses in their profiles

• Non-categorized – members that have previously been added manually.

1. Do one of the following:

• Access the distribution list.

• Create a new distribution list.

2.  In the Filter criteria section, do one of the following:

• To add contacts, select Clients. The Filter Expression section appears.

• To add resources, select Resources. The Filter Expression section appears.

• To add email addresses that were previously added manually to the distribution list, 
select Non-categorized. Go to step 7.

3.  In the Criteria, Condition and Value lists, select values to create a filter expression.

4.  Click Add.

5.  If required, add more filter expressions.

6.  Click Go.

The matching members display in a tree view in the Matching records section. 

7.  Do one of the following:

• To add individual members, click the member.

• To add all of the members, click the double left arrow.

8.  Click Update or Save.

Editing a survey distribution list

You can change the name and availability of a distribution list, and add and remove members 
from a distribution list.

1. Access the distribution list.
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2.  Make the necessary changes to name and availability.

3.  To delete a manually added member:

a. In the Member list section, click the member.

b. Click Delete.

This also removes the member from the list.

4.  To remove a member:

a. In the Member list section, click the member.

b. Click Remove.

5.  To remove all members, in the Member list section, click the double right arrow.

6.  Click Update.

Deleting a survey distribution list

1. Access the distribution list.

2.  Click Delete.

3.  Click OK to confirm.

Sending a reminder email to a respondent

You can send email reminders to respondents who have not submitted the survey.

1. Access the survey.

2.  In the Respondents section, click the number link in the Outstanding respondents field.

The Outstanding Respondents dialog box appears. In the Outstanding Respondents 
dialog box, the Reminders column indicates the number of reminders that have been sent 
to each respondent.

3.  Do one of the following:

• To send a reminder email to some of the respondents, select the Accept check box 
next to the respondent’s name.

• To send a reminder to all respondents, select the Accept check box in the header row 
of the table.

4.  Click Go.
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The New Reminder dialog box appears.

5.  Edit the Subject, Sender and Message fields, if required.

6.  Click Send.

The reminder is sent to the respondents that you selected in step 3. 

Viewing survey results from the survey profile
The survey profile lists the survey questions and responses. Each question shows the number 
of responses that were submitted. Rating and selection questions show the percentage of 
respondents who chose a specific answer. The percentage of respondents is presented visually 
as a horizontal bar.

Questions for which the respondents typed an answer display the number of submitted 
responses as a link. Click the link to view the response typed by each respondent.

There are options for viewing and analyzing survey results in the survey analysis view. For 
more information, see "Accessing the survey analysis view" on page 330.

Viewing survey results from individual respondents

In the Surveys tree view, each of the respondents is listed under the survey. The respondents 
are color-coded as follows:

• black – have submitted a survey response

• red – have not submitted a survey response

• blue – were rejected. 

To view the rejected respondents, click Options > Show rejected respondents in the Surveys 
tree view.

1. Access the survey, but instead of clicking the survey name, expand the survey.

The respondents are displayed.

Tip: You can point to the respondent to display the email address and reference 
information.

2.  Click the respondent.

The survey answers display in the Response information section.
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Viewing survey results from a resource or contact profile

You can view the surveys results from the profiles of resources or contacts who have 
submitted the survey.

1. Access the profile of the resource or contact.

2.  Click Actions > View > Surveys.

The list of surveys that the resource or contact submitted appears.

3.  In the Survey column, click the name of the survey.

The survey appears in a new window.

Viewing surveys and ratings results that are associated with an entity

If a survey includes rating questions associated with an entity (for example, a project), you can 
view the survey and the results from the associated entity profile. 

1. Access the entity. 

2.  Click Actions > View > Survey ratings.

The Survey Ratings view appears.

3.  To view a survey that is associated with the entity, click the survey link in the Entity-
based surveys section.

4.  To view the results of the ratings questions that reference the entity, click the survey link 
in the Entity-based survey questions section.

About the client report card

A client report card is a summary of client information that is available from the client profile. 
You can also view client report card data in the Client Radar report.

The report card includes the following sections:

Client information

Includes general information from the client profile.

Client status

• Number of active projects
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• Sales reference status

• Client satisfaction rating – the average of all survey responses to rating questions that do 
not have custom tags. For more information, see the Performance Metric Calculations 
Reference Guide, which is available from the Customer Success Center 
(https://success.planview.com/Planview_Changepoint).

Financial outlook

• Current candidates – The number of current candidates currently associated with the 
client. Current candidates are configured to be included in the screening process and do not 
have a specified decision.

• Total value – total of the budgeted amounts for current candidates.

• Weighted value – value of current candidates, which is calculated as follows:

sum of budgeted amount * probability * 100

Financial history

• Average days to payment – average number of the days between the date that cross 
charges were sent to the client and the date that they were paid or the current date (for 
pending payments).

• Total charge (last 12 months). The total charge amount, which is the sum of the total (net 
of taxes) for cross charges created within the last 12 months, and with the status 
Approved, Committed, Sent, Paid or Archived.

• Accounts receivable. The total amount in accounts receivable, which is the sum (including 
taxes) of payments for cross charges that are not deleted and have a status of Sent.

• Gross margin – calculated as follows:

Profit – gross margin% (Revenue – Cost) / Revenue * 100%

• Revenue = total amount of revenue from cross charged time, expenses, request 
time, fixed fees, and non-labor items – Total write-offs to date (see below)

• Cost = Total cost for cross charged time, expenses, request time, non-labor items, 
nonchargeable time, nonchargeable expenses

• Total write-offs (to date) = Total amount written off for time, expenses, support 
time, non-labor items + total for cross charges that have the status Active, 
Committed, Sent, Paid or Archived
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Viewing a client report card

1.  In Changepoint (not Changepoint Administration), click Client > Profiles .

The Clients tree view appears.

2.  Expand the folders to locate the client.

3.  Click the client name.

The client appears.

4.  Click Actions > View > Report card.

The report card appears.

About analyzing survey results
The following methods for analyzing survey results are available in the survey analysis view 
of each survey.

Reports

The following reports are available:

• Text responses – Shows the typed responses of each respondent.

• Survey summary – Shows the number of responses, the number of outstanding responses, 
the date the survey was sent, and the date the response was received. This report also 
shows a list of respondents who no longer receive email survey reminders.

• Response trend analysis – Shows the date the response was received, the date the survey 
was sent, and the name and email address of the respondent. This information shows the 
responses made to the survey over time.

• Questions and responses totals – Shows all questions in the survey, the number of 
respondents, and the percentage of respondents who choose a specific answer (except for 
questions for which respondents entered comments).

Accessing the survey analysis view

You can filter the information in the survey analysis view to specific clients, resources, or non-
categorized individuals.

1. Access the survey view.

2.  Click Actions > View > Analysis.
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The survey analysis view appears.

3.  To filter the information in the reports:

a. In the Filter criteria section, do one of the following:

• To include responses from contacts, select Clients.
• To include responses from resources, select Resources.
• To include responses from respondents that are neither contacts nor resources, 

select Non-categorized.

b. If you selected Clients or Resources, you must select a criterion, a condition, and a 
value to create an expression.

c. Click Add. The expression is added to the Expression section.

Tip: You can add more expressions, if required. To remove an expression from the list, 
select it and click Remove.

d. To restrict the time frame, edit the start date or end date.

4.  Access the reports.

Viewing the survey analysis reports

1. Access the survey analysis view.

2.  In the Reports section, click a report type.

The report opens in a new window.

3.  Do one of the following:

• To print the report, click Print.

• To close the report, click Close.

Using survey results for performance evaluation

Rating questions provide results that can be used to assess the performance of resources and 
projects, and for calculated configurable fields.

Note: Other types of questions can be used in custom calculations to collect performance 
data. For more information about custom calculations, contact your Changepoint client 
manager.
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To use surveys to collect ratings that will be used for performance evaluation, do the 
following:

• Create a metric template with a Client  feedback, Peer feedback, or Project template 
type. client feedback and peer feedback template types are for individual performance 
metrics. Both template types can be linked to a project or resource using feedback from 
internal (peer) or external (client) respondents. For more information, see "About metric 
templates".

• Create an Individual Performance Management (IPM) metric and assign it to the resource, 
or create a project metric that can be used in a project portfolio. In some cases, the survey 
is only available for selection when it is active (that is, it has been sent to a respondent).

• Create a survey with rating questions and prompt tags. Then specify the resource or 
Changepoint entity in the Prompt Tag Selection dialog box, when you send the survey to 
respondents.

• Create a metric. Then assign the metric to the resource or project to be rated. Metric 
templates can be created and metrics assigned only after the survey has been sent to 
respondents

Survey respondents rate the resource or Changepoint entity identified in a rating question and 
submit the survey. Results are collected against a metric and can be viewed and analyzed.

Exporting survey results to a TXT or XML file

1. Access the survey.

2.  Click Actions > View > Export survey.

The Export Survey Data dialog box appears.

3.  In the Date range section, change the start and end date, if required.

4.  In the Survey format section, select Details or Summary.

5.  In the File format section, select Tab-delimited file or XML.

6.  To download the information into a file on a hard drive, select Download.

7.  Click Next.

The Export Survey Data dialog box displays your selections.

8.  Click Download.
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The File Download dialog box appears.

9.  Select the export location and then click Save.

Marking a survey as complete

Only expired surveys can be marked as complete. 

1. Access the expired survey.

2.  Click Actions > Complete survey.

The survey is moved to the Completed folder in the Surveys tree view.
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About export setup

You can export data from the Changepoint database to text files for input to third-party 
applications. You must first create export definitions that define what data is exported and 
how it is exported. You can export data manually, or you can also set up automatic exports, 
referred to as export publishing, which occur according to events or schedules. 

To set up exports:

1. Create export views using database views. If required, create data types for date and 
numeric fields. 

2.  If required, create categories for the export views. 

3.  Create export definitions. 

4.  If required, configure export batch numbering. 

5.  To set up automatic exports, see "Setting up export publishing" on page 347.

Creating an export view
1. Click Import/Export > Export Views.

2.  Right-click in the table, and then select Insert.

3.  In the Export view column, enter the name for the export view.

4.  In the Description column, enter a description.

5.  In the Database view column, select the Changepoint database view to use with the 
export view.

6.  Click Save.

Modifying an export view

You cannot delete a view that is used in a group definition.

1. Click Import/Export > Export Views.

2.  To modify the export view, make the necessary changes directly in the table cells.

3.  To delete an export view:
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a. Right-click the row, and then select Delete.

b. Click OK to confirm.

4.  Click Save.

Creating an export data type
You can create data types to format numbers or dates in the export data according to the 
requirements of the third-party application. 

Note:  Changepoint supports the .NET Framework custom date format strings and custom 
numeric format strings.

1. Click Import/Export > Export Data Types.

2.  Right-click in the table, and then select Insert.

3.  In the Export data type cell, enter the name of the export data type.

4.  In the Description cell, enter a description.

5.  Click the Format type cell and do one of the following: 

• To create a numeric format type, select Numeric and enter the format in the Numeric 
format field. 

• To create a date format type, select Date and enter the format in the Date format 
field. 

6.  Click Save.

Modifying an export data type

You cannot edit the format type of an export data type. To correct the format type, you must 
delete the export data type and then recreate it.

1. Click Import/Export > Export Data Types.

2.  Make the necessary changes directly in the table cells.

3.  To delete an export data type:

a. Select the row.

b. Right-click and select Delete.

4.  Click Save.
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About creating export definitions
In an export definitions, you specify the data to be exported, and how the data is to be grouped, 
delimited, and formatted (for date and numeric fields). You can also restrict the use of an 
export definition to specific roles.

Note: You cannot use the same export definition for both manual exports and export 
publishing. Once you create an export publishing schedule, the export definition associated 
with the schedule can no longer be used in a manual export process, whether the schedule 
is active or not.

An export definition consists of the following items that are set up in a tree structure under the 
category as follows: 

Export name > File definition > Group > Line > Column.

The following is an outline of the steps to create an export definition.

1. Create the export name. You can restrict the use of the export definition to specific roles. 

2.  Create a file definition. 

3.  Create a group. 

4.  Create the rows (lines) of data. 

5.  Add the fields (columns) of data for each row. 

Creating an export definition category

Export definitions are organized under categories.

1. Click Import/Export > Export Definitions.

2.  In the Folders view, select an existing category. 

3.  Click New.

4.  In the Category field, enter the name of the category.

5.  In the Description field, enter a description for the category.

6.  Click Save.

Creating an export name

When you specify the name of the export, you can restrict the roles that can use it. 
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1. Click Import/Export > Export Definitions.

2.  Select the export category.

3.  Click New export name.

4.  In the Export name field, enter a name for the export definition.

5.  In the Description field, enter a description for the export definition.

6.  To make the export definition available for batch exports, select the Available for batch 
exports check box.

7.  To restrict the use of the export definition to resources with specific roles:

a. Select the Restrict this export to the following roles check box.

b. Select one or more roles. 

8.  Click Save.

Creating an export file definition

In the file definition, you specify the name of the export file and specify string and column 
(field) delimiters. 

1. Click Import/Export > Export Definitions.

2.  Expand the export category and then select the export name.

3.  Click New export file. 

4.  In the File definition field, enter a default name for the file definition.

5.  In the Description field, enter a description for the file definition.

6.  In the Default file name field, enter a default name for the export file. 

7.  In the String delimiter field, enter the character to use to delimit text strings in the file. 

8.  In the Column delimiter field, enter the character to use to delimit columns (fields) in the 
file. 

9.  Click Save.
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Creating an export group and selecting the export view

You must configure at least one group for the export definition. You can group the exported 
data based on the value in a field, and add a where clause to filter the data to be exported. 

1. Click Import/Export > Export Definitions.

2.  Expand the category and export name, and then select the file definition.

3.  Click New export group.

4.  In the Group name field, enter a name for the group.

5.  In the Description field, enter a description for the group.

6.  In the View name list, select the export view.

7.  To group records in the export file, select the field in the Group by list.

8.  To filter records in the export file, enter a WHERE clause in the Selection formula field.

9.  Click Save.

Adding a line to an export file

1. Click Import/Export > Export Definitions.

2.  Expand the export category folder to locate, and then select, the group definition.

3.  Click New export line.

4.  In the Line name field, enter a name for the line.

5.  In the Description field, enter a description for the line.

6.  Click Save.

Adding a column to a line in an export file

For export publishing, column names can contain only alphanumeric characters (A-Z, a-z, 0-9). 
For manual exports, column names are not restricted.

1. Click Import/Export > Export Definitions.

2.  Expand the export category to locate, and then select, the export line.

3.  Click New export column.

4.  In the Column name field, enter a name for the column.
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5.  In the Description field, enter a description for the column.

6.  To add a field from the export definition:

a. In the Column type option, select Name.

b. In the View column name list, select the field.

c. If the field is a date or numeric type, in the Format definition list, select the date or 
number format definition.

7.  To add a constant:

a. In the Column type section, select Constant.

b. Enter a fixed string, or one of the following predefined constants: 

%DATE% – date the export was created

%TIME% – time the export file was created

%BATCH% – batch number of the export

%USER% – for manual exports only, name of the resource that exported the data

Note: In export publishing there is no “user”. If %USER% is included in an export 
publishing definition, the value in the export is blank.

8.  Click Save.

9.  To change the column order, see "Changing the position of a column in an export file" on 
page 340.

Changing the position of a column in an export file

1. Click Import/Export > Export Definitions.

2.  Expand the export category to locate, and then select, the column.

3.  In the Column order list, click column, and then click the up or down arrow to move the 
column to the desired position.

4.  Click Save.
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Modifying an export definition

You can modify any of the items that are included in an export definition. However, after an 
export definition has been used for a successful batch export, you cannot modify it.

1. Click Import/Export > Export Definitions.

2.  Expand the export category folder to locate, and then select, the item.

3.  To edit the export definition item:

a. Make the necessary changes.

b. Click Save.

4.  To delete the export definition item:

a. Click Delete.

b. Click OK to confirm.

Setting up an export batch numbering scheme
1. Click Import/Export > Export Batch Numbering.

2.  In the Export name list, select the name of the export.

3.  In the Part A, Part B and Part C sections, specify the numbering scheme. For more 
information, see "Numbering scheme options" on page 296.

4.  Click Save.

Database procedures for export setup
These procedures must be performed by a database administrator.

Creating a custom database view for exports

This procedure must be performed by a database administrator.

The names of the standard database views start with Export and the names of the standard 
database views for export publishing start with ExportExpPub.

Keep the following in mind when you create a custom database view:

• the view name must start with Export

• access to the view must be granted to the cpaccess role.
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• if the view is for event-based exports, include a column called EntityId, and populate the 
field with the GUID of the entity being exported

Enabling export batch tracking in a database view
Note: This procedure must be performed by a database administrator.

When a record is exported in a batch, the export is recorded in a table called IEBatchRows. A 
record that exists in this table is not normally eligible to be exported in another batch. 
However, you can add a unique identifier in the view that allows multiple batch exports, for 
example, to allow two different exports of the same time records with different columns in 
each.

To enable batch tracking, add the following columns to the database view:

• ID – contains a unique identifier, for example, the customer id, even if there is already a 
customer id column in the view.

• BATCHTYPE – contains a user-defined, three-character code necessary to distinguish the 
records in each batch.

The standard Changepoint Export and ExportExpPub views do not contain these columns. 

To enable a standard view for multiple batch exports, you must add the ID and BATCHTYPE 
columns to the view. If the view is encrypted, you must create a new view, add the two 
columns, and then select the rest of the columns from the existing view.

Adding a new topic for export publishing

Topics are used to easily identify the exported data. Several topics are predefined in 
Changepoint. However, you can add new topics.

Note: This procedure must be performed by a database administrator.

1. In the Changepoint database, insert a new record into the ExpPubTopic table. 

For example:

 INSERT INTO 

 ExpPubTopic (ExpPubTopicId, PageContentId, TopicName, DisplayName)

 VALUES 

 (NewId(), 0, 'changepoint.newtopic', 'New Topic')

where:
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• ExpPubTopicId – Primary key field for the ExpPubTopic table. The value must be 
NewId().

• PageContentId – Identifier field from the PageContent table, which is used to localize 
the DisplayName into different languages. To display the same name for all languages, 
set the PageContentId field to 0 and enter the name that you want to display in the 
DisplayName field.

• TopicName – Topic name field, which is used by export publishing to identify and 
route the message. The format is:

  'changepoint.<newtopic>' 

where <newtopic> is the name of the new topic. For example:

  'changepoint.customers'

• DisplayName – Name to display when the PageContentId field is 0. Spaces are 
allowed. 

2.  Add an external channel for the new topic in the ChangepointDataMapper.xml file: 

a. Assign a name to the channel. 

b. Assign the new topic name to the outbound element.

For more information, see the Integration Framework Reference.

3.  When you have finished adding topics:

a. Restart all instances of the Changepoint Data Mapper Service that are listening to the 
message broker (RabbitMQ Service).

b. Restart all instances of the Changepoint Communication Dispatcher Service that are 
listening to the message broker (RabbitMQ Service).

About exporting data manually
You can export data from the Changepoint database as Unicode text files for importing into 
external systems. Exports can be of type batch or non-batch.

Batch exports

Batch exports are used to keep track of which records are exported.

When a batch is exported successfully, a batch number is created. You can re-export a batch, 
and can choose an export definition that is different from that of previous batch exports.
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Note: After a batch is exported successfully, the export definition cannot be modified. 

Export options

Based on pre-defined export definitions you can choose:

• Export category, for example, time, expenses

• Export name

• How the exported records are selected and grouped

• What fields are exported, and in what format

Before you begin an export

Before you begin an export:

• Review "Editing the export definition before exporting" on page 345 to determine if you 
need information about the Filter and Filter value fields. 

• Contact your system administrator if:

• you cannot tell, by looking at the corresponding data in Changepoint, what to use for 
filter conditions and filter values

• you need a batch number to re-export a batch

Exporting data manually

1. Click Import/Export > Export Data.

The Export Data view appears.

2.  Select the Export data using existing export definitions option, and then click Go.

The Changepoint Export dialog box appears.

3.  In the Category list, select the export category.

4.  In the Export name list, select the export definition.

5.  Click Apply.

The Confirm Export dialog box appears.

6.  To edit the export definition before exporting:

a. Click Edit. The Edit Export Definition dialog box appears. 
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b. Edit the export definition. For more information, see "Editing the export definition 
before exporting" on page 345.

7.  Click Export.

8.  Open or save the exported data file.

Re-exporting data from a previously exported batch

1. Click Import/Export > Export Data.

The Export Data view appears.

2.  Select the Re-export data from a previously exported batch option and click Go.

The Changepoint Export dialog box appears.

3.  In the Export name list, select the name of the export.

4.  In the Batch number list, select the batch number.

5.  Click Apply.

6.  If prompted, click the button for batch export or regular export.

7.  To edit the export definition before exporting, click Edit. The Changepoint Export dialog 
box appears. For more information, see "Editing the export definition before exporting" on 
page 345.

8.  To export the data, click Export.

9.  Open or save the exported data file.

Editing the export definition before exporting

1. In the Changepoint Export dialog box, select Edit.

2.  Expand the export definitions tree.

3.  For each level of the export definition:

a. Make the necessary changes. For more information, see "Changepoint Export dialog 
box options" on page 346.

b. Click Apply. 

4.  To apply a field-based filter:
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a. In the Filter list, select a filter condition: for example, is equal to, is not equal to, etc.

b. In Filter value 1, and Filter value 2 if shown, enter or select a value.

c. If the Format list displays, select a format.

d. To exclude a field from the export file, select the Excluded check box.

Changepoint Export dialog box options

When expanded, the export definitions tree has up to four levels: File, Group, Line, and Field 
name.

The following table shows what information you can modify at each level of the export 
definition.

Note: You cannot modify anything at the Line level.

If you export a batch file, you can modify only the Default file name, which is at the File 
level.

Level What you can modify

File • Default file name
• String delimiter
• Column delimiter

Group • Group by - select the field to use to group the data.

• Selection Formula (read-only) – displays if the system 

administrator has specified an SQL formula.

Line No changes are permitted at this level.

Field Name Different fields provide different options for you to use. For 

example:

• Filter list, with criteria such as is equal to, is not equal to, 

etc.

• Filter value.

• Format, for example dd-mm-yyyy or mm/dd/yyyy for a date 

field.

• Excluded – when enabled, excludes the field from the 

export file.
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Setting up export publishing
To export data automatically, you can set up export publishing. The output from export 
publishing is sent to the message broker (RabbitMQ Service), where the data can be picked up 
by  third-party applications such as Salesforce.com, and BizTalk. The third-party applications 
must be configured to pick up the exported data.

Setting up export publishing includes the following steps:

1. Creating an export definition with an export batch numbering scheme.

2.  Setting up event notifications for event-based export publishing.

3.  Configuring an export publishing schedule.

4.  Set up the Export Publishing Audit report and the Export Publishing Error report:

a. Download the report XML files from the Customer Success Center 
(https://success.planview.com/Planview_Changepoint).

b. Import the report XML files into Changepoint Analytics.

c. Add the reports to Changepoint.

d. Grant access to the reports to the resources who require access.

5.  Configuring the following Integration Framework components:

• Changepoint Data Mapper Service

• Changepoint Communication Dispatcher Service

• Export Publishing Service

Note: For more information, see the Integration Framework Reference.

6.  After data has been exported, you can confirm the status and check for errors by running 
the Export Publishing Audit report and the Export Publishing Error report.

Creating an export publishing schedule

There can be only one active export publishing schedule for a topic. If you activate a second 
setup for the same topic, the previously active topic is deactivated automatically.

1. Click Import/Export > Export Publishing Schedule.
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2.  Select any existing schedule.

3.  Click New.

4.  To activate the schedule, select the Activate the export publishing schedule check box.

5.  In the Name field, enter a name for the export publishing schedule.

6.  In the Description field, enter a description.

7.  To export all records, in the Event type list, select Regular export.

8.  To export all records since the last batch was run:

a. In the Event type list, select Batch export. 

b. To export a file that contains header information only when there is no data to export, 
select the Send non-data file check box. 

9.  To export records based on an event:

a. In the Export type section, select Event. 

b. In the Export event notification list, select the event.

10.  In the Export definition list, select the export definition.

11.  In the Topic list, select the topic.

12.  In the Configuration ID field, enter the name of the transformation file.

13.  To configure the start date and time:

a. In the Start date field, enter the date for the first export.

b. In the Daily start time field, enter the start time for the first export.

c. In the Time zone list, select the time zone.

14.  In the Export schedule section, configure the recurrence settings. For more information, 
see "Configuring the recurrence settings for an export publishing schedule" on page 348.

15.  Click Save.

Configuring the recurrence settings for an export publishing schedule
Note: The timing of the export schedule also depends on the schedule for the Export 
Publishing Service. For more information, see the Changepoint Installation Guide. 
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To configure a daily schedule

1. In the Recurrence list, select Daily.

2.  In the Recurrence setting section, select one of the following options:

• Every day

• Every weekday (Monday – Friday)

• Every <n> days, where <n> is the number that you enter (number between 1 and 30). 

3.  To repeat the export multiple times each day (applies only to Every day or Every 
workday (Monday – Friday)):

a. Select the Repeat schedule check box.

b. In the Every field, enter the interval, and then select the time unit from the list.

4.  Click Save.

To configure a weekly schedule

1. In the Recurrence list, select Weekly.

2.  In the Recurrence setting section:

a. In the Every <n> weeks on field, enter a number between 1 and 52 for the number of 
weeks between runs. 

b. Select the check boxes for the days of the week on which to run the export.

3.  Click Save.

To configure a monthly schedule

1. In the Recurrence list, select Monthly.

2.  In the Recurrence setting section, select one of the following options:

• Day <n> of every <m> month(s)

In the <n> field, enter a number between 1 and 31 for the day of the month on which 
to run the export. In months that do not have the specified number of days, the export 
runs on the last day of the month. 

Changepoint Administration | 349



15. Importing and Exporting Data

In the <m> field, enter a number between 1 and 12 for the number of months between 
runs.

• The <nth > <period> of every <m> month(s)

In the <nth> list, select First, Second, Third, Fourth, or Last. 

In the <period> list, select the period.

In the <m> field, enter a number between 1 and 12 for the number of months between 
runs.

3.  Click Save.

Modifying an export publishing schedule

1. Click Import/Export > Export Publishing Schedule.

2.  Select the export publishing schedule.

3.  Make the necessary changes and click Save.

4.  To delete the setup, click Actions > Delete.

Setting up an export event notification

1. Click Import/Export > Export Event Notifications.

2.  In the Entity type list, select the entity type associated with the event notification.

3.  To filter the entity types by status, in the Status list, select Active or Inactive.

4.  Click Load list.

5.  If the Event Notification view does not appear, select an existing event notification, and 
then click New.

6.  To activate the event notification, select the Activate this event notification for usage in 
Changepoint check box.

7.  In the Notification name field, enter a name for the event notification.

8.  In the Description field, enter a description.

9.  To set up conditions for the event notification, in the Configure Condition section, 
complete the fields as required. For more information, see "Setting up conditions for an 
export event notification" on page 351.
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10.  Click Save.

Setting up conditions for an export event notification

You first create expressions and then use the expressions to build a formula, which defines the 
conditions under which the event notification is sent.

To set up a condition based on a field value

1.  In the Configure Condition section, select the Condition based on field value option.

2.  In the Expression field, enter a name for the expression, or leave the field blank to have a 
name automatically assigned.

3.  In the Field name list, select the field.

4.  In the Condition list, select the condition.

Note: For request fields that relate to users (for example, Created by or Initiator), you 
can specify either Changepoint resources or Client Portal users by using the Any condition.

5.  In the String text field, enter the value.

6.  In the Configure Condition section, click the Save button.

To set up a condition based on when the value of a field changes

1. In the Configure Condition section, select the Condition based on field change option.

2.  In the Expression field, enter a name for the expression, or leave the field blank to have a 
name automatically assigned.

3.  In the Field name list, select the field.

4.  Do one of the following:

• To base the condition on changes from or to specific values, enter the values in the 
From value and/or To value fields.

• To base the condition on any change to the field values, leave the From value and/or 
To value fields blank.

5.  In the Configure Condition section, click the Save button.

To build a condition formula:

1. To add an expression to the formula, double-click the expression in the expression table.
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2.  To add an operator, bracket, or space, click the appropriate button:

3.  To test that the formula you have entered is valid, click Test Formula. 

4.  To display the expressions in expanded format, select the Display expanded conditional 
formula check box.

5.  Click Save.

To add an additional condition based on a SELECT statement

After you create a conditional formula, you can configure additional conditions based on an 
SQL SELECT statement, which is executed only if the conditions in the conditional formula 
are met. 

1. Select the Configure notification based on SELECT statement check box.

2.  Enter the statement in the field that appears. For more information, see "About SQL 
SELECT statements for conditional formulas" on page 353.

Modifying an event notification

Do not deactivate or delete an event notification that is associated with an export publishing 
schedule. You must first delete the export publishing schedule, or modify the schedule to 
remove the event notification before you deactivate or delete the event notification.

1. Click Import/Export > Export Event Notifications.

2.  Select the event notification.

3.  To deactivate the event notification:

a. Clear the Activate this event notification for usage in Changepoint check box.

b. Click Save.

4.  To edit the event notification:

a. Make the necessary changes.

b. Click Save.

5.  To delete the event notification:

a. Click  Delete.

b. Click OK to confirm.
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About SQL SELECT statements for conditional formulas

The SQL statement must:

• Begin with SELECT

• Not contain UPDATE, DELETE, TRUNCATE or INSERT

• Return:

• 1 if the event notification should be sent

• 0 if the event notification should not be sent.

• Use @Entityid as a parameter to represent the GUID of the entity in the SELECT 
statement. For example: WHERE requestid = @entityid

• As a best practice, include FROM table WITH (NOLOCK) in the SELECT statement to avoid 
creating deadlocks in the system. 

For example:

SELECT

  CASE 

    WHEN count (*) >=1 THEN 1

    ELSE 0

  END

  FROM request WITH (NOLOCK)

  WHERE customerid = @entityid AND requeststatus NOT IN ('clo','rej','can')

Verifying the status of export publishing exports

After the data has been exported, you can verify the status of the export by running the Export 
Publishing Audit report and the Export Publishing Error report.

These reports should be set up during the export publishing setup. For more information, see 
"Setting up export publishing" on page 347.

Resending published data

You can resend a successful export publishing export, for example, if the third-party 
application did not receive the export properly. The receiving program must be set up to detect 
when exports have been resent.

1. Click Import/Export > Export Publishing Resend.

2.  In the Export to resend list, select the export publishing schedule.
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3.  In the Export number list, select the export number that has the date and time of the 
export. The export number consists of the export number, export date, and file number.

4.  Click Resend.

About importing clients and contacts
Client data and contact data can be imported into Changepoint. You must format the data in a 
Microsoft Excel spreadsheet where you map the data to the corresponding Changepoint field 
names. You must ensure that the import data includes values for the fields that are mandatory 
in Changepoint.  

The import data is processed as follows:

• If the client name in the import file matches an existing client in Changepoint, the client's 
data is updated. 

• If the client name does not match any existing clients, a new client is created. 

• If the client name is close to, but not exactly the same as an existing client, it is listed as 
questionable in the Import Results report. You can then decide whether you want to 
update an existing client or create a new client.

• Only blank fields in Changepoint are updated with import data. Existing values are not 
overwritten.

About creating the import file for clients and contacts

You must create a Microsoft Excel spreadsheet with the import data as follows:

• The first row in the spreadsheet must contain the field names as they exist in the 
Changepoint database. For more information, see  "Available fields for importing clients" 
on page 354 and "Available fields for importing contacts" on page 357.

• To import data for lookup fields, you must use the Changepoint lookup values in the 
import file.

• You must provide values for the mandatory fields. The System Metadata report lists all 
of the fields and their settings, including whether they are mandatory or not. .

• The import file must be in Unicode text format.

Available fields for importing clients

Client data is in the customer entity table.
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Note: To import postal codes and states or provinces, you must also import the country 
field.

Field Name Length Label Type

AccountManagerID N/A Account manager Lookup

AccountType N/A Account type Lookup

AllowEngagement N/A Allow initiatives Boolean

AnnualRevenue N/A Estimated budget Lookup

Business1Address 100 Main String

Business1AddressLine2 100 Main String

Business1AddressLine3 100 Main String

Business1AddressLine3 100 Main String

Business1City 50 City String

Business1Country N/A Country Lookup

Business1Postal 20 ZIP/Postal code String

Business1Province N/A State/Province Lookup

Business2Address 100 Cross Charging String

Business2AddressLine2 100 Cross Charging String

Business2AddressLine3 100 Cross Charging String

Business2City 50 City String

Business2Country N/A Country Lookup

Business2Postal 20 ZIP/Postal Code String

Business2Province N/A State/Province Lookup
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Field Name Length Label Type

Business3Address 100 Shipping String

Business3AddressLine2 100 Shipping String

Business3AddressLine3 100 Shipping String

Business3City 50 City String

Business3Country N/A Country Lookup

Business3Postal 20 ZIP/Postal code String

Business3Province N/A State/Province Lookup

CampaignID N/A Source Lookup

Customer_Description 2048 Comments String

Customer_OtherPhone 25 Other phone String

Customer_Reference N/A Sales reference Boolean

CustomerCode1 N/A Code 1 Lookup

CustomerCode2 N/A Code 2 Lookup

CustomerCode3 N/A Code 3 Lookup

CustomerServicePhone 25 Client service String

CustomerStatus N/A Status Lookup

CustomerText1 100 Text 1 String

CustomerText2 100 Text 2 String

CustomerText3 100 Text 3 String

Employees N/A Employees Lookup

ExecutiveOfficePhone 25 Executive office phone String
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Field Name Length Label Type

FaxPhone 25 Fax String

HRPhone 25 HR phone String

IndustryType N/A Department type Lookup

MainPhone 25 Main phone String

MarketingPhone 25 Marketing phone String

Name 200 Client Name String

SalesPhone 25 Sales phone String

SalesRegion N/A Location Lookup

SalesRepID N/A Client manager Lookup

SalesStatus N/A Account status Lookup

SecurityPhone 25 Security phone String

TechnicalSupportPhone 25 Technical support phone String

TelemarketerID N/A Executive contact Lookup

TollFreePhone 25 Toll free String

UserDefinedCustomerId 25 Client ID String

WebSite 255 Web site String

Available fields for importing contacts
Note: To import postal codes and states or provinces, you must also import the country 
field.
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Field Name Length Label Type

Anniversary 50 Anniversary DateTime

AssistantName 100 Assistant name String

AssistantPhone 25 Assistant phone String

Birthday 50 Birthday DateTime

BusinessAddress 100 Main String

BusinessAddressLine2 100 Main String

BusinessAddressLine3 100 Main String

BusinessCity 50 City String

BusinessCountry N/A Country Lookup

BusinessFax 50 Business fax String

BusinessPhone 25 Business phone String

BusinessPhone2 25 Business phone 2 String

BusinessPostal 20 ZIP/Postal code String

BusinessProvince N/A Province/State Lookup

CarPhone 25 Car phone String

Contact_Description 2048 Comments String

Contact_OtherPhone 25 Other phone String

Contact_Reference N/A Sales reference Boolean

ContactCode1 N/A Code 1 Lookup

ContactCode2 N/A Code 2 Lookup

ContactCode3 N/A Code 3 Lookup
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Field Name Length Label Type

ContactText1 100 Text 1 String

ContactText2 100 Text 2 String

ContactText3 100 Text 3 String

ContactType N/A Contact type Lookup

Customer N/A Client Lookup

Department 100 Department String

Email1 100 Email 1 String

Email2 100 Email 2 String

Email3 100 Email 3 String

FirstName 50 First String

HomeAddress  100 Cross Charging String

HomeAddressLine2 100 Cross Charging String

HomeAddressLine3 100 Cross Charging String

HomeCity 50 City String

HomeCountry N/A Country Lookup

HomeFax 50 Home fax String

HomePhone 25 Home phone String

HomePhone2 25 Home phone 2 String

HomePostal 20 ZIP/Postal code String

HomeProvince N/A Province/State Lookup

LastName 50 Last String
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Field Name Length Label Type

ManagerName 100 Manager String

ManagerPhone 25 Manager phone String

MiddleName 50 Middle String

MobilePhone 25 Mobile String

Nickname 50 Nickname String

Office 100 Office String

OtherAddress 100 Shipping String

OtherAddressLine2 100 Shipping String

OtherAddressLine3 100 Shipping String

OtherCity 50 City String

OtherCountry N/A Country Lookup

OtherFax 50 Other fax String

OtherPostal 20 ZIP/Postal code String

OtherProvince N/A Province/State Lookup

Pager 50 Pager String

Prefix 20 Title String

PrimaryPhone 25 Main contact String

Profession 100 Profession String

SpouseName 50 Spouse name String

Suffix 20 Suffix String
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Field Name Length Label Type

Title 100 Job title String

WebAddress 100 Web site String

Importing clients and contacts

1. Place the import file on a local drive or a shared folder. 

2.  Click Import/Export > Import Data.

The Import Data view appears.

3.  Click Browse to locate and select the import file.

4.  In the Deleted clients section, do one of the following:

• To exclude data for deleted clients from being imported, select Ignore.

• To import data for deleted clients, select Import.

5.  In the Deleted contacts section, do one of the following:

• To exclude data for deleted contacts from being imported, select Ignore.

• To import data for deleted contacts, select Import.

6.  In the Maximum number of close names field, enter the number of similar names to 
include in the Import Results report.

7.  Click Go.

The Import Results report appears. Processing may take a few moments.

8.  To view the list of the clients that were imported, expand the Clients imported section.

9.  To view the list of contacts that were imported, expand the Contacts imported section.

10.  To process the close matches, expand the Questionable clients section.

11.  For each client in the section, do the following:

a. Expand the client. 

b. To view the client profile, click the client name link.

c. Do one of the following:
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• To create a new client profile, select Create as new client.
• To update the existing client, select Update existing client. 

12.  Click Import.

13.  To view import errors, expand the Errors section.
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Archiving overview

When you archive an initiative or a project, all the data associated with the initiative or 
project is archived with it. For example, if you archive a project, the project tasks, requests 
and knowledge items associated with the project, time and expenses entered for the project, 
project budget, and so on, are also archived.

When an entity is archived, it is physically deleted from the production database and is no 
longer available from Changepoint tree views, search results, or reports. If the system 
administrator has configured access to the archive database, users can access the archived 
data through custom Changepoint Analytics data sources.

Terminology

For the purposes of the archiving functionality, the following terms apply:

• archive administrator – resource responsible for archiving and who can access 
Changepoint Administration 

• entity manager – generic term that refers to the resource who is the initiative manager or 
project manager for the given entity

Archiving process

1.  Before data can be archived, the database administrator must set up an archive database 
and configure access to the archived data. For more information, see the Changepoint 
Installation Guide. 

2.  Entity managers use the archive options in Changepoint to flag project or initiative 
entities for archiving. 

3.  The entity archiving request appears in the Archive Approval view in Changepoint 
Administration.

4.  The archive administrator reviews the entity archiving requests, and either approves or 
rejects the entity for archiving. If a child entity is rejected by the archive administrator, 
then the parent entity is automatically rejected as well.

5.  The archive administrator runs the Archive Validation scheduled job that checks 
whether the approved entities can be safely archived. If a child entity fails the archiving 
validation, then the parent entity automatically fails as well.
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6.  The archive administrator or the entity manager clears the failed and rejected entities from 
the Archiving Validation Log report.

7.  The archive administrator runs the Archive Aged Entities scheduled job to archive the 
entities.

About retaining funding source data

There is an option that allows for funding source data to be retained even after the associated 
entity has been archived.  If the Retain funding source data option is selected, totals for past 
(and potentially current and future) periods can include the effort, cost and revenue from 
archived items, even though the archived items themselves are no longer available in the 
production database.

When the Retain funding source data option is cleared, the totals are recalculated to remove 
the funding source data for the archived entities.

Note: The Retain funding source data option must be selected in the Archive Approval 
view before the view is saved the first time. The option cannot be changed after it has been 
saved.

About accessing archived data

No standard Changepoint reporting is available. To access the archived data, you must create a 
custom Changepoint Analytics report. 

Note: The creation of custom reports is not supported by your Changepoint support 
agreement. If you require assistance, contact your Service Delivery Group representative 
or client manager to arrange for consulting services.

About approving entities for archiving
After the entity manager flags an entity for archiving in Changepoint, the archiving request 
appears in the Archive Approval view in Changepoint Administration. The archive 
administrator reviews the entity and either approves or rejects it. 

Only the entities that have been approved by the archive administrator are validated by the 
Archive Validation scheduled job.

If an entity is rejected, its parent entities are automatically rejected as well. 
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An entity that has failed validation cannot be flagged again for archiving in Changepoint or 
from the Archive Approval report until all issues listed in the report have been reviewed and 
cleared by either the entity manager or the archive administrator.

Once the entity has been cleared in the Archiving Validation Log, the entity is again available 
for archiving in Changepoint.

Approving entities for archiving

1. Click Archive > Archive Approval.

2.  To approve an entity, select the check box in the Approve column.

3.  To reject an entity:

a. Select the check box in the Reject column.

b. Enter the reason in the Rejection reason cell. 

4.  Select the Retain funding source data check box, if required.

Warning: The Retain funding source data option is available only the first time that the 
Archive Approval view is saved, and the setting cannot be changed later. It is strongly 
recommended that the archive administrator consult the Finance department before saving 
this view.

5.  Click Save.

Archive Approval view

Column Description

Approve check box Available only when the validation status is Pending 

or Passed.

Reject check box Available only when the validation status is Pending 

or Passed.

Entity name Name of the entity to be archived.

Entity type ENG (initiative), or PRJ (project)
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Column Description

Rejection reason Reason for rejecting the entity. Editable only when 

the Reject check box is selected.

Validation status One of the following statuses:

• Pending – the entity has not been validated yet

• Passed – the entity has passed validation

• Failed – the entity has failed validation

Flagged for archiving on Date that the entity was initially flagged for archiving, 

but updated to the date that the archive administrator 

saves the Archive Approval view.

Flagged for archiving by Entity manager who flagged the entity for archiving.

Validated on Date that the Archive Validation scheduled job was 

run.

Validated by Name of the archive administrator.

Canceling archiving for an entity – archive administrator

The archive administrator can cancel archiving for an entity that has a validation status of 
Pending or Passed at any time before the Archive Aged Entities scheduled job is run. 

1. Reject the entity in the Archive Approval view.

2.  Clear the rejected entity from the Archive Validation Log.

About running the Archive Validation scheduled job
The Archive Validation scheduled job checks only the entities that have been approved and 
have a validation status of Pending in the Archive Approval view. The entities that fail 
validation or have been rejected by the archive administrator are listed in the Archiving 
Validation Log report.

The archive administrator manually runs the Archive Validation scheduled job while no 
other Changepoint scheduled jobs are running. If the Archive Validation scheduled job fails, 
an email notification is sent to the entity managers.

Project validation list

For a project to pass validation, all of the following conditions must be met:
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• The project is in Completed state, but not locked.

• If the project has subprojects, all subprojects must be able to pass validation.

• The project is not associated to a expense report that is also used by other projects that are 
not being archived.

• The project is not used as a template in a workflow step.

• The project is not associated with:

• unapproved expenses

• chargeable expenses that have not been charged

• non-committed cross charges

• non-committed credit notes

• cross charge that:

• includes non-labor item records
• includes fixed fee records
• includes request time records
• is used by other projects that are not being archived

• a credit note that:

• includes non-labor item records
• includes fixed fee records
• includes request time records
• is used by other projects that are not being archived

• chargeable time that has not been charged

• unapproved time

• a workflow that has not yet been completed

• time and expense records that have been recognized

• a portfolio

Initiative validation list

For an initiative to pass validation, all of the following statements must be true:

• The initiative must be closed, but not locked.
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• All projects under this initiative must pass validation.

• The initiative is not associated with a non-committed cross charge or credit note.

• Revenue recognition must be disabled for the initiative.

About the Archiving Validation Log report
Entities that are rejected by the archive administrator or fail validation are listed in the 
Archiving Validation Log report, which is a standard Changepoint report. Entity managers 
can view the results for the entities that they flagged for archiving by accessing the Archiving 
Validation Log report in Changepoint. 

It is good practice for the entity managers or archive administrator to clear all failed and 
rejected entities from the Archiving Validation Log before the Archive Aged Entities 
scheduled job is run. Entities can be cleared either by resolving the problems that caused the 
failures and rerunning the Archive Validation scheduled job, or by deleting the entities from 
the Archiving Validation Log. 

Note: Entities that fail validation cannot be flagged for archiving nor can they be canceled 
by entity managers in the entity profile in Changepoint. 

The Archiving Validation Log report displays the following information:

• Entity name – name of the entity

• Clear – check box that, when selected, will clear the entity from the report when the report 
is saved

• Entity type – ENG (initiative) or PRJ (project)

• Rejection reason – the reason that the archive administrator rejected the entity

• Validated on – the date that the validation scheduled job was run

• Flagged for archiving by – the entity manager who initiated the archive process

Accessing the Archiving Validation Log report – archive administrator

Click Archive > Archiving Validation Log.

Clearing entities from the Archiving Validation Log report – archive 
administrator

1. Click Archive > Archiving Validation Log.
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The Archiving Validation Log view appears.

2.  To remove an entity, clear the check box in the Clear column.

3.  Click Save.

About the Archive Aged Entities scheduled job
When entities have passed validation, the archive administrator manually runs the Archive 
Aged Entities scheduled job, which does the following:

• revalidates all of the approved entities that have a validation status of Passed in the 
Archive Approval view

• copies the entities that pass validation into the archive database

• removes the entities that were successfully copied from the production Changepoint 
database

• adds a row to the Archiving Log report for each entity that was successfully archived

Running the Archive Aged Entities scheduled job

The archive administrator manually runs the Archive Aged Entities scheduled job.

1. Ensure that all users have been locked out of Changepoint. For more information, see the 
"Locking Changepoint" section on page 24.

2.  Enable and schedule the Archive Aged Entities scheduled job to run at a time when all 
users are disconnected from the database and no other scheduled jobs or tasks are running.

3.  If the Archive Aged Entities scheduled job fails:

a. Run the EnableAllTRsNFKs.sql script to ensure that the Changepoint database is in 
working condition.

b. Review the job history or Data_Archiving.dtsx.log for more details.

4.  Unlock Changepoint.

About the Archiving Log report
The entities that are successfully archived are reported in the Archiving Log report. Entity 
managers can view the results for their own entities only, but archive administrators can view 
the results for all entities.

The Archiving Log report displays the following information: 

Changepoint Administration | 369



16. Archive Management

• Entity name – name of the entity 

• Entity type – initiative or project depending on the archived entity

• Archiving date – the date that the archiving scheduled job is run

Accessing the Archiving Log report – archive administrator

Click Archive > Archiving Log.

Troubleshooting archiving

The Archive option for an entity is not available on the entity profile

For an entity to be eligible for archiving, the following conditions must be met:

• User must be the initiative manager of the initiative or project manager for the project and 
have the security access for archiving.

• Projects must have a status of Complete

• Initiatives must have a status of Closed

• Only one entity in a hierarchy can be flagged for archiving at a time. When a parent entity 
is flagged, then its children cannot be flagged. For example, if an initiative is flagged, then 
the projects for the initiative cannot be flagged. Similarly, when a child entity is flagged, 
then its parent entity cannot be flagged. These restrictions apply during the entire archiving 
process until the flagged entity is either archived or archiving is canceled for the entity.

An entity passed validation for archiving, but failed during archiving

Initiative and project entities that pass validation are locked, but can be edited as follows:

• Initiative managers and project managers can edit their entities, even after they have been 
locked.

• data associated to a locked entity can be edited by resources. 

Therefore, it is possible for an entity to pass validation during the Archive Validation 
scheduled job, but later fail during the Archive Aged Entities scheduled job. For example, 
if a project entity passed validation, but time and expenses are later entered for the project but 
are not approved, then the project entity would fail validation during the Archive Aged 
Entities scheduled job. 
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About workflow management

An entity workflow includes entity states and the activities that take place between an initial 
state of an entity and one of a set of final states. The movement from one state to another is 
called a state transition.

For each entity type, a specific workflow field is used to track the progress of an entity from 
one workflow state to another. The entity types and their corresponding workflow fields are 
as follows:

• project - Proposed phase

• request - Status

• resource request - Status

• candidate - Status

A state transition may be either:

• manual - initiated by a resource changing the current value of the workflow field to the 
new To value of the transition

• automatic - initiated by either the value of a user configurable field, or a change in value 
of a user configurable field when the Workflow Management scheduled job runs

In either case, the transition may cause the execution of a workflow process: a combination 
of steps that might include running stored procedures; comparing entity field values; sending 
workflow notifications to resources; and having resources carry out actions and then set a 
completion status.

Filters are used to determine which workflow is used for a newly-created entity.

Workflow configuration overview

To configure a workflow, you must create a state definition that includes states and state 
transitions. Optionally, for each state transition you can create a process definition. You can 
also define access restrictions for the states and state transitions.

A state definition also includes filters that determine which workflow is selected for each 
newly-created entity.

• A state is a defined “status” of the entity controlled by the workflow. 
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• A state transition is a path between states.

• A process definition consist of process steps and step transitions. 

• A step is an action to be carried out. 

• A step transition is a path between steps.

Changepoint includes a default workflow for each entity type. The default workflow is used 
when a newly-created entity does not match any workflow definition filter for that entity. 
However, it is strongly recommended that you create workflows, including default workflows, 
that match your organization’s business processes.

To create a workflow for an entity, do the following:

1.  Enable the workflow for the entity, if required.

2.  Create state definitions, each with a set of filter criteria.

3.  For each state definition, create a state workflow layout, then add states and state 
transitions.

4.  Optionally, for each workflow state and state transitions, define the edit access rights to 
the entity and the transition.

5.  Optionally, for each state transition, edit the From state and configure the fields and 
criteria that must be met to initiate the state transition.

6.  Optionally, for each  state transition,  do the following:

a. Create a process workflow layout.

b. Add and configure process steps and step transitions.

7.  When required, activate the workflow.

Enabling and disabling workflow for an entity

Workflow for request and resource request entities is mandatory and is enabled by default. 

Workflow for project and candidate entities is optional and must be enabled before you can 
configure workflows for these entity types. 

You can disable workflow for the project and candidate entities even after workflows have 
been created and are in use.
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However, if you disable workflow for an entity, all workflows for the entity that are in 
progress at that time are canceled, and the status of the entity remains unchanged.

1. Click Workflow > Workflow Configuration.

2.  To enable workflow for Project and/or Candidate entities, select the appropriate check 
boxes.

3.  To disable workflow for Project and/or Candidate entities, deselect the appropriate check 
boxes.

4.  Click Save.

Resetting a workflow process instance

You can reset a workflow process instance for an entity, for example, after you make changes 
or additions to a process workflow layout. The process instance that was in progress is 
canceled, and a new process instance is created.

1. Click Workflow > Reset Workflow Process Instance.

2.  In the Entity type list, select the entity type. 

3.  In the Process list, select the workflow process. 

4.  In the Search field, do one of the following:

• To search for a process instance, enter the search text.

• To view all process instances, leave the field blank.

5.  Click Search.

6.  In the Name/Number list, select the instances that you want to reset.

7.  Click Save.

Resetting a workflow state instance

For entity records that are in process, you can change the workflow state to another state. 
When the state is reset, the workflow in progress is canceled, and the entity is placed in the 
specified state.  No new workflow is triggered.

1. Click Workflow > Reset Workflow State Instance.

2.  In the Entity type list, select the entity.
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3.  In the Field name list, select the workflow field for the entity. 

4.  In the State list, select the state. States that have been deleted are gray.

5.  In the Search field, do one of the following:

• To search for a state instance, enter the search text.

• To view all state instances, leave the field blank.

6.  Click Search.

7.  Select the state instances.

8.  In the Change state to list, select the new state for the selected state instances.

9.  Click Save.

State definitions and layout

About workflow state definitions and filters

A workflow state definition includes all of the information needed to determine:

• Whether the workflow definition is triggered for a new instance of the entity.

• The initial state that the entity goes into when the workflow is initiated. 

• The different states the entity can reach while the workflow in progress. 

• The possible transitions  from one state to another and how each transition is effected. 

• The edit access rights to the entity in each workflow state and to the state transitions.

About activating and locking a workflow state definition

When you activate a workflow state definition it becomes locked. You can modify only the 
State definition field and Description field, and must deactivate the workflow state definition 
before you can delete it. 

Note: Deactivating a workflow state definition does not unlock it. To make changes to a 
locked workflow state definition you must make a copy of it, modify the copy, then 
activate the copy.
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About the workflow states

The workflow states come from the values of the entity field that is selected as the workflow 
field in the state definition. 

• For the request, resource request, and candidate entities, the workflow field is the Status 
field. 

• For the project entity, the workflow field is the Proposed phase field.

Note: The drop-down values for the Proposed phase field are defined in the Task lookup 
at the system-level. For more information, see the "About modifying values for standard 
drop-down (lookup) lists" section on page 177.

About filter criteria 

The filter criteria determine which workflow a newly-created entity is routed to. 

If a workflow has multiple filter criteria, the criteria are implicitly joined by an AND operator.

A configurable field can be used in a filter criterion provided it is set up as a single-selection 
list whose values are not entity-based. 

About selecting subfields in filters

Some fields in Changepoint are subfields in a hierarchy. When you select a subfield name in a 
filter, the fields higher in the  hierarchy than the subfield are added automatically as filter 
criteria. 

For example in a filter for a request, if you select an initiative, the corresponding client is 
added as a criterion; if you select a project, the corresponding initiative and  client are added as  
criteria.

How filtering works to select a workflow

When a new entity is created, the entity's field values are evaluated against the filters for all 
active workflows for that entity. The following rules are applied in the order given:

1.  If the entity is not a match to any workflow filters, the default workflow is selected.

2.  If the entity is a match to the workflow filters for only one workflow, that workflow is 
selected.

3.  If the entity is a match to the workflow filters for more than one workflow:
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a. The workflow with the largest number of filter criteria is selected. 

b. If there is more than one workflow with the same (largest) number of criteria matched, 
the workflow with the name that comes first alphabetically is selected.

Note: If there are two or more matched workflows with the same name,  it cannot be 
predicted which workflow will be selected for a new entity.

About filter criteria changes

If an entity field that is used in filter criteria is changed, the workflow is canceled.

• If the changed field values match another workflow then that other workflow is initiated 
for the entity.

• If entity records are transferred from one resource to another, the workflow is reset and 
restarted at the beginning of the workflow state definition when the record transfer is 
completed. 

• If the field is edited manually by a resource, the workflow is canceled immediately.

• If the filter field is changed by some other means (for example, through the Changepoint 
API, or as a result of a calculation), then the workflow is canceled when the workflow 
management scheduled job runs.

Creating a workflow state definition

1. Click Workflow > Workflow Definitions.

2.  In the Folders view, expand the entity, and then select any state definition.

3.  Click New.

4.  In the State definition field, enter the name for the state definition. 

5.  In the Field name list, select the workflow field for the entity.

6.  In the Reference field, enter any text. 

Typically this field is used for information that uniquely identifies the state definition and 
version. 

7.  In the Description field, enter the description of the state definition.

8.  To add a filter, in the Filter criteria section, enter the filter criteria as follows:

a. Right-click in the table, and then select Insert.
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b. In the Field name list, select the filter field. 

c. In the Value list, select the value of the field. 

9.  To delete a filter, do the following:

a. Right-click the row, and then select Delete.

b. Click OK to confirm.

10.  Click Save. 

Note: You cannot enable the Active check box and save the definition until you have 
defined at least an initial state in the state workflow layout.

Tip: Do not enable the Active check box until you have completely defined the state 
workflow layout. Once a state definition has been activated, it is locked and you cannot  
modify the workflow layout.

Editing a workflow state definition 

1. Click Workflow > Workflow Definitions.

2.  In the Folders view, expand the entity, and then select the state definition.

You can also use the Filter field to restrict the definitions displayed.

3.  To modify the state definition:

a. Make the necessary changes to the  fields.

b. Click Save.

4.  To delete the state definition:

a. Clear the Active check box and then click Save.

b. Click Delete.

c. Click OK to confirm.

Activating and validating a workflow state definition

When you have configured the state workflow layout and the required process workflow 
layouts for a state definition, you can activate the definition.  When you activate a definition, if 
an active definition exists with the same  filter criteria, it is automatically deactivated.

State definitions are validated during activation.
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1. Click Workflow > Workflow Definitions.

2.  In the Folders view, expand the entity, and then select the state definition.

3.  To activate the workflow for the state definition,, check the Active check box  and then 
click Save. 

If the workflow is invalid, the Workflow Validation dialog box appears with a list of 
validation error definitions.

4.  To correct a validation error, do the following:

a. Double-click a definition to be taken to the location of the error. 

b. Correct the error.

c. If the error was in the process workflow layout screen, click Return. 

d. Click Close on the state workflow layout screen. 

The Workflow Validation dialog box re-appears. 

e. In the Workflow Validation dialog box, click Validate.

f. If the error correction was successful, the definition is removed from the list.

5.  To deactivate the workflow for the state definition, clear the Active check box. 

6.  Click Save.

Copying a workflow state definition

When you copy a state definition, the  state definition General and Filter values, states, 
transitions, process definitions, access rights, and attachments that have been configured for 
the definition are also copied. 

1. Click Workflow > Workflow Definitions.

2.  In the Folders view, expand the entity, and then select the state definition.

You can also use the Filter field to restrict the definitions displayed.

3.  Click Copy.

Tip: Because the copy has the same name as the original, you should rename the copy (or 
the original) as soon as possible.
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About exporting and importing workflow state definitions

You can export state definitions, including the associated process definitions, from a 
Changepoint server and then import them into another Changepoint server with the same 
Changepoint version.

For example, you can export state definitions from a production server, and import them into a 
test server for testing and troubleshooting. 

State definitions are exported in XML format. 

The  state definition is validated before it is exported. For more information about validating 
definitions, see "Activating and validating a workflow state definition" on page 377.

Exporting a workflow state definition

The  state definition is validated before it is exported.

1. Click Workflow > Workflow Definitions.

2.  In the Folders view, expand the entity, and then select the state definition.

You can also use the Filter field to restrict the definitions displayed.

3.  Click Export, and save the file to the required location.

Importing a workflow state definition

1. Click Workflow > Workflow Definitions.

2.  In the Folders view, expand the entity and then select any state definition.

3.  Click Import.

The Import State Definition dialog box appears.

4.  Click Browse,  select the state definition file, and click Open. 

5.  Click Upload.

6.  In the State definition name field, edit the name of the state definition, if required. 

7.  Click Import.

8.  If the file being imported contains entity states that do not exist in the database, the 
Workflow Validation dialog box appears. For each such state do the following:

a. Select whether to create a new state or to map it to an existing state. 

Changepoint Administration | 379



17. Workflow Management

b. To  map it to an existing state, select the existing state.

Overview of the state workflow layout

The state workflow layout window includes a toolbar and a design area that displays a graphic 
representation of the state workflow. In this window, you can configure the states (represented 
as ) and state transitions (represented as ) for a state workflow.

The initial state of the workflow  is shown as .

A  state transition that has an associated workflow process is shown as .

To configure a state workflow layout, do the following:

1. Add the required states to the design area. 

2.  If required, configure each state to apply access restrictions for the entity while it is in that 
state. 

3.  Add  each required  state-to-state transition to the design area.

4.  If required, configure each state transition to apply access restrictions.
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5.  If required, configure each state to add a field value-based trigger for each state transition 
that starts at that state. 

If required, after you have configured each state transition, you can define process workflow 
steps that must be carried out before the state transition can complete.  For more information, 
see "Process workflow layout" on page 391.

Accessing the state workflow layout window

1. Click Workflow > Workflow Definitions.

2.  In the Folders view, expand the entity, and then select the state definition.

3.  Click State workflow layout

The State workflow layout window appears.

Adding a state to the state workflow layout

The values in the State drop-down list are the values for the entity workflow field. For 
example, for request workflow, all available request status values display in the drop-down 
list. 

Each State value can be placed on the design area only once.

1. Access the state workflow layout window.

2.  Drag the  icon onto the design area.

The Workflow State Configuration dialog box appears. 

3.  To make this state the default state when a new entity is created for this workflow, select 
the Initial state check box. 

4.  In the State list, select the state. 

5.  In the Name field, enter a name for the state as it is to appear on the workflow layout. 

6.  In the Description field, enter a description for the state. 

This information is  intended for internal reference only.  

7.  To restrict the editing of the entity while it is in this state, see "Restricting edit access to 
the entity while in a workflow state" on page 382.

8.  You can add a trigger to initiate a state transition for which this state is the From state. 
However, you need to add the state transition first. For more information, see "Adding a 
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state transition to the state workflow layout" on page 382 and  "Adding a trigger for  a 
workflow state transition" on page 383

9.  Click Save.

Restricting edit access to the entity while in a workflow state

By default, any user can edit an entity while it is in any workflow state. You can restrict edit 
access to the entity while the entity is in a specific workflow state to specific resources, 
system-defined participants, or roles. 

Note: You can modify access control only if the state definition is not locked.

If you restrict edit access to a specific resource whose user account is later deactivated, 
existing entities may be unable to progress past this state. This requires the workflow to be 
reset. 

1. Access the state workflow layout window.

2.  Double-click the  icon in the design area.

The Workflow State Configuration dialog box appears.

3.  Click the Access tab.

4.  To display users, do one of the following:

a. In the Search field, enter the user name, then click Search.

b. To display only users who already have access, select the Show selected items only 
check-box.

5.  Select and deselect users as required.

6.  Click Save.

Adding a state transition to the state workflow layout

1. Access the state workflow layout window.

2.  Drag the  icon onto the design area.

The State Transition dialog box appears. 

3.  In the Transition name field, enter a name for the transition. 
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Tip: Give each state transition a unique name so that you can unambiguously identify the 
transition with the link in the state workflow layout.

4.  In the Description field, enter the description of this transition. 

The description is for internal reference only. 

5.  In the From state list, select the starting state for this transition.

6.  In the To state list, select the destination state for this transition.

Note: The outcome of the state transition may not be the destination state you select here, 
because the outcome may be changed by a process workflow that performs detailed steps 
for the transition.

Restricting edit access to the  workflow state transition

Note: If both state  access controls and state transition access controls are set up, the 
resource selected for state transition access must also have edit access to the starting state. 
If not, the workflow is invalid. 

1. Access the state workflow layout window.

2.  Right-click the   icon in the design area, and select State transition configuration.

The State Transition dialog box appears.

3.  To select the resources who are allowed to perform the state transition,  do one of the 
following:

a. In the Search field, enter the user name, then click Search.

b. To display only users who already have access, select the Show selected items only 
check-box.

Note: System-defined participant in this case includes Client Portal users with workflow 
participant access rights.

4.  Select and deselect users as required.

5.  Click Save.

Adding a trigger for  a workflow state transition

You can configure a workflow state so that an entity field value-based criterion must be 
satisfied to initiate a state transition with that starting state. The field that is configured to 
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initiate the workflow is the trigger field. You can use any configurable field of the entity as 
the trigger field.

If multiple criteria are defined, the conditions are evaluated in the order in which they appear 
in the table in the Transition tab of the Workflow State Configuration dialog box. The first 
matched criterion  initiates the transition. 

Note: For request workflow, the configurable field selected is validated with the request 
type configured for the state definition, when the state configuration is saved. For planning 
requests, the configurable fields available for selection are determined the configurable 
fields that have been setup for candidates.

1. Access the state workflow layout window.

2.  Double-click the  icon in the design area.

The Workflow State Configuration dialog box appears.

3.  Click the Transition tab.

4.  Do one of the following: 

• To have the state transition initiated when a specific change occurs in the trigger field, 
select the Transition based on change to the value of the field option.

• To have the state transition initiated  when a specific value is found in the trigger field, 
select the Transition based on the value of the field option.

5.  In the Transition list, select a state transition that has been created with this state in the 
From state field.

6.  In the Field name list, select the trigger field. 

7.  If you selected Transition based on  the value of the field:

a. In the Condition list, select the condition for the transition. The available selections in 
this field depends on the data type (code, text, numeric or date) of the Field name 
field.

b. In  the String text field, select or enter the value of the field, or the range of values, 
that will trigger the transition.

8.  If you selected Transition based on change to the value of the field and the trigger field 
is not a multi-select configurable field, complete the  From value and  To value.
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To cause any change to the trigger field to initiate the workflow transition, leave the From 
value and To value fields  blank.

9.  Click the Save button above the  table.

The transition criterion is added to the table. 

10.  To reorder the criteria, use the arrows at the right of the table. 

11.  To delete a criterion, select the criterion in the table and then click the Delete button above 
the  table.

12.  To modify a criterion, select the criterion in the table, make the changes in the fields above 
the table, and then click the Save button above the  table.

Modifying a workflow state

You can delete or edit states in the state workflow layout when the state definition is not 
locked. If the definition is locked, only the state name and description can be changed. 

To make other changes to a locked state definition, copy the state definition and make the 
changes to the copy. 

When you delete a state from a state workflow layout, all state transitions  connected to the 
state are also deleted, along with their corresponding process workflows.

1. Access the state workflow layout window.

2.  Double-click the  icon in the design area.

The Workflow State Configuration dialog box appears.

3.  To edit the state, make the necessary changes and then click Save.

4.  To delete the state, click Delete.

Modifying a  workflow state transition

You can delete or edit state transitions in the workflow layout when the state definition is not 
locked. If the definition is locked, only the transition name and description can be changed. 

To make other changes when the state definition is locked,  copy the state definition and make 
the changes to the copy. 

1. Access the state workflow layout window.

2.  In the design area, right-click the icon, and select State transition configuration
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The State Transition dialog box appears.

3.  Do one of the following:

• To edit the state transition, make the necessary changes and click Save.

If you change the name of the state transition, the name of the corresponding process  
workflow is also changed.

• To delete the state transition, click Delete.

If a process workflow exists for the transition, it is also deleted.

Resource Request Workflow

Default state definitions for resource request workflow

The following table describes the default state definitions for  resource request workflows.

State Transition Configuration Edit Access

New The initial state. 

Automatic transition: Pending 
Assignment automatically transitions 

the New state to the Assigned state.

No criteria required for the transition to 

occur.

• Request Initiator

• Resource Manager (initiative staffing 

workgroup)

• Resource Manager (resource request)

• Resource Manager (resource request 

workgroup)

Assigned Automatic transition: Pending 
Approval automatically transitions the 

Assigned state to the Approved state. 

No criteria required for the transition to 

occur.

• System Administrator

Approved No automatic transition. 

The Approved state transitions to the 

Canceled by Initiator and Canceled 
by Resource Manager states.

Only the Request Initiator can select 

Canceled by Initiator and only the 

Resource Manager can select 

Canceled by Resource Manager.

• Request Initiator

• Resource Manager (initiative staffing 

workgroup)

• Resource Manager (resource request)

• Resource Manager (resource request 

workgroup)
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State Transition Configuration Edit Access

Rejected Automatic transition:Assignment 
Rejected automatically transitions the 

Rejected state to the Assigned state. 

No criteria required for the transition to 

occur.

• Resource Manager (initiative staffing 

workgroup)

• Resource Manager (resource request)

• Resource Manager (resource request 

workgroup)

Re-Opened Automatic transition: Re-Opened 
Assigned automatically transitions the 

Re-Opened state to the Assigned 

state. 

No criteria required for the transition to 

occur.

• Request Initiator

• Resource Manager (initiative staffing 

workgroup)

• Resource Manager (resource request)

• Resource Manager (resource request 

workgroup)

Canceled No automatic transition. 

The Canceled state transitions to the 

Re-Opened state based on user 

selection, or the system can set the 

state to Re-Opened via the project 

team or task editing screen.

Either the request initiator or the 

resource manager can make the 

transition.

• Request Initiator

• Resource Manager (initiative staffing 

workgroup)

• Resource Manager (resource request)

• Resource Manager (resource request 

workgroup)

Canceled by 
Initiator

No automatic transition. 

The Canceled by Initiator state 

transitions to the Re-Opened state 

based on user selection, or the system 

can set the state to Re-Opened via the 

project team or task editing screen.

Only the request initiator can make this 

transition.

• Request Initiator

• Resource Manager (initiative staffing 

workgroup)

• Resource Manager (resource request)

• Resource Manager (resource request 

workgroup)
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State Transition Configuration Edit Access

Canceled by 
Resource 
Manager

No automatic transition. 

The Canceled by Resource Manager 
state transitions to the Re-Opened 

state based on user selection, or the 

system can set the state to Re-Opened 

via the project team or task editing 

screen. 

Only the resource manager can make 

this transition.

• Request Initiator

• Resource Manager (initiative staffing 

workgroup)

• Resource Manager (resource request)

• Resource Manager (resource request 

workgroup)

Send to 
Resource 
Manager

Automatic transition: Mark as In 
Progress automatically transitions the 

Send to Resource Manager state to 

the In Progress (Resource Manager) 
state.

No criteria required for the transition to 

occur.

• Resource Manager (initiative staffing 

workgroup)

• Resource Manager (resource request)

• Resource Manager (resource request 

workgroup)

In Progress 
(Resource 
Manager)

Automatic transition: In Progress - RM 

automatically transitions the In 
Progress (Resource Manager) state 

to the Assigned state. 

No criteria required for the transition to 

occur.

• Resource Manager (initiative staffing 

workgroup)

• Resource Manager (resource request)

• Resource Manager (resource request 

workgroup)

Send to 
Initiator

Automatic transition: In Progress 
Initiator - Mark as In Progress 

automatically transitions the Send to 
Initiator state to In Progress (Initiator) 
state.

No criteria required for the transition to 

occur.

• Request Initiator
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State Transition Configuration Edit Access

In Progress 
(Initiator)

Automatic transition: In Progress - 
Initiator automatically transitions the In 
Progress (Initiator) state to Assigned 

state. 

No criteria required for the transition to 

occur.

• Request Initiator

Re-Assigned Automatic transition: Re-Assigned 

automatically transitions the Re-
assigned state to Assigned state.

No criteria required for the transition to 

occur.

• Resource Manager (initiative staffing 

workgroup)

• Resource Manager (resource request)

• Resource Manager (resource request 

workgroup)

Stored procedures for logic execution steps in resource request workflow

WFCALC_Approve

Performs a resource leveling check, and then populates the pass/fail status into the step 
(Approved is a pass). If resource leveling is passed, the stored procedure also populates the 
resource into the task assignment, project team, and projected resource record.

WFCALC_Assign

Performs a resource leveling check, and then populates the pass/fail status into the step 
(Assigned is a pass). If resource leveling is passed, the stored procedure also populates the 
resource into the project team entry. In the default resource request workflow, resources are 
populated earlier for project team records (after Assigned) than for projected resources and 
task assignment records (after Approved). If you want the task assignment, project team, and 
projected resource record to be populated at the same point in the workflow, use WFCALC_
Approve instead.

WFCALC_Cancel

Performs a validation of the cancel, and populates the pass/fail status into the step. If the 
validation passes, the stored procedure also removes the resource from the project team, task 
assignment or projected resource record.
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WFSPLIT_RequestInitiateLevel

Identifies the source of the resource request. 

Returns:

• ENG – initiative level

• PRJ – project level

• TSK – task level

WFSPLIT_RmLevel

For use in a split decision to determine how to route the resource request based on the 
information that is populated in the request.

Returns: 

• NotAvailable

• ResourceRequest

• ResourceRequestWorkgroup

• EngagementStaffingWorkgroup

WFSPLIT_ValidateCanceling

Use with WFCALC_Cancel to check if the resource can be removed from the project team or 
task assignment. 

For project team entries, if task assignments exist for the resource, then the resource can only 
be removed if there are no existing project team entries to cover the time period for the task 
assignments. 

For task assignments, the resource can only be removed if there are no time or expenses 
associated with the task assignment.

WFSPLIT_ValidateLeveling

Use with WFCALC_Assign and WFCALC_Approve to double-check resource leveling 
requirements are still met, and route the resource request differently if leveling fails.
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Process workflow layout
After you have configured a state transition, you can create a workflow process for it. 

A  workflow process is a series of steps or activities that must be completed before the 
associated state transition can complete. 

A state transition that has no associated process completes immediately when it is triggered. 

Some of the process steps types require manual action by an assigned workflow participant 
(system-defined participant, resource, role, or configurable field participant). 

Creating a process workflow

To create a process workflow for a state transition, do the following:

1. Access the state workflow layout window.

2.  Right-click the  icon for the state transition and select Process configuration.

The Process Workflow Layout window appears. The beginning and ending states of the 
state transition are included automatically.

3.  Do one of the following:

• Click  to save the process layout.

• Drag any step icon onto the design area then either click Return or click . 

When you refresh the workflow definitions tree, the process definition  appears in the  tree 
as a child of the corresponding workflow state definition. 

Add process steps and step transitions to build the process workflow. 

4.  Click .

5.  Click Return.

6.  Click Close.

Modifying a process workflow definition

When a process definition  is locked, you can edit only the process name and description, and 
you cannot delete the process definition.
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If you change the process name, the name of the corresponding state workflow transition is 
also changed.

To delete a process definition, delete the corresponding state workflow state transition.

1. Click Workflow > Workflow Definitions.

2.  In the Folders view, expand the entity  and the state definition, and then select the process 
definition.

3.  To edit the process definition, make the necessary changes and click Save. 

4.  To delete the process definition, do the following:

a. In the State Workflow Layout window, open the state transition configuration for the 
corresponding state transition. 

b. Delete the state transition.

About the process workflow layout window

The process workflow layout window  includes a toolbar and a design area that displays a 
graphic representation of the process workflow. In this window, you can configure the steps  
and step transitions for the process workflow.

The toolbar consists of two sets of buttons:

• layout management buttons

Use these buttons to  print, filter the display, etc.

• process step icons

Drag and drop these icons to the design area to graphically design the process workflow 
by adding steps, and transitions between steps. 
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Accessing the process workflow layout window

To access the process layout window from the Workflow Definitions tree:

1. Click Workflow > Workflow Definitions.

2.  In the Folders view, expand the entity, and then expand the state definition.

3.  Under the state definition, select the process workflow.

4.  Click Process Workflow Layout.

The process workflow layout window opens.

To access the process layout window from the State Workflow layout:

1. Access the state workflow layout window.

2.  In the design area, double-click the  icon of the state workflow transition that 

corresponds to the process workflow.

The process workflow layout window opens.

Process workflow step icons

Drag  these icons to the design area to graphically design the process workflow by adding steps 
and transitions between steps. 
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Icon Action

Logic Execution – Executes a stored procedure.

Action – Requires a participant to perform an approval action.

Status – Requires a participant to provide a status.

Decision – Adds a split decision or a join decision. 

No user action is required for a decision step.

Notification – Sends an email notification. 

This step does not require an action from the participant, but is used to inform 

users about actions, such as notifying the initiator that a request has been 

approved.

State – Drag to the design area to add an alternate state to the process 

workflow.

Alternate states are used when the outcome of a process workflow results in 

a state change that differs from the end state defined for the workflow state 

transition. 

Note: You can only add states that have been included in the state workflow 

layout.

Copy project – Creates a new project from an existing project. 

Note: This step is not available for resource request workflows.

Tri-state approval – Can transition to one or more of several paths as a result 

of the participant's selection of one of three different outcomes.

System-driven survey – Sends a survey to a list of recipients.

Drag to the design area to add a transition between two steps.

User-driven survey – Requires the participant to send a survey to a list of 

recipients

Upload – Requires the participant to upload a document and then mark the 

step as complete. 
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Creating a  process workflow layout

After you have created the state workflow layout, for each state transition that requires a 
process workflow, use the process workflow layout window to add and configure the process 
workflow steps. 

1. Access the process workflow layout window.

2.  Add and configure the required steps. For more information, see the configuration topics 
for the following steps:

• "Configuring a process workflow state" on page 397

• "Configuring a process workflow logic execution step" on page 398

• "Configuring a process workflow action step" on page 399

• "Configuring a process workflow status step" on page 399

• "Configuring a process workflow decision step" on page 400

• "Configuring a process workflow notification step" on page 401

• "Configuring a process workflow copy project step" on page 402

• "Configuring a process workflow tri-state approval step" on page 403

• "Configuring a process workflow system-driven survey step" on page 403

• "Configuring a process workflow user-driven survey step" on page 404

• "Configuring a process workflow upload step" on page 405

3.  Add and configure the step transitions between the steps. For more information, see 
"Configuring a process workflow step transition" on page 406.

4.  Click  to save the process layout.

About process workflow steps

When you first open the process workflow layout window of a workflow state transition, the 
start and end states for the state transition are displayed in the design area. These states cannot 
be removed from the layout. 
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However, you can add additional states to the process workflow. Additional states are required 
in situations where the outcome of a step needs to be a state other than the destination (end) 
state of the state workflow transition. 

You can only add states that exist in the state workflow layout. Each state can be added only 
once.

Example

In the following example, the state transition begins in the New state and ends in the 
Approved state. 

However, the process workflow for the state transition includes a step to assess the 
requirements and determine whether to proceed with the project or to ask for clarification of 
project goals. If the decision maker requires more information, the Clarification Required 
state is the end state instead of the Approved state.

So in this case the Clarification Required state must be added to the process workflow 
layout.

Deleting process workflow steps

As long as the workflow parent of a process workflow is not locked, you can delete any of the 
process workflow steps that have been added to the process workflow layout.
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Decisions

Apart from the process state, each process step dialog has a Join decision tab and a Split 
decision tab. In general there is no need to add a decision step to a process layout because the 
step Join decision and Split decision tabs provide exactly the same functionality as the 
decision step.

Reference information

The workflow participant for a step may require reference information, such as a link, or a 
template, to complete a step. Use the Create Knowledge Item menu item included in each 
step dialog box.

Tip: Give each step a unique name so that you can unambiguously identify the step with 
the icon in the process workflow layout.

Configuring a process workflow state

1. Access the process workflow layout window.

2.  Drag the  icon onto the design area.

The State Step dialog box appears.

3.  In the Add state list, select the state. 

4.  In the Step name field, enter the name for the step.

5.  Click Save.

About process workflow logic execution steps

Use a logic execution step to execute stored a procedure as a stand-alone process.

No user action is required for this step.  

Sample stored procedure used in logic execution steps

In the following example, the stored procedure calculates the estimated effort for a request in 
hours. 

CREATE PROCEDURE dbo.WFCALC_Request_EstimatedHours (@EntityId as 

UNIQUEIDENTIFIER, @Entity as VARCHAR(25), @StepId as UNIQUEIDENTIFIER, 

@strOutput as NVARCHAR(255) output)

AS

select @strOutput= convert(varchar(255),cast(isnull(EstimatedHours,0) as int)) 

from Request where RequestId = @EntityId

return
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GO

If you create a custom stored procedure for a logic execution step, follow these rules:

• Begin  the procedure name with WFCALC_

• Parameters are positional. Do not modify the names or types of the four mandatory 
parameters shown in the sample above

• @EntityId represents the GUID of the entity associated with the workflow step, and 
can be used, for example, in a select statement to retrieve information about the entity

• @Entity represents the name of the entity type, for example, Request

• @StepId is the GUID of the process step instance

• (as in the example), convert @strOutput to NVARCHAR(255)

• Add your own variables, if required

Configuring a process workflow logic execution step

Note: To use a custom stored procedure, create the procedure before you configure the 
logic execution step.

1. Access the process workflow layout window.

2.  Drag the  icon onto the design area.

The Logic Execution dialog box appears.

3.  In the Step name field, enter the name for the step.

4.  In the Instructions field, enter information about the step.

5.  To configure a join decision, click the Join decision tab. For more information, see 
"About workflow join decisions" on page 413.

6.  To configure a split decision, click the Split decision tab. For more information, see 
"About workflow split decisions" on page 415.

7.  Click the Action tab.

8.  In the Stored procedure to be executed list, select the stored procedure.

9.  Click Save.
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Configuring a process workflow action step

Use the action step when a workflow participant is required to perform an action and/or 
provide an approval. 

Participants who are assigned an action step receive a workflow notification in their My 
Reminders portlet in Changepoint. 

1. Access the process workflow layout window.

2.  Drag the  icon onto the design area.

The Action dialog box appears.

3.  In the Step name field, enter the name for the step.

4.  In the Instructions field, enter instructions for the workflow participant to complete the 
step.

5.  To assign the step to a participant, click the Assignment tab. For more information, see 
"Selecting a workflow step participant" on page 409.

6.  To configure escalation rules, click the Escalation tab. For more information, see "About 
workflow escalation" on page 411.

7.  To configure a join decision, click the Join decision tab. For more information, see "About 
workflow join decisions" on page 413.

8.  To configure a split decision, click the Split decision tab. For more information, see 
"About workflow split decisions" on page 415.

9.  Click Save.

Configuring a process workflow status step

Use the status step when a workflow participant is required to perform a task and mark the task 
as completed. For example,  when the participant is required to review a schedule and then 
mark the review as completed.

Participants who are assigned a status step receive a workflow notification in their My 
Reminders portlet in Changepoint. They must perform the task and update the status to 
Completed, In progress, On hold, or Reassigned.

1. Access the process workflow layout window.

2.  Drag the  icon onto the design area.
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The Status dialog box appears.

3.  In the Step name field, enter the name for the step.

4.  In the Instructions field, enter instructions to complete the step.

5.  To assign the step to a participant, click the Assignment tab. For more information, see 
"Selecting a workflow step participant" on page 409.

6.  To configure escalation rules, click the Escalation tab. For more information, see "About 
workflow escalation" on page 411.

7.  To configure a join decision, click the Join decision tab. For more information, see 
"About workflow join decisions" on page 413.

8.  To configure a split decision, click the Split decision tab. For more information, see 
"About workflow split decisions" on page 415.

9.  Click Save.

Configuring a process workflow decision step

Use the decision step to configure a split or join decision in the process workflow.

In general, configuring split or join decisions using the Split  decision tab or the Join decision 
tab in each step type is functionally identical to using a separate Decision step. 

No user action is required for decision steps.

Warning: If you configure a split decision with mutually exclusive decisions, and later 
two or more of the paths from these decisions converge in a join decision that requires all 
to be completed, workflow will stall at the step with the join decision.

1. Access the process workflow layout window.

2.  Drag the  icon onto the design area.

The Decision dialog box appears.

3.  In the Step name field, enter the name for the step.

4.  In the Instructions field, enter instructions for the workflow participant to complete the 
step.

5.  To configure a join decision, click the Join decision tab. For more information, see 
"About workflow join decisions" on page 413.
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6.  To configure a split decision, click the Split decision tab. For more information, see 
"About workflow split decisions" on page 415.

7.  Click Save.

Configuring a process workflow notification step

Use the notification step to send an email notification about actions taken as part of the process 
workflow. Notifications can be sent to any resource. 

No user action is required for this step.

Note: Before you start, ensure that you have access to a suitable email template.

1. Access the process workflow layout window.

2.  Drag the  icon onto the design area.

The Notification dialog box appears.

3.  In the Step name field, enter the name for the step.

4.  In the Instructions field, enter information about the step.

5.  Click the Notification tab.

6.  Select the Send an email check box.

7.  In the Template list, select the email template for the notification.

The Subject and Message fields display the email subject and message of the selected 
template. You cannot edit these fields.

8.  Select the recipients of the email notification. For more information, see "Selecting a 
workflow step participant" on page 409.

9.  To configure a join decision, click the Join decision tab. For more information, see "About 
workflow join decisions" on page 413.

10.  To configure a split decision, click the Split decision tab. For more information, see 
"About workflow split decisions" on page 415.

11.  Click Save.
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Configuring a process workflow copy project step

Use the copy project step to allow workflow participants to either create a new project based 
on existing project data. The project information such as tasks, task assignments, work codes 
and work locations are copied from a source project to a new or existing project.

1. Access the process workflow layout window.

2.  Drag the  icon onto the design area.

The Copy Project dialog box appears.

3.  In the Step name field, enter the name for the step.

4.  In the Instructions field, enter instructions for the workflow participant to complete the 
step.

5.  To assign the step to a participant, click the Assignment tab. For more information, see 
"Selecting a workflow step participant" on page 409.

Note: Client Portal users cannot be selected as a participant on a copy project step.

6.  Click the Source tab. 

7.  In the Phase field, select one or more task phases. Only tasks that are associated with the 
selected phases in the source project are copied to the target project. If no phase is 
selected, then all the tasks from the source project are copied to the target project. 

8.  To allow the step participant to add or remove task phases when creating a new project, 
select the Allow participants to add/remove phases check box. 

9.  Do one of the following:

• To use a project as the source, select the Select a project option, and then select the 
client, initiative, and project.

• To use a project configurable field as the source, select the Select a configurable field 
option, and then select the Project configurable field field.

10.  To configure escalation rules, click the Escalation tab. For more information, see "About 
workflow escalation" on page 411.

11.  To configure a join decision, click the Join decision tab. For more information, see 
"About workflow join decisions" on page 413.
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12.  To configure a split decision, click the Split decision tab. For more information, see 
"About workflow split decisions" on page 415.

13.  Click Save.

Configuring a process workflow tri-state approval step

For tri-state approval steps, the Split decision tab is used to configure the step to transition to 
up to three different conditions as a result of the split decision.

1. Access the process workflow layout window.

2.  Drag the  icon onto the design area.

The Tri-State Approval dialog box appears.

3.  In the Step name field, enter the name for the step.

4.  In the Instructions field, enter instructions for the workflow participant to complete the 
step.

5.  To assign the step to a participant, click the Assignment tab. For more information, see 
"Selecting a workflow step participant" on page 409.

6.  To configure escalation rules, click the Escalation tab. For more information, see "About 
workflow escalation" on page 411.

7.  To configure a split decision, click the Split decision tab. For more information, see 
"About workflow split decisions" on page 415.

8.  Click Save.

Configuring a process workflow system-driven survey step

Use the system-defined survey step to send a survey to a list of recipients. You can configure 
only active surveys that are not automated. If the selected survey has expired before the 
workflow reaches this step, the step is skipped.

No user action is required for this step.

1. Access the process workflow layout window.

2.  Drag the  icon onto the design area.

The System-driven survey dialog box appears.

3.  In the Step name field, enter the name for the step.
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4.  In the Instructions field, enter information about this step.

5.  To configure a join decision, click the Join decision tab. For more information, see 
"About workflow join decisions" on page 413.

6.  To configure a split decision, click the Split decision tab. For more information, see 
"About workflow split decisions" on page 415.

7.  Click the Survey tab.

8.  In the Surveys list, select a survey.

9.  To allow this step to be marked Complete before all survey recipients have responded, 
select the Auto-complete survey check-box, and then in the Response fields, do the 
following:

• Optionally, in the % field, enter the percentage of survey responses that must be 
received for this process workflow  step to be marked Complete.

• In the day(s) field, enter the number of days that the process workflow will wait 
before this process workflow  step is marked Complete. 

The process workflow  step is marked Complete when either the percentage  of responses 
received condition or the number of days condition is satisfied.

10.  To select the recipients of the survey, do the following:

a. In the body of the Recipients table, right-click and select Insert.

b. In the Participant column, expand the tree view and select a participant.

c. To assign a participant who is organizationally related to the resource assigned to a 
predecessor step (for example, the resource's manager), do the following:

• Select the system-defined participant.
• In the Previous step column, select the predecessor step. 

11.  Click Save.

Configuring a process workflow user-driven survey step

Use the user-driven survey step when the workflow participant is the assigned resource to 
distribute the survey to specified recipients. You can configure only active surveys that are not 
automated.

1. Access the process workflow layout window.
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2.  Drag the  icon onto the design area.

The User-driven survey dialog box appears.

3.  In the Step name field, enter the name for the step.

4.  In the Instructions field, enter instructions for the workflow participant to complete the 
step.

5.  To assign the step to a participant, click the Assignment tab. For more information, see 
"Selecting a workflow step participant" on page 409.

6.  To configure escalation rules, click the Escalation tab. For more information, see "About 
workflow escalation" on page 411.

7.  To configure a join decision, click the Join decision tab. For more information, see "About 
workflow join decisions" on page 413.

8.  To configure a split decision, click the Split decision tab. For more information, see 
"About workflow split decisions" on page 415.

9.  Click the Survey tab.

10.  In the Surveys list, select a survey.

11.  To allow this step to be marked Complete before all survey recipients have responded, 
select the Auto-complete survey check-box, and then in the Response fields, do the 
following:

• Optionally, in the % field, enter the percentage of survey responses that must be 
received for this process workflow  step to be marked Complete.

• In the day(s) field, enter the number of days that the process workflow will wait before 
this process workflow  step is marked Complete. 

The process workflow  step is marked Complete when either the percentage  of responses 
received condition or the number of days condition is satisfied.

12.  Click Save.

Configuring a process workflow upload step

Use the upload step when the workflow participant is required to upload a file as part of the 
process workflow. 
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Participants who are assigned an upload step receive a workflow notification in their My 
Reminders portlet in Changepoint. The available statuses for upload steps are: Done, On hold, 
and Reassigned.

1. Access the process workflow layout window.

2.  Drag the  icon onto the design area.

The Upload dialog box appears.

3.  In the Step name field, enter the name for the step.

4.  In the Instructions field, enter instructions for the workflow participant to complete the 
step.

5.  To assign the step to a participant, click the Assignment tab. For more information, see 
"Selecting a workflow step participant" on page 409.

6.  To configure escalation rules, click the Escalation tab. For more information, see "About 
workflow escalation" on page 411.

7.  To configure a join decision, click the Join decision tab. For more information, see 
"About workflow join decisions" on page 413.

8.  To configure a split decision, click the Split decision tab. For more information, see 
"About workflow split decisions" on page 415.

9.  Click Save.

Configuring a process workflow step transition

After you have configured the steps in the process, you can configure the transitions between 
steps. 

1. Access the process workflow layout window.

2.  Drag the  icon onto the design area.

The Transition Step dialog box appears. 

3.  In the Transition name field, enter the name for the transition. 

Tip: Give each step transition a unique name so that you can unambiguously identify the 
transition with the link in the process workflow layout.

4.  In the Description field, enter a description for the transition. 
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5.  In the From list, select the starting step for the transition.

6.  In the To list, select the ending step for the transition.

7.  Click Save.

About assigning workflow steps to participants

If user action is required for a step, you must assign the step to one or more workflow 
participants.  Participants who are assigned to a step receive a workflow notification in their 
Changepoint My Reminders portlet. 

Tip: When you assign a step to a workflow participant,  be sure to configure escalation 
rules so that the step is automatically escalated if it is not resolved within a certain period 
of time. Otherwise the workflow is stalled if the participant cannot complete the step.

Workflow participants include:

• Resources

• Roles

• System-defined participants

• Configurable field participants

Resources

If a resource is assigned to a step and the resource’s user account is later deactivated, the 
process workflow stalls.

Roles

When you assign a role, all resources with the specified role are assigned to the step. If you 
select a role as a participant in the workflow step, ensure that there are resources who are 
assigned to the role. Otherwise, the workflow step stalls.

System-defined participants

System-defined participants are resources who have been assigned to a system-defined function 
on a specific entity. For example, for a request entity, the Request responsible function refers 
to the resource selected in the Responsible field. 
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Make the appropriate field  mandatory to ensure that a value is entered in the field. If the field 
is empty or invalid, the workflow step is skipped, and this is noted in the workflow log.

Note:  Client Portal users that have been granted workflow participant access rights can 
also be a assigned to a system-defined function, such as a Request initiator.

You can assign a participant who has a system-defined relationship (for example, Manager) 
with the assigned resource from a previous step in the process workflow. To do so, assign the 
step to the appropriate system-defined participant, and select the previous step. Previous steps 
are available for selection once the steps and transitions have been configured in the design 
area. 

Configurable field participants

If you use a configurable field as a participant in a workflow step, make  the field  mandatory to 
ensure that a value is entered in the field. If the field is left blank, the active step is not 
assigned to anyone and the workflow stalls. 

Only resource and role entity-based configurable fields are supported. The step assignment 
may be changed based on user selection of the configurable field. For example, if a user 
selects a value in the configurable field that has a role associated to it, the step will be assigned 
to that role. 

If the participant is a Client Portal user, the validation for workflow steps is performed when 
the user signs into Client Portal. The Client Portal user is considered valid if:

• they are assigned to the configurable field 

• they are associated to the client of the workflow entity

• they have the workflow participant access rights. 

If the participant  is invalid, the workflow stalls. 
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Note: You cannot select contact configurable fields as participants for Copy project steps 
or User-driven survey steps.

Selecting a workflow step participant

1. Access the process workflow layout window.

2.  Double-click the step icon.

The step dialog box appears.

3.  Click the Assignment tab.

4.  In the Assigned to field, expand the tree view and select the participant.

Tip: Right-click in the tree view or on one of the elements in the tree view to display a 
context menu that you can use to quickly expand or collapse the elements.

5.  To assign the step to a participant who has a system-defined relationship with the resource 
assigned to a predecessor step in the process workflow, do the following:

a. Select a system-defined participant in the Assigned to field.

b. Select the predecessor step in the Previous step field.

6.  Click Save.

7.  To send a notification to the participant to inform them about the assignment, see "Sending 
an email notification to a workflow participant" on page 410.

About sending notifications to workflow participants

To send a notification to a workflow participant, you can use either a Notification step, or the 
Notification section of the Assignment tab in the step dialog. The following table shows the 
features of each method.

Notification step Notification section of the Assignment tab

You must configure an email message You can optionally configure an email message to the 

participants

You can send the email message to any 

resource

The email message is sent only to the participants 

assigned to the step
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Notification step Notification section of the Assignment tab

The participants do not receive a workflow 

notification  in the My Reminders portlet

The participants receive a workflow notification  in the My 
Reminders portlet

There is no associated escalation If escalation is configured, it uses the same email 

template that you select in the Notification section of the 

Assignment tab

One default workflow notification email template is included with Changepoint.

Note: Only the following parameters are supported in workflow email notifications: 

• ÿNameÿ – name of the entity, or number of the request.

• ÿDescriptionÿ – the request short description field, or the description from the 
Comments field for an entity other than a request.

• ÿIDÿ – internal GUID of the entity or request.

• ÿQuickLinkÿ – quicklink parameter allowing you to sign in to Changepoint and 
directly access the entity profile page.

For information on creating custom email templates, see the "About email notifications" 
section on page 272.

System-defined and configurable field participants

To send the notification  to a resource who has a system-defined relationship with the resource 
assigned to a predecessor step, you select the appropriate system-defined participant and then 
the predecessor step. For example, if you select Manager from the system-defined participant 
list and select a previous step, the notification is sent to the manager of the resource who is 
assigned to the selected previous step. Previous steps are available for selection once  the steps 
and transitions have been configured in the design area.

If you select a configurable field participant, and the configurable field is associated with 
resources, the notification is sent to the list of resources. If the configurable field is associated 
with roles, the notification is sent to the list of resources with the roles.

Sending an email notification to a workflow participant

1. Access the process workflow layout window.

2.  Double-click the step icon.
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The step dialog box appears.

3.  Click the Assignment tab.

4.  Select a participant. For more information, see "Selecting a workflow step participant" on 
page 409.

5.  Click the Send an email check box.

6.  In the Template list, select the workflow notification email template.

7.  Click Save.

Adding attachments and links to a workflow step

You can attach documents and/or links to a URL or shared folder repository to steps in a 
process workflow to provide reference information (for example process guidance or templates 
that the user needs to complete the step).

After the state definition is activated, the name of the attachment or link displays in the 
Guidance section of the workflow step dialog in Changepoint.

Note: The Create Knowledge Item link on the step dialog box is only available after the 
step has been saved.

1. Access the process workflow layout window.

2.  Double-click the step icon.

The step dialog box appears.

3.  Click Create Knowledge Item. 

The Create Knowledge Item dialog box appears.

4.  Complete the fields as required.

5.  Click Save.  

About workflow escalation

You can configure escalation rules to escalate steps automatically if they are not resolved 
within a certain period of time, to avoid delays in the workflow. The following escalation 
options are available: 

Changepoint Administration | 411



17. Workflow Management

• Email notification only – an email is automatically sent to the participants to remind them 
to complete the step. If you select this option, make sure that the notification settings are 
set up in the Assignment tab. Escalations use the same email template as you selected in 
the Notification section of the Assignment tab.

• Reassignment – the step is reassigned to another participant. The new participant receives 
a workflow notification in the My Reminders portlet in Changepoint.

• Conclude – the process moves to the next step, even if the participant did not completed 
the required action. In the case of a split decision, the workflow is marked as completed or 
rejected, depending on the configuration of the default status for the step type.

To avoid escalation, workflow steps must be marked as follows:

• Action step – Accepted or Rejected

• Status step – Completed

• Upload step – Done

• User-driven survey step – Done

• Copy project step – Done

• Tri-state approval step – Accepted, Rejected, or Routed To

Workflow escalation is processed by a scheduled job. For more information about scheduled 
jobs, see the Changepoint Installation Guide.

Configuring a workflow escalation

1. Access the process workflow layout window.

2.  Double-click the step icon.

The step dialog box appears.

3.  Click the Escalation tab.

4.  In the Required time to complete step field, enter the time (in hours) given to 
participants to complete the step.  

5.  To define an escalation rule, do the following:

a. In the table, right-click and select Insert.
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b. In the Timer (hours) column, enter the number of hours before the escalation is 
triggered. 

c. In the Escalation type column, select the escalation type.

d. In the Participant column, select the participant. For more information, see "Selecting 
a workflow step participant" on page 409.

To assign a participant who is organizationally related to the resource assigned to a 
predecessor step, do the following:

• Select a system-defined participant.
• In the Previous step column, select the predecessor step. 

6.  Click Save.

About workflow join decisions

Use the join decision step, or the join decision tab, to converge two or more steps into a single 
subsequent step. The join decision determines the number of incoming steps that must be 
completed before the single step begins. 

Join decision types

• ALL previous steps are completed – If all of the incoming steps must be completed to 
converge into this step. 

• ONE previous step is completed – If only one of the incoming steps must be completed 
to converge into this step.

• Specify number of steps to be completed – If you have more than 2 incoming steps and 
only some of them must be completed to converge into this step.

Note: In this situation, the term “completed” does not mean that a step was necessarily 
marked as Completed. It means that it was marked as Approved, Rejected or Completed 
by the user, all of which are considered by workflow to indicate that no further action is 
required or possible.

In the following example, as soon as the assigned workflow participants mark both the Create 
Resource Plan step and the Create Project Plan step as “completed”, the steps converge to 
the Identify project team status step. 
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To have the process move to the Identify project team step only when both previous steps are 
marked as status = Completed, configure each of the Create Resource Plan step and the 
Create Project Plan step with a split decision to continue to the Identify project team step 
only if the step is Completed, and to redirect the process to another point in the workflow 
otherwise.

Configuring a workflow join decision

1. Access the process workflow layout window.

2.  Double-click the step icon.

The step dialog box appears.

3.  Click the Join decision tab.

4.  In the Join decision type list, select one of the following:

• If all of the incoming steps must be completed to converge into this step, select ALL 
previous steps are completed. 

• If only one of the incoming steps must be completed to converge into this step, select 
ONE previous step is completed.

• If you have more than 2 incoming steps and only some of them must be completed to 
converge into this step, select Specify number of steps to be completed, and then 
enter a number in the Number of steps to be completed field.

5.  Click Save.
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About workflow split decisions

Use the split decision step, or the split decision tab, to diverge one step into two or more 
parallel paths. The split decision determines which paths the workflow process takes after the 
current step finishes processing. 

For example, you can set the split to follow one path if the workflow participant changes the 
status on an action step to Accepted, and another path if the status is set to Rejected.

In the following example, the Upload and create project charter step branches out to two 
status steps and two upload steps. The split decision is configured on the Upload and create 
project charter step. 

Use the Split Decision tab to create one or more expressions to determine the possible 
outcomes of a split decision. The expressions can use the status from the current or previous 
step, or a result from a stored procedure. 

• When the split decision is executed, each expression that is true causes the process to 
follow the corresponding process transition to the next step.

• When you create the second and subsequent expression, they  must be either all Numeric or 
all Text, and must all be of the same decision type (or use the same stored procedure).

• You must configure at least one expression that results in a "Go to step" for each step that 
the split can transition to.
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Split decision type

• Transition to ALL steps – Use this decision type to follow all process transitions that 
branch out from this step. 

When you select this type, all steps that branch out from the current step display in the 
table. The process proceeds to each of these steps when the current step is completed.

• Current Step Status – Use this decision type to determine which process transition to 
follow based on the outcome of the current step. 

This decision type is available only for steps that require user interaction, such as action or 
status steps. 

• Previous Step Status – Use this decision type to determine which process transition to 
follow based on the outcome of a predecessor step.

This decision type is available only if the current step has at least one predecessor step. 
The previous step status is not available if the step has a join condition.

• You can use the result of a stored procedure (including a custom stored procedure) as the 
basis to determine which process transition to follow. When you select a stored procedure, 
you specify whether the result that is passed  is treated as text or numeric.

• The procedure must exist before you can build the expression. 

• The procedure name must begin with WFSPLIT_. 

Configuring a workflow split decision

1. Access the process workflow layout window.

2.  Double-click the step icon.

The step dialog box appears.

3.  Click the Split decision tab.

4.  In the Split decision type list, select one of the following: 

• To transition to all steps that branch out from this step, select Transition to ALL 
steps and click Save.

• To base the decision on the outcome of the current step, select Current step status 
and complete the expression.
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• To base the decision on the outcome of the previous step, select Previous step status 
and complete the expression.

• If workflow stored procedures are available for selection, select the stored procedure 
and complete the expression.

To complete the expression for the current or previous step status

Note: For the Current step status or the Previous step status decision type, the Text 
option is selected because the status is always a  text string.

1. In the Condition list, select the condition. For more information, see "Available conditions 
in the workflow split expression builder" on page 418.

2.  In the Value field, enter the value to complete the expression.

• If the expression is based on the current or previous step status, and the step is not a 
tri-state approval step, only the statuses that cause the step to be marked as completed 
(for example Done) or that do not transition the step to a state (for example On hold) 
are available. 

• If the step is a tri-state approval step, you can configure the step to transition to up to 
three different states as a result of the split decision, by creating expressions with 
different outcomes.

3.  In the Go to step list, select the step that the process proceeds to when the result matches 
the condition and value set for this expression.

4.  Click the Save button above the table  to add the expression to the table.

5.  Add another expression, if required.

6.  Click the Save link.

To complete the expression for a stored procedure

1. Select one of the following options to determine how the result is returned:

• To return a numeric value, such as the estimated effort for a project, select Numeric.

• To return a text value, such as a project name, select Text. 

2.  In the Condition list, select the condition. For more information, see "Available conditions 
in the workflow split expression builder" on page 418.

3.  In the Value field, do the following:
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• If you selected the Numeric option, enter a number to return the result as a numeric 
value.

• If you selected the Text option, enter a text string to return the result as text.

4.  In the Go to step drop-down list, select the step the process is routed to when the result 
matches the condition and value set for this expression.

5.  Click the Save button above the table  to add the expression to the table.

6.  Add another expression, if required.

7.  Click Save.

Available conditions in the workflow split expression builder

The available conditions vary depending on whether the expression is configured to return a 
text value or a numeric value. 

For text results, the process proceeds to the step selected in the expression:

• Equal to – If the returned text is a case-insensitive match for the Value in the expression.

• Not equal to – If the returned text does not match the Value in the expression.

• Like – If the returned text contains the Value in the expression.

For numeric results, the process proceeds to the step selected in the expression:

• Equal to – If the returned number is equal to the Value in the expression.

• Less than equal to – If the returned number is less than or equal to the Value in the 
expression.

• Less than – If the returned number is less than the Value in the expression.

• Greater than or equal to – If the returned number is greater than or equal to the Value in 
the expression.

• Greater than – If the returned number is greater than the Value in the expression.

Sample stored procedure used in workflow split decision

The name of a stored procedure for a split decision must begin with WFSPLIT_. 

In the following example, the stored procedure retrieves the estimated effort for a request in 
hours.
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CREATE PROCEDURE dbo.WFSPLIT_Request_EstimatedHours (@EntityId as 

UNIQUEIDENTIFIER, @Entity as VARCHAR(25), @StepId as UNIQUEIDENTIFIER, 

@strOutput as NVARCHAR(255) output)

AS

select @strOutput= convert(varchar(255),cast(isnull(EstimatedHours,0) as int)) 

from Request where RequestId = @EntityId

return

GO

If you create a custom stored procedure for a split decision, follow these rules:

• begin  the procedure name with WFSPLIT_

• the parameters are positional. Do not modify the names or types of the four mandatory 
parameters shown in the sample above

• @EntityId represents the GUID of the entity associated with the workflow step, and 
can be used, for example, in a select statement to retrieve information about the entity

• @Entity represents the name of the entity type, for example, Request

• @StepId is the GUID of the process step instance

• (as in the example), convert @strOutput to NVARCHAR(255)

• if needed, you can add your own variables

About editing  a workflow process 

Unlocked workflow state definition

If a state definition is not locked, you can edit or delete steps, transitions and states in a process 
workflow layout that belongs to a state transition in the state workflow layout. 

You cannot delete the initial or end states from a process workflow (that is, the states that 
belong to the corresponding workflow state transition). 

When you delete a state or step from a process workflow layout, all process step transitions 
connected to the state or step are also deleted.

Locked workflow state definition

If the workflow state definition is locked, the only fields that can be edited are those that do 
not affect the workflow:

• process state names and descriptions
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• process transition names

• step names and instructions

• the value in the Required time to complete step field for escalations. 

You can also create knowledge items.

To make other changes to a process when the workflow state definition is locked, copy the 
state definition, then make the changes to the copy before you activate it. 

Editing a workflow process

1. Display the process workflow layout.

2.  To  rearrange the icons on the layout, use drag and drop.

3.  To edit a process step or a process step state, double-click the step or state icon.

The step dialog box appears.

4.  To create a knowledge item for the step, click Create Knowledge Item. For more 
information, see "Adding attachments and links to a workflow step" on page 411.

5.  Make the required changes and then click Save.

6.  To edit a step transition, right-click the transition icon and select Step transition 
configuration.

The transition step dialog box appears.

7.  Make the required changes and then click Save.
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A

Access Control dialog box options  311

Actions menu
adding items, about  211
submenu header, adding  212
submenu headers, rearranging  212
submenu items, adding  213
submenu items, editing  215
submenu items, rearranging  215

Add Target dialog box options  94

additional UI fields. See informational 
fields  252

address types
field labels, changing  163

adjustment reasons
creating  157
modifying  157

alternate names
setting up  290

Archive Validation scheduled job  366

archiving
entities, approving, about  364

archiving data
archived data, accessing  364
Archiving Log report, about  369
Archiving Validation Log report, 

about  368
entities, approving/rejecting  365
entities, canceling, archive 

administrator  366
funding source data, retaining  364
initiative validation list  367

options, about availability  370
overview  363
project validation list  366
running the Archive Aged Entities sched-

uled job  369
validation errors/failures, clearing  368
validation job, running  366

Archiving Log report
about  369
accessing. archive administrator  370

Archiving Validation Log report
about  368
accessing, archive administrator  368

ASP reports
removing  260
settings, editing  260

asset option lookups
creating  255
modifying  255

asset options
creating  253
modifying  254

asset types
assigning options to  254
creating  253
modifying  253

assets
about  253

auto-numbering
about setting up  294
custom stored procedures  295
example  298
options  296
setting up  294

automated revenue transfers
configuring  156
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Index: automated surveys – client report cards

automated surveys
about  304
approving respondents  322
rejecting respondents  322

B

background images
adding to surveys  312

batch cross charge printing
setting printing options  35

batch cross charge printing options  36

budget exchange rates
default dates, configuring  160-161

budget item types
about  158
configuring default  159
creating  158
modifying  158

budget settings
about  157

budgets
default budget item types, configuring  159
request types for contingency, 

configuring  159
revision used for calculations, 

specifying  160

burden rates
configuring for cost centers  100

C

calculated fields
about  184
creating  184
formulas, using stored procedures in  187
rules  185

candidate status
about  237

candidates
configuring status values  237
deleting status values  237
editing status values  237

Changepoint
locking  24

Changepoint Administration
about  21
accessing  21

Changepoint Analytics reports
synchronizing  259

Changepoint email notification service
about  272

Changepoint Export dialog box options  346

check-in/checkout controls
for knowledge categories, about  231

client feedback metrics
templates, creating  84

Client Portal
Client Portal Access view options  264
configuring  263

Client Portal management
about  263

Client Portal User view, General section 
options  267

Client Portal User view, Security access section 
options  268

Client Portal users
accessing  265
managing  265

client report cards
about  328

422 | Changepoint PPM 2021



Index: clients – cost structures

viewing  330

clients
available customer fields for 

importing  354
enabling history tracking  271

closed periods
about  126
accessing  127
configuring  127
editing  128

Cognos integration in Changepoint Admin-
istration  258

competencies
about  39
creating  41
modifying  41

concepts and terms  71

configurable field groups
creating  188
headers, about  189
headers, creating  189
rearranging in tab or section  190

Configurable Field Settings view 
options  169

configurable field values
conditional formulas, creating  181
conditions, modifying  183
drop-down list, creating  178
drop-down list, using entity records 

for  177
properties, setting up conditions 

for  180

configurable fields
about  164
access to, restricting  175
access to, restricting, about  174
code, creating  168

creating same field for multiple 
entities  173

default, about  167
default, enabling  167
editing  176
for initiatives, creating  166
layout, specifying  188
rearranging in the Configurable Fields 

tab  190
setting up conditions for values  179
shared, creating  173
text, creating  168

Configure Theme dialog box options  314

contacts
importing records  357

corporate templates
creating  318

cost centers
about  98
burden rates, configuring  100
changing defaults  100
configuring automated revenue trans-

fers  156
creating  98
modifying  99

cost rates
staffing level role vs. resource 

based  146

cost structures
about  128
about cross charge approval 

settings  137
accessing  129
configuring settings  131
copying  145
creating  129
creating staffing levels  138
cross charge approval settings, con-
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figuring  137
daily rate conversions  149
granting user access to  142
modifying  144

Cost Structures view, Settings tab options  132

countries
enabling  270

Create/Edit Metric dialog, General tab 
options  93

Create/Edit Survey view options  305

cross charge approval
about cross charge approval settings  137

cross charge approval settings
configuring  137

cross charge formats
adding to cost structures  151
modifying  152

cross charge numbers
configuring  138

cross charges
configuring logos  130

currency exchange
about  101

custom ASP reports
adding to Changepoint  259
setting up  259

custom e-mail templates
about creating scheduled jobs  286

custom help
links, editing  211
links, setting up  210
setting up links to, about  210

custom name formatting
setting up  290

custom section items
access, controlling  201
creating  200
modifying  200

custom sections
about  198
creating  199
modifying  199
reordering  200

cutoff dates for closed periods
about  126

D

daily charge rates
modifying  149

dashboards
about  204
access, restricting  205
creating  205
default, prioritizing  207
default, prioritizing, about  206
editing  206
layout, configuring  207

data export  345
about  343
manually  344
re-exporting data  345

demand funding
double counting, preventing  67

distribution lists
about  323
accessing  323
adding members  324
creating  323
deleting  326
editing  325
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editing members  324
selecting members  325

drop-down lists
entity records, using as values  177
standard, modifying values  177
values, editing  179

E

e-mail links
embedding in templates  273

email integration
setting up  289

email links
embedding in templates  273
triggers for embedded links  288

email notifications
about  272
about grouping  279
adding recipients  282
example  285
grouping examples  279
setting conditions  283
setting up  281, 285
SQL statements  283
trigger-based,guidelines for creating 

triggers  281

email templates
about  274
creating  274
email links, embedding  273
enablling  276
modifying  277

Email templates view
General section options  275
Template information section 

options  276

event-based export publishing
event notification, setting 

conditions  351
event notifications, modifying  352

exchange rates
configuring  102
editing  103

expense approval
about  31

expense categories
adding GL account codes  222
creating  221
deleting  223
editing  223

expense reports
attachments, enabling  225

expense taxation
setting up  117

expense taxation setup
editing  119

Expense Taxation Setup options  118

expense transfer rules  227

expense types
creating  223
deleting  225
editing  225

expenses
about issuing and reconciling expense 

advances  226
attachments, enabling  225
creating advances  226
deleting advances  226
setting up, about  221
transferring  228
transferring, about  227
viewing all advances  226
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export batch numbering
example  298
options  296
setting up  341

export batch tracking
enabling, about  342

export categories
creating  337

export columns
column order, changing  340
configuring  339

export data
filtering  339
grouping  339

export data types
creating  336
modifying  336

export definitions
categories, creating  337
creating  337
creating, about  337
editing  345
export columns, configuring  339
export line, configuring  339
file definitions, configuring  338
groups, creating  339
modifying  341

export event setup  352

export groups
creating  339

export lines
configuring  339

export publishing
data, resending  353
event notifications, setting up  350
new topics, adding  342

setting up  347
verifying status of  353

export publishing schedules
creating  347
modifying  350
recurrence, configuring  348

export setup
about  335

export views
mapping to, creating  335
mapping to, modifying  335

F

fields, hiding  195

file definitions
configuring  338

Financial Settings section options  33

fiscal periods
about  125
creating  125

fiscal years
about  125
accessing  125
creating  125
editing  126

functions
about  42
creating  42
modifying  43

G

generic resources
about  46
profiles, creating  46
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GL account codes
about  97
creating  97
modifying  98
selecting revenue types  157

GL account types  97

global workgroups
about  27
accessing  27
creating  28
modifying  28
setting inheritance rules  27

H

history tracking
clients, enabling  271

I

individual performance
default settings, about  73
default settings, defining  74
reporting periods, defining  74
reporting periods, editing  75

informational fields
displaying on the Request dialog box, 

about  252
setting up  252

initiative workflows
about  141
configuring  142

IPM metrics
about  91

K

knowledge categories
about  231
check-in/checkout controls, 

enabling  232
creating  232
modifying  232
version control, about  231
version control, enabling  232

knowledge item approval workflow
modifying  235
setting up  234

knowledge item attachments
restricting access to, about  234

knowledge item workflows
defining participants  234

knowledge items
configuring a legal disclaimer for 

attachments  231

knowledge management
about  231

knowledge subcategories
creating  232
modifying  233

knowledge subscriptions
about  233
configuring  233
modifying  234

L

legal disclaimers
configuring  231

licenses
importing  24
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information, viewing  23
managing  23

M

merge fields
creating parameters  278
editing parameters  278
setting up in email template  277

metadata
about  191
settings, configuring  192

metric calculations
about  76
creating  80
editing  81
examples, rollup  90
viewing  80

metric calculations, setting up  73

metric templates
about  81
accessing  82
creating  82
deactivating  89
deleting  89
editing  89
for adoption metrics, creating  83
for client feedback, creating  84
for peer feedback, creating  85
for projects, creating  86
for result metrics, creating  83
for user-entered metrics, creating  86
target values, entering  88
thresholds, entering  88
user-entered, configurable fields, about  87

metric types
adoption  77
client feedback  78

peer feedback  78
project  78
results  77

metrics
about creating metrics  92
about team metrics  95
accessing metrics  92
accessing metrics from a template  92
adding a target to metrics  94
adjusting the weighting of metrics for a 

resource  96
assigning metrics to a resource  94
assigning metrics to a team  95
categories, about  76
creating from the New menu  93
creating metrics from a template  92
editing metric assignments  96
rollup, example  90
types, about  76

Modify Global Workgroup section options  28

Modify Metadata Settings section options  192

N

name formates
setting up  290

non-labor item taxation setup
creating for a non-labor item  122
editing  124

Non-Labor Item Taxation Setup options  123

non-project time
about  219

non-project time items
creating  219
editing  220

nonworking days
about  64
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configuring  65
modifying  66

O

operations centers
about  240
creating  240
editing  243
restricting access to requests  241
restricting view and edit access to 

requests  242

outstanding respondents
sending reminders  326

P

password
configuring rules  291
rules  291
validation  291

payment terms
creating statements  151
modifying  151

payroll information  48

PCIDs
about  196
custom, creating  198

pending resource changes
canceling  59
viewing  59

performance
about individual and team per-

formances  69
about project portfolio 

performances  70

performance evaluation
using surveys  331

performance management
metric calculations, about  76
metric calculations, creating  80
metric calculations, editing  81
metric calculations, viewing  80
metric categories, about  76
metric types, about  76
overview  69
terminology  71

personal templates
creating  318

planning units
default, setting, about  62
defaults, setting  62

portfolio health
setting up  298

portlets
about  201
access, controlling  203
access, controlling, about  203
creating  202
modifying  204

process layout window
accessing  392-393

profile page integration  261

project phases
creating  177

project requests
access, restricting  251

projects
project plan editors, specifying 

default  144

Prompt Tag Selection dialog box 
options  322
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prompt tags
about  309

provinces
changing system-wide

states

changing system-wide  271
editing  270
setting up  270

Q

qualification categories
creating  40
modifying  40

qualifications
about  39
creating  40
modifying  41

question editor
deleting questions  308
editing questions  308

Question editor options  306

question types
about  307

quick links. See email links  288

R

rating questions
about  308

reason codes
adding for write-offs/write-ups  143
modifying for write-offs/write-ups  143

records
removing from a resource  26
transferring, about  25

unlocking manually  26

Recoverable Tax Setup options  116

recoverable taxes
editing  116
setting up  115

reminder emails
sending to outstanding respondents  326

remit to addresses
creating  150
modifying  150

report categories
changing the category of a report  257
creating  257
modifying  258

reports
Archiving Log report, about  369
Archiving Validation Log report, about  368
changing the report category  257
configuring, about  257
export publishing  353
integrating in entity profiles  261
integration in entity profiles, about  261

request categories
creating  248
modifying  248

request management
about  239

request numbering
example  298
options  296

request numbers
configuring  241

request queues
about  249
creating  250
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modifying  250
restricting access  251
routing criteria  249

request subcategories
creating  248

request time entry
restricting for request statuses  245
restricting to specific resources or 

roles  246
restricting, about  245

request types
about  243
creating  244
modifying  247
restricting edit access  247
restricting time entry for request 

statuses  245
restricting time entry for, about  245
restricting time entry to specific 

resources or roles  246

resource demand analysis
setting up  68
setting up, about  67

resource leveling
enabling  66

resource managers
specifying for a workgroups  35

resource profiles
attaching a picture  57
copying values, about  57
values, copying  57

resource request workflow
stored procedures for logic execution 

steps  389

resource requests
resources, exempting from  46

resources
accessing profiles in User Setup  43
canceling pending changes  59
confidential information, entering  50
cross charge and cost rates, 

acessing  52
deleting  61
editing  59
editing, about  58
exempting from resource requests  46
new cross charge or cost rates, 

adding  52
organizational information, 

specifying  54
payroll information, specifying  48
profiles, creating  44
qualifications and functions, 

specifying  53
security access settings, about  53
security access, specifying  54
terminating  61
terminating, about  60
transferring workgroups  60
transferring workgroups, about  60
unlocking accounts  61
user-managed information, 

specifying  47
viewing pending changes  59

revenue recognition
about  153
configuring  154

Revenue Recognition view options  155

revenue types
selecting for GL account codes  157

role and feature mapping
about  38

roles
creating  38
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modifying  39

S

scenario comparisons
options  153
setting up  152

scheduled jobs
Archive Validation  366

sections and section item names, editing  199

security
enabling enhanced session management  293
enabling SSL  293

security acces for resources  53

security access changes
tracking  64

server integration
setting up  269

Server Integration view options  269

service taxation setup
creating  120
editing  121

Service Taxation Setup options  121

SQL statements
for conditional formulas  353

SSL
enabling  293

standard request types
about  243

state definitions
about  374
activating  377
creating  376
filter criteria, about  374

validating  377

state workflow layout
accessing  381
configuring states in  381

states
editing  270
setting up  270

states. See workflow states  382

submenu headers
editing  213

Submenu Item view, General Options  214

survey analysis
accessing  330
available reports  330

survey analysis reports
viewing  331

Survey Email dialog box options  321

survey email messages
configuring  313

survey header
configuring  311

survey management
about  301

Survey Management portlet
adding or removing surveys  316

survey results
about performance evaluations  70
analyzing, about  330
exporting  332
from individual respondents, viewing  327
viewing from contact profiles  328
viewing from resource profiles  328
viewing from survey profiles  327
viewing results associated to entities  328
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survey status  301

survey template categories
creating  316
deleting  317
editing  317

survey templates
about  316
accessing  318
creating a survey from  305
deleting  319
editing  318
saving as corporate templates  319
saving as personal templates  319

survey theme configuration
adding background images  312
email messages  313
removing images from surveys  312
survey header  311
uploading images  312

surveys
accessing  302
accessing, about  301
adding questions  306
adding to the Survey Management port-

let  316
creating  304
creating, about  303
deleting  309
editing  308
granting access to  310
inserting prompt tags into 

questions  309
layout, configuring  311
marking as complete  333
previewing  308
question types  307
reactivating after expiry  322
removing from the Survey Management 

portlet  316

saving as corporate templates  319
saving as personal templates  319
sending  320
sending with prompt tags, about  320
sending, about  319
templates, about  316
tree view options  302
trigger events for automated 

surveys  304
using for performance evaluation  331

T

Tax Rate Setup options  105

tax rates
about  104
accessing  105
activating  106
creating  105
deactivating  106
deleting  106
editing  106

tax schedules
about  104
accessing  107
activating  110
adding tax rates  108
copying  109
creating  108
deactivating  110
deleting  110
editing, about  109
tax rates, deleting  109

taxation rules settings
about  114

taxation setup
about  103
process  104
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troubleshooting  124

team folders
changing the team leader  235
closing  235
configuring  235
reopening  235

terminating resources
about  60

terminology
standard Changepoint, changing  163

threshold expense approval
about  31

time
transferring  228
transferring, about  227

time and expense transfer
split charge conditions  228

time control
settings  217

time transfer rules  227

topics
adding to export publishing  342

triggers
embedded email links  288

U

user access to workgroups
restricting or granting  63

user interface
default language, setting  208
display options, configuring  208
elements, hiding, about  194

user interface strings
about  196

editing  197
translated, entering  197

user setup
about  43

User Setup dialog, Confidential tab options  51

User Setup dialog, Organizational information 
tab options  55

User Setup dialog, Payroll information tab 
options  49

User Setup dialog, Resource information tab 
options  45

User Setup dialog, User-managed information 
tab options  48

V

version control
for knowledge categories, about  231

W

work code categories
about  110
creating  110
editing  111

work codes
about  110
creating  111
editing  112

work location groups
creating  112
editing  112

work locations
creating  113
editing  113
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workflow
disabling  372
enabling  372
resource request defaults  386

workflow management
about  371

workflow process
configuration  395, 397
creating  395
deleting steps  419
editing  420
resetting  373
split decision, configuring  415-416

workflow state definitions
copying  378
editing  377
exporting  379
exporting, about  379
importing  379

workflow state transitions
automatic, configuring  383
configuration  382
deleting  385

workflow states
access, configuring  382
configuration  381
deleting  385
resetting  373
See also state workflow layout  382

workflow steps
action, configuring  399
assignments, configuring  407, 409-410
attachments, adding  411
copy project, configuring  402
decision, configuring  400
deleting  419
escalation, configuring  411-412

join decision, configuring  413-414
logic execution, configuring  397-398
notification, configuring  401
status, configuring  399
system-driven survey, configuring  403
transitions, configuring  406
tri-state approval, configuring  403
upload, configuring  405
user-driven survey, configuring  404

workflows
initiatives, configuring  142

workgroup access
about  34
granting  35

workgroup transfer
about  60

Workgroup view, General tab options  30

workgroups
about  27
access rights, granting  35
accessing  29
batch cross charge printing, setting 

options  35
creating  29
default revenue transfer settings, over-

riding  34
expense approval, about  31
financial settings, configuring  32
granting access, about  34
modifying  38
planning unit options, setting

planning units setup

workgroup level  37
resource managers, assigning  34
resource managers, specifying  35
setting inheritance rules  27
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write-offs/ups
creating reason codes  143
modifying reason codes  143

Z

zip/postal codes
validations  271
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